Old 08-24-2015, 12:45 PM   #401
cyrilfb
Human being with feelings
 
cyrilfb's Avatar
 
Join Date: Apr 2012
Location: Denver, CO
Posts: 247
Default FAQ

Quote:
Originally Posted by airon View Post
Maybe I should write an FAQ in PDF form.
YES!!!

+++++

I like that idea.
__________________
Cy Ball
Reaper + inspiration = music.
soundcloud.com/cyball or cyball.bandcamp.com/ or cyrilfb.com
cyrilfb is online now   Reply With Quote
Old 08-24-2015, 12:53 PM   #402
Fran Guidry
Human being with feelings
 
Fran Guidry's Avatar
 
Join Date: Dec 2007
Location: Walnut Creek, CA
Posts: 779
Default

Exporting H.264 on an i7 with hardware support is often half real-time or better. I don't know if FFmpeg works with the Intel hardware accelerator though.

Fran
Fran Guidry is offline   Reply With Quote
Old 08-24-2015, 04:46 PM   #403
Tod
Human being with feelings
 
Tod's Avatar
 
Join Date: Jan 2010
Location: Just outside of Glacier National Park
Posts: 12,601
Default

Quote:
Originally Posted by airon View Post
Maybe I should write an FAQ in PDF form.
Yes, I agree airon, there are so many things to be aware of. I think I've read most everything you've posted and everything else I could get my hands on. But I'm still confused about a lot of things, which could very well be this old brain of mine.

I'm just now finding out (or think I am anyway) the importance of not only the size you take the video, your pictures, or what ever, but also the size you render them. That seems to be a factor, however I'm still not exactly sure of that.

I'm still confused about how to get the best quality for YouTube.

This is one I did about a week ago that I edited/processed with Reaper. I rendered it with the settings you recommend and then processed it with Handbrake. I think the size was 1300x908 for both what I recorded and what I rendered.

https://youtu.be/zBmX2zDPfJ0

This is one I put together about 4 days ago and I used Movie Studio for it. It includes a series of pictures I took along with a short video using the same camera which is actually a rather cheap camera. I rendered it with XDCAM EX using "HQ 1920x1080-60i, 35 Mbps VBR" for my settings. It basically matched the size, or maybe I should say the same ratio, of my pictures.

https://youtu.be/MS8z9eomSRM

The 2nd one has much, much better quality and I'd like to know why?

Could it actually be the quality of the software I used for the screen capture?

I guess what I could do for an experiment, is edit and render the 2nd video with Reaper and see what happens.
__________________
Kontakt Vid Tutorials->Create Outputs / Create Templates -|- SMDrums Free drums -|- Elk Video Productions -|- Tod's Music
Tod is offline   Reply With Quote
Old 08-24-2015, 11:35 PM   #404
G-Sun
Human being with feelings
 
G-Sun's Avatar
 
Join Date: May 2010
Location: Norway
Posts: 7,248
Default

Quote:
Originally Posted by urednik View Post
Welcome to the video world ...
It won't get much faster!
Ok, well, good to know anyway.

Rendered some MJPEG 16bit, and it was 0,7-1,4 realtime. Much faster. But not recommended?
__________________
Reaper x64, win 8.1
My music on Bandcamp
G-Sun is offline   Reply With Quote
Old 08-24-2015, 11:37 PM   #405
G-Sun
Human being with feelings
 
G-Sun's Avatar
 
Join Date: May 2010
Location: Norway
Posts: 7,248
Default

Quote:
Originally Posted by airon View Post
Maybe I should write an FAQ in PDF form.
That would be excellent. If not preferring the wiki though. Then you'd not be the only one to be able to update it.
__________________
Reaper x64, win 8.1
My music on Bandcamp
G-Sun is offline   Reply With Quote
Old 08-24-2015, 11:44 PM   #406
urednik
Human being with feelings
 
urednik's Avatar
 
Join Date: Apr 2010
Posts: 1,163
Default

Quote:
Originally Posted by G-Sun View Post
Ok, well, good to know anyway.

Rendered some MJPEG 16bit, and it was 0,7-1,4 realtime. Much faster. But not recommended?
It depends - see the result. It is complicated to say what is good in the video world, before you see the result. It is a fiddle thing to do.
I thought you expected the same renderrate as audio
Normally a HD video at 25 framrate would render with a compression codec at lower speed than 1:0,5 on an avarage laptop if only one core is working.
__________________
W10 (64) Lenovo E540 - SSD; Lenovo B590; W7 (32), Compaq 610 (2.1Ghz core 2 duo, L2 cache, 2GB RAM); Neumann mk184 (pair), AEA Ribbon 88mk, AKG SolidTUBE; Focusrite Scarlett 18i20, M-Audio Fast Track Ultra; SWS; Python Playlists; recording merely live acoustic music.
urednik is offline   Reply With Quote
Old 08-25-2015, 01:04 AM   #407
G-Sun
Human being with feelings
 
G-Sun's Avatar
 
Join Date: May 2010
Location: Norway
Posts: 7,248
Default

Quote:
Originally Posted by urednik View Post
It depends - see the result. It is complicated to say what is good in the video world, before you see the result. It is a fiddle thing to do.
I thought you expected the same renderrate as audio
Normally a HD video at 25 framrate would render with a compression codec at lower speed than 1:0,5 on an avarage laptop if only one core is working.
Thanks!
I was just expecting the non-compressing codec to render faster (MKV, huffyuv, 24-bit pcm audio).
The result-file seemed at least uncompressed when judging from file-size.
__________________
Reaper x64, win 8.1
My music on Bandcamp
G-Sun is offline   Reply With Quote
Old 08-25-2015, 04:55 AM   #408
G-Sun
Human being with feelings
 
G-Sun's Avatar
 
Join Date: May 2010
Location: Norway
Posts: 7,248
Default Short test

Ran a short test.

Video, 1920x1080, 29fps, 48khz

Render:
MKV, huffyuv, 24 bit pcm ; 0,6-0,8 realtime; 1,26Gb
MP4, MJPEG, 95%, 24bit pcm; 0,7-0,8 realtime, 203Mb

Handbrake
MKV > m4v, q 20, 25,8mb
MKV > m4v, q 10, 25,8Mb
MP4 > mp4, q 20, 25,7Mb (twice as fast encoding)

A quick look at images seems like no/small visual differences in end result.

This with no special consideration for audio.
__________________
Reaper x64, win 8.1
My music on Bandcamp
G-Sun is offline   Reply With Quote
Old 08-25-2015, 09:57 AM   #409
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 5,538
Default

For Playback and editing I was using the AVFoundation decoder but was getting a lot of crashes.
That one is great for playing back ProRes format and doing shrinking/stretching, seems to drop frames less than VLC. Until it crashes.

I've now switched to editing with VLC for H.264 and it's much more stable. Doesn't handle ProRes format.

Either of those allow you to jump around the timeline and have the video window update in about 500ms.

Couldn't get FFMPEG decoder to work at all, may have the wrong version installed.

For export for youtube I do AVFoundation M4v non-streaming optimized h.264
12,000 kbps (!)
AAC 320

That encoder is only on OSX but I'm extremely happy with the quality of the export and the results on Youtube.

One bug with it is that the last 2-3 seconds may freeze frame. I've obsessed over the last few seconds of my videos for hours.

Simple solution is to just export a little longer than you need and use the freeze frame for your Call To Action annotations.
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is online now   Reply With Quote
Old 08-26-2015, 04:46 PM   #410
Tod
Human being with feelings
 
Tod's Avatar
 
Join Date: Jan 2010
Location: Just outside of Glacier National Park
Posts: 12,601
Default

Quote:
Originally Posted by Tod View Post
Could it actually be the quality of the software I used for the screen capture?
First of all it's obvious I know nothing about how the video works. I just experiment, do various things, and sometimes it works and sometimes it doesn't.

Today I thought I'd check out how the size works as well as the Frame Per Second (fps). I set up a screen capture for 1920x1080 which is basically the whole screen. I also recorded at 30fps.

What I got was a nice picture, but the video plays back more than twice as fast as it should and it's much shorter. The original is about 67sec, but the video turned out to be about 28sec.

I don't have a clue what's going on, when I play it back in Reaper, the properties all show as they should but it's way fast? Heh heh, the picture looks nice but?

This video is AVI that my screen capture software puts out. That's what I dragged into Reaper as well as my Platinum 12 Movie Studio, and they both play it back the same.

What am I doing wrong?
__________________
Kontakt Vid Tutorials->Create Outputs / Create Templates -|- SMDrums Free drums -|- Elk Video Productions -|- Tod's Music
Tod is offline   Reply With Quote
Old 08-27-2015, 08:04 AM   #411
Tod
Human being with feelings
 
Tod's Avatar
 
Join Date: Jan 2010
Location: Just outside of Glacier National Park
Posts: 12,601
Default

Quote:
Originally Posted by Tod View Post
First of all it's obvious I know nothing about how the video works. I just experiment, do various things, and sometimes it works and sometimes it doesn't.

Today I thought I'd check out how the size works as well as the Frame Per Second (fps). I set up a screen capture for 1920x1080 which is basically the whole screen. I also recorded at 30fps.

What I got was a nice picture, but the video plays back more than twice as fast as it should and it's much shorter. The original is about 67sec, but the video turned out to be about 28sec.

I don't have a clue what's going on, when I play it back in Reaper, the properties all show as they should but it's way fast? Heh heh, the picture looks nice but?

This video is AVI that my screen capture software puts out. That's what I dragged into Reaper as well as my Platinum 12 Movie Studio, and they both play it back the same.

What am I doing wrong?
Bump, anybody know why the video plays back more than twice as fast?
__________________
Kontakt Vid Tutorials->Create Outputs / Create Templates -|- SMDrums Free drums -|- Elk Video Productions -|- Tod's Music
Tod is offline   Reply With Quote
Old 08-27-2015, 09:20 AM   #412
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 5,538
Default

so reaper is set to 30fps and the capture is 30fps?

Project and item playrate are set to 1?
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is online now   Reply With Quote
Old 08-27-2015, 01:14 PM   #413
Tod
Human being with feelings
 
Tod's Avatar
 
Join Date: Jan 2010
Location: Just outside of Glacier National Park
Posts: 12,601
Default

Quote:
Originally Posted by EpicSounds View Post
so reaper is set to 30fps and the capture is 30fps?

Project and item playrate are set to 1?
Thanks for the reply ES, yes 30fps and Playrate is at 1. It played back fast in Movie Studio too.
__________________
Kontakt Vid Tutorials->Create Outputs / Create Templates -|- SMDrums Free drums -|- Elk Video Productions -|- Tod's Music
Tod is offline   Reply With Quote
Old 08-28-2015, 12:44 PM   #414
Tod
Human being with feelings
 
Tod's Avatar
 
Join Date: Jan 2010
Location: Just outside of Glacier National Park
Posts: 12,601
Default

Quote:
Originally Posted by Tod View Post
Bump, anybody know why the video plays back more than twice as fast?
Quote:
Originally Posted by EpicSounds View Post
so reaper is set to 30fps and the capture is 30fps?

Project and item playrate are set to 1?
Quote:
Originally Posted by Tod View Post
Thanks for the reply ES, yes 30fps and Playrate is at 1. It played back fast in Movie Studio too.
Just another little bump. Has this never happened to anybody else before?
__________________
Kontakt Vid Tutorials->Create Outputs / Create Templates -|- SMDrums Free drums -|- Elk Video Productions -|- Tod's Music
Tod is offline   Reply With Quote
Old 08-28-2015, 02:46 PM   #415
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 5,538
Default

might want to check your capture and export settings. twice as fast would indicate 15 fps.
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is online now   Reply With Quote
Old 08-28-2015, 04:19 PM   #416
Tod
Human being with feelings
 
Tod's Avatar
 
Join Date: Jan 2010
Location: Just outside of Glacier National Park
Posts: 12,601
Default

Quote:
Originally Posted by EpicSounds View Post
might want to check your capture and export settings. twice as fast would indicate 15 fps.
Thanks again for the reply ES.

Actually I was capturing my screen captures using 15ips which I thought might have accounted for the lower quality.

So in this instance, I captured using 30fps, which is what is playing back much faster. When I check the properties of the video file it is definitely 30fps, and Reaper is also set up for 30fps with no Playrate changes, it's set with a rate of 1.

It's kind of hard to move on from here without knowing why this is happening. I should mention that what I'm trying to do is get better quality with my screen captures.

If no one else has run into this before, then there must be something I'm missing, I just don't know what it could be.
__________________
Kontakt Vid Tutorials->Create Outputs / Create Templates -|- SMDrums Free drums -|- Elk Video Productions -|- Tod's Music
Tod is offline   Reply With Quote
Old 09-17-2015, 11:51 AM   #417
boka
Human being with feelings
 
boka's Avatar
 
Join Date: May 2007
Location: Hungary,Europe
Posts: 800
Default

Is Reaper capable of displaying the timecode of the video file? I do not find it All it says to me in the "video file item properties" is the following :

Length: 0:03.103
Video: 1920x1080@30.00fps, Aspect=1.00, Decoding format=I420/YV12
Audio: 48000Hz 2ch 16bps

Using OSX 10.7+ AVFoundation Video Decoder
Using OSX 10.7+ AVFoundation Audio Decoder

Thanks.
__________________
15" Retina MBP, Adobe CC, UA Apollo
boka is offline   Reply With Quote
Old 09-30-2015, 09:29 AM   #418
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 5,538
Default

If you want to use AVCHD footage (from Panasonic and Sony cameras) in REAPER 5 you need to re-wrap the file to MOV, or transcode it. Quicktime can play the footage but resaving it will reduce the bitrate and quality.

After much searching I've figured out a good way to do this on OSX.

Media Converter app
http://media-converter.sourceforge.net/

install Re-wrap AVCHD for Quicktime - uncompressed Audio Preset

http://sourceforge.net/projects/medi...t.zip/download


Take your AVCHD file, Right-click, show package contents.
Find the BDMV file, Right-click, show package contents.
Inside this folder is the Stream folder, this your footage in .mts format
If it was a long recording it will be broken up into chunks of 4.29GB

Select the preset in Media-Converter, choose the export path in preferences, then drag & drop the .mts files onto the app.

Because it's not transcoding it should only take a minute to process the mov files.

Now these files will work in any video editing app including reaper 5 and resolve 12.
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is online now   Reply With Quote
Old 11-24-2015, 05:26 PM   #419
karmacazee
Human being with feelings
 
Join Date: Jul 2012
Posts: 6
Default

Point me to the right direction if this question has already been answered, apologies beforehand.

I work with video. I'd like to be able to scrub through my video one frame at a time using the arrow keys (left/right) no matter what my zoom settings are at.

Also , can I configure the gridlines to match the video framerate?
karmacazee is offline   Reply With Quote
Old 11-24-2015, 11:59 PM   #420
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 5,538
Default

you can set the grid to frames, yes

I use alt+ left/right to move the cursor 1 frame/grid division at a time. But you'll have to look in the action list for that
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is online now   Reply With Quote
Old 12-12-2015, 12:05 AM   #421
ecl
Human being with feelings
 
ecl's Avatar
 
Join Date: Jul 2014
Posts: 398
Default

Really hepful this thread ¡¡¡

THANKS AIRON AND EVERY BODY HERE

I could move all my simple video work from Vega to Reaper for You Tube Video Tutorial following the advices.

Video: 1280 X 800 . mov
Converted to mp4 with Stream Clip.
Exported to: lossless codec HUFFYUV
http://forum.cockos.com/showpost.php...&postcount=252

Obtained a large file and procesed it with handbrake:
For instance: 15gb .mkv ends in about 25mb mp4.

For some moments in which audio is important I splitted the item and rendered as a new take. Keep in the original track the video one and seprate the obtained audio rendered in a new trak.

Used volume envelope for silence the audio in video track without lossing the image.

I´m finishing about 20 new Reaper Tutorials in my language (Spanish) when I had them public in my Reaper´s Youtube Channel I´ll post here so you can check the results.

THANKS AGAIN ¡¡¡¡

ecl is offline   Reply With Quote
Old 12-12-2015, 11:26 AM   #422
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 5,538
Default

Quote:
Originally Posted by ecl View Post
Used volume envelope for silence the audio in video track without lossing the image.
Move the audio to a new track by duplicating the video track and glueing it.
On the video clip open source properties and ignore audio. This should let you zoom and scroll faster in the project without lag from reading the compressed audio.
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is online now   Reply With Quote
Old 12-13-2015, 03:45 AM   #423
ecl
Human being with feelings
 
ecl's Avatar
 
Join Date: Jul 2014
Posts: 398
Default

Quote:
Originally Posted by EpicSounds View Post
Move the audio to a new track by duplicating the video track and glueing it.
On the video clip open source properties and ignore audio. This should let you zoom and scroll faster in the project without lag from reading the compressed audio.
Done ¡¡¡¡¡ Fantastic ¡¡¡

Thanks Epic Sounds ¡¡¡

ecl is offline   Reply With Quote
Old 12-13-2015, 04:43 PM   #424
Twangothan
Human being with feelings
 
Twangothan's Avatar
 
Join Date: Oct 2011
Location: Hertfordshire, UK
Posts: 357
Default

I'm finding Reaper incredibly frustrating for video. On the plus side I love that the editing is the same, and I can use all my plugins for audio enhancement - I'm mostly editing footage of my or friends bands, so it's ideal. But why won't it display properly? I have simple widescreen from my camera which loads fine into MS Moviemaker, Apple's awful iMovie or even QuickTime. But Reaper screws it up, somehow. I have a 1024x576 file (that's from its properties in Finder) yet I load it in Reaper and it is squashed upwards and the source properties say it's 720x576 at 30 fps. It isn't. It's 1024x576 at 25fps. Then it renders squashed and wrong, despite entering those dimensions in the rendering. I am more than prepared to believe I am getting it wrong but I'm mystified why it is so difficult. Why doesn't it just load up the file and display the same properties? I have wasted hours on this. Can anyone suggest something to help, or do I just give up? The annoying thing is sometimes, for no apparent reason (though obviously there must be one) it works fine. But I can't recreate it in a reliable, repeatable process, which is what we want, isn't it? Or is it just really flakey and trying to get it to work is just part of the fun?
Twangothan is offline   Reply With Quote
Old 12-13-2015, 06:14 PM   #425
musicbynumbers
Human being with feelings
 
musicbynumbers's Avatar
 
Join Date: Jun 2009
Location: brighton, uk
Posts: 12,745
Default

Try going into the video tab in project settings (alt key+enter) and try limiting the dimensions there in the given setting. That might help.

Quote:
Originally Posted by Twangothan View Post
I'm finding Reaper incredibly frustrating for video. On the plus side I love that the editing is the same, and I can use all my plugins for audio enhancement - I'm mostly editing footage of my or friends bands, so it's ideal. But why won't it display properly? I have simple widescreen from my camera which loads fine into MS Moviemaker, Apple's awful iMovie or even QuickTime. But Reaper screws it up, somehow. I have a 1024x576 file (that's from its properties in Finder) yet I load it in Reaper and it is squashed upwards and the source properties say it's 720x576 at 30 fps. It isn't. It's 1024x576 at 25fps. Then it renders squashed and wrong, despite entering those dimensions in the rendering. I am more than prepared to believe I am getting it wrong but I'm mystified why it is so difficult. Why doesn't it just load up the file and display the same properties? I have wasted hours on this. Can anyone suggest something to help, or do I just give up? The annoying thing is sometimes, for no apparent reason (though obviously there must be one) it works fine. But I can't recreate it in a reliable, repeatable process, which is what we want, isn't it? Or is it just really flakey and trying to get it to work is just part of the fun?
__________________
subproject FRs click here
note: don't search for my pseudonym on the web. The "musicbynumbers" you find is not me or the name I use for my own music.
musicbynumbers is offline   Reply With Quote
Old 10-30-2016, 11:35 AM   #426
JEL
Human being with feelings
 
Join Date: Mar 2012
Posts: 34
Default

For WINDOWS users:

I was hoping for updated info on which codec to install on Windows, now that Quicktime isn't supported anymore.

https://www.us-cert.gov/ncas/alerts/TA16-105A
https://support.apple.com/kb/dl837?locale=en_US

I'm not exactly sure how to go about things after reading the first post (I tried what it says but couldn't get it to work in Reaper)

So does any Windows users have a step-by-step guide on which codec-pack to get and how to install it so Reaper5 can use it to encode H264 MP4 video with uncompressed PCM audio (and NOT quicktime MOV video, which is what it currently does with the included ffmprg/libav encoder included in Reaper by default)?

Thanks
JEL
JEL is offline   Reply With Quote
Old 10-31-2016, 04:16 AM   #427
airon
Human being with feelings
 
airon's Avatar
 
Join Date: Aug 2006
Location: Berlin
Posts: 10,384
Default

I'll go over the first post now, though I might just post a link to the Wiki entry and work on that instead, because there's no size limit like there is in this forum.

Basically Quicktime files work file by using VLC as a playback engine. I use Quicktime ProRes Proxy files for example. I produce those with TEncoder.

Remember to install the 64-bit version of VLC is you're using the 64-bit version of Reaper. Then it should all just work.
__________________
Dialogue/FX Editor & Re-Recording Mixer
(Video)Using Latch Preview
"My ego comes pre-shrunk" - Randy Thom
airon is offline   Reply With Quote
Old 11-02-2016, 10:34 AM   #428
JEL
Human being with feelings
 
Join Date: Mar 2012
Posts: 34
Default

Quote:
Originally Posted by airon View Post
I'll go over the first post now, though I might just post a link to the Wiki entry and work on that instead, because there's no size limit like there is in this forum.

Basically Quicktime files work file by using VLC as a playback engine. I use Quicktime ProRes Proxy files for example. I produce those with TEncoder.

Remember to install the 64-bit version of VLC is you're using the 64-bit version of Reaper. Then it should all just work.
Thank you
Confirming things work
JEL is offline   Reply With Quote
Old 12-11-2016, 01:06 AM   #429
airon
Human being with feelings
 
airon's Avatar
 
Join Date: Aug 2006
Location: Berlin
Posts: 10,384
Default

I generally do only the simplest of edits in Reaper when it comes to video.

For very simple titles, the video processor is ok. The more. interesting presets for the video processor make it really special though. It simply depends on what you find useful for your work.

I have Movie Studio Platinum 13, which works well. I still prefer that for my hobbyist video needs. Reaper is great for quick cuts.
__________________
Dialogue/FX Editor & Re-Recording Mixer
(Video)Using Latch Preview
"My ego comes pre-shrunk" - Randy Thom
airon is offline   Reply With Quote
Old 12-11-2016, 03:45 AM   #430
dimitris
Human being with feelings
 
Join Date: Nov 2008
Posts: 88
Default

The only thing I wish Reaper would add to video rendering is fading, i.e. fade-to/from-black and crossfading. I don't think this can be done presently, right?
dimitris is offline   Reply With Quote
Old 12-11-2016, 05:26 AM   #431
akademie
Human being with feelings
 
Join Date: Mar 2007
Posts: 549
Default

Quote:
Originally Posted by dimitris View Post
The only thing I wish Reaper would add to video rendering is fading, i.e. fade-to/from-black and crossfading. I don't think this can be done presently, right?
Hi dimitris,
for fading in/out of clips insert Videoprocessor plugin on the track and pick "item fades affect video" preset ... it will use fade in-out handles of your media clips to fade image/video ;-)

akademie
akademie is offline   Reply With Quote
Old 12-11-2016, 05:54 AM   #432
dimitris
Human being with feelings
 
Join Date: Nov 2008
Posts: 88
Default

Quote:
Originally Posted by akademie View Post
Hi dimitris,
for fading in/out of clips insert Videoprocessor plugin on the track and pick "item fades affect video" preset ... it will use fade in-out handles of your media clips to fade image/video ;-)

akademie
Hi and thanks!! I'm excited to hear that there is a video processor plugin, I didn't know about it.

However, I cannot find it, it doesn't exist in my FX list. The only reference to "video processor" I could find was in the Actions menu, there is a certain "Insert dedicated video processor item" command. But I don't suppose you meant that, I'm guessing you meant that there should be a plugin to be inserted in the track FX chain, right?

Any idea why the plugin is missing and where I can find it?
dimitris is offline   Reply With Quote
Old 12-11-2016, 06:12 AM   #433
dimitris
Human being with feelings
 
Join Date: Nov 2008
Posts: 88
Default

All the references I could find show that there is a Video Processor FX plugin, that can be inserted into the FX chain. For example: http://www.audioordeal.co.uk/2016/07...tos-music.html

The action that I mentioned only inserts an item, not a FX plugin. And it doesn't seem to affect video items on the same track (or other tracks). What am I doing wrong? :P
dimitris is offline   Reply With Quote
Old 12-11-2016, 06:30 AM   #434
akademie
Human being with feelings
 
Join Date: Mar 2007
Posts: 549
Default

dimitris,
Click on FX button of the track, now in the FX Chain window select "Add FX" from File menu... FX browser opens and here select "All Plugins" in the left tree !!! - Then the very first item in right list of plugins is "Video processor", so select it and add it.

akademie
akademie is offline   Reply With Quote
Old 12-11-2016, 06:36 AM   #435
dimitris
Human being with feelings
 
Join Date: Nov 2008
Posts: 88
Default

Quote:
Originally Posted by akademie View Post
dimitris,
Click on FX button of the track, now in the FX Chain window select "Add FX" from File menu... FX browser opens and here select "All Plugins" in the left tree !!! - Then the very first item in right list of plugins is "Video processor", so select it and add it.

akademie
It wasn't there, but I found out why. In the Options menu of the FX browser there is a section named "Show in FX list". In there there Video Processor was unchecked. I enabled it and now I can see it. Thanks for you help!
dimitris is offline   Reply With Quote
Old 12-11-2016, 06:48 AM   #436
akademie
Human being with feelings
 
Join Date: Mar 2007
Posts: 549
Default

Great that you get to it
Now there is drop-down menu in Videoprocessor FX window where you can select "presets" = effects. If you need combination of more effects, then add another Videoprocessor and ... you know.

Tip: Parameters (if given effect preset has any) can be automated ! :-D

akademie
akademie is offline   Reply With Quote
Old 12-11-2016, 07:46 AM   #437
akademie
Human being with feelings
 
Join Date: Mar 2007
Posts: 549
Default

Quote:
Originally Posted by TonE View Post
Which have? Most or few?
TonE,
"Most" of original presets from default installation have some parameters knobs (e.g. for opacity, x/y position, size, alpha, text size, contrast, brightness, R-G-B ...)

akademie
akademie is offline   Reply With Quote
Old 12-11-2016, 10:51 AM   #438
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 5,538
Default

Quote:
Originally Posted by dimitris View Post
The only thing I wish Reaper would add to video rendering is fading, i.e. fade-to/from-black and crossfading. I don't think this can be done presently, right?
Quote:
Originally Posted by akademie View Post
Hi dimitris,
for fading in/out of clips insert Videoprocessor plugin on the track and pick "item fades affect video" preset ... it will use fade in-out handles of your media clips to fade image/video ;-)

akademie
you can also automate opacity/alpha when needed. when video and audio are grouped you probably want to fade the audio to avoid clicks but you don't want the video to keep dipping to black.
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is online now   Reply With Quote
Old 12-11-2016, 11:04 AM   #439
akademie
Human being with feelings
 
Join Date: Mar 2007
Posts: 549
Default

Good point EpicSounds,
though I rarely use audio+video from the same clip. I use separate tracks for videos and separate for audios (lots of cuts and editing in audio parts).
Thanks Justin we have got more possibilities to do what we need specifically

akademie
akademie is offline   Reply With Quote
Old 12-12-2016, 05:29 AM   #440
airon
Human being with feelings
 
airon's Avatar
 
Join Date: Aug 2006
Location: Berlin
Posts: 10,384
Default

You can use a single image as a background.

For fading a video to black:

Place the video on a track and insert the video processor in the FX Chain. Choose the "Item fades affect video" preset.

Place an image that's completely black on a second track below the track with the video. Extend the item of the image by dragging one of its edges about. Make it as long as you need it.

Access the Item Properties of the black image item(F2 is the default shortcut, or right-click on the item and choose Properties).

Check the "Loop source" checkbox. It has to be on. Now you will have a black background for as long as you make the item.
__________________
Dialogue/FX Editor & Re-Recording Mixer
(Video)Using Latch Preview
"My ego comes pre-shrunk" - Randy Thom

Last edited by airon; 12-13-2016 at 01:54 PM.
airon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:02 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.