COCKOS
CONFEDERATED FORUMS
Cockos : REAPER : NINJAM : Forums
Forum Home : Register : FAQ : Members List : Search :
Old 06-18-2021, 11:48 AM   #1
luham
Human being with feelings
 
Join Date: Jun 2021
Posts: 1
Default Nimjam + MIDI piano

Hello everyone!

I have been trying to explore NimJam in Reaper with MIDI piano.

In the NimJam User Guide page 4 it is written that "Reaper [...] also provides native NINJAM support and allows you to use VST/VSTi/ReWire/MIDI hardware/etc with NINJAM"

I have been trying with a colleague to use NimJam connecting two digital pianos using MIDI interface (one local and one remote MIDI piano). However, We have noticed that xmit does not move when we are using MIDI track.

We tried to use the audio track instead of MIDI and that worked out.

Has anybody used NimJam with digital piano (MIDI piano)? If so, how could we set up the system?

I really apreciate any guidance.

Looking forward to hearing from you.

Best regards!
luham is offline   Reply With Quote
Old 06-19-2021, 01:00 AM   #2
pljones
Human being with feelings
 
pljones's Avatar
 
Join Date: Aug 2007
Location: London, UK
Posts: 746
Default

MIDI is not audio.

NINJAM transfers audio. If you've not understood what it does already, read this.

If you connect MIDI Out on your piano to your computer's MIDI In, you're receiving MIDI, not audio. So you need to turn the MIDI into audio using piano VST instrument before sending the audio to NINJAM using ReaNINJAM.

- Start Reaper
- Create a new project
- Right-click, Insert virtual instrument on new track
- From the list of instruments, pick the piano sound you want, for example mda Piano
- Check that the channel inputs say "MIDI: All channels" and if you click and hover "Input: MIDI", the next level has "All MIDI Inputs" selected - and that your MIDI input is actually list on that level above the selected item.
- Check that "Record Monitoring" is "On"
- Check that "Record" is "input (audio or MIDI)"
- Leave the "ROUTE" settings alone for now
- Check that "Record Armed" shows

When you play your MIDI keyboard now, you should see the track and master level meters respond. If you can hear audio from the MIDI keyboard itself - disable it! You want to be hearing the audio from your computer. So now check you can hear the piano sounds from your computer.

OK, so that's one piano fed to one track, routed directly to master.

I don't understand what you mean by "one local and one remote MIDI piano". Could you explain?
__________________
Quote:
Originally Posted by Tony Williams
...Playing fast around the drums is one thing. But to play with people for others, to listen to, that's something else. That's a whole other world.
pljones is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:34 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.