Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 07-17-2019, 11:28 AM   #1
Sanzy
Human being with feelings
 
Join Date: Jul 2019
Posts: 1
Default Presets for Fabfilter ProQ3 plug-in not acting properly with sidechain

Steps:
- Create track
- Add equalizer to track 2 (insert) Fabfilter ProQ3.
- Open plug-in pin connector
- Press I/O
- Request VST3 bus channel count
- Click stereo
- Close "plug-in pin connector" window
- Press plus
- Save preset as default

later on...

- Create 2 tracks.
- Routing sidechain track 1 into track 2 (audio channel: 3/4, 5/6 maybe others work as well)
- Add equalizer to track 2 (insert) Fabfilter ProQ3.
- Open plug-in pin connector
- Press I/O
- Request VST3 bus channel count
- (Bug here) Stereo appears to be checked but you have to click it so it really is selected.

Not sure if it is your bug or ProQ3 bug

ProQ3 takes channels 3/4 not as side chain but as channels for surround system. But if we want to use those as side chain then we have to force stereo in VST3 version of plugin so those channels are used as side chain. If side chain is added before ProQ3 then the preset for stereo doesn't work properly. On the other hand if ProQ3 is already present on a track then the preset works properly.

The main problem with the plugin is that the channels 3/4 placed on the track trigger dynamic equalization points intended for channel 1/2. for this, it is necessary to include forced stereo, so that channels 3/4 would not be perceived as surround channels. But while saving the preset, such an annoying bug comes out.

My config:
- Xeon x3480
- DDR3 1600 32 gb
- Windows 10 ver. 1809
- Reaper ver. 5.980
- Fabfilter Pro Q3 ver. 3.10

Last edited by Sanzy; 07-19-2019 at 02:21 PM.
Sanzy is offline   Reply With Quote
Old 07-19-2019, 01:24 AM   #2
multibody
Human being with feelings
 
Join Date: Oct 2016
Location: Germany
Posts: 115
Default

Same problem here. Since I only work in stereo it is very annoying to request the vst3-channel count for each Pro-Q3 instance.
multibody is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:46 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.