Old 07-23-2019, 01:26 PM   #1
Mark King
Human being with feelings
 
Mark King's Avatar
 
Join Date: Sep 2011
Location: Indiana
Posts: 28
Default Why does my Windows 10/Reaper hate ASIO?

This is all way over my head, but I keep paddling. My system is:

Up-to-date Windows 10 64-bit
Core i7-3770 3.40GHz 64-bit
10 GB RAM

Up-to-date Reaper

I've installed ASIO4ALL. I've tried to use ASIO, but it doesn't seem to allow anything to happen. Used some of the others just for giggles -- only WaveOut and DirectSound allow me to even use Reaper. Am now using a Behringer UMC404 as my interface. DirectSound is the only thing working with this setup.

Bottom line is I can never get my buffers down below 8 x 512, 92 ms. Which is pretty horrible for playing keyboard. Any suggestions? Thanks! <3
Attached Images
File Type: png Reaper_Audio_Device_Prefs_7-23-19.png (37.0 KB, 12 views)
Mark King is offline   Reply With Quote
Old 07-23-2019, 02:21 PM   #2
Ollie
Super Moderator (no feelings)
 
Ollie's Avatar
 
Join Date: Dec 2007
Location: On or near a dike
Posts: 9,730
Default

If I understood that right the UMC-404 has native ASIO drivers you should use instead of ASIO4ALL:

https://www.behringer.com/Categories...oogtrans(en|en)
Ollie is offline   Reply With Quote
Old 07-23-2019, 02:35 PM   #3
Mark King
Human being with feelings
 
Mark King's Avatar
 
Join Date: Sep 2011
Location: Indiana
Posts: 28
Default

I may have found a sort-of solution. See attached gif. ASIO4ALL has a control panel (accessible within Reaper audio settings) and I was able to choose the UMC404, etc. and a 256 buffer came up as default. The Reaper settings still say "512" but things seem to work in Reaper with an occasional slight delay at playback start. Recording MIDI keyboard/VST is lovely at 256 buffer setting. However, no other sound source (internet browser, audio player, etc) will emit sound with ASIO chosen -- my choices in Reaper's settings evidently globally control audio for the computer (?). So when I leave Reaper, it seems I must re-set the Reaper audio settings back to DirectSound to have typical PC audio. Good grief
Mark King is offline   Reply With Quote
Old 07-23-2019, 02:38 PM   #4
Mark King
Human being with feelings
 
Mark King's Avatar
 
Join Date: Sep 2011
Location: Indiana
Posts: 28
Default

Quote:
Originally Posted by Ollie View Post
If I understood that right the UMC-404 has native ASIO drivers you should use instead of ASIO4ALL:

https://www.behringer.com/Categories...oogtrans(en|en)
Thanks!!! I just found that "UMC ASIO" choice in Reaper dialog. Am about to try it...

AND IT WORKS BEAUTIFULLY! Ollie, thanks for the nudge to the newbie! It's amazing the emotional roller coaster this kind of problem-solving can be, lol.
Mark King is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:53 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.