Old 09-15-2019, 03:43 AM   #4681
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,677
Default

Quote:
Originally Posted by mschnell View Post
Very obviously different project will use different plugins and/or the same plugins in different tracks or in a different position or count in the FX chains.
When you map plugins, you are not mapping to a particular track or position, that would be project specific.

You are mapping how a plugin behaves with your surface(s) in all projects.

Quote:
Originally Posted by mschnell View Post
It seems that a purely general setup of CSI would not be able to cope with that.
Why not, that's exactly what it is meant to do -- be part of your own customized setup across all projects -- for this Page , don't forget you can have as many Pages as you want.


Quote:
Originally Posted by mschnell View Post
OTOH much of the setup for CSI will not the same for all projects.
Why not ?

Quote:
Originally Posted by mschnell View Post
In fact it seems to depend on the user how "variable" he will do the layout of their projects.

-Michael
Right, but that will tend to be the same for all projects, or at least all projects of a given flavour.

Pages are good for setting up different flavours.

Have you downloaded and tried the software ?
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is offline   Reply With Quote
Old 09-15-2019, 03:48 AM   #4682
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,677
Default

Quote:
Originally Posted by Freex View Post
So how are we defining Surface widgets?
For OSC, there are:
Control
FB_Processor

That's it

Quote:
Originally Posted by Freex View Post
How do I get Shift to Toggle on/off?
You could do this:
Code:
Shift+Toggle+Press+someButton some Action
but since Toggle implies Press, you don't need it, it is added automatically internally.

That means your .zon files that use Toggle don't need Press and they will look more familiar and be more portable:

Code:
Shift+Toggle+someButton some Action
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is offline   Reply With Quote
Old 09-15-2019, 05:07 AM   #4683
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 815
Default

Same as last one, but updated for Windows (forgot to update the Windows save sub. Sorry)

Last edited by MixMonkey; 09-27-2019 at 11:46 AM.
MixMonkey is online now   Reply With Quote
Old 09-15-2019, 05:44 AM   #4684
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,677
Default

Hey @MixMonkey, would like your thoughts on the following:

If we always wrote out CR+LF, and stripped CR on the way in -- CSI strip would do nothing in Windows as CR is already gone -- but CSI would strip the CR on Mac.

Seems like that would give us cross platform for raw FX and .zon files.

Does that make any sense, or is there some other nefarious stuff in play ?
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is offline   Reply With Quote
Old 09-15-2019, 05:59 AM   #4685
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 815
Default

Quote:
Originally Posted by Geoff Waddington View Post
Hey @MixMonkey, would like your thoughts on the following:

If we always wrote out CR+LF, and stripped CR on the way in -- CSI strip would do nothing in Windows as CR is already gone -- but CSI would strip the CR on Mac.

Seems like that would give us cross platform for raw FX and .zon files.

Does that make any sense, or is there some other nefarious stuff in play ?
Always writing out CR+LF seems to be the best way of ensuring cross platform compatibility, as at the moment CSIMac seems to ignore the CR anyway- so if you need to add an additional strip step for another reason I don't see a problem. As long as CR+LF are both present in the rawFX and .zon files, WindowsCSI seems to be happy.

The whole EOL thing is a sh** sh**, so just try it and let's see what happens

On a related note, when writing the Configurator, I discovered that Excel on Mac insists on adding an (invisible) CR to the end of the result of every cell formula. This means that comparisons in the code fail for no obvious reason (until I realised what was happening) and now my sheet and code formula are full of CLEAN commands to strip out the CR so that the comparisons work.
MixMonkey is online now   Reply With Quote
Old 09-15-2019, 06:11 AM   #4686
mschnell
Human being with feelings
 
mschnell's Avatar
 
Join Date: Jun 2013
Location: Krefeld, Germany
Posts: 7,872
Default

Quote:
Originally Posted by Geoff Waddington View Post
can have as many Pages as you want.
OK, So you would create pages that fit with the types projects you use.

Might be a reasonable way.
-Michael
mschnell is online now   Reply With Quote
Old 09-15-2019, 08:53 AM   #4687
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,677
Default

Quote:
Originally Posted by MixMonkey View Post
Always writing out CR+LF seems to be the best way of ensuring cross platform compatibility, as at the moment CSIMac seems to ignore the CR anyway- so if you need to add an additional strip step for another reason I don't see a problem. As long as CR+LF are both present in the rawFX and .zon files, WindowsCSI seems to be happy.

The whole EOL thing is a sh** sh**, so just try it and let's see what happens

On a related note, when writing the Configurator, I discovered that Excel on Mac insists on adding an (invisible) CR to the end of the result of every cell formula. This means that comparisons in the code fail for no obvious reason (until I realised what was happening) and now my sheet and code formula are full of CLEAN commands to strip out the CR so that the comparisons work.
Man, you would think after a mere 30-40 years they would have sorted this out.
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is offline   Reply With Quote
Old 09-15-2019, 08:54 AM   #4688
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,677
Default

New build is up.

You should see no difference, just adding CR characters for cross platform compatibility -- let me know if anything broke
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is offline   Reply With Quote
Old 09-16-2019, 03:15 AM   #4689
MalcolmG
Human being with feelings
 
MalcolmG's Avatar
 
Join Date: Jun 2015
Location: Sydney, Australia
Posts: 104
Default Cross-surface Modifiers

Just wondering if Modifiers are meant to work across surfaces? ie. Can I use Shift on one surface to modify a Widget on another?

If it is meant to work, I can't seem to make it.

I have the following widget defined in my AlphaTrack.mst

Code:
Widget Shift 
	Press 90 46 7f 90 46 00
WidgetEnd
Then in my BCF2000.mst I have:
Code:
Widget UpperButton1 
    Press 90 20 7f  90 20 00
    FB_TwoState 90 20 7f  90 20 00
WidgetEnd
In my BCF2000Left.zon I have:
Code:
Zone Channel|1-8 
	TrackNavigator
	RotaryG1| TrackPan
	UpperButton| TrackSelect
	Shift+UpperButton| TrackSolo 
	LowerButton| TrackRecordArm
	Fader|  TrackVolume
ZoneEnd
Everything works fine, except holding down the Shift button on the AlphaTrack while pressing the button on my BCF doesn't seem to trigger anything. The button by itself is triggering TrackSelect ok.

Anything obvious?

UPDATE: Solved, thanks to Freex below. Need to add Shift Shift to any zone that uses Shift
__________________
My CSI Notes wiki : https://github.com/malcolmgroves/reaper_csi/wiki

Last edited by MalcolmG; 09-16-2019 at 04:37 AM.
MalcolmG is offline   Reply With Quote
Old 09-16-2019, 03:34 AM   #4690
MalcolmG
Human being with feelings
 
MalcolmG's Avatar
 
Join Date: Jun 2015
Location: Sydney, Australia
Posts: 104
Default Few questions on Zones

I have a few, probably basic, questions on Zones that I haven't been able to answer by searching through the forum:

- I'm assuming that the Home zone is a special zone, in that CSI looks for this on first loading and makes it the "starting" zone. Is this correct? Otherwise, I can't see how my setup knows to begin with this one.

- I can see how to load a new zone (using GoZone). However I don't see how to return to the previous zone, other than explicitly saying GoZone back to the previous one?

- Possibly related to the last one, I'm wondering why some zones define a ParentZone, but then not all do. Haven't been able to spot the key difference as to why.

- From what I've done so far it seems that Zones are cross-surface. Obviously a .zon file is specific to a surface, but if you define two zones in two different surfaces both with the same name, and then in one surface you call GoZone on that zone name, it'll load the zone on both surfaces. Is this correct?

- What's the difference between GoZone and GoSubZone? I can't find an example of GoSubZone being used , but I picked it up from somewhere. Maybe in an old version and it's since been deprecated?
__________________
My CSI Notes wiki : https://github.com/malcolmgroves/reaper_csi/wiki
MalcolmG is offline   Reply With Quote
Old 09-16-2019, 03:43 AM   #4691
Freex
Human being with feelings
 
Freex's Avatar
 
Join Date: Jul 2011
Location: Northern Ireland
Posts: 572
Default

Quote:
Originally Posted by MalcolmG View Post
Just wondering if Modifiers are meant to work across surfaces? ie. Can I use Shift on one surface to modify a Widget on another?

If it is meant to work, I can't seem to make it.

I have the following widget defined in my AlphaTrack.mst

Code:
Widget Shift 
	Press 90 46 7f 90 46 00
WidgetEnd
Then in my BCF2000.mst I have:
Code:
Widget UpperButton1 
    Press 90 20 7f  90 20 00
    FB_TwoState 90 20 7f  90 20 00
WidgetEnd
In my BCF2000Left.zon I have:
Code:
Zone Channel|1-8 
	TrackNavigator
	RotaryG1| TrackPan
	UpperButton| TrackSelect
	Shift+UpperButton| TrackSolo 
	LowerButton| TrackRecordArm
	Fader|  TrackVolume
ZoneEnd
Everything works fine, except holding down the Shift button on the AlphaTrack while pressing the button on my BCF doesn't seem to trigger anything. The button by itself is triggering TrackSelect ok.

Anything obvious?
From my experience you need to have the surfaces sync'd and of course you need the
Quote:
shift+somecontrol someaction
in the BCF zone.
Freex is offline   Reply With Quote
Old 09-16-2019, 03:49 AM   #4692
MalcolmG
Human being with feelings
 
MalcolmG's Avatar
 
Join Date: Jun 2015
Location: Sydney, Australia
Posts: 104
Default What Message Generator to use for this?

I have a FCB1010, which is a foot controller. It has a bunch of foot switches and two expression pedals. One of the expression pedals maps perfectly as a Fader7Bit, the other one is a bit odd.

Basically anytime it moves in the bottom half of its range, it transmits ba 0a 00. Regardless of whether it is increasing or decreasing, as long as it is under half way, it sends that same message

Equally, if it is in the top half of its range, it sends ba 0a 01. Again, regardless of whether it is increasing or decreasing.

This seems really odd. If it sent 00 when decreasing and 01 when increasing, that would make sense. I've tried resetting it back to default settings, but still the same behavior.

Anyone seen a control like this before? Any idea how I define it as a widget?
__________________
My CSI Notes wiki : https://github.com/malcolmgroves/reaper_csi/wiki
MalcolmG is offline   Reply With Quote
Old 09-16-2019, 03:51 AM   #4693
MalcolmG
Human being with feelings
 
MalcolmG's Avatar
 
Join Date: Jun 2015
Location: Sydney, Australia
Posts: 104
Default

Quote:
Originally Posted by Freex View Post
From my experience you need to have the surfaces sync'd and of course you need the in the BCF zone.
Thanks Freex,

It's in the BCF zone, but can you expand on the "surfaces sync'd" part? How do you do that?

Cheers
Malcolm
__________________
My CSI Notes wiki : https://github.com/malcolmgroves/reaper_csi/wiki
MalcolmG is offline   Reply With Quote
Old 09-16-2019, 03:52 AM   #4694
Freex
Human being with feelings
 
Freex's Avatar
 
Join Date: Jul 2011
Location: Northern Ireland
Posts: 572
Default

Quote:
Originally Posted by MalcolmG View Post
I have a few, probably basic, questions on Zones that I haven't been able to answer by searching through the forum:

- I'm assuming that the Home zone is a special zone, in that CSI looks for this on first loading and makes it the "starting" zone. Is this correct? Otherwise, I can't see how my setup knows to begin with this one.

- I can see how to load a new zone (using GoZone). However I don't see how to return to the previous zone, other than explicitly saying GoZone back to the previous one?

- Possibly related to the last one, I'm wondering why some zones define a ParentZone, but then not all do. Haven't been able to spot the key difference as to why.

- From what I've done so far it seems that Zones are cross-surface. Obviously a .zon file is specific to a surface, but if you define two zones in two different surfaces both with the same name, and then in one surface you call GoZone on that zone name, it'll load the zone on both surfaces. Is this correct?

- What's the difference between GoZone and GoSubZone? I can't find an example of GoSubZone being used , but I picked it up from somewhere. Maybe in an old version and it's since been deprecated?
To get back to HomeZone you need to have a GoZone Home,
so in the Home zone you may have "somebutton GoZone AnotherZone", in AnotherZone you can use the same button to say "GoZone Home".

All Zones are "loaded" on startup so they're ready to go. If you have the surfaces sync'd and have a Zone in both surfaces with the same name, AFAIK a GoZone will not discriminate it will load the zone(s).

SubZone was used as a term rather than a command when you have FXzone and have goZones within that zone we term them as subzones or child zones there is no command other than GoZone
Freex is offline   Reply With Quote
Old 09-16-2019, 03:58 AM   #4695
MalcolmG
Human being with feelings
 
MalcolmG's Avatar
 
Join Date: Jun 2015
Location: Sydney, Australia
Posts: 104
Default

Quote:
Originally Posted by Freex View Post
To get back to HomeZone you need to have a GoZone Home,
so in the Home zone you may have "somebutton GoZone AnotherZone", in AnotherZone you can use the same button to say "GoZone Home".
yeah, that's what I thought. However this has the restriction that if I have two zones, A and B, that both GoZone C, in C I don't have a way to say "GoZone whoever called me"

Quote:
SubZone was used as a term rather than a command when you have FXzone and have goZones within that zone we term them as subzones or child zones there is no command.
Hmmm, ok, that's weird. I picked it up as an Action from somewhere, but doesn't seem to be mentioned anywhere now. Probably means I can stop wondering what it does :-)
__________________
My CSI Notes wiki : https://github.com/malcolmgroves/reaper_csi/wiki
MalcolmG is offline   Reply With Quote
Old 09-16-2019, 03:59 AM   #4696
Freex
Human being with feelings
 
Freex's Avatar
 
Join Date: Jul 2011
Location: Northern Ireland
Posts: 572
Default

Quote:
Originally Posted by MalcolmG View Post
Thanks Freex,

It's in the BCF zone, but can you expand on the "surfaces sync'd" part? How do you do that?

Cheers
Malcolm
In Config of CSI
Reaper Options>preferences>Control/OCS/Web.
Control Surface Integrator
You now see Page and surface (sometimes you need to click on the page to show surfaces, in edit for each surface there's a tick box "sync zones across surfaces"
Freex is offline   Reply With Quote
Old 09-16-2019, 04:01 AM   #4697
MalcolmG
Human being with feelings
 
MalcolmG's Avatar
 
Join Date: Jun 2015
Location: Sydney, Australia
Posts: 104
Default

Quote:
Originally Posted by Freex View Post
In Config of CSI
Reaper Options>preferences>Control/OCS/Web.
Control Surface Integrator
You now see Page and surface (sometimes you need to click on the page to show surfaces, in edit for each surface there's a tick box "sync zones across surfaces"
Ahhh, OK, that's the UseZoneLink in CSI.INI. Didn't know it by that other name.

Unfortunately that was turned on, so still no joy on the cross-surface Shift.
__________________
My CSI Notes wiki : https://github.com/malcolmgroves/reaper_csi/wiki
MalcolmG is offline   Reply With Quote
Old 09-16-2019, 04:02 AM   #4698
Freex
Human being with feelings
 
Freex's Avatar
 
Join Date: Jul 2011
Location: Northern Ireland
Posts: 572
Default

Quote:
Originally Posted by MalcolmG View Post
yeah, that's what I thought. However this has the restriction that if I have two zones, A and B, that both GoZone C, in C I don't have a way to say "GoZone whoever called me"
Have you tried putting "Somebutton GoZone Home" in the C zone?

In FXZones I use 2 buttons, one for forward one of back, Zone 1 back does nothing forward puts me into zone 2, in zone 2 back sends me to zone 1 again, forwardd puts me to zone 3 and so on,

You can also have them cycle, so if you had A B & C
in A
back GoZone C
Forward GoZone B

in B
back GoZone C
Forward GoZone A

in C
back GoZone B
Forward GoZone A

sounds weird but you end up with a loop, either button can cycle thru but you can also back and forth.
Freex is offline   Reply With Quote
Old 09-16-2019, 04:07 AM   #4699
MalcolmG
Human being with feelings
 
MalcolmG's Avatar
 
Join Date: Jun 2015
Location: Sydney, Australia
Posts: 104
Default

Quote:
Originally Posted by Freex View Post
Have you tried putting "Somebutton GoZone Home" in the C zone?
Yeah, it seems to take me back to my Home zone, rather than the zone that invoked GoZone C to get me there.
__________________
My CSI Notes wiki : https://github.com/malcolmgroves/reaper_csi/wiki
MalcolmG is offline   Reply With Quote
Old 09-16-2019, 04:08 AM   #4700
Freex
Human being with feelings
 
Freex's Avatar
 
Join Date: Jul 2011
Location: Northern Ireland
Posts: 572
Default

Quote:
Originally Posted by MalcolmG View Post
Ahhh, OK, that's the UseZoneLink in CSI.INI. Didn't know it by that other name.

Unfortunately that was turned on, so still no joy on the cross-surface Shift.
AHHH You also need shift defined in the Zone "Shift Shift" even thou it doesn't have a shift, because you want to use it.
Freex is offline   Reply With Quote
Old 09-16-2019, 04:10 AM   #4701
MalcolmG
Human being with feelings
 
MalcolmG's Avatar
 
Join Date: Jun 2015
Location: Sydney, Australia
Posts: 104
Default

Quote:
Originally Posted by Freex View Post
In FXZones I use 2 buttons, one for forward one of back, Zone 1 back does nothing forward puts me into zone 2, in zone 2 back sends me to zone 1 again, forwardd puts me to zone 3 and so on,

You can also have them cycle, so if you had A B & C
in A
back GoZone C
Forward GoZone B

in B
back GoZone C
Forward GoZone A

in C
back GoZone B
Forward GoZone A

sounds weird but you end up with a loop, either button can cycle thru but you can also back and forth.
I think this is what I'll do in the mean time. I'd kind of been thinking of zones as a stack, and that I could just pop the top off the stack and go back to the calling zone, but maybe not. Meantime I'll just name them explicitly.

Thanks for your help mate, appreciate the responses.
__________________
My CSI Notes wiki : https://github.com/malcolmgroves/reaper_csi/wiki
MalcolmG is offline   Reply With Quote
Old 09-16-2019, 04:12 AM   #4702
Freex
Human being with feelings
 
Freex's Avatar
 
Join Date: Jul 2011
Location: Northern Ireland
Posts: 572
Default

Quote:
Originally Posted by MalcolmG View Post
Yeah, it seems to take me back to my Home zone, rather than the zone that invoked GoZone C to get me there.
what you're looking was deemed a bit of a rabbit warren or maze in the design, with subzones and subsubzones etc,

If you need to get to A or B from C then in C put two buttons as GoZone A and GoZone B
Freex is offline   Reply With Quote
Old 09-16-2019, 04:14 AM   #4703
MalcolmG
Human being with feelings
 
MalcolmG's Avatar
 
Join Date: Jun 2015
Location: Sydney, Australia
Posts: 104
Default

Quote:
Originally Posted by Freex View Post
AHHH You also need shift defined in the Zone "Shift Shift" even thou it doesn't have a shift, because you want to use it.
The more I reread that sentence, the more it makes me laugh :-)

So if I get what you're saying, in my BCF .zon, I would define something like this:

Code:
Zone Channel|1-8 
	TrackNavigator
	RotaryG1| TrackPan
	UpperButton| TrackSelect
        Shift Shift
	Shift+UpperButton| TrackSolo 
	LowerButton| TrackRecordArm
	Fader|  TrackVolume
ZoneEnd
Have I understood right?
__________________
My CSI Notes wiki : https://github.com/malcolmgroves/reaper_csi/wiki
MalcolmG is offline   Reply With Quote
Old 09-16-2019, 04:28 AM   #4704
MalcolmG
Human being with feelings
 
MalcolmG's Avatar
 
Join Date: Jun 2015
Location: Sydney, Australia
Posts: 104
Default

Quote:
Originally Posted by Freex View Post
AHHH You also need shift defined in the Zone "Shift Shift" even thou it doesn't have a shift, because you want to use it.
Yep, that did it. Thanks mate, you're a champion!
__________________
My CSI Notes wiki : https://github.com/malcolmgroves/reaper_csi/wiki
MalcolmG is offline   Reply With Quote
Old 09-16-2019, 05:11 AM   #4705
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,677
Default

Quote:
Originally Posted by MalcolmG View Post
I think this is what I'll do in the mean time. I'd kind of been thinking of zones as a stack, and that I could just pop the top off the stack and go back to the calling zone, but maybe not. Meantime I'll just name them explicitly.

Thanks for your help mate, appreciate the responses.
Yup, we started out with that in mind, that's why you are recalling SubZones, etc.

Turned out to be a quagmire.

Pop means put the state back to what is was before this -- that implies you have to keep the "state before this" somewhere -- that is complicated by the "shape" of Zone definitions -- it is entirely possible to get a situation where, because of the "shape" (aka definitions) of a Zone, Go Previous means restore control A to the Zone new down on the stack, but since B wasn't defined in that Zone it would mean restore B to the Zone 2 back down the stack -- add to that considerations for more than just pop -- certain operations would make it necessary to yank things out of the middle of the stack -- then there's the... -- well no need to go on, the stack concept got scrapped after a long battle to keep it alive, mostly by me Fortunately cooler heads prevailed, thanks @MixMonkey, and @Freex and others, who were a tremendous help
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is offline   Reply With Quote
Old 09-16-2019, 05:13 AM   #4706
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,677
Default

Shift works just fine cross-surface here, suggest Zone definitions/activations are causing you to have to redefine Shift.

Is something like GoZone causing a redefinition/loss of definition on the Surface with the original Shift definition ?
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is offline   Reply With Quote
Old 09-16-2019, 08:55 AM   #4707
Freex
Human being with feelings
 
Freex's Avatar
 
Join Date: Jul 2011
Location: Northern Ireland
Posts: 572
Default

Quote:
Originally Posted by MalcolmG View Post
Yep, that did it. Thanks mate, you're a champion!
Yes there are lots of, AHHHH momonets with CSI and more to come I'm sure, but getting things working is always a great feeling.

As you will realise,(if you haven't already) the design architecture Geoff has created is only limited by your imagination, there are ways an means to do most things, and workarounds for the rest lol.

Somethings make no sense on the surface, but they really do when you think of what you're asking it to do.

With the Shift for example, your asking a surface that has no definition for "Shift" means to "Shift+somecontrol", so you need to explain Shift means Shift,


Glad you got it working. Happy to help.
Freex is offline   Reply With Quote
Old 09-16-2019, 09:33 AM   #4708
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 815
Default

Quote:
Originally Posted by Geoff Waddington View Post
Man, you would think after a mere 30-40 years they would have sorted this out.
This kind of technological breakthrough needs at least a century, with five generations or more of MS employees passing the knowledge down.

Quote:
New build is up.

You should see no difference, just adding CR characters for cross platform compatibility -- let me know if anything broke
Nothing broke, but you've ended up in exactly the same bind as I did

On Mac, LearnMode writes out exactly as you want, finishing every line with CR+LF. On Windows, however, you now get CR at the end of the line and on a new line you get CR+LF. Was that the intention? and to then strip out that extra CR?

My solution was to have separate subs to write out the file for Win and Mac. On Mac you add the CR, on Windows you don't. Then the files are identical, regardless of whether they're created on Win or Mac.
MixMonkey is online now   Reply With Quote
Old 09-16-2019, 09:38 AM   #4709
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,677
Default

Quote:
Originally Posted by Freex View Post
With the Shift for example, your asking a surface that has no definition for "Shift" means to "Shift+somecontrol", so you need to explain Shift means Shift.
Yeah, except it works fine here, including with 'Synch Zones Across Surfaces" unchecked.

If I Press Shift on the Avid Control, the Console 1 has Shifted behaviour.

i'm also staring at the code, and it clearly operates on a Page level, not a Surface level.

Yet, somehow it doesn't work for you and @MalcolmG.

The only thing I can think of is that the Shift key definitions on the other Surface are somehow getting changed, interesting problem...
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is offline   Reply With Quote
Old 09-16-2019, 09:46 AM   #4710
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,677
Default

Quote:
Originally Posted by MixMonkey View Post
Nothing broke, but you've ended up in exactly the same bind as I did

On Mac, LearnMode writes out exactly as you want, finishing every line with CR+LF. On Windows, however, you now get CR at the end of the line and on a new line you get CR+LF. Was that the intention? and to then strip out that extra CR?
Nope, lazy programmer, I was prepending lines with line feed, which is the same as appending them to the line before -- not so with CR -- Grrr...


Quote:
Originally Posted by MixMonkey View Post
My solution was to have separate subs to write out the file for Win and Mac. On Mac you add the CR, on Windows you don't. Then the files are identical, regardless of whether they're created on Win or Mac.
Yup, gonna have to resort to something like that

Code:
string GetLineEnding()
{
#ifdef WIN32
      return "\n";
#else
      return "\r\n" ;
#endif
}
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is offline   Reply With Quote
Old 09-16-2019, 09:49 AM   #4711
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 815
Default

Quote:
Originally Posted by Geoff Waddington View Post
Nope, lazy programmer, I was prepending lines with line feed, which is the same as appending them to the line before -- not so with CR -- Grrr...




Yup, gonna have to resort to something like that

Code:
string GetLineEnding()
{
#ifdef WIN32
      return "\n";
#else
      return "\r\n" ;
#endif
}
Or WIN64 ?
MixMonkey is online now   Reply With Quote
Old 09-16-2019, 10:02 AM   #4712
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,677
Default

Quote:
Originally Posted by MixMonkey View Post
Or WIN64 ?
Nah, it's typical MS BS -- WIN32 is defined for BOTH 32 bit and 64 bit, BUT WIN64 is ONLY defined for 64 bit

Anyway, that code is now working and will be in the next build, so we'll see if I got it right
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is offline   Reply With Quote
Old 09-16-2019, 12:10 PM   #4713
pepe44
Human being with feelings
 
pepe44's Avatar
 
Join Date: Jul 2013
Location: Portugal
Posts: 638
Default

ok, here comes the CSI noob
i managed to get it working the plugins on the X touch with the code you guys gave me. NICE. i noticed that there is a new version with the learn mode. i installed the latest version , couldnt get it to work.
i have my plugin window focused but no learn windows opens.
Is there anything else i should do ?
sorry guys, i know i have not has much knowledge in this subjuct has you guys that do programming and have been working with CSI for a long time.
Thanks in advanced.
__________________
Intel core i7 6700K - socket 1151 LGA - Chipset z170 - 16G DDR4 - Nvidia GTX 1060
pepe44 is online now   Reply With Quote
Old 09-16-2019, 12:52 PM   #4714
Freex
Human being with feelings
 
Freex's Avatar
 
Join Date: Jul 2011
Location: Northern Ireland
Posts: 572
Default

Quote:
Originally Posted by Geoff Waddington View Post
Yeah, except it works fine here, including with 'Synch Zones Across Surfaces" unchecked.

If I Press Shift on the Avid Control, the Console 1 has Shifted behaviour.

i'm also staring at the code, and it clearly operates on a Page level, not a Surface level.

Yet, somehow it doesn't work for you and @MalcolmG.

The only thing I can think of is that the Shift key definitions on the other Surface are somehow getting changed, interesting problem...
Mine works fine, but I have shift defined on both surfaces because both have a shift button,
@MalcolmG has one with shift button and one without, so the shift function wasn't defined on the second surface. That was my thinking anyway, and he seems to have got it working.

Have you shift defined on the console1? Console1 doesn't have a shift button correct?

Last edited by Freex; 09-16-2019 at 01:05 PM.
Freex is offline   Reply With Quote
Old 09-16-2019, 01:33 PM   #4715
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 815
Default

Quote:
Originally Posted by pepe44 View Post
ok, here comes the CSI noob
i managed to get it working the plugins on the X touch with the code you guys gave me. NICE.
Great Do the displays work ok? (plugin parameter name/value)

Quote:
i noticed that there is a new version with the learn mode. i installed the latest version , couldnt get it to work.
i have my plugin window focused but no learn windows opens.
Is there anything else i should do ?
To open the learn window, you need to assign a button:
Code:
SomeButton ToggleLearnMode
By all means familiarise yourself with the Learn window, but LearnMode itself is still being developed, so it might be a while before you can map plugins with it.

Quote:
sorry guys, i know i have not has much knowledge in this subjuct has you guys that do programming and have been working with CSI for a long time.
Thanks in advanced.
No problem Once get the hang of how Zones work and have mapped few plugins it will seem a lot easier
MixMonkey is online now   Reply With Quote
Old 09-16-2019, 01:36 PM   #4716
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 815
Default

Quote:
Originally Posted by Freex View Post
Mine works fine, but I have shift defined on both surfaces because both have a shift button,
@MalcolmG has one with shift button and one without, so the shift function wasn't defined on the second surface. That was my thinking anyway, and he seems to have got it working.
Me too. Press Shift on the C4 and I see all the auto lights on the MCU come on (Shifted behaviour, no ZoneLink). Both surfaces have Shift definitions in their Zones.
MixMonkey is online now   Reply With Quote
Old 09-16-2019, 01:38 PM   #4717
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 815
Default

Quote:
Originally Posted by Geoff Waddington View Post
Nah, it's typical MS BS -- WIN32 is defined for BOTH 32 bit and 64 bit, BUT WIN64 is ONLY defined for 64 bit

Anyway, that code is now working and will be in the next build, so we'll see if I got it right
I suppose we should be grateful they still support 32 bit, Apple have just killed support for it.
MixMonkey is online now   Reply With Quote
Old 09-16-2019, 02:01 PM   #4718
Freex
Human being with feelings
 
Freex's Avatar
 
Join Date: Jul 2011
Location: Northern Ireland
Posts: 572
Default

C4emu OSC HELLLLLLPPPPPP

I'm on latest build, I've added the press+ (i think in the correct place)

What used to work doesn't, I was testing with fabfilter, now it doesn't even load the setting on the tablet

If I'm in learn mode, and move a control I see it highlighted but no zone is loading or showing any links to actions.

Also I can see the shift keys in the ParamViewWindow but they don't register in the learn as being pressed,

If i use Press+Shift Shift I see 1 on press and 0 on release
If i use Toggle+Shift Shift I see 1 on press there is never a 0 off. So when it was working as soon as I pressed Shift the display changed to show shift params but just stayed like that.

If I hold down Bank I see the other windows fill.

Its all a bit hit and miss.

Play and stop are working (and EQ to open learn mode). But again i only see the other windows in Learn mode fill when i hold them down.

Now after a minute or 5 the windows are being populated and staying when i press the bank buttons while others only while i hold. and then it's gone again. WTF

Last edited by Freex; 09-16-2019 at 02:21 PM.
Freex is offline   Reply With Quote
Old 09-16-2019, 02:38 PM   #4719
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,677
Default

Quote:
Originally Posted by Freex View Post
Mine works fine, but I have shift defined on both surfaces because both have a shift button,
@MalcolmG has one with shift button and one without, so the shift function wasn't defined on the second surface. That was my thinking anyway, and he seems to have got it working.

Have you shift defined on the console1? Console1 doesn't have a shift button correct?
Right it doesn't have a Shift.

The Shift function doesn't have to be defined for each Surface -- Shift is at a Page level.

Whatever Surface you Press Shift on doesn't matter -- any Shift pressed on any Surface Shifts the whole Page.
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is offline   Reply With Quote
Old 09-16-2019, 02:41 PM   #4720
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 3,677
Default

Quote:
Originally Posted by Freex View Post
C4emu OSC HELLLLLLPPPPPP

I'm on latest build, I've added the press+ (i think in the correct place)

What used to work doesn't, I was testing with fabfilter, now it doesn't even load the setting on the tablet

If I'm in learn mode, and move a control I see it highlighted but no zone is loading or showing any links to actions.

Also I can see the shift keys in the ParamViewWindow but they don't register in the learn as being pressed,

If i use Press+Shift Shift I see 1 on press and 0 on release
If i use Toggle+Shift Shift I see 1 on press there is never a 0 off. So when it was working as soon as I pressed Shift the display changed to show shift params but just stayed like that.

If I hold down Bank I see the other windows fill.

Its all a bit hit and miss.

Play and stop are working (and EQ to open learn mode). But again i only see the other windows in Learn mode fill when i hold them down.

Now after a minute or 5 the windows are being populated and staying when i press the bank buttons while others only while i hold. and then it's gone again. WTF
Please post the contents of your .ost and .zon files immediately, before any more stress is incurred

Seriously, post 'em and we'll get you sorted.
__________________
CSI - You can donate here: geoffwaddington.ca
Alpha software: https://stash.reaper.fm/v/36903/CSI%20alpha.zip
Reaper forum thread: https://forum.cockos.com/showthread.php?t=183143
Geoff Waddington is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:33 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.