Go Back   Cockos Incorporated Forums > REAPER Forums > MIDI Hardware, Control Surfaces, and OSC

Reply
 
Thread Tools Display Modes
Old 04-19-2020, 04:34 PM   #8521
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 2,007
Default

Quote:
Originally Posted by Cragster View Post
Thank you !! Yes that definitly helps. So foe example if i had a 3 step parameter it would be [ (0.5) ] ?? is That correct ?? Thanks for your help
I believe that's right. But you can still also define all 3 steps the old way if you already did...or if you wanted to create a custom order of steps.

So this new way just creates some additional flexibility and is a way to keep things simple if needed.
Funkybot is online now   Reply With Quote
Old 04-19-2020, 04:49 PM   #8522
Cragster
Human being with feelings
 
Join Date: Apr 2019
Location: Quakertown PA USA
Posts: 575
Default

Quote:
Originally Posted by Funkybot View Post
I believe that's right. But you can still also define all 3 steps the old way if you already did...or if you wanted to create a custom order of steps.

So this new way just creates some additional flexibility and is a way to keep things simple if needed.
Ok cool.I think I got it. Thank you very much !!!
Cragster is offline   Reply With Quote
Old 04-19-2020, 04:55 PM   #8523
cjewellstudios
Human being with feelings
 
Join Date: Sep 2017
Posts: 549
Default

I'm with Cragster where I still need to be coddled lol. I still only sorta get it but will take funkybots suggest for reacomp and see if I can work that out. (Thx again Funkybot, you've been a huge help)

So we can define the range in the zones now (or can we just do less than 0 to 1?). Am I correct in assuming that we could attempt JS plugs now then?
cjewellstudios is offline   Reply With Quote
Old 04-19-2020, 05:24 PM   #8524
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,815
Default

Quote:
Originally Posted by Funkybot View Post
The new build looks to do two things: 1) allow users to easily customize the parameter step values with encoders, and 2) set custom range limits.

So let's say you've got an EQ parameter and you want the gain to be in 0.001 steps (talking VST parameter ranges not necessarily gain) but maybe that same resolution is too fine for the EQ frequency control because you'd be turning way too much. Maybe for Freq, you determine that .025 steps feel better. You can now do something like:

Code:
Rotary1 FXParam 7 'Low Gain' [ (0.001) ]
Rotary2 FXParam 8 'Low Freq' [ (0.025) ]
Now lets say you're mapping ReaComp and you want 0.001 steps, but you want them only mapped to the first third of the attack time parameter (because you're never going to use some of the really long attack times). And maybe you only want to map the first half of the Release knob. You could do something like this where you set the step size first, then define the minimum and maximum range of the parameter that you want mapped...

Code:
Rotary1 FXParam 1 'Attack'  [ (0.001) 0.0-0.33 ]
Rotary2 FXParam 2 'Release' [ (0.001) 0.0-0.5 ]
Hope that helps. Geoff, correct me if I'm wrong.
Yup, that's it, except you can set the range by itself as well.

And yes, you can still use stepped values.

If stepped values are present, any delta and/or range settings also present are ignored:

Code:
       aWidget anAction [ (0.004) 0.0-1.0 0.0 0.25 0.5 0.75 1.0 ]
In the above, (0.004) is ignored, 0.0-1.0 is ignored, but 0.0 0.25 0.5 0.75 1.0 get used.
Geoff Waddington is offline   Reply With Quote
Old 04-19-2020, 05:48 PM   #8525
Cragster
Human being with feelings
 
Join Date: Apr 2019
Location: Quakertown PA USA
Posts: 575
Default

Hey all. i just updated to the new build and when i started reaper a reascript output box or something came up with all kinds off like error messages throughout the mst and zones files and my surface wasnt connecting with reaper. i went back to the old build. anyone have any feedback of what that problem might be. im assumimg its me cause i havnt heard anyone else having problem on this new build ?? thanks
Cragster is offline   Reply With Quote
Old 04-19-2020, 06:17 PM   #8526
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,815
Default

Quote:
Originally Posted by Cragster View Post
Hey all. i just updated to the new build and when i started reaper a reascript output box or something came up with all kinds off like error messages throughout the mst and zones files and my surface wasnt connecting with reaper. i went back to the old build. anyone have any feedback of what that problem might be. im assumimg its me cause i havnt heard anyone else having problem on this new build ?? thanks
Please take the time to read those messages, that would help diagnose the problem

Did you make a subfolder in your Zone folder to save some stuff ?

Don't forget, CSI searches all subfolders too -- it would get a mess of duplicates if you copied some stuff to a subfolder for safe keeping.
Geoff Waddington is offline   Reply With Quote
Old 04-19-2020, 06:43 PM   #8527
Cragster
Human being with feelings
 
Join Date: Apr 2019
Location: Quakertown PA USA
Posts: 575
Default

Quote:
Originally Posted by Geoff Waddington View Post
Please take the time to read those messages, that would help diagnose the problem

Did you make a subfolder in your Zone folder to save some stuff ?

Don't forget, CSI searches all subfolders too -- it would get a mess of duplicates if you copied some stuff to a subfolder for safe keeping.
ok so there a whole bunch of messages saying...Trouble in C:/UsersAppdata/Roaming/etc/My MstFile around line 81. And theres one for line 326 too. so im assumimg this new build is not liking my mst files ? works with the old build ?? but i also just added another surface in the mix and i made a new mst file for it .its another icon surface . a small version of the pro x so alot of the buttons are the same.but the error messages are for line 326 of the prox mst and line 81 of my new mst. i dont know what any of this means.??
Cragster is offline   Reply With Quote
Old 04-20-2020, 01:11 AM   #8528
WaveTrans
Human being with feelings
 
Join Date: Aug 2019
Location: Forest City
Posts: 227
Default

Thanks for explaining!
Think I got the .zon side to it now.

But how does it work with encoder values in the .mst file?

If I turn knobs on the surface, I got numbers between 01 to 07 (CW) and 41 to 47 on one and 41 to 4a on the other surface.

So I have to put into the .mst file something like

Code:
Encoder b0 10 [ > 01-07 < 41-4a ]
The increment-values I get are somehow floating between margins; guess that comes from uneven movement? Does this matter or is it just the margins which are important defining the actual increments?



Quote:
Originally Posted by Funkybot View Post
The new build looks to do two things: 1) allow users to easily customize the parameter step values with encoders, and 2) set custom range limits.

So let's say you've got an EQ parameter and you want the gain to be in 0.001 steps (talking VST parameter ranges not necessarily gain) but maybe that same resolution is too fine for the EQ frequency control because you'd be turning way too much. Maybe for Freq, you determine that .025 steps feel better. You can now do something like:

Code:
Rotary1 FXParam 7 'Low Gain' [ (0.001) ]
Rotary2 FXParam 8 'Low Freq' [ (0.025) ]
Now lets say you're mapping ReaComp and you want 0.001 steps, but you want them only mapped to the first third of the attack time parameter (because you're never going to use some of the really long attack times). And maybe you only want to map the first half of the Release knob. You could do something like this where you set the step size first, then define the minimum and maximum range of the parameter that you want mapped...

Code:
Rotary1 FXParam 1 'Attack'  [ (0.001) 0.0-0.33 ]
Rotary2 FXParam 2 'Release' [ (0.001) 0.0-0.5 ]
Hope that helps. Geoff, correct me if I'm wrong.
WaveTrans is offline   Reply With Quote
Old 04-20-2020, 03:48 AM   #8529
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,815
Default

Quote:
Originally Posted by Cragster View Post
ok so there a whole bunch of messages saying...Trouble in C:/UsersAppdata/Roaming/etc/My MstFile around line 81. And theres one for line 326 too. so im assumimg this new build is not liking my mst files ? works with the old build ?? but i also just added another surface in the mix and i made a new mst file for it .its another icon surface . a small version of the pro x so alot of the buttons are the same.but the error messages are for line 326 of the prox mst and line 81 of my new mst. i dont know what any of this means.??

It means CSI got confused at those lines.

OK, please post the contents of "My MstFile.mst", it's most likely a bug, there was substantial change (as noted in the build post), let's have a look and fix it.
Geoff Waddington is offline   Reply With Quote
Old 04-20-2020, 04:00 AM   #8530
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,815
Default

Quote:
Originally Posted by WaveTrans View Post
Thanks for explaining!
Think I got the .zon side to it now.

But how does it work with encoder values in the .mst file?
It doesn't... yet

Quote:
Originally Posted by WaveTrans View Post
If I turn knobs on the surface, I got numbers between 01 to 07 (CW) and 41 to 47 on one and 41 to 4a on the other surface.

So I have to put into the .mst file something like

Code:
Encoder b0 10 [ > 01-07 < 41-4a ]
The increment-values I get are somehow floating between margins; guess that comes from uneven movement? Does this matter or is it just the margins which are important defining the actual increments?
You can only use that style if you see 01, 02, 03, 04, ... 07.

Otherwise you must specify them exactly:

Code:
Widget aWidgetName
        Encode b0 10 7f [ > 01 03 05 07 < 41 43 45 47 ] 
WidgetEnd
Geoff Waddington is offline   Reply With Quote
Old 04-20-2020, 04:30 AM   #8531
tdc
Human being with feelings
 
Join Date: Oct 2019
Location: Sydney
Posts: 458
Default

Geoff, the scope of your parser is doing my head in. You must be a regex guru!

:-)
tdc is offline   Reply With Quote
Old 04-20-2020, 06:05 AM   #8532
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,852
Default

New build throws out an error, 'around line 3' of my C4 .mst (testing on laptop, C4 only surface connected)

First few lines of C4.mst are nothing controversial:
Code:
Widget DisplayUpperA1
	FB_C4DisplayUpper 0 0
WidgetEnd

Widget DisplayUpperA2
	FB_C4DisplayUpper 0 1
WidgetEnd
MixMonkey is offline   Reply With Quote
Old 04-20-2020, 06:31 AM   #8533
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,815
Default

New build is up.

Fixes Midi Widget parsing issues.
Geoff Waddington is offline   Reply With Quote
Old 04-20-2020, 06:32 AM   #8534
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,815
Default

Quote:
Originally Posted by tdc View Post
Geoff, the scope of your parser is doing my head in. You must be a regex guru!

:-)
Busted, there is indeed regex involved

But, as amply demonstrated by the previous few posts, I know just enough regex to be extremely dangerous
Geoff Waddington is offline   Reply With Quote
Old 04-20-2020, 06:32 AM   #8535
WaveTrans
Human being with feelings
 
Join Date: Aug 2019
Location: Forest City
Posts: 227
Default

OK, thanks, I´ll wait for the build which implements the encoder steppings...
But thanks for explaning beforehand.

Actually, I also got an "error in line 386/line 3" message with the new build.

The build from 14th works fine with the same .mst


Quote:
Originally Posted by Geoff Waddington View Post
It doesn't... yet



You can only use that style if you see 01, 02, 03, 04, ... 07.

Otherwise you must specify them exactly:

Code:
Widget aWidgetName
        Encode b0 10 7f [ > 01 03 05 07 < 41 43 45 47 ] 
WidgetEnd

Last edited by WaveTrans; 04-20-2020 at 06:43 AM.
WaveTrans is offline   Reply With Quote
Old 04-20-2020, 07:06 AM   #8536
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,852
Default

Quote:
Originally Posted by Geoff Waddington View Post
New build is up.

Fixes Midi Widget parsing issues.
New build loads fine and bounds are fixed

Could we have the simple acceleration back? I like the fineness of the default step size, but it's a 'bit of a knob turner'

I'm trying to hold off changing 400 FX.zon
MixMonkey is offline   Reply With Quote
Old 04-20-2020, 07:30 AM   #8537
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,815
Default

Quote:
Originally Posted by MixMonkey View Post
New build loads fine and bounds are fixed
Cool.

Quote:
Originally Posted by MixMonkey View Post
Could we have the simple acceleration back? I like the fineness of the default step size, but it's a 'bit of a knob turner'

I'm trying to hold off changing 400 FX.zon
Don't touch that dial

Just working on the next phase, so hold off, should have a first rough draft later today or tomorrow -- famous last words

Here's the gist of it.

You will be able to enter a series of deltas, each one for an acceleration level:

Code:
        aWidget anAction [ (0.001,0.0025,0.0050,0.0075,0.01) ]
These are just arbitrary numbers to illustrate the concept.

Conversely the Widget end will be defined thusly:

Code:
Widget "aWidgetName"
        Encode b0 10 7f [ > 01 03 05 07 < 41 43 45 47 ] 
WidgetEnd
The widget receives a midi message and determines an acceleration percentage, in the aforementioned example:
01 = 0% acceleration
03 = 33% acceleration
05 = 67% acceleration
07 = 100% acceleration

It sends this percentage to the Action, which determines the correct delta to use buy matching the percentage to the Action delta values bucket.

0% -- use 0.001
33% -- use 0.025, or perhaps interpolate between 0.0025 and 0.0050 ?
67% - use 0.05, or perhaps interpolate between 0.005 and 0.0075 ?
100% - use 0.01

This way, even accelerated Widgets values that don't line up exactly with the delta values will work.

Obviously the easy ones are ones that map exactly, and the person building FX Zones will probably make this the case more often than not

What say you good folk ?
Geoff Waddington is offline   Reply With Quote
Old 04-20-2020, 07:53 AM   #8538
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,852
Default

Quote:
Originally Posted by Geoff Waddington View Post
Cool.



Don't touch that dial

Just working on the next phase, so hold off, should have a first rough draft later today or tomorrow -- famous last words

Here's the gist of it.

You will be able to enter a series of deltas, each one for an acceleration level:

Code:
        aWidget anAction [ (0.001,0.0025,0.0050,0.0075,0.01) ]
These are just arbitrary numbers to illustrate the concept.

Conversely the Widget end will be defined thusly:

Code:
Widget "aWidgetName"
        Encode b0 10 7f [ > 01 03 05 07 < 41 43 45 47 ] 
WidgetEnd
The widget receives a midi message and determines an acceleration percentage, in the aforementioned example:
01 = 0% acceleration
03 = 33% acceleration
05 = 67% acceleration
07 = 100% acceleration

It sends this percentage to the Action, which determines the correct delta to use buy matching the percentage to the Action delta values bucket.

0% -- use 0.001
33% -- use 0.025, or perhaps interpolate between 0.0025 and 0.0050 ?
67% - use 0.05, or perhaps interpolate between 0.005 and 0.0075 ?
100% - use 0.01

This way, even accelerated Widgets values that don't line up exactly with the delta values will work.

Obviously the easy ones are ones that map exactly, and the person building FX Zones will probably make this the case more often than not

What say you good folk ?
This sounds good Tons of control. SNL are becoming redundant for all but the most complex cases. Which is a good thing They take ages to load.

Would it be possible to have a default acceleration that operates on the default step size?

So, if the default step size is (0.001) and there are 4 messages defined for the widget, you would get step sizes of (0.001)(0.005)(0.01)(0.2) (don't hold me to those values)

If the widget only outputs a single value, will there be the old style acceleration (ie CSI works out how fast the widget is being turned)
MixMonkey is offline   Reply With Quote
Old 04-20-2020, 08:07 AM   #8539
tdc
Human being with feelings
 
Join Date: Oct 2019
Location: Sydney
Posts: 458
Default

Quote:
Originally Posted by MixMonkey View Post
Would it be possible to have a default acceleration that operates on the default step size?
Apologies MixMonkey if I am misunderstanding your request, but I would strongly campaign for a default of No acceleration. As outlined in a previous post, I believe acceleration is a dilution of our goal of tactility. Obviously there are valid edge cases as you have pointed out, but in my experience it’s not common.

Again, much respect :-)
tdc is offline   Reply With Quote
Old 04-20-2020, 08:08 AM   #8540
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 2,007
Default

Geoff, will there be acceleration defaults? I like the approach you're going for, but I almost think there should be a default set of values out of the box to keep things simple.

So for example:

Code:
   aWidget anAction
When combined with...

Code:
Widget "aWidgetName"
        Encode b0 10 7f [ > 01 03 05 07 < 41 43 45 47 ] 
WidgetEnd
Would just have some built in default acceleration value. Where maybe the 01 message equates to a .001 value and the 07 defaults to a .05 value, with interpolated steps in between.

This way, you could ignore adding custom acceleration values to each action, but still get some acceleration. But if you wanted to override the acceleration values because it was too fine, or not fine enough, etc. you could always just do so by adding it back in like you proposed above with:

Code:
aWidget anAction [ (0.001,0.0025,0.0050,0.0075,0.01) ]
Funkybot is online now   Reply With Quote
Old 04-20-2020, 08:10 AM   #8541
tdc
Human being with feelings
 
Join Date: Oct 2019
Location: Sydney
Posts: 458
Default

Quote:
Originally Posted by Geoff Waddington View Post
What say you good folk ?
Just catching up on the day’s developments, this good folk says Linear is Golden. As a default at least.
tdc is offline   Reply With Quote
Old 04-20-2020, 08:12 AM   #8542
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 2,007
Default

Quote:
Originally Posted by tdc View Post
Apologies MixMonkey if I am misunderstanding your request, but I would strongly campaign for a default of No acceleration. As outlined in a previous post, I believe acceleration is a dilution of our goal of tactility. Obviously there are valid edge cases as you have pointed out, but in my experience it’s not common.

Again, much respect :-)
Looking at Geoff's proposal, it seems like you'd have a couple of options:

1. Turn acceleration off on your surface if possible, if not, but you want linear by default then...

2. Modify the .zon to "turn off" acceleration like this:

Code:
aWidget anAction [ (0.001, 0.001) ]
If it interpolates between the lowest and highest value, it would always return a value of 0.001 using that. Or at least, hopefully Geoff can design it that way. I think most of us who have encoders with acceleration would want it on by default.

EDIT:
Also, think of it from an end-user perspective. I'm going into the CSI Edit Mode window to map some FX's on a surface with acceleration. I just expect acceleration to work and it doesn't. Then the question becomes, "hey, can you enhance CSI to add encoder acceleration?" And we have to explain how to manually edit .zon files to add it. Much better to have it on by default with some default acceleration values. Then there could be a "No Acceleration" checkbox in the Edit window to turn it off if needed. The only time an end user would ever need to manually edit a .zon would be if they wanted to customize the acceleration. Makes much more sense to have it on by default with an option to turn off IMO.

Last edited by Funkybot; 04-20-2020 at 08:49 AM.
Funkybot is online now   Reply With Quote
Old 04-20-2020, 08:43 AM   #8543
Cragster
Human being with feelings
 
Join Date: Apr 2019
Location: Quakertown PA USA
Posts: 575
Default

Quote:
Originally Posted by Geoff Waddington View Post
It means CSI got confused at those lines.

OK, please post the contents of "My MstFile.mst", it's most likely a bug, there was substantial change (as noted in the build post), let's have a look and fix it.
Hi Geoff. It seems to be working again with your latest new build. I only had time to try real quick but no reascrpt errors or confusion. thank you
Cragster is offline   Reply With Quote
Old 04-20-2020, 09:18 AM   #8544
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,815
Default

Quote:
Originally Posted by Cragster View Post
Hi Geoff. It seems to be working again with your latest new build. I only had time to try real quick but no reascrpt errors or confusion. thank you
Cool, glad you're up and running again.
Geoff Waddington is offline   Reply With Quote
Old 04-20-2020, 09:23 AM   #8545
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,815
Default

Great points all WRT acceleration.

I think, for me at least, the answer is, I don't yet know what the best default characteristic should be.

I don't even know if these new acceleration methods will work worth a sh^t

So, I say let's forget about defaults right now and just play with the new stuff, a default may emerge naturally.

Because of the internal architecture, it will also be possible to have different defaults for say, FX vs Sends, etc.
Geoff Waddington is offline   Reply With Quote
Old 04-20-2020, 09:47 AM   #8546
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,852
Default

Quote:
Originally Posted by tdc View Post
Apologies MixMonkey if I am misunderstanding your request, but I would strongly campaign for a default of No acceleration. As outlined in a previous post, I believe acceleration is a dilution of our goal of tactility. Obviously there are valid edge cases as you have pointed out, but in my experience it’s not common.

Again, much respect :-)
I'm sure there'll be a way to disable it, probably on the Widget level

It's early days on this, let's see how it pans out, now we know what the surfaces are sending out.
MixMonkey is offline   Reply With Quote
Old 04-20-2020, 01:17 PM   #8547
Cragster
Human being with feelings
 
Join Date: Apr 2019
Location: Quakertown PA USA
Posts: 575
Default

Hi all. I hate to blow things off course but i just added a 2nd surface into my mix. Its just a small 8 fader... 8 rotary...a few buttons. My plan is to use this for strictly fx plugins control. Got them both working but it seems to be either one or the other. Can i control the normal stuff with my main surface and plugins with this smaller one ? Like while im adjusting fx params on one i can still work the normal stuff on the other kind of thing at the same time ? Can my modifier buttons on the main surface work for the other surface as well ? For example if i go into say shift latch mode on the main surface it will also be in shift mode for the smaller surface ? Ive always had just the one surface so this is new to me. Im trying to come up with the best way to use them together. Any help.or suggestions will be appreciated. Thanks a ton guys
Cragster is offline   Reply With Quote
Old 04-20-2020, 01:25 PM   #8548
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 2,007
Default

Quote:
Originally Posted by Cragster View Post
Hi all. I hate to blow things off course but i just added a 2nd surface into my mix. Its just a small 8 fader... 8 rotary...a few buttons. My plan is to use this for strictly fx plugins control. Got them both working but it seems to be either one or the other. Can i control the normal stuff with my main surface and plugins with this smaller one ? Like while im adjusting fx params on one i can still work the normal stuff on the other kind of thing at the same time ? Can my modifier buttons on the main surface work for the other surface as well ? For example if i go into say shift latch mode on the main surface it will also be in shift mode for the smaller surface ? Ive always had just the one surface so this is new to me. Im trying to come up with the best way to use them together. Any help.or suggestions will be appreciated. Thanks a ton guys
I'm pretty sure that's exactly what MixMonkey is doing. I could be wrong, but I think I recall him saying he has a C4 just for FX and another surface for mixing.

Anyway, look at the .zon file for your new surface. It probably will have all the Channel|1-8 stuff...you probably don't want any of that stuff. You probably want to think instead about how to configure that surface just for FX. Maybe you're using SelectedTrackNavigator and FXMenu, then entering in and out of FX Zon's that way.

Pretty sure someone can help get you setup.

Makes me wonder how many Control Surfaces Geoff is responsible for selling. I wouldn't have bought an X-Touch One if not for CSI. I'd probably have dumped my Steinberg CMC too.
Funkybot is online now   Reply With Quote
Old 04-20-2020, 01:27 PM   #8549
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,852
Default

Quote:
Originally Posted by Cragster View Post
Can i control the normal stuff with my main surface and plugins with this smaller one ?Like while im adjusting fx params on one i can still work the normal stuff on the other kind of thing at the same time ?
Yes, this is the best way of operating imho. My C4 just follows the main surface's selection and displays sends and the FX menu. When you select an FX slot from the menu it maps the FX parameters to the surface.
Quote:
Can my modifier buttons on the main surface work for the other surface as well ?
Yes, modifiers are global. If they are activated on one surface they apply to all surfaces.
MixMonkey is offline   Reply With Quote
Old 04-20-2020, 01:35 PM   #8550
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,852
Default

Here's my C4.zon:
Code:
Zone Home
        OnTrackSelection MapSelectedTrackSendsToWidgets
        OnTrackSelection MapSelectedTrackFXToMenu
        IncludedZones
            "C4_Buttons|"
            "Widget_Blank|1-8"
        IncludedZonesEnd
ZoneEnd

Zone "Widget_Blank|"
        DisplayUpperA|                  NoAction
        DisplayLowerA|                  NoAction
        RotaryPushA|                    NoAction
        RotaryA|                        NoAction
                
        DisplayUpperB|                  NoAction
        DisplayLowerB|                  NoAction
        RotaryPushB|                    NoAction
        RotaryB|                        NoAction

Zone "C4_Buttons|"
        BankLeft                        TrackBank "-8"
        BankRight                       TrackBank "8"
        ChannelLeft                     TrackBank "-1"
        ChannelRight                    TrackBank "1"
        Lock                            MapSelectedTrackFXToMenu
        Lock                            MapSelectedTrackSendsToWidgets
        Shift+Lock                      Reaper "_S&M_FXBYPALL"          //Toggle all FX bypass for selected track
        SpotErase                       Reaper "_S&M_TOGLFXCHAIN"		// Toggle FX chain window for selected track
        Split                           Reaper "_S&M_WNCLS4"            //Close all FX chain windows
        Split                           Reaper "_S&M_WNCLS3"            //Close all floating FX windows
        Shift                           Shift
        Option                          Option
        Control                         Control
        Alt                             Alt
        Marker                          NoAction
        ChanStrip                       NoAction
        Track                           NoAction
        Function                        NoAction
ZoneEnd

Zone "FXMenu|1-8"
        SelectedTrackNavigator
        DisplayUpperD|                  FXNameDisplay |
        DisplayLowerD|                  NoAction
        RotaryD|                        NoAction
        RotaryPushD|                    GoFXSlot |
        RotaryPushD|                    Reaper "_S&M_SHOWFXCHAIN|"
        Shift+RotaryPushD|              Reaper "_S&M_FXBYP|"            //Bypass FX Slot
        Option+RotaryPushD|             Reaper "_S&M_FXOFF|"            //Offline FX slot
ZoneEnd


Zone "Send|1-8"
        SelectedTrackNavigator
        DisplayUpperC|                  TrackSendNameDisplay
        DisplayLowerC|                  TrackSendVolumeDisplay
        RotaryPushC|                    TrackSendMute
        RotaryC|                        TrackSendVolume
ZoneEnd
In the CSI prefs for the C4, 'Auto Map Sends' and 'Auto Map FX Menu' are enabled.
MixMonkey is offline   Reply With Quote
Old 04-20-2020, 02:43 PM   #8551
Cragster
Human being with feelings
 
Join Date: Apr 2019
Location: Quakertown PA USA
Posts: 575
Default

Quote:
Originally Posted by MixMonkey View Post
Here's my C4.zon:
Code:
Zone Home
        OnTrackSelection MapSelectedTrackSendsToWidgets
        OnTrackSelection MapSelectedTrackFXToMenu
        IncludedZones
            "C4_Buttons|"
            "Widget_Blank|1-8"
        IncludedZonesEnd
ZoneEnd

Zone "Widget_Blank|"
        DisplayUpperA|                  NoAction
        DisplayLowerA|                  NoAction
        RotaryPushA|                    NoAction
        RotaryA|                        NoAction
                
        DisplayUpperB|                  NoAction
        DisplayLowerB|                  NoAction
        RotaryPushB|                    NoAction
        RotaryB|                        NoAction

Zone "C4_Buttons|"
        BankLeft                        TrackBank "-8"
        BankRight                       TrackBank "8"
        ChannelLeft                     TrackBank "-1"
        ChannelRight                    TrackBank "1"
        Lock                            MapSelectedTrackFXToMenu
        Lock                            MapSelectedTrackSendsToWidgets
        Shift+Lock                      Reaper "_S&M_FXBYPALL"          //Toggle all FX bypass for selected track
        SpotErase                       Reaper "_S&M_TOGLFXCHAIN"		// Toggle FX chain window for selected track
        Split                           Reaper "_S&M_WNCLS4"            //Close all FX chain windows
        Split                           Reaper "_S&M_WNCLS3"            //Close all floating FX windows
        Shift                           Shift
        Option                          Option
        Control                         Control
        Alt                             Alt
        Marker                          NoAction
        ChanStrip                       NoAction
        Track                           NoAction
        Function                        NoAction
ZoneEnd

Zone "FXMenu|1-8"
        SelectedTrackNavigator
        DisplayUpperD|                  FXNameDisplay |
        DisplayLowerD|                  NoAction
        RotaryD|                        NoAction
        RotaryPushD|                    GoFXSlot |
        RotaryPushD|                    Reaper "_S&M_SHOWFXCHAIN|"
        Shift+RotaryPushD|              Reaper "_S&M_FXBYP|"            //Bypass FX Slot
        Option+RotaryPushD|             Reaper "_S&M_FXOFF|"            //Offline FX slot
ZoneEnd


Zone "Send|1-8"
        SelectedTrackNavigator
        DisplayUpperC|                  TrackSendNameDisplay
        DisplayLowerC|                  TrackSendVolumeDisplay
        RotaryPushC|                    TrackSendMute
        RotaryC|                        TrackSendVolume
ZoneEnd
In the CSI prefs for the C4, 'Auto Map Sends' and 'Auto Map FX Menu' are enabled.
Hey thanks guys . Yes rhats exactly what im looking for . Ill start experimenting with your all suggestions soon as im back home. My fx is mapped using the selectedtracknavigator/ menu style. I noticed some boxes on the csi setup. Sync surfaces or its sync pages. Something like that .im not at my computer right now. Do those boxes need checking ? And only the fx zones in the new surface folder ? I have lots questions im sure . Ill just wait till im at my station. But thanks guys yous gave me enough to get started.
@funkybot...haha yes CSI is definitely selling some control surfaces. Im always checking out new stuff since i started csi. Geoff should be getting some kind of commission haha. Wishful thinking. My 10 a month will hafta do. Thanks all
Cragster is offline   Reply With Quote
Old 04-20-2020, 03:33 PM   #8552
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,815
Default

New build is up.

Implements first draft of the acceleration stuff we have been discussing.

Nothing will change in your .mst file if you choose not to use acceleration.

If you do venture into these waters, know this:

I have no encoders, so I'm totally winging it here, might blow up on you -- fair warning...

Anyway, it's as described before:
Code:
Widget "aWidgetName"
        Encoder b0 10 7f [ > 01 03 05 07 < 41 43 45 47 ] 
WidgetEnd

Zone "aZoneName"
      aWidget anAction [ (0.001,0.0025,0.0050,0.0075,0.01) ]
ZoneEnd
Note there are no spaces in the delta amounts, be careful not to put any in there

[edit] Oops, forgot to put Encoder range in there so this won't work yet:
Code:
Widget "aWidgetName"
        Encoder b0 10 7f [ > 01-07 < 41-47 ] 
WidgetEnd

Last edited by Geoff Waddington; 04-20-2020 at 03:40 PM.
Geoff Waddington is offline   Reply With Quote
Old 04-20-2020, 04:20 PM   #8553
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 2,007
Default

It's working great. The syntax is a little messy with all the values, but this feels pretty good so far:

Code:
Widget Rotary1
	Encoder b0 00 7f [ < 3f 3e 3d 3c 3b 3a 39 38 36 33 2f > 41 42 43 44 45 46 47 48 4a 4d 51 ]
	FB_Fader7Bit b0 00 00
WidgetEnd
Code:
Rotary16 FXParam "3" "Blend" [ (0.001,0.002,0.003,0.005,0.0075,0.015,0.025,0.040,0.05,0.06,0.07) ]
I'm trying to fine tune that nice balance of being able to quickly turn a knob for a fast response, while also being able to get really fine control when going slow.
Funkybot is online now   Reply With Quote
Old 04-20-2020, 04:22 PM   #8554
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,815
Default

Quote:
Originally Posted by Funkybot View Post
It's a little messy with all the values, but feels pretty good so far:

Code:
Widget Rotary1
	Encoder b0 00 7f [ < 3f 3e 3d 3c 3b 3a 39 38 36 33 2f > 41 42 43 44 45 46 47 48 4a 4d 51 ]
	FB_Fader7Bit b0 00 00
WidgetEnd
Code:
Rotary16 FXParam "3" "Blend" [ (0.001,0.002,0.003,0.005,0.0075,0.01,0.025,0.040,0.05,0.06,0.066) ]
OK, so you are saying it actually works ?
Geoff Waddington is offline   Reply With Quote
Old 04-20-2020, 04:27 PM   #8555
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 2,007
Default

Quote:
Originally Posted by Geoff Waddington View Post
OK, so you are saying it actually works ?
Yes, was editing my post for clarity as you were replying. It really, really works. I've tried a bunch of different acceleration values for my MFTwister widgets and they update as expected from too fast to too fine to "honing in on just right!" Works great!
Funkybot is online now   Reply With Quote
Old 04-20-2020, 04:31 PM   #8556
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,852
Default

Nice one Geoff!

Working here with:
Code:
Widget RotaryD1
	Encoder b0 18 7f [ > 01 04 08 0C 0f < 41 44 48 4c 4f ]
	FB_Encoder b0 18 7f
WidgetEnd
and

Code:
DisplayUpperD1 FXParamNameDisplay 0 "Thresh"
DisplayLowerD1 FXParamValueDisplay 0 
RotaryD1 FXParam 0 [ (0.001,0.005,0.01,0.05,0.1) 0.0-1.0 ]
Toggle+RotaryPushD1 NoAction
Hours of fun to be had playing with the acceleration factors!
MixMonkey is offline   Reply With Quote
Old 04-20-2020, 04:41 PM   #8557
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,852
Default

Looks like I'll be getting a few more of these together
Code:
(FXParam\s\d+)(?!\s\[\s)		//add step size to bare parameter
& (0.01)		

(\d\.\d-\d\.\d)				//add step size to bounded parameter
\(0.01) &
MixMonkey is offline   Reply With Quote
Old 04-20-2020, 05:39 PM   #8558
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 2,007
Default

Not sure if this is a bug or me just not getting the finer points of the new syntax, but I have an encoder widget mapped to a 3 step parameter as such...

Code:
Rotary11 FXParam "11" "Tone Shift" [ 0.0 0.5 1.0 ]
Code:
Widget Rotary11
	Encoder b0 0a 7f [ < 3f 3e 3d 3c 3b 3a 39 38 36 33 2f > 41 42 43 44 45 46 47 48 4a 4d 51 ]
	FB_Fader7Bit b0 0a 00
WidgetEnd
Turning the encoder counter clockwise repeatedly cycles through the three steps at way too fast a setting to be useful. Also, after it gets to the top, it goes back to the bottom and starts over (endless looping!).

Geoff, is there a way to slow this down to get a more useful range out of stepped parameters+encoders? Also, is there a way to set upper/lower bounds so stepped parameters don't spin endlessly?
Funkybot is online now   Reply With Quote
Old 04-20-2020, 05:43 PM   #8559
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,815
Default

Quote:
Originally Posted by Funkybot View Post
Yes, was editing my post for clarity as you were replying. It really, really works. I've tried a bunch of different acceleration values for my MFTwister widgets and they update as expected from too fast to too fine to "honing in on just right!" Works great!
Haha, cool
Geoff Waddington is offline   Reply With Quote
Old 04-20-2020, 05:43 PM   #8560
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,815
Default

Quote:
Originally Posted by MixMonkey View Post
Looks like I'll be getting a few more of these together
Code:
(FXParam\s\d+)(?!\s\[\s)		//add step size to bare parameter
& (0.01)		

(\d\.\d-\d\.\d)				//add step size to bounded parameter
\(0.01) &
Haha, bring it !!
Geoff Waddington is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:10 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.