Go Back   Cockos Incorporated Forums > REAPER Forums > Recording Technologies and Techniques

Reply
 
Thread Tools Display Modes
Old 11-09-2019, 01:48 PM   #1
Castle Starter
Human being with feelings
 
Join Date: Oct 2019
Posts: 3
Default Newbie question: Latency with MIDI keyboard driving virtual instrument

Hi, I have my MIDI keyboard connected to my laptop running Reaper. The keyboard end is 5-pin DIN and the laptop end is USB2. There is a little box of tricks midway along the cable which I'm guessing converts between 5-pin DIN and USB. I have a synth virtual instrument on my track and I listen to the output with headphones in the laptop headphone socket.

When I record, with the metronome on, I press the keys on my MIDI keyboard in time with the metronome pips but I don't hear the synth sound for about a quarter of a second. Very disconcerting and difficult to play.

After finishing recording and listening to what I've recorded, the synth is in time with the metronome pips.

My laptop processor is Intel i5-4200U 1.6Ghz 2 core 2301Mhz.

Is there a way to remove/reduce the latency between pressing a key and hearing the synth virtual instrument?

Do I need to buy a MIDI controller so I have a direct USB to USB connection between keyboard and laptop?

Many thanks for any help.
Castle Starter is offline   Reply With Quote
Old 11-09-2019, 09:01 PM   #2
drumphil
Human being with feelings
 
drumphil's Avatar
 
Join Date: Jun 2006
Location: Australia
Posts: 3,547
Default

The midi interface is unlikely to be the source of your latency problems.

Do you have a dedicated audio interface, our are you using the on board audio device?


Smaller buffer size = lower latency, but there will be a limit where the device can't maintain stable operation, or you run out of cpu power, and get glitches.

If you have a decicated audio device it will likely have an asio driver. In the reaper audio preferences switch to asio mode, and then see how low you can set the asio buffer size.

If you're using on board sound try WASAPI in exclusive mode, or try ASIO4ALL which is a program that sits between a DAW and the windows audio drivers to simulate having an asio driver.

For WASAPI you set the buffer size using the block size setting in the reaper audio preferences. For ASIO4ALL you set it using the ASIO4ALL control panel, which you access by clicking the asio configuration button in reaper audio prefrences.
drumphil is offline   Reply With Quote
Old 11-10-2019, 07:22 AM   #3
Castle Starter
Human being with feelings
 
Join Date: Oct 2019
Posts: 3
Default

Thanks Drumphil, that's fixed it.

I don't have a dedicated audio interface, I'm using the onboard processor. So I switched to WASAPI and Reaper reports I'm down to 10ms latency. Block size 512. I can't hear any latency now.

Many thanks,

Castle
Castle Starter is offline   Reply With Quote
Old 11-10-2019, 12:33 PM   #4
drumphil
Human being with feelings
 
drumphil's Avatar
 
Join Date: Jun 2006
Location: Australia
Posts: 3,547
Default

You can probably do better than 512, at least if you use exclusive mode WASAPI.

I can run at 64 with realtek on board audio.

If 512 is acceptable, then maybe shoot for 128.

Less latency is always a good thing if you can get it without problems.

Last edited by drumphil; 11-10-2019 at 12:50 PM.
drumphil is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:49 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.