Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER for Linux

Reply
 
Thread Tools Display Modes
Old 07-22-2018, 05:26 PM   #1
nikolalkc
Human being with feelings
 
nikolalkc's Avatar
 
Join Date: Feb 2017
Location: Belgrade, Serbia
Posts: 145
Default UserPlugins undetected in KXStudio

Hi there folks. I've decided to try native Linux REAPER build for the first time.
I've installed Ubuntu Studio first. I was able to install reapack and sws extensions, but was having trouble with JACK. Then I found out about KXStudio.
I deleted Ubuntu Studio, installed KXStudio and downloaded REAPER. It runs fine, but it looks like REAPER is ignoring everything i put in my UserPlugins folder.

I have reaper unpacked (not installed) in Downloads folder and i'm running it directly from there. I pasted .so plugins for reapack and sws into /home/my_username/.REAPER/UserPlugins/

But it seems to me that REAPER is just not able to recognize these plugins.

Can anyone help me?
nikolalkc is offline   Reply With Quote
Old 07-22-2018, 05:53 PM   #2
lilith93
Human being with feelings
 
lilith93's Avatar
 
Join Date: Apr 2018
Location: Karlsruhe
Posts: 216
Default

What kind of plugins are you using? Linux VSTs? These can be located in /home/yourusername/.vst. The . means that the folder is invisible. Best to put them there for another test. You also can define plugin folders in the preferences of Reaper.

When you install VSTs they go to /usr/lib/lxvst or /usr/local/lib/lxvst typically.
lilith93 is offline   Reply With Quote
Old 07-22-2018, 05:58 PM   #3
nikolalkc
Human being with feelings
 
nikolalkc's Avatar
 
Join Date: Feb 2017
Location: Belgrade, Serbia
Posts: 145
Default

I'm actually talking just about ReaPack and SWS. Vst-s are working fine with airwave. I can't detect these .so plugins.
nikolalkc is offline   Reply With Quote
Old 07-23-2018, 10:26 AM   #4
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,770
Default

Quote:
Originally Posted by nikolalkc View Post
I'm actually talking just about ReaPack and SWS. Vst-s are working fine with airwave. I can't detect these .so plugins.
Hmm, would you happen to have a ~/.config/REAPER too, or maybe a reaper.ini in the directory with the executable?
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 07-24-2018, 05:17 AM   #5
Tobbe
Human being with feelings
 
Tobbe's Avatar
 
Join Date: Sep 2009
Location: Backe, Jämtland, Sweden
Posts: 302
Default

Quote:
Originally Posted by nikolalkc View Post
I'm actually talking just about ReaPack and SWS. Vst-s are working fine with airwave. I can't detect these .so plugins.
How did you make the VST's work with airwave? I tried it also but doesn't work.
__________________
OS: MX-Linux 5.0.0-18.1-liquorix-amd64 #1 ZEN SMP PREEMPT liquorix (64Bit), Reaper For Linux (64Bit) (16GB RAM), HoRNet VST Plugin, Amplesound Bass & Acoustic (Free) and many other free stuff. Behringer U-PHORIA UMC22.
Tobbe is offline   Reply With Quote
Old 07-24-2018, 07:28 AM   #6
shosty
Human being with feelings
 
Join Date: Aug 2015
Posts: 144
Default

Quote:
Originally Posted by Tobbe View Post
How did you make the VST's work with airwave? I tried it also but doesn't work.
Just follow the instructions on their github page. Linvst is much better and more reliable these days though so I would forget about airwave unless you have a particular reason not to.
shosty is offline   Reply With Quote
Old 07-24-2018, 08:12 AM   #7
Tobbe
Human being with feelings
 
Tobbe's Avatar
 
Join Date: Sep 2009
Location: Backe, Jämtland, Sweden
Posts: 302
Default

Quote:
Originally Posted by shosty View Post
Just follow the instructions on their github page. Linvst is much better and more reliable these days though so I would forget about airwave unless you have a particular reason not to.
I tried LinVST to. Took one dll file and put it i to a separate folder, and LinVST created a .so file in the same directory. I start Reaper and I point it to the folder I created. The scanning runs very fast and I see the so file flashing by but it ain't showing up under FX choice as new plugin.
__________________
OS: MX-Linux 5.0.0-18.1-liquorix-amd64 #1 ZEN SMP PREEMPT liquorix (64Bit), Reaper For Linux (64Bit) (16GB RAM), HoRNet VST Plugin, Amplesound Bass & Acoustic (Free) and many other free stuff. Behringer U-PHORIA UMC22.
Tobbe is offline   Reply With Quote
Old 07-24-2018, 09:44 AM   #8
shosty
Human being with feelings
 
Join Date: Aug 2015
Posts: 144
Default

Quote:
Originally Posted by Tobbe View Post
I tried LinVST to. Took one dll file and put it i to a separate folder, and LinVST created a .so file in the same directory. I start Reaper and I point it to the folder I created. The scanning runs very fast and I see the so file flashing by but it ain't showing up under FX choice as new plugin.
Did you search for it by name?
Did you put the necessary linvst server files in /usr/bin and run
Code:
sudo chmod +x /usr/bin/lin-vst-server*
?
shosty is offline   Reply With Quote
Old 07-24-2018, 10:50 AM   #9
Tobbe
Human being with feelings
 
Tobbe's Avatar
 
Join Date: Sep 2009
Location: Backe, Jämtland, Sweden
Posts: 302
Default

Quote:
Originally Posted by shosty View Post
Did you search for it by name?
Did you put the necessary linvst server files in /usr/bin and run
Code:
sudo chmod +x /usr/bin/lin-vst-server*
?
It works now. I missed your last tips. Thank you.
__________________
OS: MX-Linux 5.0.0-18.1-liquorix-amd64 #1 ZEN SMP PREEMPT liquorix (64Bit), Reaper For Linux (64Bit) (16GB RAM), HoRNet VST Plugin, Amplesound Bass & Acoustic (Free) and many other free stuff. Behringer U-PHORIA UMC22.
Tobbe is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:31 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.