COCKOS
CONFEDERATED FORUMS
Cockos : REAPER : NINJAM : Forums
Forum Home : Register : FAQ : Members List : Search :
Old 11-12-2006, 12:36 AM   #1
scott_karana
Human being with feelings
 
Join Date: Nov 2006
Posts: 2
Default ninjamsrv weirdness on FreeBSD

I run a SPARC FreeBSD 6 server. Ninjamsrv basically works, but a few things outright fail:
I can't for the life of me get passwords working, and ninjamsrv exhibits weird, unpredictable behaviour regarding output to terminals, or output to pipes.
I tried, first, lines like "User scott plaintextpassword CK", and then after that failed to work, I looked at the sourcecode and guess ninjam might want an sha1 password, or the
Code:
username:password
summed, so I tried that as well. None of that has worked.
In regards to the output, Ninjam seemed to not output to pipes or file redirections unless I had a logfile set. This is kind of minor, but quite annoying to people who might need to use pipes in this way (daemontools users).
scott_karana is offline   Reply With Quote
Old 01-24-2007, 05:57 AM   #2
xphilius
Human being with feelings
 
Join Date: Jan 2007
Posts: 4
Default Any progress on your password issue?

I recently installed the ninjam server on FreeBSD 6 on an AMD deck. We have only done a couple sessions, but passwords seem to be working as advertised. Looks like you know what you are doing more than I do, so I am not sure what I can do to help out, but thought you'd appreciate a post from a fellow FreeBSD'er. Are you having a client issue maybe?

Jason
xphilius is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:38 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.