Old 06-28-2019, 06:42 PM   #1
dangguidan
Human being with feelings
 
Join Date: Jan 2019
Posts: 74
Default Overlapping note import error!

If the imported MIDI file has overlapping notes, there will be a note length error in Reaper. Please correct this error.

Last edited by dangguidan; 08-07-2019 at 06:48 AM.
dangguidan is online now   Reply With Quote
Old 07-05-2019, 06:26 PM   #2
dangguidan
Human being with feelings
 
Join Date: Jan 2019
Posts: 74
Default

MIDI files will inevitably overlap notes. At present, this situation can only be imported into Reaper after MIDI overlap events are fixed in other sequencers. I hope you can attach importance to this problem and fix it.
dangguidan is online now   Reply With Quote
Old 07-11-2019, 04:12 AM   #3
juliansader
Human being with feelings
 
Join Date: Jul 2009
Posts: 2,659
Default

The MIDI standard doesn't really provide for overlapping notes, so when importing standard MIDI files, REAPER has to guess which note-on event is linked with which note-off, and REAPER will inevitably guess wrong sometimes.

It is best to avoid overlapping notes altogether when working with MIDI. Even while working in REAPER itself, you will encounter problems if you try to run actions such as Humanize on overlapping notes.

EDIT:
That said, REAPER can probably be smarter when guessing matching note-ons. Always assume that the next note-off is matched with the first remaining unmatched note-on.

Also, in order to handle overlapping notes beter, REAPER can move away from the plain MIDI standard, as I wrote elsewhere:
Quote:
Originally Posted by juliansader View Post
REAPER is step-by-step moving away from the plain MIDI standard: First, MIDI events got flags for selected and muted, then notation was added, and now CC envelopes.

Perhaps this is a good time to completely re-think how REAPER stores MIDI data.

In particular, notes can be transformed into miniature "items" that store more than just a note-on:

* Instead of separate note-ons and note-offs, each note event can store the note length. This will avoid all the problems with overlapping notes that get infinitely extended or chopped off.

* Each note can store its own polyphonic aftertouch events, which will allow REAPER to eventually develop something similar to Cubase's "note expression".

* Each note can store its own notation, so that scripts don't have to search the MIDI stream for a matching notation event.

Last edited by juliansader; 07-11-2019 at 08:17 AM.
juliansader is offline   Reply With Quote
Old 07-11-2019, 08:24 AM   #4
cool
Human being with feelings
 
Join Date: Dec 2017
Location: Sunny Siberian Islands
Posts: 146
Default

I opened the attached file. No issues. But, in my default template, option "Automatically correct overlapping notes" always on.

cool is offline   Reply With Quote
Old 07-11-2019, 08:42 AM   #5
juliansader
Human being with feelings
 
Join Date: Jul 2009
Posts: 2,659
Default

As cool implied, if you enable the MIDI editor option "Automatically correct overlapping notes" *before* importing the .mid file, REAPER should correct (shorten) overlapping notes while importing.
juliansader is offline   Reply With Quote
Old 07-11-2019, 06:59 PM   #6
dangguidan
Human being with feelings
 
Join Date: Jan 2019
Posts: 74
Default

Thank you. The problem has been solved, but I don't know what would be wrong with editing MIDI if this option was left open all the time. Let's try for a while and thank you again for your kind help.
dangguidan is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:13 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.