Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER for Linux

Reply
 
Thread Tools Display Modes
Old 05-26-2018, 12:29 PM   #441
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,770
Default

Quote:
Originally Posted by halfshavedyaks View Post
tahanks

aptitude gave me more sensible dependencies so that part may be ok now.

what version of qjackctl do you recommend? I'm using Mint and have qjackctl 0.4.2 which is already quite old... (but it is what is in the repo)

I really wish distros/repos made downgrades easier...
If so, then that's probably not the problem. Just that there was a new release of qjackctl a few days ago, which seems to have a problem on my system. Otherwise qjackctl has been stable for me for a long time. For me it started breaking after upgrading from 0.5.0 to 0.5.1. But I wouldn't worry about the version, there hasn't been any huge changes, maybe better to use the one the distro ships
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 05-26-2018, 04:12 PM   #442
halfshavedyaks
Human being with feelings
 
Join Date: May 2018
Posts: 26
Default

I'm trying the appimage of the latest qjackctl and it hasn't frozen yet. However neither the installed one that was freezing nor the appimage will actually use the configuration that is set and saved in /.config/rncbc.org

it doesn't run it's startup script, nor obey many/most of it's other settings.

ah well i guess this is OT for this thread. Not getting far with the plugins when the basics don't work though!
halfshavedyaks is offline   Reply With Quote
Old 05-26-2018, 04:17 PM   #443
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,770
Default

Quote:
Originally Posted by halfshavedyaks View Post
I'm trying the appimage of the latest qjackctl and it hasn't frozen yet. However neither the installed one that was freezing nor the appimage will actually use the configuration that is set and saved in /.config/rncbc.org

it doesn't run it's startup script, nor obey many/most of it's other settings.

ah well i guess this is OT for this thread. Not getting far with the plugins when the basics don't work though!
Sorry, that sounds like a distro problem Maybe skip JACK and just use ALSA directly (unless you need midi at this stage).
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 06-04-2018, 03:09 AM   #444
Garrick
Human being with feelings
 
Garrick's Avatar
 
Join Date: Jul 2009
Location: Wellington
Posts: 4,525
Default

If any of you use Ableton for your instruments will be glad to know that it installs with no extra dlls or overrides on wine devel 3.9
Garrick is online now   Reply With Quote
Old 06-06-2018, 07:12 PM   #445
hmoller
Human being with feelings
 
Join Date: Aug 2017
Posts: 8
Default PowerDrumkit not working in linvst 2.2.1

Hi @osxmidi I installed LinVst2.2.1 (I'm still on ubuntu 16.04, thats why I dont use 2.2.2) and MT powerdrumkit doesn't work on it. In 17.6 work w/o problems.

Quote:
Originally Posted by osxmidi View Post
I've fixed the MT PowerDrumKit display update problem in LinVst 1.5.1

I also need to disable d2d1 for my old testing hardware.
hmoller is offline   Reply With Quote
Old 06-06-2018, 11:07 PM   #446
4duhwinnn
Human being with feelings
 
Join Date: Mar 2017
Posts: 385
Default

A strange issue with the new Europa synth, derived by
Propellorheads from their Reason software collection:

there are three panels with drawable/dragable parts inside,
these work, and the preset browser works,
but turning almost any knob the tiniest bit,
crashes reaper 5.90 instantly, always the same, and
tested with wine 2 and 3x, nvidia driver or nouveau,
rpm or deb distros. Reapers alternate sliders interface works OK,
so things can still get done changing presets, and drawing,
then switching to the sliders if some serious sound editing is desired.

Does this behavior jog any memories? A whole boatload of
'api-ms-win-core' items populate the wine terminal crash report.

The price goes up July 1st, from $99 to $150
Seems like a very nice instrument, even if the peanut gallery
chides it for being just an old Reason escapee,
put in the vst market to make some quick cash.
Cheers
4duhwinnn is offline   Reply With Quote
Old 06-07-2018, 06:36 AM   #447
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,770
Default

@osxmidi

Wondering what you are planning to do with the Steinberg header files needed to build this. Apparently Steinberg is discontinuing support for VST2, even worse is that they are removing it from the VST3 SDK. This essentially means that anyone not already having aquired the SDK from Steinberg won't be able to get the needed header files in the future...:S

There exists a clean room reverse engineered version known as Vestige, but at least one project on GitHub using it has received a DCMA take down request... Don't know if they are actually going to try to kill the Vestige headers too, or if it was just a mistake seeing the header file name is the same as the original steinberg header... Time will tell I guess.
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 06-07-2018, 01:20 PM   #448
nosucherror
Human being with feelings
 
nosucherror's Avatar
 
Join Date: Oct 2013
Location: London, Perfidious Albion
Posts: 57
Default windows.h

Hi OSXMIDI,
I'm having trouble installing LinVst, I'm using WINE development. When I 'make' I get the error:
lin-vst-server.cpp:45:10: fatal error: windows.h: No such file or directory

My windows.h file is in:
/usr/include/wine-development/wine/windows/
but it seems to be looking in:
/usr/include/wine-development/windows

Any help appreciated.
__________________
Kubuntu 18.04 | M-Audio Fast Track Ultra & M-Audio Delta 1010 | AMD FX-8320 | 16Gib RAM
nosucherror is offline   Reply With Quote
Old 06-08-2018, 12:52 PM   #449
4duhwinnn
Human being with feelings
 
Join Date: Mar 2017
Posts: 385
Default

No-brainer alert! Fathom Modular synth $12 Friday June 8th only!
Seems to work fine in wine reaper, drawable waves, drag/drop modules,
smooth pro gui, beefy sounds


Serial number from email seems oddly needed for the next update you download, to unlock that archive, not the first one purchased...
the mono version of Fathom is free.
Cheers

details/links etc

http://www.kvraudio.com/forum/viewto...p?f=1&t=482501

Last edited by 4duhwinnn; 06-08-2018 at 12:56 PM. Reason: time's a wastin'
4duhwinnn is offline   Reply With Quote
Old 06-10-2018, 03:31 AM   #450
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,770
Default

@osxmidi:

Maybe this discussion is of interest. Possibly you should make sure that you have signed an agreement before it's too late. Like that you could at least build binaries for everyone, as users won't be able to get the header files needed from Steinberg... Though maybe files from Vestige or JUCE might help if they don't get taken down...

https://forum.juce.com/t/steinberg-c...for-good/27722
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 06-10-2018, 06:54 AM   #451
brainwreck
Human being with feelings
 
Join Date: Jul 2006
Posts: 20,574
Default

Quote:
Originally Posted by Jack Winter View Post
@osxmidi

Wondering what you are planning to do with the Steinberg header files needed to build this. Apparently Steinberg is discontinuing support for VST2, even worse is that they are removing it from the VST3 SDK. This essentially means that anyone not already having aquired the SDK from Steinberg won't be able to get the needed header files in the future...:S

There exists a clean room reverse engineered version known as Vestige, but at least one project on GitHub using it has received a DCMA take down request... Don't know if they are actually going to try to kill the Vestige headers too, or if it was just a mistake seeing the header file name is the same as the original steinberg header... Time will tell I guess.
That really blows. I wonder what the roadblocks are for plugin developers adopting LV2 as a crossplatform format.
__________________
It's time to take a stand against the synthesizer.
brainwreck is offline   Reply With Quote
Old 06-10-2018, 08:49 PM   #452
hmoller
Human being with feelings
 
Join Date: Aug 2017
Posts: 8
Default

Upgraded to ubuntu 18.04 and use linvst 2.2.2 and worked like a charm.

Quote:
Originally Posted by hmoller View Post
Hi @osxmidi I installed LinVst2.2.1 (I'm still on ubuntu 16.04, thats why I dont use 2.2.2) and MT powerdrumkit doesn't work on it. In 17.6 work w/o problems.
hmoller is offline   Reply With Quote
Old 06-10-2018, 09:18 PM   #453
4duhwinnn
Human being with feelings
 
Join Date: Mar 2017
Posts: 385
Default

Quote:
Originally Posted by brainwreck View Post
That really blows. I wonder what the roadblocks are for plugin developers adopting LV2 as a crossplatform format.
I'm not a coder, but from what I've read, one format places giant rocks in the way, and the other places boulders in the way. And then daw-coders
must be willing and able to fully integrate lv2 as it changes
(hopefully for the better) over the years.

From a musicians point of view, I think lv2 needs a robust preset
load/save system, as easy to use as fxp/fxb, and beyond that,
some really great in-app preset managers, and a rigorous implementation
of matching verbage, rather than every dev implementing
their own pet buzzwords and catch-phrases. Reinventing the wheel is fine,
if one really must, as long as it's still called a wheel in the menus...
Cheers
4duhwinnn is offline   Reply With Quote
Old 06-15-2018, 10:12 AM   #454
kytdkut
Human being with feelings
 
Join Date: May 2017
Posts: 45
Default

just a heads up for anyone using linvst and systemd or whatever on arch and related distros

I was having an issue where I couldn't get REAPER to load any more vsts

reaper.ini sets its open file limit to auto (defaults to 16384 or system max), but in my system ulimit -n would output 1024, and that is because:

https://wiki.archlinux.org/index.php/Limits.conf

"Note: /etc/security/limits.conf does not work if systemd exists."

so, basically you have to extend the max file descriptors in /etc/systemd/system.conf DefaultLimitNOFILE=number (I put 16384 here to match reaper.ini)
I did the same on /etc/systemd/user.conf

now I can keep adding vsts

why set the limit so low by default? games use a lot of open files too, I guess

I solved my problem following a hunch... I feel weird...

maybe this info would benefit the wiki

cheers!

edit: wineserver.exe is using 1034 files

Last edited by kytdkut; 06-15-2018 at 10:24 AM.
kytdkut is offline   Reply With Quote
Old 06-15-2018, 11:11 AM   #455
shosty
Human being with feelings
 
Join Date: Aug 2015
Posts: 144
Default

Quote:
Originally Posted by kytdkut View Post
"Note: /etc/security/limits.conf does not work if systemd exists."
That's very interesting, I've never heard of that before. I do wonder how valid/universal a statement that is though, I'm sure I've encountered similar issues in other software where this does fix the issue despite systemd being there.
shosty is offline   Reply With Quote
Old 06-16-2018, 05:21 AM   #456
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,770
Default

I don't think it's right that the existence of /etc/systemd/system.conf and /etc/systemd/user.conf in some way disables the limit.conf file, though I haven't tried It might serve to limit things further though?

The two above files are default on my archlinux, but I have added the following to /etc/security/limits.d/99-realtime.conf (and added a realtime group and my own user to the realtime group).

@realtime - rtprio 98
@realtime - memlock unlimited
@realtime - nofile 65536

You could just use your username instead of a group, like this:

jack - rtprio 98
jack - memlock unlimited
jack - nofile 65536
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 06-16-2018, 10:25 AM   #457
kytdkut
Human being with feelings
 
Join Date: May 2017
Posts: 45
Default

yes, thats a better approach I guess. I already had that file with this contents:

@audio - rtprio 98
@audio - nice -10
@audio - memlock unlimited

Will be adding nofile there and leaving the other two files to its defaults

thanks Jack and shosty!
kytdkut is offline   Reply With Quote
Old 06-16-2018, 10:51 AM   #458
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,770
Default

Quote:
Originally Posted by kytdkut View Post
@audio - nice -10
This one you can leave out, as it's not pertinent.
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 06-25-2018, 04:39 AM   #459
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,770
Default

@osxmidi:

If it takes a long time to start lin-vst-server it seems like the result is that reaper hangs and the terminal output shows: "ERROR: Remote VST startup failed". Wouldn't it be possible to make the linux part come up but as a disabled plugin instead? At least one wouldn't have to kill reaper to be able to recover.

In the same spirit, sometimes when windows vsts have crashed they just take reaper down with them, wouldn't it be possible to recover more gracefully in case of problems? Though I haven't had the latter happen for a long time...
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 06-27-2018, 02:51 AM   #460
4duhwinnn
Human being with feelings
 
Join Date: Mar 2017
Posts: 385
Default

tested some plugins with linvst and the wine-staging-3.11,
some nice ones work well,
Fathom modular synth
Kirnu Cream arpeggiator
Tantra multi-effects
ThornCM
Wiggle
Synthmaster2
Rhino
DrumCore/KitCore
Amplitube
LaGrange

Lot's of previous wine over-rides have what appears to be
replacements of nearly the same size in the wine install,
so I used those instead of over-rides. I'm not sold on
that strategerie in this release, but time will tell.

Also, there appears to be some trouble
with multiple dot net frameworks, (a shocking developement wink wink)

I read where one user solved a problem by deleting two dotnets
that were not installed in the order m-soft released them,
and then reinstalled in the order somewhat likely to have been
planned for by m-soft, 2015 before 2017 etc
Food 4 thought

Fathom modular synth dev may have another $12 Friday sale this week, after some
long coding sessions to optimize and beautymize the instrument.
An ongoing topic is at kvr-instruments forum.
Cheers

Last edited by 4duhwinnn; 06-27-2018 at 02:53 AM. Reason: clearity
4duhwinnn is offline   Reply With Quote
Old 06-27-2018, 11:14 AM   #461
4duhwinnn
Human being with feelings
 
Join Date: Mar 2017
Posts: 385
Default

Oatmeal synth is loading again! In a fresh wine-staging 3.11,
with the latest Reaper 5.92. For too long, the oatmealprs.dat file
was unliked by Reaper & Co, but that appears to be history (again)

Why Oatmeal? Pro sound, and one of the best randomizers out there.
So new sounds are easy, among the nice collections in the fullpack
linked below.
The quirks also may be local to me and mine, hopefully that's the case.
Worth giving it a shot!

Some caveats, perhaps because it's pretty old?
When loading a bank, or other choice, the mouse pointer disappears,
but if you aim well, you can open a bank, or other choice,
whereupon the mouspointer remains visible during the session.
(there is also a text box that displays
items as the mouse hovers, for those with poor arcade skillz)

In linux reaper, the arrow keys don't traverse the sounds list.
But there is a gui widget for that, and the reaper popup is large,
and not a huge pain when auditioning.

There is a V3.8 'Fullpack' out there holding the plugin and
a large collection of soundbanks and skins:

https://sites.google.com/site/uproar24/downloads


I use the 'lf_lumina' skin by limeflavor (the designers nik, not the color)

Cheers
4duhwinnn is offline   Reply With Quote
Old 07-01-2018, 01:48 PM   #462
Tobbe
Human being with feelings
 
Tobbe's Avatar
 
Join Date: Sep 2009
Location: Backe, Jämtland, Sweden
Posts: 295
Default Finally got things up and running

Hi,

I installed Reaper For Linux and LinVST. Did some tests on:

* Amplesound Acoustic Guitar LITE
* Amplesound BASS LITE
* SForzando and a bunch of sfz files, orchestra, piano, cello etc,etc
* Manda Powerdrumkit
* LinuxDSP plugins (bought then ages ago) Dyn500, EQ500, GT500 & PEQ-2A
* T-Force Alfa Plus (Free Synth)
* Keyzone Classic (Free Piano), and finally
* Hornet VUMeter MK3

Everything seems ok. Loaded up one song made in Wine/Reaper with the same VSTi as above and it sounded great. When I play Amplesound Acoustic alone, testing different tempo and settings I get a little cracking noise, not much but it's there. The bassguitar is ok, and every other instrument.

One thing in Reaper itself is the white bar I have beside mastertrack and (right side) and between mixer and tcp, also a white bar/line. Doesn't matter if I change theme.

I'm gonna try to see if Harrison Mixbus plugins works also. I bought some of them.

Thanks all for all your work on this. You are the best.

//Tobbe
__________________
OS: MX-Linux 5.0.0-18.1-liquorix-amd64 #1 ZEN SMP PREEMPT liquorix (64Bit), Reaper For Linux (64Bit) (16GB RAM), HoRNet VST Plugin, Amplesound Bass & Acoustic (Free) and many other free stuff. Behringer U-PHORIA UMC22.
Tobbe is online now   Reply With Quote
Old 07-04-2018, 10:26 AM   #463
David Else
Human being with feelings
 
David Else's Avatar
 
Join Date: Mar 2012
Location: Near London, UK
Posts: 575
Default

LinVST just got a mention in the new official Ubuntu Studio Audio Handbook:

https://help.ubuntu.com/community/Ub...ecordingArdour

See the bottom. I expect they would add more info if requested.

Quote:
LinVST

In the course of writing this book, I came across a relatively new way of using Windows-only .dll VST plugins in Linux. It looks like the setup is fairly involved, but the general principle is that a program is used to copy the Windows .dll file to a .so file, and they are stored together. A Linux DAW can then read the .so file. No need for Wine or Carla. You can read more about it here: https://github.com/osxmidi/LinVst
A PDF download is “coming soon”...
__________________
----------> Fedora Linux Distribution = Computing Joy & Freedom <----------
Learn Digital Audio Home | 'Nebula Explained' Course Out Now! | YouTube Channel | Twitter
David Else is offline   Reply With Quote
Old 07-05-2018, 03:26 AM   #464
shosty
Human being with feelings
 
Join Date: Aug 2015
Posts: 144
Default

Quote:
Originally Posted by David Else View Post
LinVST just got a mention in the new official Ubuntu Studio Audio Handbook:

https://help.ubuntu.com/community/Ub...ecordingArdour

See the bottom. I expect they would add more info if requested.



A PDF download is “coming soon”...
That seems a questionable statement that they used. You do need wine and, as far as I know, the latest version you can get.
shosty is offline   Reply With Quote
Old 07-05-2018, 03:31 AM   #465
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,770
Default

Quote:
Originally Posted by shosty View Post
That seems a questionable statement that they used. You do need wine and, as far as I know, the latest version you can get.
That ubuntu book seems chockfull of dubious information :S
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040,etc. :)
Jack Winter is offline   Reply With Quote
Old 07-09-2018, 06:36 AM   #466
SuperEB
Human being with feelings
 
Join Date: Jan 2016
Posts: 25
Default

Regarding Waves plugins, has anyone been able to move the licenses back and forth between drive_c / flash drive and/or the cloud running Waves central in WINE?

It seems like using "Easy Activate and Install" is a different operation than doing an install and move licenses in separate steps. Waves Central will show drive_c is disconnected, but if you do the easy activate/install, it just dumps the licenses onto the drive. If you do it any other way, the license part requires either USB drive serial number or network card ID if you want to use drive_c. The problem is you cannot find or move the licenses back to the cloud or a flash drive. WC show the drive as disconnected.

Unfortunately most of my plugins are V9 and V10 came out, you have to use the offline installer for V9 which does not have easy activate and install as an option.
SuperEB is offline   Reply With Quote
Old 07-11-2018, 08:39 AM   #467
nosucherror
Human being with feelings
 
nosucherror's Avatar
 
Join Date: Oct 2013
Location: London, Perfidious Albion
Posts: 57
Default windows.h missing

Quote:
Originally Posted by nosucherror View Post
Hi OSXMIDI,
I'm having trouble installing LinVst, I'm using WINE development. When I 'make' I get the error:
lin-vst-server.cpp:45:10: fatal error: windows.h: No such file or directory

My windows.h file is in:
/usr/include/wine-development/wine/windows/
but it seems to be looking in:
/usr/include/wine-development/windows

Any help appreciated.
Turns out this was easily fixed: in the LinVst-master folder open Makefile with a text editor and change the path on line 16 to match your system's.

Is OSXMIDI out there? Haven't heard anything from you in a while my friend.
__________________
Kubuntu 18.04 | M-Audio Fast Track Ultra & M-Audio Delta 1010 | AMD FX-8320 | 16Gib RAM
nosucherror is offline   Reply With Quote
Old 07-12-2018, 11:26 PM   #468
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 517
Default

Quote:
Originally Posted by nosucherror View Post
Turns out this was easily fixed: in the LinVst-master folder open Makefile with a text editor and change the path on line 16 to match your system's.

Is OSXMIDI out there? Haven't heard anything from you in a while my friend.
Yes, thanks for asking.

I've got a lot going on at the moment so I'm taking a bit of a break from LinVst.
osxmidi is offline   Reply With Quote
Old 07-12-2018, 11:31 PM   #469
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 517
Default

Quote:
Originally Posted by Jack Winter View Post
@osxmidi

Wondering what you are planning to do with the Steinberg header files needed to build this. Apparently Steinberg is discontinuing support for VST2, even worse is that they are removing it from the VST3 SDK. This essentially means that anyone not already having aquired the SDK from Steinberg won't be able to get the needed header files in the future...:S

There exists a clean room reverse engineered version known as Vestige, but at least one project on GitHub using it has received a DCMA take down request... Don't know if they are actually going to try to kill the Vestige headers too, or if it was just a mistake seeing the header file name is the same as the original steinberg header... Time will tell I guess.
Interesting.

Maybe a modified Vestige is ok, I'll look into it when I get the time.

I have previously looked at the possibility of a LinVst VST3 based wrapper.
osxmidi is offline   Reply With Quote
Old 07-12-2018, 11:38 PM   #470
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 517
Default

Quote:
Originally Posted by SuperEB View Post
Regarding Waves plugins, has anyone been able to move the licenses back and forth between drive_c / flash drive and/or the cloud running Waves central in WINE?

It seems like using "Easy Activate and Install" is a different operation than doing an install and move licenses in separate steps. Waves Central will show drive_c is disconnected, but if you do the easy activate/install, it just dumps the licenses onto the drive. If you do it any other way, the license part requires either USB drive serial number or network card ID if you want to use drive_c. The problem is you cannot find or move the licenses back to the cloud or a flash drive. WC show the drive as disconnected.

Unfortunately most of my plugins are V9 and V10 came out, you have to use the offline installer for V9 which does not have easy activate and install as an option.
Yes I moved the licence from the cloud to drive_c and back and to usb I think but I've only used the week long demo licence as a test, I would think that the full commercial license wouldn't be much different but I havn't tested it.

Problems might be due to distro/wine libraries etc.
osxmidi is offline   Reply With Quote
Old 07-16-2018, 05:26 AM   #471
SuperEB
Human being with feelings
 
Join Date: Jan 2016
Posts: 25
Default

Quote:
Originally Posted by osxmidi View Post
...Problems might be due to distro/wine libraries etc.
Ok thanks. I've completely nuked and re-installed wine/libraries without success. Glad to know its possible, was questioning whether I should invest any more time into this. Currently I'm using Mint.

Unless you or anyone else has a better recommendation, I'll try Xubuntu next, mainly because I'm already using it on another machine.
SuperEB is offline   Reply With Quote
Old 07-17-2018, 10:29 PM   #472
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 517
Default

Quote:
Originally Posted by SuperEB View Post
Ok thanks. I've completely nuked and re-installed wine/libraries without success. Glad to know its possible, was questioning whether I should invest any more time into this. Currently I'm using Mint.

Unless you or anyone else has a better recommendation, I'll try Xubuntu next, mainly because I'm already using it on another machine.
Why not try a Waves demo license first and see what happens and then if that's ok delete the wine prefix and start again with the full version.

Waves V10 needs some additional steps to work btw which are up on the LinVst Github page.
osxmidi is offline   Reply With Quote
Old 07-18-2018, 11:58 AM   #473
4duhwinnn
Human being with feelings
 
Join Date: Mar 2017
Posts: 385
Default

I installled wine-staging 3.12 in Mint 18, and without any over-rides,
was able to install and authorize IK Multimedia's free
SampleTank 3 Custom Shop and then import legacy soundsets from their older
32 bit collections. ST3 is on sale for $99 through August 4th,
33 gig of samples, 4000 instruments in 21 categories.
It's 16 part multi-timbral, with a great multi-effects system,
and simmple to use. IK's authorization manager gives
constant access to purchase history, serial numbers,
and available updates. Most important, it actually works.
Cheers
4duhwinnn is offline   Reply With Quote
Old 07-18-2018, 01:02 PM   #474
4duhwinnn
Human being with feelings
 
Join Date: Mar 2017
Posts: 385
Default

Quote:
Originally Posted by SuperEB View Post
Ok thanks. I've completely nuked and re-installed wine/libraries without success. Glad to know its possible, was questioning whether I should invest any more time into this. Currently I'm using Mint.

Unless you or anyone else has a better recommendation, I'll try Xubuntu next, mainly because I'm already using it on another machine.
Hi, I assume you're financially vested in Waves, and really like
using them, so what I would do, tedious as it may be, is start
with an empty wine staging 3.12, add an over-ride, and test,
one at a time, and remove each over-ride that seemingly
accomplishes nothing, as you go. When one has a positive effect,
chronicle that, and continue. The ones of no visible effect
can be added back later, as there may be cumulative over-ride
teamwork efforts needed to make some things spring to life.

In the meantime, IK Multimedia has a free Amplitube Custom Shop
version with a basic set of gear, to let you use and test
the sound quality, and ease of use.
Amplitube gear models can be tested for 48 hours,
twice a year, to be purchased ala-cart, if you have a specialty
need, rather than buying a large package. I bought the Fulltone
collection, 3 classic items in one go, and Amplitube 4,
and find both the retail end of the Custom shop, and the
authorization manager app work well in wine-reaper,
and my IK 'user area' listed 4 updates available,
which I'll do today, cyber willing.

http://www.ikmultimedia.com/products/fulltone/

I doubt switching between ubuntu flavors will
directly affect waves use, but may be desired on
other merits.

Cheers
4duhwinnn is offline   Reply With Quote
Old 07-18-2018, 04:56 PM   #475
SuperEB
Human being with feelings
 
Join Date: Jan 2016
Posts: 25
Default

Quote:
Originally Posted by osxmidi View Post
Why not try a Waves demo license first and see what happens and then if that's ok delete the wine prefix and start again with the full version.

Waves V10 needs some additional steps to work btw which are up on the LinVst Github page.
Thanks. I did try this, but got the following message when loading Waves Central as well as when I attempted to install the C1 demo:

No connected devices
No USB flash drives were detected and your Ethernet card seems to be disabled. Please enable your Ethernet card and/or connect your USB flash drives, and reload Central." My ethernet is enabled and my USB drive with the Waves licenses is always plugged in!

Quote:
Originally Posted by 4duhwinnn View Post
Hi, I assume you're financially vested in Waves, and really like
using them, so what I would do,
Thanks for the suggestion. Yes I do have a bunch of Waves stuff, but really If I could replace AR Plates and the 670, I could do without the rest. I've tried many alternatives. My problem was not with running Waves plugins,as the first time I ran WC, WC mysteriously dumped licenses onto my system. The plugins worked great, but WC could not find them after the fact so that they could be moved as needed! When I booted from my W10 partition, somehow WC was able to find and retrieve them, but moving them back to my hard drive in W10 did not make them available in Linux.
SuperEB is offline   Reply With Quote
Old 07-18-2018, 06:45 PM   #476
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 517
Default

Quote:
Originally Posted by SuperEB View Post
Thanks. I did try this, but got the following message when loading Waves Central as well as when I attempted to install the C1 demo:

No connected devices
No USB flash drives were detected and your Ethernet card seems to be disabled. Please enable your Ethernet card and/or connect your USB flash drives, and reload Central." My ethernet is enabled and my USB drive with the Waves licenses is always plugged in!
I get that error when I start Waves Central with no usb stick plugged in.

It looks to me like your usb port/drive letter is not working with wine for some reason.
osxmidi is offline   Reply With Quote
Old 07-18-2018, 07:00 PM   #477
SuperEB
Human being with feelings
 
Join Date: Jan 2016
Posts: 25
Default

Quote:
Originally Posted by osxmidi View Post
I get that error when I start Waves Central with no usb stick plugged in.

It looks to me like your usb port/drive letter is not working with wine for some reason.
Wine recognizes it as F:. Does wine show a serial number for your flash drive in winecfg? Mine does not and when I enter the serial number, it does not save it. Also tried placing it in a .serial file with no luck.
SuperEB is offline   Reply With Quote
Old 07-18-2018, 07:48 PM   #478
osxmidi
Human being with feelings
 
Join Date: Feb 2014
Posts: 517
Default

Quote:
Originally Posted by SuperEB View Post
Wine recognizes it as F:. Does wine show a serial number for your flash drive in winecfg? Mine does not and when I enter the serial number, it does not save it. Also tried placing it in a .serial file with no luck.
I get it as D: /media/"LinuxUser"/Lexar

Path /media/"LinuxUser"/Lexar

Type Autodetect

Device /dev/sdb1

Label

Serial 0

I have had reports of someone getting Waves V9 and Waves V10 running on their system.

Certain distros have their own wine builds (for Ubuntu or Debian or whatever) and maybe some are more compatible than others, I don't know.

I've only tried Waves out with Debian Stretch and the Debian Wine Staging build and it seems to run Waves plugins pretty well with no dll overrides needed.

On one system that I've had Waves running ok on I'm using MX Linux based on Debian Sid and the liquorix kernel.

I don't need to setup the usb drive in wine, I just plug it in and then Waves Central picks it up.

Last edited by osxmidi; 07-18-2018 at 09:02 PM.
osxmidi is offline   Reply With Quote
Old 07-19-2018, 06:14 AM   #479
SuperEB
Human being with feelings
 
Join Date: Jan 2016
Posts: 25
Default

Quote:
Originally Posted by osxmidi View Post

Certain distros have their own wine builds (for Ubuntu or Debian or whatever) and maybe some are more compatible than others, I don't know...
Ok, drive settings in wine look comparable. I think I will try debian stretch as soon as I have the chance. I only chose Mint because it was my first serious venture into the world of Linux and there was an online guide for optimizing for DAW use.
SuperEB is offline   Reply With Quote
Old 07-20-2018, 03:04 PM   #480
Nixon
Human being with feelings
 
Nixon's Avatar
 
Join Date: Dec 2011
Posts: 275
Default

Did someone get one of the latest TAL plugins working via LinVST?
__________________
Item FX Sends -
Nixon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:15 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.