Old 12-08-2015, 03:22 PM   #1
hdpixiedust
Human being with feelings
 
Join Date: Mar 2011
Posts: 7
Default Using ducking with Reaper live

I use ReaComp for ducking on tracks that are already recorded.

I want to use Reaper for a live event, background music playing through Reaper, when someone pics up the mic to make an announcement it will duck the music.

When I use ReaComp in input FX on the background music track I can't get track one, the mic, to trigger the compressor.

Thanks for your help.
hdpixiedust is offline   Reply With Quote
Old 12-08-2015, 04:29 PM   #2
Dstruct
Human being with feelings
 
Join Date: Jul 2006
Posts: 12,296
Default

1. Don't use Input FX on the Background track. Normal FX.
2. Route audio from Mic track channels 1/2 -> Background track channels 3/4 + Disable Mic parent send
3. Set Mic track to Monitor Input

Last edited by Dstruct; 12-08-2015 at 04:44 PM.
Dstruct is offline   Reply With Quote
Old 12-08-2015, 04:36 PM   #3
msmucr
Human being with feelings
 
Join Date: Jun 2009
Location: Praha, Czech republic
Posts: 590
Default

I wouldn't do it via input FXs, but via normal track FXs.
- Create two tracks in Reaper.
First stereo track with live music input, second track with live mic input
- Create pre-fader send from mic track to the channels 3-4 at music track.
- Set volume fader at mic track to zero (you'll likely don't want this control signal to be heard)
- Add ReaComp to music track, set its Detector input to Auxiliary input, ratio 1:10 or so, some longer attack, longer release (eg. 1.5s) and possibly adjust RMS size to some time like 50ms to avoid jumpy behavior.
- Arm both tracks and enable record monitoring via speaker icon

Michal
__________________
FRs: Better FX bypass
msmucr is offline   Reply With Quote
Old 12-08-2015, 04:45 PM   #4
Dstruct
Human being with feelings
 
Join Date: Jul 2006
Posts: 12,296
Default

Quote:
Originally Posted by msmucr View Post
- Arm both tracks and enable record monitoring via speaker icon
No need to arm the music track ...
Dstruct is offline   Reply With Quote
Old 12-08-2015, 04:59 PM   #5
msmucr
Human being with feelings
 
Join Date: Jun 2009
Location: Praha, Czech republic
Posts: 590
Default

Quote:
Originally Posted by Dstruct View Post
No need to arm the music track ...
According to description, I've assumed, Reaper won't be music source ("background music playing through Reaper"). So it depends, if he needs to apply ducking to live stereo input or music at that track. For the first case, he will likely need to arm that track as well.

Michal
__________________
FRs: Better FX bypass
msmucr is offline   Reply With Quote
Old 12-08-2015, 05:03 PM   #6
Dstruct
Human being with feelings
 
Join Date: Jul 2006
Posts: 12,296
Default

Oops, you're right.
Dstruct is offline   Reply With Quote
Old 12-08-2015, 06:33 PM   #7
hdpixiedust
Human being with feelings
 
Join Date: Mar 2011
Posts: 7
Default Still not working

I am so grateful for the help and I carefully gone over the answers several times but I must be doing something wrong.

Music is coming from Winamp on the same computer that is running Reaper.

Track 1 is vocal –
Master / parent send is checked
Parent channels 1-4
Track channels 4
Send to track 2 music (4ch)
Audio ½ to ¾
Pre-fader (post FX)

Track 2 is music (Winamp) –
Master / parent send is checked
Parent channels 1-4
Track channels 4
Receive from track 1 vocal (4ch)
Audio ½ to ¾
Pre-fader (post FX)

ReaComp is on music track 2, normal FX
The 4 in 2 out routing is standard
Detector input is set to: Auxiliary Input L+R
Threshold -30
Wet is at +0.0
Dry is at the bottom, inf

I have varied the compression ratio from 10:1 to 50:1 to try and hear a difference.

I can adjust pre-comp, attack and release once the compression is working.

Winamp is playing on track 2, music track
Mic works and displays on the meter of track 1

Both tracks are armed
Record monitoring is on for the vocal (mic) track
The music is showing up on the green meter bars on the threshold fader.

*** There is no output showing on the ReaComp.

Speaking into the mic shows up in the track 1 meter and gives me red compression in ReaComp but it is not ducking the music???

I have checked and unchecked master/parent send on both io’s with no change.

I tried hitting record to see if actually recording the process would help but no change.

I’m stumped?

Any ideas?
hdpixiedust is offline   Reply With Quote
Old 12-08-2015, 06:37 PM   #8
Dstruct
Human being with feelings
 
Join Date: Jul 2006
Posts: 12,296
Default

You need to enable monitoring on both tracks (speaker button) too. Mic track also only needs 2 channels, not 4.
Dstruct is offline   Reply With Quote
Old 12-09-2015, 10:37 AM   #9
hdpixiedust
Human being with feelings
 
Join Date: Mar 2011
Posts: 7
Default Still not working part 2

Dstruct (and Msmucr),

I greatly appreciate the suggestions and have followed your advice. I still can’t get the 2nd track, the music track, to be compressed.
hdpixiedust is offline   Reply With Quote
Old 12-09-2015, 10:59 AM   #10
Dstruct
Human being with feelings
 
Join Date: Jul 2006
Posts: 12,296
Default

Does the sidechain signal get into ReaComp (check "preview filter")?
Dstruct is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 07:56 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.