COCKOS
CONFEDERATED FORUMS
Cockos : REAPER : NINJAM : Forums
Forum Home : Register : FAQ : Members List : Search :

Go Back   Cockos Incorporated Forums > Other Software Discussion > WDL users forum

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 02-11-2021, 04:22 PM   #1
Nonlinear
Human being with feelings
 
Join Date: Apr 2018
Posts: 391
Default ISwitchControl "write" automation erratic in Logic Pro X

I've discovered a problem that none of my ISwitch controls write automation properly in Logic Pro X. They work properly everywhere else including Audio Units in Reaper, AAX in Pro Tools and VST/VST3. All controls READ data properly if manually drawn in Logic's timeline.

1) When "write" automation is turned on in Logic, toggling a button/switch on the plugin only records in Logic if it is toggled SLOWLY - i.e., with some time between toggles. Press the button/switch too fast and the change does not get recorded even though it DOES change the status in the plugin. In other words, you can hear/see that the control is working in the plugin but Logic doesn't record the change. I have tried different automation settings in Logic with no improvement.

2) The status shown in the Inspector section of Logic's tracks window sometimes doesn't match the automation value shown in the Tracks section of Logic. Here is an example where I toggle the BYPASS button in my plugin - the Plugin changes state; Logic's Inspector shows that change; but the change does not get recorded in the timeline:

https://drive.google.com/file/d/1RL1...ew?usp=sharing

What's going on here and why only in Logic Pro X? Is this a bug in the plugin - or in LOGIC? This is only happening with ISwitch controls - IKnobMulti and IRadioButton controls work properly.

Last edited by Nonlinear; 02-11-2021 at 07:52 PM.
Nonlinear is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:11 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.