Old 01-02-2020, 12:36 PM   #1
Human being with feelings
Join Date: Nov 2019
Posts: 223
Default Reaper GUI low fps on higher resolutions

Before reading: I always keep the opening post up to date, so people new to this thread (or devs) don't have to read through all the comments.

Short time ago I moved from Cubase to Reaper. Now that I have set up everything as I needed it I have some serious lag problems when dealing with bigger projects.
My track template is about 100 tracks, my main Monitor is a 4k 32" and my second monitor is a 1680x1050 one. I experience lags especially when hand scrolling/vertical scrolling around a bunch of split up items on the 4k monitor, not on the smaller one. In my example I have 2 drum performances of ~3 minutes each, which are dynamically split up at their snare and kick hits. A normal scenario when editing recorded drums.

Before I used a GT1030 which is bare minimum for a 4k monitor and I thought that is the issue, then I ordered a RX590 which should be much more powerful, but still lags, even if it is a little bit better. Overall the smaller screen feels snappier in Reaper, even with no items visible. Windows itself is as snappy as it can get. For comparison: In Cubase it lags a lot less when dealing with similar numbers of tracks and items.

Now everybody says that Reaper doesn't use the GPU, but I can see how 3D usage goes up when scrolling in Reaper. It also depends on the zoom level in the arrangement view. I noticed, that on the 4k screen the 3D GPU usage is always ~double than on the smaller 1680x1050 screen. When zoomed out to max the GPU usage goes up to 70% on the 4k screen and 35% on the smaller one. When zoomed in that all items of the drum performances are visible, the GPU usage drops to 20-30% for each screen, only that it lags on the 4k and is snappy on the smaller screen.

Videos which show the issue:

Video 1a shows you how it lags on the 4k screen when scrolling around the split up drum performances, but not on some single drawn midi items.


Video 1b shows you how the GPU 3D usage goes up when zoomed out to max and scrolling. It is around 60%-70% and feels also fast.


Video 2a shows that on the 1680x1050 screen it is always fluid and reacts quickly.


Video 2b shows you how the GPU 3D usage goes up when zoomed out to max and scrolling. It is around 30%-35% and feels also fast.


Video 3 shows you how it lags in the midi editor when moving notes during playback on the 4k monitor.


Video 4 shows no lag in the midi editor when moving notes during playback on the 1680x1050 monitor.


What I have tried + additional info:

- There is no real big difference from using a Geforce GT1030 with 2GB RAM and a (way faster) AMD RX 590 with 8GB RAM
- Scrolling horizontally is not that bad as scrolling vertically or hand scrolling
- It gets a bit worse sometimes if there is a time selection visible
- I installed Reaper 6.02 freshly
- It behaves exactly the same even with all toolbars disabled
- On one page there are around 80 tracks visible
- does not matter which theme is loaded
- no plugins are loaded
- installed the newest drivers on each graphic card when testing
- tried various display settings like 8bit or 10 bit colors
- free sync on-off, game mode on display on/off (was even worse when it was on)
- different display cables (hdmi 2.0/displayport 1.2)
- installed older drivers or just the standard drivers from windows update
- disabling/enabling integrated graphics
- Cleaned up all remaining GPU/audio drivers with the DDU removal tool and reinstalled drivers
- newest windows update (installed 1909)
- booted to win safe mode to test it
- tried various appearance prefs and UI tweaks in Reaper but no luck (multimon aware/aware/etc)
- scanned my system for virusses/malware/mining with Norton PE/Roguekiller/etc.
- tried various audio buffer settings from lowest to highest
- windows/browsing/office/videos run as smooth as they can be on this PC
- pref hi-resolution peaks is set to off
- tested it positive on multiple systems (read below)

How to reproduce:

I uploaded a project, so others can try to reproduce my issue on a hi-res screen (4k). Would help a lot if others could confirm the issue:

1) Open the project and load the Reaper 5 default theme on a 4k screen
2) adjust the zoom level so the items fill the screen horizontally like this

3) marquee select and time select the items and hand/vertical scroll around them
4) then try to zoom in vertically to fill the screen with the items, and repeat Nr. 3). Any change?
5) optionally: try the same on a 1080 screen. In my case its night and day difference
6) You can try to lower the minimum track height in the rtconfig.ini file, this makes it even worse

PS: I sliced the audio up in a lot of pieces to simulate a quantized drum performance and/or a project with a lot of stuff going on. Doesn't matter if plugins are missing, since it happens also without them.
Thank you very much!

I also could reproduce this issue all the time on other systems:

I was able to reproduce this issue on 2 systems which are completely different from mine, to report my findings here. And in both cases I was able to get about the same behaviour on 4k (I downloaded and installed Reaper directly from the homepage and then opened the project I attached in this thread):

AMD Ryzen 7 2700X 8X 3,7Ghz - 32gb RAM - 500gb SSD M2 - GTX 1080 ti - Windows 1803 installed on June 2019
AMD FX8300 8x 3,3 GHz - 8gb RAM - 256 SSD - GT 1030 - Windows 1909 freshly installed

So now I am pretty sure that this must be an issue for everyone with higher resolutions.

Last edited by Eraz; 01-20-2020 at 08:11 AM.
Eraz is offline   Reply With Quote
Old 01-03-2020, 04:59 AM   #2
Human being with feelings
Join Date: Jul 2006
Posts: 1,384

Your videos have been assigned as Private (no one else except you could watch them).
Please make them Public (from properties or attributes menus).
♦ YouTube → .: Pashkuli Keyboard :.
♦ Gmail → pashkuli.keyboard@gmail.com
adXok is offline   Reply With Quote
Old 01-03-2020, 05:05 AM   #3
Human being with feelings
Join Date: Nov 2019
Posts: 223

Originally Posted by adXok View Post
Your videos have been assigned as Private (no one else except you could watch them).
Please make them Public (from properties or attributes menus).
Okay thanks, changed it. Should now be visible for everyone!
Eraz is offline   Reply With Quote
Old 01-03-2020, 12:38 PM   #4
Human being with feelings
Join Date: Nov 2019
Posts: 223


When (hand)scrolling in Reaper it's the process csrss.exe which uses the GPU. That happens only in Reaper though, when scrolling around in other programs like chrome or explorer csrss.exe is around 2-3%.

And the lag gets better when Reaper is not opened full screen on the 4k monitor. When resizing the Reaper window to ~25% it is nearly as responsive as on the smaller monitor.

Also when setting the 4k monitor down to 1680x1050 resolution, the lag is gone and it is as snappy as on the smaller monitor.
That could lead to the conclusion that the lag is related also to the max displayed track count, cause on 4k I see around 80 tracks at the same time, and on 1920x1200 I see around 40 (on top of that it also depends on the max item count displayed on the screen as seen in video 1a).


Tried to hide also most of the tracks using the track manager, but that does not change anything when resizing the remaining tracks to fill the screen it seems. So not even the track count is the culprit, it seems Reaper just struggles in general on 4k when the full screen is used...

Last edited by Eraz; 01-03-2020 at 03:36 PM.
Eraz is offline   Reply With Quote
Old 01-04-2020, 12:10 PM   #5
Human being with feelings
Join Date: Nov 2019
Posts: 223


Also when time selecting/marquee selecting/drawing items (basically anything GUI related, some things more, some things less) csrss.exe jumps up when doing any of the operations mentioned before:

- If you have no/less amount of items on your screen it lags less, but csrss.exe uses way more GPU.
- If you have lots of items on your screen it lags more, but the process csrss.exe uses way less GPU.

There must be some correlation to that process.
It seems somehow that with more things going on the view (tracks+items), Reaper limits the amount of usable CPU/GPU for GUI stuff, therefore the CPU/GPU usage goes down and it begins to lag. If less tracks and items are visible, Reaper releases more resources to GUI stuff, the CPU/GPU usage goes up, and everything becomes more snappy again.

This seems to become more of an issue on bigger screens (4K) as more details/pixels/ whatever need to be rendered.
These are all assumptions of course, but it behaves exactly like that.

I also checked if normal tasks in Win10 do spike the GPU use of csrss.exe (since other users complained about that on google), then I checked Cubase with a heavy loaded project, but in both cases it stays below 1%. So only Reaper triggers that process..

Last edited by Eraz; 01-15-2020 at 03:21 PM.
Eraz is offline   Reply With Quote
Old 01-05-2020, 09:21 AM   #6
Human being with feelings
Xenakios's Avatar
Join Date: Feb 2007
Location: Oulu, Finland
Posts: 8,062

I don't understand how csrss.exe would even relate to Reaper, since it should mostly deal with console (command line) windows. (Do you have those open while operating Reaper?)
I am no longer part of the REAPER community. Please don't contact me with any REAPER-related issues.
Xenakios is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -7. The time now is 06:02 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.