Old 07-21-2020, 02:34 PM   #1
airon
Human being with feelings
 
airon's Avatar
 
Join Date: Aug 2006
Location: Berlin
Posts: 10,995
Default CSI Faderport 8 / 16 / v2 builds

This thread is all about using the Presonus Faderport 16, 8 and v2 with the Control Surface Integrator.

Download the CSI beta here or via the links in the signature of the first post of the main CSI thread.

CSI Documentation Wiki

Click on the thumbnails for high resolution images of each unit, all from Presonus themselves.


CSI requires two kinds of files for the most part. MST and ZON files. MST describes what the units sends, putting a name to each message and what feedback to provide. The ZONe files tell CSI what each control resource(button, fader, displays,etc.) actually does and shows. These packages of MST and ZON files will get updated as folks will surely post their own versions too.

Presonus Faderport 16 and 8
Faderport 16 and 8 .MST and .ZON files are collected in this little ZIP file. Download it here:
https://stash.reaper.fm/40068/fp16_and_fp8_csi.zip (updated on 22.07.2020 to fix Faderport 8 MST)

For installation instructions refer to the Documentation Wiki.


We're using the Faderport 16 & 8 in STUDIO ONE mode. This enables you to have to use only one midi device in and out. Using the Faderport 16 in MCU(Logic) mode requires you to use two midi devices which becomes a bit of a mess IMHO. Also, we're free to do whatever we want with the Faderports with the Control Surface Integrator.

Setting up Modifiers
Modifiers can be any button that sends a message when it is pressed, and another when it is let go. There are four global modifiers available that are all assigned in a Zone file.

Right SHIFT button is assgined to be the SHIFT modifier.
In the MST file this button is assigned like so
Code:
Widget ShiftRight 
  Press 90 06 7f 90 06 00
WidgetEnd
In the Zone file it is then assigned like so
Code:
ShiftRight   Shift

Left SHIFT button is assgiend to be the ALT modifier.


You can change these assignments in the Zone file to suit your needs. Just be sure the button you're using sends a press-down and a release message.

Faders
Faders controll the volume of tracks upon startup. The scribble strips indicate the track name. When a fader is touched, the current track volume value is indicated instead. Use the buttons Prev and Next to bank by 16 (Faderport 16) or 8 (Faderport 8) tracks. These buttons are to the right and left of the very large knob on the upper right.
Modifers
Shift + Fader
This controls the PAN of the track

Alt + Fader
Controls the second PAN, i.e. width or channel 2 pan, depending on the panning mode the track was set to.

There are some other modifier functions, so the faders will jump around a bit every time you hold Shift or Alt.

Send mode
Press Send (button to the right of the faders, third from the top) to show the send volume levels on the first 8 faders. Modifiy the Zone file is you'd like more. I don't know how to bank here yet. Mute buttons toggle the mute on the sends. The Select buttons still select tracks.

To go back to controlling the track volume, press Send again, and then press Track. This is due to a bug in CSI at this time(22.07.2020). Usually just pressing Send should have been enough. When it's fixed, nothing needs to be changed.

Small Rotary knob in top left corner
Now controls a single selected tracks PAN, until you change it to do something else.
Automation


The automation buttons are easy. The Off button actually activates Latch Preview. Disregard the Audio button. It is not used in automation matters, unless you yourself want to make it so.

Alt+button changes the mode for all tracks.

Shift+button does a global override. Shift+Pan turns the global override off, which is why the Pan button may be lit up all the time.
Arming
I've taken this out, but feel free to add it back in. Place it in the "Buttons|" zone.

Code:
/ BUTTONS LEFT OF FADERS
  Arm    TrackRecordArm // arms selected tracks
  Shift+Arm Reaper "40490" // arm all tracks
  Alt+Arm  Reaper "40491" // unarm all tracks
  SoloClear Reaper "40340" // Track: Unsolo all tracks
  MuteClear Reaper "40339" // Track: Unmute all tracks
Suggestions and ideas are welcome. Feel free to use and modify anything here to your hearts content.
__________________
(Video)Using Latch Preview - Faderport16 CSI config
Airon Audio Dia/FX Edit&Mix
"My ego comes pre-shrunk" - Randy Thom

Last edited by airon; 07-23-2020 at 04:48 AM.
airon is offline   Reply With Quote
Old 07-21-2020, 03:34 PM   #2
tpulse
Human being with feelings
 
tpulse's Avatar
 
Join Date: Aug 2009
Posts: 272
Smile

Great to have an own thread for us Faderport 8 / 16 owners

My scribble strips indicates nothing...i tried all mcu modes and "studio one" mode works best in Faderport 8

/Pekka
tpulse is offline   Reply With Quote
Old 07-21-2020, 10:34 PM   #3
mschnell
Human being with feelings
 
mschnell's Avatar
 
Join Date: Jun 2013
Location: Krefeld, Germany
Posts: 10,226
Default

Quote:
Originally Posted by tpulse View Post
Great to have an own thread for us Faderport 8 / 16 owners
It would be graet to have a dedicated subforum for the CSI extension !
-Michael
mschnell is offline   Reply With Quote
Old 07-22-2020, 08:28 AM   #4
airon
Human being with feelings
 
airon's Avatar
 
Join Date: Aug 2006
Location: Berlin
Posts: 10,995
Default

Updated the MST for Faderport 8 to fix display issue, thanks to tpulse. See first post for download link.
__________________
(Video)Using Latch Preview - Faderport16 CSI config
Airon Audio Dia/FX Edit&Mix
"My ego comes pre-shrunk" - Randy Thom
airon is offline   Reply With Quote
Old 07-22-2020, 08:57 AM   #5
tpulse
Human being with feelings
 
tpulse's Avatar
 
Join Date: Aug 2009
Posts: 272
Default

Quote:
Originally Posted by airon View Post
Updated the MST for Faderport 8 to fix display issue, thanks to tpulse. See first post for download link.
Thanks, you're welcome
tpulse is offline   Reply With Quote
Old 07-22-2020, 10:08 AM   #6
airon
Human being with feelings
 
airon's Avatar
 
Join Date: Aug 2006
Location: Berlin
Posts: 10,995
Default

Updated the files again.

Small Rotary knob in top left corner
Now controls a single selected tracks PAN, until you change it to do something else.
__________________
(Video)Using Latch Preview - Faderport16 CSI config
Airon Audio Dia/FX Edit&Mix
"My ego comes pre-shrunk" - Randy Thom
airon is offline   Reply With Quote
Old 07-22-2020, 11:15 AM   #7
tpulse
Human being with feelings
 
tpulse's Avatar
 
Join Date: Aug 2009
Posts: 272
Default

Quote:
Originally Posted by airon View Post
Updated the files again.

Small Rotary knob in top left corner
Now controls a single selected tracks PAN, until you change it to do something else.
Great!!! ....but i tried...sorry no difference yet

Last edited by tpulse; 07-23-2020 at 01:38 AM.
tpulse is offline   Reply With Quote
Old 07-23-2020, 04:49 AM   #8
airon
Human being with feelings
 
airon's Avatar
 
Join Date: Aug 2006
Location: Berlin
Posts: 10,995
Default

Has anyone implemented Faderport v2 support yet ?

If it's uploaded, I could include the link to it in the first post, if you wish.
__________________
(Video)Using Latch Preview - Faderport16 CSI config
Airon Audio Dia/FX Edit&Mix
"My ego comes pre-shrunk" - Randy Thom
airon is offline   Reply With Quote
Old 07-23-2020, 11:33 AM   #9
Matthijs
Human being with feelings
 
Matthijs's Avatar
 
Join Date: Jan 2011
Location: The Hague, The Netherlands
Posts: 17
Default reaper_csurf_integrator.dll in Plugins: Reaper stops

Hi, just bought the Faderport 8. Following the instructions on the CSI installation: CSI as a folder in Reaper resource path, stop Reaper, put reaper_csurf_integrator.dll in Plugins-folder of same resource path. I open Reaper. But then, after two seconds, Reaper stops, vanishes. Any suggestions?
Matthijs is offline   Reply With Quote
Old 07-23-2020, 01:06 PM   #10
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 2,121
Default

Quote:
Originally Posted by Matthijs View Post
Hi, just bought the Faderport 8. Following the instructions on the CSI installation: CSI as a folder in Reaper resource path, stop Reaper, put reaper_csurf_integrator.dll in Plugins-folder of same resource path. I open Reaper. But then, after two seconds, Reaper stops, vanishes. Any suggestions?
Did you install to the Plugins folder or the UserPlugins folder? As of more recent builds, it should be the latter.

If you're still having issues, please pop over to the main CSI thread as it may not be FaderPort related.
Funkybot is online now   Reply With Quote
Old 07-24-2020, 01:47 AM   #11
tpulse
Human being with feelings
 
tpulse's Avatar
 
Join Date: Aug 2009
Posts: 272
Default

Quote:
Originally Posted by Matthijs View Post
Hi, just bought the Faderport 8. Following the instructions on the CSI installation: CSI as a folder in Reaper resource path, stop Reaper, put reaper_csurf_integrator.dll in Plugins-folder of same resource path. I open Reaper. But then, after two seconds, Reaper stops, vanishes. Any suggestions?
1: Put the reaper_csurf_integrator.dll in userplugins: In windows:
C:\Users\yourname\AppData\Roaming\REAPER\UserPlugi ns

2: Put the csi folder in: C:\Users\yourname\AppData\Roaming\REAPER\

Keep only :\CSI\Surfaces\Midi
and : CSI\Zones
I've only the Faderport 8 files left in zones and in surfaces
tpulse is offline   Reply With Quote
Old 07-24-2020, 04:48 AM   #12
Matthijs
Human being with feelings
 
Matthijs's Avatar
 
Join Date: Jan 2011
Location: The Hague, The Netherlands
Posts: 17
Default

Thanks, appreciate it. I already did exactly as you said but then in my configuration Reaper stops. I think it's got something to do with the (routing to the) plugin-folders. I only have one plugin in my Userplugins-folder (reaper_reapack-x64.dll) so far and when I add the integrator dll the problem starts. Funkybot is right, this hasn't got to do with the Faderport, I pop over to the main CSI thread. Thanks anyway!
Matthijs is offline   Reply With Quote
Old 07-25-2020, 02:48 AM   #13
tpulse
Human being with feelings
 
tpulse's Avatar
 
Join Date: Aug 2009
Posts: 272
Default

I've tried it all with studio one mode in fp8 without success to control the small blue rotary.

It works with MCU-Logic mode in FP( when using CSI Mcu for FP8 in Reaper
tpulse is offline   Reply With Quote
Old 07-25-2020, 04:18 AM   #14
airon
Human being with feelings
 
airon's Avatar
 
Join Date: Aug 2006
Location: Berlin
Posts: 10,995
Default

tpulse, you could verify that the knob sends the data the widget expects. I worked off the specs in the manual which were identical to the FP16, but there could be a mistake on my side.

Call up the action CSI edit mode, check the two in and out checkboxes on the right and start moving the knob, and change the .mst if necessary.

If all is well however, then it could be just a mistake in installation or configuration when setting up . Install the package again, more slowly.

I‘ve got an update coming that puts in VCA mode, adds pan width to the big knob and brings in more colour to the automation buttons for shift and alt combos.
__________________
(Video)Using Latch Preview - Faderport16 CSI config
Airon Audio Dia/FX Edit&Mix
"My ego comes pre-shrunk" - Randy Thom
airon is offline   Reply With Quote
Old 07-25-2020, 07:27 AM   #15
tpulse
Human being with feelings
 
tpulse's Avatar
 
Join Date: Aug 2009
Posts: 272
Default

I'll try to re-install later. I remember having all options ticked . I looked at faderport manual and when it is in "studio one mode" it speaks sysex language, the weird thing is that the faders work nut the problem starts when trying to adress the encoders.

I'm not an expert on this but interested, you should see how happy i was when i found the "display" issue.. i felt like an expert haha
tpulse is offline   Reply With Quote
Old 07-25-2020, 08:33 AM   #16
airon
Human being with feelings
 
airon's Avatar
 
Join Date: Aug 2006
Location: Berlin
Posts: 10,995
Default

Quote:
Originally Posted by tpulse View Post
I'll try to re-install later. I remember having all options ticked . I looked at faderport manual and when it is in "studio one mode" it speaks sysex language, the weird thing is that the faders work nut the problem starts when trying to adress the encoders.

I'm not an expert on this but interested, you should see how happy i was when i found the "display" issue.. i felt like an expert haha
Ah well. I have everything UNchecked for the surface in the CSI preferences config of the setting.
__________________
(Video)Using Latch Preview - Faderport16 CSI config
Airon Audio Dia/FX Edit&Mix
"My ego comes pre-shrunk" - Randy Thom
airon is offline   Reply With Quote
Old 07-25-2020, 09:13 AM   #17
tpulse
Human being with feelings
 
tpulse's Avatar
 
Join Date: Aug 2009
Posts: 272
Default

Hmm. Maybe that fixes the issue for me haha.

I think you should add more into the "install and
settings" so all we who use your files can set this up like you have.
tpulse is offline   Reply With Quote
Old 07-29-2020, 10:53 AM   #18
Exquse
Human being with feelings
 
Join Date: Jul 2020
Posts: 2
Default

Im comming form cubase ande studo one and sinds two months in Reaper and i think ist a keeper. (rock solid on audio and controlling VST instruments and a fresh new approach one a DAW),

I have a faderport 8 and know running as a mackie/MCu devices. What I,m missing is that i can select a group of tracks, lets say buschannels, that are spread all over my main mixwindow, and have those selected bus channels also selected on teh faderport 8.

I have tryed a workaround with screenset/mixerlayouts, and the window/mixer selecting works wel, althoug the faderport 8 dont't pick up the channges, therefore i have to mousclick one a channel,and fadewrport jumps back in concetion with the selected channels

So, verry interresting thread, and my suggestion is to make use of the audio, VI BUs VCA button, like the way they are ussed in studio one,

I know Reaper only has channels, maby this can work by colorcoding channels (busses blue, VI channels green) ect,

Anny way keep up the good work!

A Reaper newby

P.S. My dutch is much better than my English

Last edited by Exquse; 07-29-2020 at 11:02 AM.
Exquse is offline   Reply With Quote
Old 07-30-2020, 10:41 PM   #19
todoublez
Human being with feelings
 
todoublez's Avatar
 
Join Date: Aug 2019
Location: beijing
Posts: 507
Smile

Hi airon ,

I'm only using v2,

is thrr anything I can download here ?
__________________
Reaper 6.15 / SWS/S&M: v2.11.0 / Hackintosh OSX High Sierra 10.13.6
i9 9900KS / 8 Cores base:4.0Ghz turbo:5.0Ghz / 64G RAM /
JS_ReaScriptAPI: v1.215 / Ultraschall API: v43220.00

Last edited by todoublez; 07-30-2020 at 11:40 PM.
todoublez is offline   Reply With Quote
Old 07-31-2020, 04:29 AM   #20
tpulse
Human being with feelings
 
tpulse's Avatar
 
Join Date: Aug 2009
Posts: 272
Default

Quote:
Originally Posted by airon View Post
tpulse, you could verify that the knob sends the data the widget expects. I worked off the specs in the manual which were identical to the FP16, but there could be a mistake on my side.

Call up the action CSI edit mode, check the two in and out checkboxes on the right and start moving the knob, and change the .mst if necessary.

If all is well however, then it could be just a mistake in installation or configuration when setting up . Install the package again, more slowly.

I‘ve got an update coming that puts in VCA mode, adds pan width to the big knob and brings in more colour to the automation buttons for shift and alt combos.
I installed the package again and it seems that you've not updated /upload the newest files yet.
in both 8 and 16 files there's still shift+fader for panning
tpulse is offline   Reply With Quote
Old 07-31-2020, 11:49 AM   #21
cemark
Human being with feelings
 
cemark's Avatar
 
Join Date: Jun 2014
Location: Sweden
Posts: 249
Default

A couple of you have asked about CSI-files for the FPv2.

I have posted my files for the v2 in the CSI thread. Just search my posts and you'll find it.

There are also some files for the v2 over at the Reaper-stash. But I do believe I got a bit further with mine. As usual, YMMV.
cemark is offline   Reply With Quote
Old 08-02-2020, 01:50 AM   #22
todoublez
Human being with feelings
 
todoublez's Avatar
 
Join Date: Aug 2019
Location: beijing
Posts: 507
Default

Quote:
Originally Posted by cemark View Post
A couple of you have asked about CSI-files for the FPv2.

I have posted my files for the v2 in the CSI thread. Just search my posts and you'll find it.

There are also some files for the v2 over at the Reaper-stash. But I do believe I got a bit further with mine. As usual, YMMV.
thx mate, after installing ur v2 profile ,I finally got it wrking.
although it still needs to be configured by editing the mst file to fully fit my wrkflow , but so far so good.

very appreciated yo wrk. thank u
__________________
Reaper 6.15 / SWS/S&M: v2.11.0 / Hackintosh OSX High Sierra 10.13.6
i9 9900KS / 8 Cores base:4.0Ghz turbo:5.0Ghz / 64G RAM /
JS_ReaScriptAPI: v1.215 / Ultraschall API: v43220.00
todoublez is offline   Reply With Quote
Old 11-17-2020, 09:29 AM   #23
James Jams
Human being with feelings
 
James Jams's Avatar
 
Join Date: May 2020
Posts: 5
Cool Doesn't seem to work for me...

Hello! And thank you so much for doing the work to get this controller to work with Reaper! CUDOS! I just purchased it a few days ago so it and the whole CSI thing is very new to me, so if my questions seem novice, they are...

I successfully installed CSI and am able to select the 'Control Surface Integrator' in the control surface selector, so that's working... I added a new Midi Surface and named it 'faderport 16' and under Templates for Surface and Zone I selected the 'FP16s1' files you provided, that I manualy inserted into the Zones and Surfaces folders in the CSI folder (this was not in your instructions but figured it was necessary?) I set the midi In and Out to Persons FP16 - port 1 and clicked ok. Oh and put the controller in Studio one mode of course, but nothing is happening. No fader movements, no nothing...

It feels like I did everything right but it doesn't work. Any ideas?

The one error I found when following the CSI installation instruction was when I tried to run the action 'CSI Edit Mode' nothing came up...perhaps this is a sign for a issue with my install? Any help is greatly appreciated!

ps. I am running Reaper v6.15/64 on Mac OS X 10.12
James Jams is offline   Reply With Quote
Old 11-17-2020, 09:39 AM   #24
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 2,121
Default

Quote:
Originally Posted by James Jams View Post
Hello! And thank you so much for doing the work to get this controller to work with Reaper! CUDOS! I just purchased it a few days ago so it and the whole CSI thing is very new to me, so if my questions seem novice, they are...

I successfully installed CSI and am able to select the 'Control Surface Integrator' in the control surface selector, so that's working... I added a new Midi Surface and named it 'faderport 16' and under Templates for Surface and Zone I selected the 'FP16s1' files you provided, that I manualy inserted into the Zones and Surfaces folders in the CSI folder (this was not in your instructions but figured it was necessary?) I set the midi In and Out to Persons FP16 - port 1 and clicked ok. Oh and put the controller in Studio one mode of course, but nothing is happening. No fader movements, no nothing...

It feels like I did everything right but it doesn't work. Any ideas?

The one error I found when following the CSI installation instruction was when I tried to run the action 'CSI Edit Mode' nothing came up...perhaps this is a sign for a issue with my install? Any help is greatly appreciated!

ps. I am running Reaper v6.15/64 on Mac OS X 10.12
Are you using the latest CSI build? If yes, there have been some very CSI syntax changes from the beta to version 1.0 so .mst and .zon files from older builds will need to be updated to work in version 1.0.

I outlined some of changes here: https://forum.cockos.com/showpost.ph...ostcount=11490

Please pop on over to the main CSI thread if you need additional help.
Funkybot is online now   Reply With Quote
Old 11-17-2020, 05:54 PM   #25
James Jams
Human being with feelings
 
James Jams's Avatar
 
Join Date: May 2020
Posts: 5
Default YUP!

Quote:
Originally Posted by Funkybot View Post
Are you using the latest CSI build? If yes, there have been some very CSI syntax changes from the beta to version 1.0 so .mst and .zon files from older builds will need to be updated to work in version 1.0.

I outlined some of changes here: https://forum.cockos.com/showpost.ph...ostcount=11490

Please pop on over to the main CSI thread if you need additional help.
Yes! That was the issue! I rolled the CSI back to the Beta version and everything worked fine. Figures just as I jump into this it's on the day it's being updated...pfff. ha!

I will use the beta for a while till the Zone's are updated for the faderport on v1. Thanks again!
James Jams is offline   Reply With Quote
Old 11-21-2020, 10:17 AM   #26
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 2,121
Default

Quote:
Originally Posted by James Jams View Post
Yes! That was the issue! I rolled the CSI back to the Beta version and everything worked fine. Figures just as I jump into this it's on the day it's being updated...pfff. ha!

I will use the beta for a while till the Zone's are updated for the faderport on v1. Thanks again!
The syntax changes are pretty easy. You should consider taking a stash at them and trying 1.0.
Funkybot is online now   Reply With Quote
Old 11-24-2020, 03:51 AM   #27
Lophophora
Human being with feelings
 
Lophophora's Avatar
 
Join Date: Mar 2014
Location: Singapore
Posts: 333
Default

Hi,

I have tried to setup my FaderPort V2, with little to no success so far.

First, in Reaper Preferences I selected PreSonus FaderPort FP2 (dev 1.2). At first it worked but it stopped working after a short while. The device seems to be somewhat connected because the fader moves every time I start Reaper but then, none of the buttons, fader or knob do anything. The provided USB cable is too short so I used a longer one, can this be the cause of my problem?

Later, I saw this thread and tried to follow the instructions on https://github.com/GeoffAWaddington/...i/Installation

but I got stuck during the installation at step 10, which reads:

Quote:
There is a default Page ("HomePage") already defined to get you started.
I can't see anything in my drop down menu. What am I missing?
__________________
SoundWise Music Production

Last edited by Lophophora; 11-24-2020 at 07:51 AM.
Lophophora is offline   Reply With Quote
Old 12-03-2020, 12:33 PM   #28
benf
Human being with feelings
 
benf's Avatar
 
Join Date: Oct 2008
Location: France
Posts: 3,095
Default

The same for me. Bienvenue au club !
__________________
Ecouter et télécharger ma musique sur : https://benest.bandcamp.com/
benf is offline   Reply With Quote
Old 12-03-2020, 12:41 PM   #29
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 2,121
Default

If there's no Home page, add one, or just copy over the CSI.ini from the download.

For CSI setup questions, please head over here as we've got a dedicated thread for that topic and more people who don't own a Faderport can help get it setup:

https://forum.cockos.com/showthread.php?t=245280
Funkybot is online now   Reply With Quote
Old 12-03-2020, 05:28 PM   #30
simonluca
Human being with feelings
 
Join Date: Oct 2007
Posts: 140
Lightbulb

Hello!
So even though my question fell on deaf ears, I bought a Faderport8 and started to learn CSI. My starting point is of course Airon's implementation, but since it was done on the beta version, I'm also "updating" it. Of course as soon as I will get a good version I'll share it. I'm also trying comment it as much as I can so that it will be clear to everyone in the future (hopefully).

Well, i'm starting to have some satisfactory results, but I'm still missing some things and - also because of the lack of documentation - some things are still kind of obscure. I have some questions for you.

- I can't show the dB value of the faders. Old Beta code was
Code:
TrackTouch+FPScribble| TrackVolumeDisplay
but since all the "touch" commands are gone as stated here (https://forum.cockos.com/showpost.ph...ostcount=11490) I deleted the line. I tried
Code:
Fader+FPScribble| TrackVolumeDisplay
and it works, but it overrides the name of the track. Is there a way to have both? I saw in other implementations (eg Xtouch) that it is possible to define a lower and upper part of the display:
Code:
 Widget DisplayLower1
	FB_MCUDisplayLower 0
WidgetEnd
. I tried that but it didn't work. Maybe because this command looks like it's based on MCU and Airon implementation is based on the Studio One Profile?

- Scrub. I really don't know how to implement the scrub. I'd like to use the big knob to move the edit cursor. Any suggestions?

- Since the "Select" buttons are RGB, I thought it would be nice to color them according to the corresponding automation mode (green for read, purple for latch, yellow for touch, red for write, off for trim). Do you think it's possible?

- Is it possible to light a button only when it is pressed (for ex: the fast forward, you want it to be lit only when it is pressed)? I've read several times that it's not (either they're on or off) but since you never know to which version the answers are related to, I'll ask that again. Maybe something changed.

- My Reaper volumes go from -INF to +12dB. The "0" in the Faderport is slightly off. Do you know if there is the possibility to calibrate it?

- As you know, in MCU mode the blue buttons change the behaviour of the big knob. But If I understood correctly "only" 4 modifiers are available and we already use two (the two "shifts"). Do you confirm that there is no other way but to map, for example, the "zoom" button to the "alt" and so on?

- In standard MCU mode, if you hold the shift, it locks. Is there a way to do that in CSI?

- Is there a way to map the tracks not sequentially? I work a lot with folders (as everyone here) so It could be very useful to map them instead of the tracks.

and then there is a not CSI related question but still, very important:

- Is it possible to physically move two faders at the same time in opposite directions (like in a manual crossfade) without Reaper (and the FP) to get crazy? Have you ever tried?

Thank you!

SL
__________________
www.sluca.net
simonluca is offline   Reply With Quote
Old 01-15-2021, 03:07 PM   #31
Musiccreator
Human being with feelings
 
Join Date: Jul 2020
Posts: 35
Default

Hello everyone! I am trying to configure my faderport to work in midi mode to control the cc values when working in the Spitfire VST plugin ( expression control etc).
I know that in the latest firmware version, they made it possible to work in two modes, these are MCU control and MIDI.
I downloaded all the latest firmware updates and update the controller. Everything works fine, but I cannot activate the control in the mode MIDI.
Perhaps I made some wrong settings in the Reaper or in the controller itself. Maybe someone is working with this controller knows a solution?
https://www.youtube.com/watch?v=Oz9O...ature=youtu.be
here I wrote down how I tried to set up the FP8 but nothing worked ... please help me

Last edited by Musiccreator; 01-15-2021 at 03:08 PM. Reason: error
Musiccreator is offline   Reply With Quote
Old 01-24-2021, 10:53 AM   #32
valankar
Human being with feelings
 
Join Date: Jan 2016
Posts: 14
Default

I have a Faderport 8. The send button and the pan rotary don't seem to do anything. Any ideas?

Also I was not sure what to enter in the Midi Surface dialog, so I put:

Number of Channels: 8
CSI Channel Start Position: 0
Number of Sends: 8
Number of FX Menu: 8
valankar is offline   Reply With Quote
Old 01-24-2021, 01:20 PM   #33
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 2,121
Default

Quote:
Originally Posted by valankar View Post
I have a Faderport 8. The send button and the pan rotary don't seem to do anything. Any ideas?

Also I was not sure what to enter in the Midi Surface dialog, so I put:

Number of Channels: 8
CSI Channel Start Position: 0
Number of Sends: 8
Number of FX Menu: 8
The settings look good. Which .zon file are you using?
Funkybot is online now   Reply With Quote
Old 01-24-2021, 01:58 PM   #34
valankar
Human being with feelings
 
Join Date: Jan 2016
Posts: 14
Default

I'm using the files from the zipfile in the first post.

Surface: FP8s1.mst
Zone: FP8s1
valankar is offline   Reply With Quote
Old 01-24-2021, 03:02 PM   #35
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 2,121
Default

The files dated July 2020? Those are out of date. Quite a few things changed since then, which is why those files no longer work.

Try the Faderport16 files in Airon's signature instead. Those are updated for the latest CSI. Linked to them here:

https://stash.reaper.fm/40914/CSI_Faderport16_CSIv1.ZIP

I'm thinking the FP16 files will work with FP8.
Funkybot is online now   Reply With Quote
Old 01-25-2021, 10:23 AM   #36
valankar
Human being with feelings
 
Join Date: Jan 2016
Posts: 14
Default

Tried with those files and it seems to not work at all. Faders don't move, etc. It seems the fp16 files are not working with Faderport 8.
valankar is offline   Reply With Quote
Old 01-25-2021, 11:20 AM   #37
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 2,121
Default

Ok, that's helpful to know. I'm not sure if Airon is still using the FP8 and has it working with CSI v1.0, if so, maybe he can share some updated files. If not, or you just want to move forward on your own, we can help you get setup.

There were some CSI syntax changes before 1.0 was released. See this post and make the changes in the FP8.zon file...

https://forum.cockos.com/showpost.ph...ostcount=11490

You can also check the Wiki page for how to fix sends if you need more details:

https://github.com/GeoffAWaddington/...iki/Send-Zones

If you're still stuck after making the changes, post the contents of your zone file here in the forum and wrap them in [code] brackets. If you do get it working, please share your updated files so others can benefit.

Last edited by Funkybot; 01-25-2021 at 11:30 AM.
Funkybot is online now   Reply With Quote
Old 01-25-2021, 03:21 PM   #38
airon
Human being with feelings
 
airon's Avatar
 
Join Date: Aug 2006
Location: Berlin
Posts: 10,995
Default

The Faderport 16 MST uses STUDIO ONE mode. That's the most important aspect.

You'll need to delete the upper 8 faders/mute/solo/select buttons in the MST and save that to a new MST of a different name.

Apart from those faders, EVERYTHING is identical.
__________________
(Video)Using Latch Preview - Faderport16 CSI config
Airon Audio Dia/FX Edit&Mix
"My ego comes pre-shrunk" - Randy Thom

Last edited by airon; 01-25-2021 at 03:34 PM.
airon is offline   Reply With Quote
Old 01-26-2021, 08:48 AM   #39
valankar
Human being with feelings
 
Join Date: Jan 2016
Posts: 14
Default

Thanks. Creating new files with 9-16 removed seems to mostly work. The .zon file also had some comments about changing for Faderport 8 so I did that too. There were also some other things like Display going to 16 in the .mst file, which I removed.

It seems the display above the faders stays blank always. Also the small pan rotary doesn't seem to do anything. Selecting Pan, then the big rotary does the pan changes.
valankar is offline   Reply With Quote
Old 01-26-2021, 10:58 AM   #40
airon
Human being with feelings
 
airon's Avatar
 
Join Date: Aug 2006
Location: Berlin
Posts: 10,995
Default

Quote:
Originally Posted by valankar View Post
Thanks. Creating new files with 9-16 removed seems to mostly work. The .zon file also had some comments about changing for Faderport 8 so I did that too. There were also some other things like Display going to 16 in the .mst file, which I removed.

It seems the display above the faders stays blank always. Also the small pan rotary doesn't seem to do anything. Selecting Pan, then the big rotary does the pan changes.
The small pan, by default controls the second pan. That's either the pan width or the second channel pan, depending on the mode the track is using.

"Send" button calls the send mode. Press "Track" to return.

"Edit Plugins" will show plugin parameters if a zone file exists for the plugin.
__________________
(Video)Using Latch Preview - Faderport16 CSI config
Airon Audio Dia/FX Edit&Mix
"My ego comes pre-shrunk" - Randy Thom
airon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:59 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.