Old 09-20-2019, 04:33 AM   #81
Soli Deo Gloria
Human being with feelings
 
Soli Deo Gloria's Avatar
 
Join Date: Oct 2013
Location: Buenos Aires, Argentina
Posts: 909
Default

Quote:
Originally Posted by Soli Deo Gloria View Post
Devs, I´ve just realized that during this pre cycle, some SWS tempo envelope actions have been broken again - and I say "again", since this has already happened during the v5.65 pre cycle, almost two years ago -.

Take a look :




This happens since reaper5983+dev0829. With v5.83, it works as usual.

There I´m using "SWS/BR: Freehand draw envelope while snapping points to left side grid line (perform until shortcut released)". Also, the action called "SWS/BR: Set closest envelope point's value to mouse cursor (perform until shortcut released)" is also broken, and maybe there are more SWS actions broken. These two, at least, are vital for my workflow.

Please, I hope you can fix this for the next pre-release since I depend heavily on these actions for most of my work.

Thank you very much in advance

I´m sorry to come up with this again in the midst of an interesting discussion about MIDI playback, offset, missing notes, etc (things which I have been observing through the years but could never actually explain nor reproduce accurately).



I´ll add an observation to the report of the broken SWS actions : the behaviour shown in the gif posted above seems to happen only when the tempo envelope is shown in a lane. When it´s drawn in the Master track, things seem to work fine (that certainly alleviates my preoccupation with the issue). It would be good, though, to solve the bug as soon as you can, since those actions represent the only way we have - until now - to achieve a real freehand envelope in the tempo map*.



* On a side note (sorry for the OT, but this issue reminds me of it), I´ve been drawing tempo maps with those actions since Breeder blissfully created them, and I can assure you that, at least in the context of my work with heavy MIDI projects, I´ve never observed any performance pitfall with dense tempo maps. I say this because I can´t really see any reason not to include the functionality natively in its full form. To be able only to draw tempo envelope points at the 1/4 grid does not make sense at all. The possibility to have full fledged tempo envelopes, with all the functionalities of any other envelope (including bypass, movement along with items, automation items, etc) is surely a must for any MIDI composer.
Soli Deo Gloria is offline   Reply With Quote
Old 09-20-2019, 04:47 AM   #82
nofish
Human being with feelings
 
nofish's Avatar
 
Join Date: Oct 2007
Location: home is where the heart is
Posts: 9,048
Default

Quote:
Originally Posted by Soli Deo Gloria View Post
the behaviour shown in the gif posted above seems to happen only when the tempo envelope is shown in a lane.
Justin has made a contribution to SWS recently to take into account the new TCP/MCP architecture in recent +dev versions for some Breeder actions. I could imagine that may fix your issue too (but not sure).

You may try with the SWS version found on Landoleet (if you're not already using that version anyway) and report back if it fixes.
nofish is offline   Reply With Quote
Old 09-20-2019, 05:05 AM   #83
Soli Deo Gloria
Human being with feelings
 
Soli Deo Gloria's Avatar
 
Join Date: Oct 2013
Location: Buenos Aires, Argentina
Posts: 909
Default

Thanks so much for the tip, Nofish! That fixed the issues with the tempo envelope lane. Breeder´s actions work fine again!
Soli Deo Gloria is offline   Reply With Quote
Old 09-20-2019, 06:50 AM   #84
Argle
Human being with feelings
 
Join Date: Aug 2011
Posts: 1,263
Default

This negative offset looks interesting. I have always used a negative audio delay on the output channels of my orchestral tracks to individually fix the timing of instruments, and it's worked fine for me. Does this new method have additional uses? It would be nice to have that setting in the TCP vs a plugin.
Argle is offline   Reply With Quote
Old 09-20-2019, 08:00 AM   #85
Thonex
Human being with feelings
 
Join Date: May 2018
Location: Los Angeles
Posts: 748
Default

I had my anniversary last night... so I wasn't able to work on this. I'm here now and will put together a formula that should only be a few lines of code for Note_On.

Back in a few.
__________________
Cheers,
Andrew K
v5.982/64 Mac 10.12.+, i7 Quad 2.9GHz, 24GB
Thonex is online now   Reply With Quote
Old 09-20-2019, 10:35 AM   #86
Subz
Human being with feelings
 
Subz's Avatar
 
Join Date: Jun 2006
Location: UK
Posts: 2,963
Default

Quote:
Originally Posted by Neutronic View Post
+ Tracks: support positive or negative playback time offset without affecting PDC



thank you
Subz is offline   Reply With Quote
Old 09-20-2019, 12:21 PM   #87
Thonex
Human being with feelings
 
Join Date: May 2018
Location: Los Angeles
Posts: 748
Default

Since there is a new dev version, I'm continuing the negative MIDI delay discussion an that new thread here:

https://forum.cockos.com/showthread.php?t=225238
__________________
Cheers,
Andrew K
v5.982/64 Mac 10.12.+, i7 Quad 2.9GHz, 24GB
Thonex is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:27 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.