Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Q&A, Tips, Tricks and Howto

Reply
 
Thread Tools Display Modes
Old 10-15-2018, 02:46 AM   #121
Skijumptoes
Human being with feelings
 
Join Date: Mar 2018
Location: Norfolk, UK
Posts: 267
Default

Quote:
Originally Posted by puddi View Post
I've played around with the pad settings but it didn't seem to help. Like if I play notes in rapid succession (just rolling my fingers left to right or whatever) it consistently registers every note in Ableton whereas in Reaper it does it like 30% of the time. Idk, maybe it's just an issue on my end.
I tried playing fast like you described, it does miss some notes unless i bring the Pad Threshold down to around -15. That's on a Push 1. So the software is capable of dealing with fast notes, i still think it's your settings - did you try the Threshold in negative values?

I'm on a Mac, if it makes any difference. Also, you've not got the push device setup anywhere else in REAPER as an input have you?
Skijumptoes is offline   Reply With Quote
Old 10-15-2018, 02:54 AM   #122
Skijumptoes
Human being with feelings
 
Join Date: Mar 2018
Location: Norfolk, UK
Posts: 267
Default

Quote:
Originally Posted by heavybeats View Post
Tested this on my laptop and same crashes with Melda plugins
I only have the free versions but tried (stacked on the same track):-
VST3 MSpectralPan
VST3 MAutopan
VST MSaturator

And there's no issues there for me in terms of stability, no crashing. However, certain plugin parameters don't update on the Push display (AutoPan being one of them), but you can control the plugin fine.

This is on MacOS 10.13.6 Running REAPER v5.95/64 with Push 1 and MCU connected.
Skijumptoes is offline   Reply With Quote
Old 10-15-2018, 04:58 AM   #123
heavybeats
Human being with feelings
 
Join Date: Jun 2013
Posts: 19
Default

Quote:
Originally Posted by Skijumptoes View Post
I only have the free versions but tried (stacked on the same track):-
VST3 MSpectralPan
VST3 MAutopan
VST MSaturator

And there's no issues there for me in terms of stability, no crashing. However, certain plugin parameters don't update on the Push display (AutoPan being one of them), but you can control the plugin fine.

This is on MacOS 10.13.6 Running REAPER v5.95/64 with Push 1 and MCU connected.
I’m on Windows 10, push2 and latest Reaper so maybe a windows issue. Thanks for trying though!
heavybeats is offline   Reply With Quote
Old 10-17-2018, 12:32 PM   #124
heavybeats
Human being with feelings
 
Join Date: Jun 2013
Posts: 19
Default

Quote:
Originally Posted by heavybeats View Post
I’m on Windows 10, push2 and latest Reaper so maybe a windows issue. Thanks for trying though!
Ive just realised that DrivenByMoss spits out error logs for this Melda Plugins issue I'm having. According to MossGabbers website I should log bugs here but I haven't heard anything from Moss. Where do I send error logs too, anyone know?
Cheers
heavybeats is offline   Reply With Quote
Old 10-18-2018, 09:17 AM   #125
transistor
Human being with feelings
 
Join Date: Aug 2017
Posts: 3
Default

Quote:
Originally Posted by moss View Post
Not quite sure what you mean by that. Sounds like you stored it like this as your default template?!
Can you give me some steps to reproduce or which device script you think causes this?
Hi! Check this video

https://youtu.be/g-Q68xFzzAg
transistor is offline   Reply With Quote
Old 10-18-2018, 12:46 PM   #126
Indirect
Human being with feelings
 
Join Date: Dec 2015
Posts: 121
Default

Did a mixing session with push and reaper recently.
1. Its annoying that once you "add FX" there is no way to cancel or confirm FX added
2. Added FX is sometimes added after, sometimes before. This is critical to mixing process. Live does it with shift+addfx button (add before selected FX). Similar function would be very valuable. Also its better to explicitly push a "load" or "cancel" button
3. Any way to go out of folder track? For example I mix the drum folder, so there is BD, SD, OH, LT, Ht etc. Its fine, but if I want to add bass (which is up one level in hierarchy, alongside with drum folder), I cannot do it with push, got to select track outside of the folder

????????????

About media looping. There is a loop parameter within each media item. For audio it means loop from start to end for duration of media item, unless "section" box is ticked. MIDI works in similar way. Also in midi there is explicit "loop bracket" (inside midi editor). Moving those "section" and "loop bracket" was always a major pain: crop item to be looped, open item properties, tick "section", tick "loop". Meh

++++++++++++

Clip=Media item is gold. I have items for verse/chorus and just hit those to mix specific part. no need to create markers and stuff. AWESOME.

I'll sure have camera ready next time I'll be mixing to catch all the bugs I'll encounter. Thank you for your hard work! It feels so good to be part of something great, to make someones work with technology more enjoyable. So great to see love for reaper, it deserves a well working control surface for sure!!!
Indirect is offline   Reply With Quote
Old 10-19-2018, 10:17 AM   #127
HammyHavoc
Human being with feelings
 
HammyHavoc's Avatar
 
Join Date: Jun 2018
Location: Liverpool, United Kingdom
Posts: 43
Default

Hi Moss!

Beautiful work on your software. KKMK2 works beautifully! :- )

I have a slight issue which EvilDragon suggested you may have some info on.

My Maschine MK3 doesn't return to the project's start point after pressing the stop button whilst playback is stopped, whereas the KKMK2 does, and that's the expected behaviour. More info here: https://forum.cockos.com/showthread.php?p=2047081
__________________
Hammy Havoc | Split An Atom
HammyHavoc is offline   Reply With Quote
Old 10-19-2018, 12:27 PM   #128
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 392
Default

Quote:
Originally Posted by emirpasic View Post
Great, Thank you once more.
I have one question regarding automation. It seems that automation is not implemented, or is there something I do not understand? When I choose to write automation in Reaper, nothing happens when I tweak the rotary buttons. On the other hand moving them with a mouse works fine.
Thanks for reporting! Will be fixed in the next update.
moss is offline   Reply With Quote
Old 10-19-2018, 12:29 PM   #129
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 392
Default

Quote:
Originally Posted by heavybeats View Post
Ive just realised that DrivenByMoss spits out error logs for this Melda Plugins issue I'm having. According to MossGabbers website I should log bugs here but I haven't heard anything from Moss. Where do I send error logs too, anyone know?
Cheers
Just post them here.
moss is offline   Reply With Quote
Old 10-19-2018, 12:38 PM   #130
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 392
Default

Quote:
Originally Posted by transistor View Post
Hi! Check this video

https://youtu.be/g-Q68xFzzAg
Ah, I guess I know what's going on:

You can choose between 3 workspace layouts (these are the 3 Bitwig layouts) if you long press the Master button you see them in the lower left (first 3 buttons).
I mapped these 3 layouts to the first 3 Screensets (View->Screensets/Layouts). When you start Reaper the 2nd is selected (Mix layout). I guess you have stored this small MIDI editor in that Screenset.
moss is offline   Reply With Quote
Old 10-19-2018, 01:27 PM   #131
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 392
Default

Quote:
Originally Posted by Indirect View Post
Did a mixing session with push and reaper recently.
1. Its annoying that once you "add FX" there is no way to cancel or confirm FX added
Press "Browse" to confirm. Press "Shift+Browse" to cancel.

Quote:
Originally Posted by Indirect View Post
2. Added FX is sometimes added after, sometimes before. This is critical to mixing process. Live does it with shift+addfx button (add before selected FX). Similar function would be very valuable. Also its better to explicitly push a "load" or "cancel" button
Yes, would like to have that too but could not make that work with Reaper.

Quote:
Originally Posted by Indirect View Post
3. Any way to go out of folder track? For example I mix the drum folder, so there is BD, SD, OH, LT, Ht etc. Its fine, but if I want to add bass (which is up one level in hierarchy, alongside with drum folder), I cannot do it with push, got to select track outside of the folder
I guess you are using Push 1? Press the last button in the second row or long press any of the first row buttons.

Quote:
Originally Posted by Indirect View Post
About media looping. There is a loop parameter within each media item. For audio it means loop from start to end for duration of media item, unless "section" box is ticked. MIDI works in similar way. Also in midi there is explicit "loop bracket" (inside midi editor). Moving those "section" and "loop bracket" was always a major pain: crop item to be looped, open item properties, tick "section", tick "loop". Meh
I did not get all of that. There is a "loop source" parameter for items. But when I turn it off, Reaper now takes now the looped length as the new length. So turning it on again does not show the same effect. Nevertheless, I can use that one for the clip loop on/off. Not sure about the other parameters you mentioned (couldn't find them).
moss is offline   Reply With Quote
Old 10-19-2018, 01:28 PM   #132
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 392
Default

Quote:
Originally Posted by HammyHavoc View Post
Hi Moss!

Beautiful work on your software. KKMK2 works beautifully! :- )

I have a slight issue which EvilDragon suggested you may have some info on.

My Maschine MK3 doesn't return to the project's start point after pressing the stop button whilst playback is stopped, whereas the KKMK2 does, and that's the expected behaviour. More info here: https://forum.cockos.com/showthread.php?p=2047081
I do not have a Maschine. So, I am afraid I cannot help you.
moss is offline   Reply With Quote
Old 10-19-2018, 03:38 PM   #133
heavybeats
Human being with feelings
 
Join Date: Jun 2013
Posts: 19
Default

Quote:
Originally Posted by moss View Post
Just post them here.
#
# A fatal error has been detected by the Java Runtime Environment:
#
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x000000006b60db80, pid=4072, tid=0x0000000000001994
#
# JRE version: Java(TM) SE Runtime Environment (8.0_181-b13) (build 1.8.0_181-b13)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.181-b13 mixed mode windows-amd64 compressed oops)
# Problematic frame:
# C 0x000000006b60db80
#
# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
#
# If you would like to submit a bug report, please visit:
# http://bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

--------------- T H R E A D ---------------

Current thread (0x0000000037fca000): JavaThread "pool-3-thread-1" [_thread_in_native, id=6548, stack(0x000000003a640000,0x000000003a740000)]

siginfo: ExceptionCode=0xc0000005, reading address 0x0000000000000020

Registers:
RAX=0x0000000000000000, RBX=0x000000000578c950, RCX=0x00000000ffffffff, RDX=0x000000000578c920
RSP=0x000000003a73f1f0, RBP=0x000000003a73f220, RSI=0x000000000578c920, RDI=0x000000000578c948
R8 =0x000000003a73f158, R9 =0x000000003a73f220, R10=0x0000000000000000, R11=0x0000000000000246
R12=0x0000000000050000, R13=0x0000000037f75b60, R14=0x0000000000000001, R15=0x0000000037fca000
RIP=0x000000006b60db80, EFLAGS=0x0000000000010297

Top of Stack: (sp=0x000000003a73f1f0)
0x000000003a73f1f0: 000000000578c920 000000006b6073eb
0x000000003a73f200: 000000000578c950 000000006b602271
0x000000003a73f210: 0000000000000000 0000000000001298
0x000000003a73f220: 000000003a73f2b0 000000006b60544d
0x000000003a73f230: 000000003a73f280 000000006b60198a
0x000000003a73f240: 000000003a73f280 000000006b606302
0x000000003a73f250: 000000000578c948 0000000005719bb0
0x000000003a73f260: 000000003a73f2b0 000000003a73f33c
0x000000003a73f270: 0000000005719b40 000000000578c950
0x000000003a73f280: 000000003a73f310 000000006b606a1b
0x000000003a73f290: 0000000037b3b0d0 000000000578c920
0x000000003a73f2a0: 00000000000016ed 00000000397c1040
0x000000003a73f2b0: 000000006b616631 0000000005733d10
0x000000003a73f2c0: 0000000000000002 000000000578c950
0x000000003a73f2d0: 0000000005733d10 0000000000000002
0x000000003a73f2e0: 000000003a73f340 000000006b606aae

Instructions: (pc=0x000000006b60db80)
0x000000006b60db60: 55 48 89 e5 48 83 ec 30 0f b6 41 3a 84 c0 74 63
0x000000006b60db70: 3c 03 77 2c 48 8b 41 30 48 89 ca b9 ff ff ff ff
0x000000006b60db80: 48 8b 40 20 48 8b 40 6c 48 8b 80 90 00 00 00 48
0x000000006b60db90: 83 c4 30 5d 48 ff e0 66 0f 1f 84 00 00 00 00 00


Register to memory mapping:

RAX=0x0000000000000000 is an unknown value
RBX=0x000000000578c950 is an unknown value
RCX=0x00000000ffffffff is an unknown value
RDX=0x000000000578c920 is an unknown value
RSP=0x000000003a73f1f0 is pointing into the stack for thread: 0x0000000037fca000
RBP=0x000000003a73f220 is pointing into the stack for thread: 0x0000000037fca000
RSI=0x000000000578c920 is an unknown value
RDI=0x000000000578c948 is an unknown value
R8 =0x000000003a73f158 is pointing into the stack for thread: 0x0000000037fca000
R9 =0x000000003a73f220 is pointing into the stack for thread: 0x0000000037fca000
R10=0x0000000000000000 is an unknown value
R11=0x0000000000000246 is an unknown value
R12=0x0000000000050000 is an unknown value
R13=0x0000000037f75b60 is an unknown value
R14=0x0000000000000001 is an unknown value
R15=0x0000000037fca000 is a thread


Stack: [0x000000003a640000,0x000000003a740000], sp=0x000000003a73f1f0, free space=1020k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C 0x000000006b60db80
C 0x000000006b60544d
C 0x000000006b606a1b
C 0x000000006b606aae
C 0x000000006b606e08
C 0x0000000070883736
C 0x000000000c1dd84d

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
J 2392 org.usb4java.LibUsb.bulkTransfer(Lorg/usb4java/DeviceHandle;BLjava/nio/ByteBuffer;Ljava/nio/IntBuffer;J)I (0 bytes) @ 0x000000000c1dd7cf [0x000000000c1dd740+0x8f]
J 2826 C2 de.mossgrabers.controller.push.mode.track.TrackMod e.updateDisplay2()V (841 bytes) @ 0x000000000c3c6870 [0x000000000c3c4a80+0x1df0]
J 2523 C1 de.mossgrabers.controller.push.mode.BaseMode.updat eDisplay()V (31 bytes) @ 0x000000000c24abac [0x000000000c24a7e0+0x3cc]
J 2605 C1 de.mossgrabers.framework.view.AbstractView.updateC ontrolSurface()V (44 bytes) @ 0x000000000c282284 [0x000000000c281dc0+0x4c4]
J 2604 C1 de.mossgrabers.framework.controller.AbstractContro lSurface.scheduledFlush()V (35 bytes) @ 0x000000000c282fb4 [0x000000000c282b00+0x4b4]
J 2468 C1 de.mossgrabers.framework.controller.AbstractContro lSurface$$Lambda$127.run()V (8 bytes) @ 0x000000000c216b0c [0x000000000c2169c0+0x14c]
J 2695 C1 de.mossgrabers.framework.utils.LatestTaskExecutor$ $Lambda$128.run()V (8 bytes) @ 0x000000000c2f1224 [0x000000000c2f0ea0+0x384]
j java.util.concurrent.ThreadPoolExecutor.runWorker( Ljava/util/concurrent/ThreadPoolExecutor$WorkerV+95
j java.util.concurrent.ThreadPoolExecutor$Worker.run ()V+5
j java.lang.Thread.run()V+11
v ~StubRoutines::call_stub




--------------- S Y S T E M ---------------

OS: Windows 10.0 , 64 bit Build 16299 (10.0.16299.431)

CPU:total 12 (initial active 12) (6 cores per cpu, 2 threads per core) family 6 model 158 stepping 10, cmov, cx8, fxsr, mmx, sse, sse2, sse3, ssse3, sse4.1, sse4.2, popcnt, avx, avx2, aes, clmul, erms, rtm, 3dnowpref, lzcnt, ht, tsc, tscinvbit, bmi1, bmi2, adx

Memory: 4k page, physical 33395840k(29026968k free), swap 33395840k(27429692k free)

vm_info: Java HotSpot(TM) 64-Bit Server VM (25.181-b13) for windows-amd64 JRE (1.8.0_181-b13), built on Jul 7 2018 04:01:33 by "java_re" with MS VC++ 10.0 (VS2010)

time: Wed Oct 17 22:32:58 2018
elapsed time: 83 seconds (0d 0h 1m 23s)
heavybeats is offline   Reply With Quote
Old 10-19-2018, 03:40 PM   #134
heavybeats
Human being with feelings
 
Join Date: Jun 2013
Posts: 19
Default

Hi Moss, Had to delete Process section from above error log as it exceeded character count for a post by a big margin but if you need I can post it as well
heavybeats is offline   Reply With Quote
Old 10-19-2018, 03:49 PM   #135
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 392
Default

3.31 is up!

- New: Clip Loop parameter turns on/off the media items "Loop item source" parameter.
- Fixed: Recording Track Automation did not work.
moss is offline   Reply With Quote
Old 10-20-2018, 03:03 AM   #136
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 392
Default

Quote:
Originally Posted by heavybeats View Post
#
J 2392 org.usb4java.LibUsb.bulkTransfer(Lorg/usb4java/DeviceHandle;BLjava
It seems to me that one of the plugins you use corrupts the memory buffer which is used for the USB display transmission. Unlike Bitwig, Reaper does not separate plugins in its own process.
Therefore, I am afraid I can not do anything about it.

Update: Just saw that Reaper has a setting under "Plug-ins->Compatibility": VST bridging/Firewalling
Try to set that to "In dedicated process per plugin".
moss is offline   Reply With Quote
Old 10-20-2018, 04:36 AM   #137
heavybeats
Human being with feelings
 
Join Date: Jun 2013
Posts: 19
Default

Quote:
Originally Posted by moss View Post

Update: Just saw that Reaper has a setting under "Plug-ins->Compatibility": VST bridging/Firewalling
Try to set that to "In dedicated process per plugin".
Ah yes, this totally worked, thank you so much Moss! Keep up the great work!
heavybeats is offline   Reply With Quote
Old 10-20-2018, 09:18 AM   #138
x7i7l
Human being with feelings
 
Join Date: Sep 2018
Posts: 8
Default

Hi Moss,

I'm unable to get the latest version to work on a new installation of Ubuntu Neon and Reaper.

The Reascript console gives the output:
drivenbymoss: JAVA_HOME environment variable is not configured!

I get the same message when I use openjdk from the ubuntu repositories,
and also when I install Oracle Java following this guide.

https://tecadmin.net/install-oracle-...-18-04-bionic/

In the terminal

echo $JAVA_HOME

gives the output:

/usr/lib/jvm/java-11


So I'm not sure what I am doing wrong.

Any guidance you can give would be appreciated
x7i7l is offline   Reply With Quote
Old 10-20-2018, 12:36 PM   #139
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 392
Default

Quote:
Originally Posted by x7i7l View Post
Hi Moss,

I'm unable to get the latest version to work on a new installation of Ubuntu Neon and Reaper.

The Reascript console gives the output:
drivenbymoss: JAVA_HOME environment variable is not configured!

I get the same message when I use openjdk from the ubuntu repositories,
and also when I install Oracle Java following this guide.

https://tecadmin.net/install-oracle-...-18-04-bionic/

In the terminal

echo $JAVA_HOME

gives the output:

/usr/lib/jvm/java-11


So I'm not sure what I am doing wrong.

Any guidance you can give would be appreciated
If you cannot make the variable visible globally (no idea why) you should always be able to start Reaper from the console which shows you the correct output of the variable.
moss is offline   Reply With Quote
Old 10-22-2018, 12:52 AM   #140
aMUSEd
Human being with feelings
 
aMUSEd's Avatar
 
Join Date: Jun 2006
Posts: 1,290
Default

I have installed java and SWS plus the DbyM extension but when I try the last part of the instructions to add it under Control the extension shows but I get an error 'drivenbymoss: JAVA_HOME environment variable is not configured!' but if I click configure it crashes Reaper.

I'm on MasOs Sierra so didn't think I needed to do that complicated Java stuff in the text file
aMUSEd is offline   Reply With Quote
Old 10-22-2018, 03:30 AM   #141
Skijumptoes
Human being with feelings
 
Join Date: Mar 2018
Location: Norfolk, UK
Posts: 267
Default

aMUSEd,
Which version of the Java JDK are you running? If it's 10.0.2 you just need to run the following in terminal to set the JAVA_HOME variable for your logon session:-

launchctl setenv JAVA_HOME /Library/Java/JavaVirtualMachines/jdk-10.0.2.jdk/Contents/Home

If it's a different version then change the part where it references the 10.0.2 in that string above.
Skijumptoes is offline   Reply With Quote
Old 10-22-2018, 03:33 AM   #142
aMUSEd
Human being with feelings
 
aMUSEd's Avatar
 
Join Date: Jun 2006
Posts: 1,290
Default

Quote:
Originally Posted by Skijumptoes View Post
aMUSEd,
Which version of the Java JDK are you running? If it's 10.0.2 you just need to run the following in terminal to set the JAVA_HOME variable for your logon session:-

launchctl setenv JAVA_HOME /Library/Java/JavaVirtualMachines/jdk-10.0.2.jdk/Contents/Home

If it's a different version then change the part where it references the 10.0.2 in that string above.
Just installed it so the newest one

So if Java gets updated will that need to be done each time?
aMUSEd is offline   Reply With Quote
Old 10-22-2018, 03:38 AM   #143
aMUSEd
Human being with feelings
 
aMUSEd's Avatar
 
Join Date: Jun 2006
Posts: 1,290
Default

OK did that so the home path shows now - but clicking configure still causes a crash (and even if I ignore it and just click OK the controller doesn't get added)
aMUSEd is offline   Reply With Quote
Old 10-22-2018, 03:43 AM   #144
aMUSEd
Human being with feelings
 
aMUSEd's Avatar
 
Join Date: Jun 2006
Posts: 1,290
Default

This is the Java version I installed

https://www.java.com/en/download/
aMUSEd is offline   Reply With Quote
Old 10-22-2018, 06:45 AM   #145
Skijumptoes
Human being with feelings
 
Join Date: Mar 2018
Location: Norfolk, UK
Posts: 267
Default

Ah ok, you need Java JDK, thats just plain 'java' which you've downloaded, the JDK contains additional elements which this application requires.

Actually, it's on version 11 now, and doesn't look like the version 10 links are on their site, so:-

Click the link for the jdk-11.0.1_osx-x64_bin.dmg file and install it from this link:

https://www.oracle.com/technetwork/j...s-5066655.html

Then you'll need to run this in terminal to set the JAVA_HOME variable.

launchctl setenv JAVA_HOME /Library/Java/JavaVirtualMachines/jdk-11.0.1.jdk/Contents/Home

And yes, you need to run it everytime MacOS has restarted, sadly.

You can set an icon to run the terminal script. There's probably a way of getting that to run on startup automatically too but i've not looked into it, but if you want help setting it up to autorun i can do it on mine and let you know how i accomplished it.
Skijumptoes is offline   Reply With Quote
Old 10-22-2018, 03:24 PM   #146
aMUSEd
Human being with feelings
 
aMUSEd's Avatar
 
Join Date: Jun 2006
Posts: 1,290
Default

Thanks didn't realise there was a difference - the restart thing is a pain - why isn't that needed with the Bitwig version?
aMUSEd is offline   Reply With Quote
Old 10-22-2018, 11:39 PM   #147
ghizzu
Human being with feelings
 
Join Date: Oct 2018
Posts: 10
Default

Hi Moss, great work with KK Mk2 integration, very appreciated. I have a KK S61 mk2 and some question/issues:

1) the tracks can be muted/soloed but not unmuted/unsoloed
2) the scrub with the 4D controller doesn't seems to work, it merely changes the volume on the selected track (redundant, since it can be done with the knobs)
3) the STOP button behaves more like a pause one, i.e. it stops the playing BUT it moves the edit cursor to the last playing position, so it's impossible to set the edit cursor to a fixed position and start to play from there. (pressing STOP two times returns the edit cursor at the start of the song as expected)

And the most important question: is it possible to customize the controls, using for example SHIFT+Button1-8 to arm the tracks?
ghizzu is offline   Reply With Quote
Old 10-24-2018, 01:37 PM   #148
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 392
Default

Quote:
Originally Posted by ghizzu View Post
1) the tracks can be muted/soloed but not unmuted/unsoloed
Good catch! I used the track type "Generic" since anything can be placed on a Reaper track but it seems that Mute and Solo is not working for that track type. I changed it now to audio which seems to work fine. Will be in the next update.

Quote:
Originally Posted by ghizzu View Post
2) the scrub with the 4D controller doesn't seems to work, it merely changes the volume on the selected track (redundant, since it can be done with the knobs)
I cannot communicate with the device instead I have to talk to this NI background service and this it what it sends (or pan if that is selected).

Quote:
Originally Posted by ghizzu View Post
3) the STOP button behaves more like a pause one, i.e. it stops the playing BUT it moves the edit cursor to the last playing position, so it's impossible to set the edit cursor to a fixed position and start to play from there. (pressing STOP two times returns the edit cursor at the start of the song as expected)
I cannot see a problem. When I click somewhere in the timeline to set the play position and then start playback on the Kontrol it starts from there?!

Quote:
Originally Posted by ghizzu View Post
And the most important question: is it possible to customize the controls, using for example SHIFT+Button1-8 to arm the tracks?
Same problem as above. You can only get what NI wants you to do...
moss is offline   Reply With Quote
Old 10-25-2018, 12:12 AM   #149
ghizzu
Human being with feelings
 
Join Date: Oct 2018
Posts: 10
Default

Quote:
Originally Posted by moss View Post
I cannot see a problem. When I click somewhere in the timeline to set the play position and then start playback on the Kontrol it starts from there?!
True. But if you press the STOP button (on the KK) the edit cursor will be moved to the position of the occurred stop. This is how the "pause" in Reaper's control bar behaves, not the "stop". So if you want to restart playing from the previous position you have to move back the edit cursor manually with the mouse.

Instead, if you click on Reaper's "stop" while playing, the playback is stopped but the edit cursor is NOT moved, so you can restart playing or recording from the position you have previously set. And if you click again the Reaper's "play" button WHILE PLAYING, the playback restarts from the edit cursor position, while if you press PLAY on the KK while playing nothing happens.
I hope I explained myself, english is not my first language.

Last edited by ghizzu; 10-25-2018 at 02:06 AM.
ghizzu is offline   Reply With Quote
Old 10-25-2018, 01:12 AM   #150
ghizzu
Human being with feelings
 
Join Date: Oct 2018
Posts: 10
Default

Quote:
Originally Posted by moss View Post
I cannot communicate with the device instead I have to talk to this NI background service and this it what it sends (or pan if that is selected).
So, if I understand correctly, your extension can't read the buttons state of the KK Mk2 directly but reads the OSC messages provided from the NI Background Service and sends them to Reaper's OSC interface, right? If so, maybe some extent of customisation could be possible, maybe writing a .ReaperOSC file?
ghizzu is offline   Reply With Quote
Old 10-25-2018, 04:31 AM   #151
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 392
Default

Quote:
Originally Posted by ghizzu View Post
True. But if you press the STOP button (on the KK) the edit cursor will be moved to the position of the occurred stop. This is how the "pause" in Reaper's control bar behaves, not the "stop". So if you want to restart playing from the previous position you have to move back the edit cursor manually with the mouse.

Instead, if you click on Reaper's "stop" while playing, the playback is stopped but the edit cursor is NOT moved, so you can restart playing or recording from the position you have previously set. And if you click again the Reaper's "play" button WHILE PLAYING, the playback restarts from the edit cursor position, while if you press PLAY on the KK while playing nothing happens.
I hope I explained myself, english is not my first language.
OK, that's what I guessed. I like it that way but I will add it to my notes to maybe make this an option.
moss is offline   Reply With Quote
Old 10-25-2018, 04:48 AM   #152
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 392
Default

Quote:
Originally Posted by ghizzu View Post
So, if I understand correctly, your extension can't read the buttons state of the KK Mk2 directly but reads the OSC messages provided from the NI Background Service and sends them to Reaper's OSC interface, right?
Close. I use my own OSC implementation, since you cannot modify the Reaper OSC (except changing the mapping and naming of the functions).

Quote:
Originally Posted by ghizzu View Post
If so, maybe some extent of customisation could be possible, maybe writing a .ReaperOSC file?
No that's not possible. When you turn the big knob you get the same OSC message as when you turn the individual channel knob. So, you cannot distinct what the user has done.
moss is offline   Reply With Quote
Old 10-28-2018, 11:59 AM   #153
barbaroja
Human being with feelings
 
barbaroja's Avatar
 
Join Date: Jul 2009
Posts: 272
Default

Reporting back after a while.

Tried last version.

Current project I am working is unable to load if transformator is running. Crashes reaper inmediately after asking it to load.

My docked toolbars got crazy. They change positions randomly. I order them again and if transformator is running, they get screwed at every start.
barbaroja is offline   Reply With Quote
Old 10-29-2018, 12:51 AM   #154
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 392
Default

Quote:
Originally Posted by barbaroja View Post
Reporting back after a while.

Tried last version.

Current project I am working is unable to load if transformator is running. Crashes reaper inmediately after asking it to load.

My docked toolbars got crazy. They change positions randomly. I order them again and if transformator is running, they get screwed at every start.
That's actually a feature :-)

You can choose between 3 workspace layouts (these are the 3 Bitwig layouts) if you long press the Master button on the Push you see them in the lower left (first 3 buttons).
I mapped these 3 layouts to the first 3 Reaper Screensets (View->Screensets/Layouts). When you start Reaper the 2nd is selected (Mix layout). Store in that Screenset how you want to look Reaper when you start up.
moss is offline   Reply With Quote
Old 10-29-2018, 08:42 AM   #155
barbaroja
Human being with feelings
 
barbaroja's Avatar
 
Join Date: Jul 2009
Posts: 272
Default

Quote:
Originally Posted by moss View Post
That's actually a feature :-)

You can choose between 3 workspace layouts (these are the 3 Bitwig layouts) if you long press the Master button on the Push you see them in the lower left (first 3 buttons).
I mapped these 3 layouts to the first 3 Reaper Screensets (View->Screensets/Layouts). When you start Reaper the 2nd is selected (Mix layout). Store in that Screenset how you want to look Reaper when you start up.
Aw my bad. That is actually pretty cool, then.

The change from eel really fixed the speed issues. Great work, Moss.

Any word about project loading crashes? How could it be related to transformator? My alphatrack actually gets delayed and it catches on the project (I can tell because the fader moves) after it has finished loading. Maybe something like this would help?
barbaroja is offline   Reply With Quote
Old 10-29-2018, 12:10 PM   #156
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 392
Default

Quote:
Originally Posted by barbaroja View Post
Any word about project loading crashes? How could it be related to transformator? My alphatrack actually gets delayed and it catches on the project (I can tell because the fader moves) after it has finished loading. Maybe something like this would help?
If you report bugs please be as specific as possible: What are you exactly doing (step-by-step)? What crashes? Are there any logging outputs? What is your operating system?
moss is offline   Reply With Quote
Old 10-30-2018, 10:00 AM   #157
Indirect
Human being with feelings
 
Join Date: Dec 2015
Posts: 121
Default

Hi. Submitting the jog wheel bug
https://youtu.be/p4XWAPMmAoA

Take a look at the cpu meter. Cannot handle jogging while project is playing (i7, power mode is on performance).
Indirect is offline   Reply With Quote
Old 10-30-2018, 10:06 AM   #158
Vincent Sermonne
Human being with feelings
 
Vincent Sermonne's Avatar
 
Join Date: Feb 2009
Location: Marseille France
Posts: 5,986
Default

Hi Moss, I can't install. There is a "ReaScript Console Exit" warning window telling me that "drivenbymoss: JAVA_HOME environment variable is not configured!", when I click on "configure" when selecting the DrivenByMoss4Reaper, Reaper exits.

I must specify that I am on Windows 10, Java 1.8.0_191 is installed, the environment variable window 10 "set JAVA_HOME" is well directed to C:\Program Files\Java\jdk1.8.0_191.
I tried uninstalling java for version 11 but nothing works. Version 11 doesn't work with any other app I use so I went back to version 8.
I'm sad I can't use my push 1 and Reaper with your script !
__________________
Vincent
ReaperDrummer
http://www.tchackpoum.fr

Last edited by Vincent Sermonne; 10-30-2018 at 01:00 PM.
Vincent Sermonne is offline   Reply With Quote
Old 10-30-2018, 02:20 PM   #159
machinesworking
Human being with feelings
 
Join Date: Jan 2018
Posts: 114
Default

Just a quick positive.
I love Live for various things, but it kind of sucks with Push when you use the Arrangement view, which means if you're using backing tracks and playing instruments like guitar etc. you can't easily repeat various parts of a song while players learn the parts etc. You could probably do it with Session view but it would require way more planning than necessary with a linear timeline setup. I think it should be easily done in Moss4Reaper since it's using the Arrangement to fire clips etc. adding a loop of a part of a song creates a new clip done! This is a real solution for now, if it was a paid product I would buy it in a heartbeat.
machinesworking is offline   Reply With Quote
Old 10-30-2018, 10:27 PM   #160
mschnell
Human being with feelings
 
mschnell's Avatar
 
Join Date: Jun 2013
Location: Krefeld, Germany
Posts: 7,900
Default

Quote:
Originally Posted by machinesworking View Post
repeat various parts of a song while players learn the parts
GREAT !
Finally a useful application for loops in a DAW

-Michael
mschnell is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:03 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.