Go Back   Cockos Incorporated Forums > REAPER Forums > newbieland

Reply
 
Thread Tools Display Modes
Old 08-20-2019, 10:52 AM   #1
LTRAX
Human being with feelings
 
Join Date: Aug 2019
Posts: 5
Default Reaper lagging with plugins; what to do about it?

Hi everybody,

I'm very new to Reaper and I really hope some of you can help me out with this issue. I recorded a song and I now have a significant amount of tracks in Reaper.
However, I'm mixing the song and I've now got plugins loaded on two tracks (one each) and Reaper starts lagging. The lag is so bad I can't continue mixing like this.

The fact that I've got a pretty simple laptop doesn't help I guess.

So what can I do about it? Some adjustments regarding buffer or latency maybe?

Thanks so much in advance,

Larry
LTRAX is offline   Reply With Quote
Old 08-21-2019, 03:01 PM   #2
ivansc
Human being with feelings
 
Join Date: Aug 2007
Location: Near Cambridge UK and Near Questembert, France
Posts: 18,941
Default

Assuming that you are using a proper audio/midi interface rather than your laptop`s internal soundcard,
make sure you are running the interface`s ASIO driver and set the ASIO buffer up around 1024 instead of the more ususal 256-512.

Hope that helps.

It wont if you are trying to use the internal soundcard, sadly. although you could try downloading & installing asio4all , which is a kludge that makes your computer think your internal card can do proper audio MIDI multitrack recording. It sorta works for some people, but frankly IF reapers audio system selection window offers you WASAPI I would try that first.
__________________
Brexit Schmexit. Lets have a violent revolution instead. Bagsy the first go with a nuke! (Here, Moggy Moggy...)

Last edited by ivansc; 08-22-2019 at 09:59 AM.
ivansc is offline   Reply With Quote
Old 08-22-2019, 05:06 AM   #3
Dr. Who
Human being with feelings
 
Join Date: Oct 2012
Posts: 27
Default

Quote:
Originally Posted by LTRAX View Post
Hi everybody,

I'm very new to Reaper and I really hope some of you can help me out with this issue. I recorded a song and I now have a significant amount of tracks in Reaper.
However, I'm mixing the song and I've now got plugins loaded on two tracks (one each) and Reaper starts lagging. The lag is so bad I can't continue mixing like this.

The fact that I've got a pretty simple laptop doesn't help I guess.

So what can I do about it? Some adjustments regarding buffer or latency maybe?

Thanks so much in advance,

Larry
We really need details of your setup to be able to help i.e. spec of laptop, what audio interface is being used or internal soundcard etc.
Dr. Who is offline   Reply With Quote
Old 08-22-2019, 06:26 AM   #4
wolfdogg
Human being with feelings
 
Join Date: Oct 2016
Posts: 87
Default

What they said... and go to 'View - > Performance Meter' to see how CPU/RAM are being used in Reaper.
wolfdogg is offline   Reply With Quote
Old 08-24-2019, 10:17 AM   #5
LTRAX
Human being with feelings
 
Join Date: Aug 2019
Posts: 5
Default

Quote:
Originally Posted by ivansc View Post
Assuming that you are using a proper audio/midi interface rather than your laptop`s internal soundcard,
make sure you are running the interface`s ASIO driver and set the ASIO buffer up around 1024 instead of the more ususal 256-512.

Hope that helps.

It wont if you are trying to use the internal soundcard, sadly. although you could try downloading & installing asio4all , which is a kludge that makes your computer think your internal card can do proper audio MIDI multitrack recording. It sorta works for some people, but frankly IF reapers audio system selection window offers you WASAPI I would try that first.
Thanks for your response!

So it seems that I was indeed using the internal soundcard, I set up asio4all and this did improve everything a bit but unfortunately Reaper is still lagging at times.

Is there maybe a way that I can wait for a few tracks to buffer so I can then listen to them without any lag?; like 'loading' them?
LTRAX is offline   Reply With Quote
Old 08-24-2019, 10:50 AM   #6
Xenakios
Human being with feelings
 
Xenakios's Avatar
 
Join Date: Feb 2007
Location: Oulu, Finland
Posts: 7,929
Default

Quote:
Originally Posted by LTRAX View Post
Is there maybe a way that I can wait for a few tracks to buffer so I can then listen to them without any lag?; like 'loading' them?
What do you actually mean by "lagging"? What is lagging and how?
__________________
For info on SWS Reaper extension plugin (including Xenakios' previous extension/actions) :
http://www.sws-extension.org/
https://github.com/Jeff0S/sws
--
Xenakios blog (about HourGlass, Paul(X)Stretch and λ) :
http://xenakios.wordpress.com/
Xenakios is offline   Reply With Quote
Old 08-24-2019, 11:10 AM   #7
LTRAX
Human being with feelings
 
Join Date: Aug 2019
Posts: 5
Default

Quote:
Originally Posted by Xenakios View Post
What do you actually mean by "lagging"? What is lagging and how?
Basically just hearing clicks and pops, as if it continuously stops playing every few milliseconds...
LTRAX is offline   Reply With Quote
Old 08-24-2019, 11:17 AM   #8
Xenakios
Human being with feelings
 
Xenakios's Avatar
 
Join Date: Feb 2007
Location: Oulu, Finland
Posts: 7,929
Default

Quote:
Originally Posted by LTRAX View Post
Basically just hearing clicks and pops, as if it continuously stops playing every few milliseconds...
OK, that's a lot clearer explanation and sounds like your computer just can't keep up with the project playback. Have you turned off record and input monitoring on all the tracks? If those are on, Reaper won't be able to use the anticipative FX processing, which could help with the playback. What specs does your computer actually have : CPU (hopefully that's at least a 2 core one), RAM, hard drive?
__________________
For info on SWS Reaper extension plugin (including Xenakios' previous extension/actions) :
http://www.sws-extension.org/
https://github.com/Jeff0S/sws
--
Xenakios blog (about HourGlass, Paul(X)Stretch and λ) :
http://xenakios.wordpress.com/
Xenakios is offline   Reply With Quote
Old 08-24-2019, 12:06 PM   #9
LTRAX
Human being with feelings
 
Join Date: Aug 2019
Posts: 5
Default

Quote:
Originally Posted by Xenakios View Post
OK, that's a lot clearer explanation and sounds like your computer just can't keep up with the project playback. Have you turned off record and input monitoring on all the tracks? If those are on, Reaper won't be able to use the anticipative FX processing, which could help with the playback. What specs does your computer actually have : CPU (hopefully that's at least a 2 core one), RAM, hard drive?
Oh okay. Yes, record and input monitoring is turned off and the other tracks are muted as well.

My CPU is a Intel Pentium N3540 / 2.16 GHz, wouldn't know how many cores that is.

I have a 1600 MHZ memory speed, 1 x 4 GB, DDR3L SDRAM RAM.

I have a 5400 rpm spindle speed, HDD, 500 GB hard drive.

Is this clear to you?

Thanks in advance.
LTRAX is offline   Reply With Quote
Old 08-24-2019, 12:40 PM   #10
Xenakios
Human being with feelings
 
Xenakios's Avatar
 
Join Date: Feb 2007
Location: Oulu, Finland
Posts: 7,929
Default

Quote:
Originally Posted by LTRAX View Post
Oh okay. Yes, record and input monitoring is turned off and the other tracks are muted as well.

My CPU is a Intel Pentium N3540 / 2.16 GHz, wouldn't know how many cores that is.

I have a 1600 MHZ memory speed, 1 x 4 GB, DDR3L SDRAM RAM.

I have a 5400 rpm spindle speed, HDD, 500 GB hard drive.
It seems to be a 4 core CPU, which is fine. The clock speed isn't incredible, but expected for a 2014 CPU model. The memory is probably something that has been determined to work well enough with that processor and laptop design. There's not much of it, though, have you checked is your system maybe close to using the 4GB limit? (If you have a 32 bit operating system, you won't be able to add more anyway, though...)

I would guess the hard drive is the problematic thing. A 5400RPM mechanical drive just isn't that great for audio work, especially since the operating system and other stuff runs from it too. You could attempt increasing the media buffering size in Reaper, but don't get your hopes up that will actually work.

If possible, turn off any unneeded background processes like virus scanners. (Or at least make them not scan the folders where your audio recordings are.)

Wireless network is a common cause of problems on laptops. Turn that off when doing audio work and see if there's any difference.

What are the plugins that start causing the playback problems? Are they effects or audio instruments?
__________________
For info on SWS Reaper extension plugin (including Xenakios' previous extension/actions) :
http://www.sws-extension.org/
https://github.com/Jeff0S/sws
--
Xenakios blog (about HourGlass, Paul(X)Stretch and λ) :
http://xenakios.wordpress.com/
Xenakios is offline   Reply With Quote
Old 08-24-2019, 12:46 PM   #11
ivansc
Human being with feelings
 
Join Date: Aug 2007
Location: Near Cambridge UK and Near Questembert, France
Posts: 18,941
Default

Unfortunately you are down at the edge of minimum performance to run reaper unless you keep your projects really small & simple. A 5400rpm drive is not really up to coherent multitrack recording and at 4gb memory you are also on thin ice, assuming you are using anything newer than Win7. And that cpu doesnt seem like it is up to a whole lot of multitracking especially with plugins in use. Shame.

Simplest way to see how good bad or indifferent things are currently is to download resplendence.com`s excellent latency monitoring application. It will give you an idea as to whether or not your system can really "do" multitrack recording or not.

Add to all this that you are not using a "proper" audio/MIDI interface & you have a raft of possible problem areas.

What are you using in the way of plugins and virtual instruments?

Incidentally, I just realised I have a refurb Dell Latitude e6400 sitting in a carrier bag in my studio which runs faster than yours but only has two cores. Its running win10 with 4gb of ram and has an even smaller hard drive than yours (80gb!!!) but the dual core is a 2.5ghz. I may try sticking reaper on it and seeing how it gets on with no interface. Might come up with some tweaks for you.
__________________
Brexit Schmexit. Lets have a violent revolution instead. Bagsy the first go with a nuke! (Here, Moggy Moggy...)
ivansc is offline   Reply With Quote
Old 08-25-2019, 07:44 AM   #12
LTRAX
Human being with feelings
 
Join Date: Aug 2019
Posts: 5
Default

Quote:
Originally Posted by Xenakios View Post
It seems to be a 4 core CPU, which is fine. The clock speed isn't incredible, but expected for a 2014 CPU model. The memory is probably something that has been determined to work well enough with that processor and laptop design. There's not much of it, though, have you checked is your system maybe close to using the 4GB limit? (If you have a 32 bit operating system, you won't be able to add more anyway, though...)

I would guess the hard drive is the problematic thing. A 5400RPM mechanical drive just isn't that great for audio work, especially since the operating system and other stuff runs from it too. You could attempt increasing the media buffering size in Reaper, but don't get your hopes up that will actually work.

If possible, turn off any unneeded background processes like virus scanners. (Or at least make them not scan the folders where your audio recordings are.)

Wireless network is a common cause of problems on laptops. Turn that off when doing audio work and see if there's any difference.

What are the plugins that start causing the playback problems? Are they effects or audio instruments?
Oh okay. Yeah, I really did try to turn off as much as possible except for Reaper. The specific plugin that's causing the playback problems is Izotope Nectar 3, so 'effects'.

So is there nothing else that I can do right now?...

Last edited by LTRAX; 08-25-2019 at 09:03 AM.
LTRAX is offline   Reply With Quote
Old 08-25-2019, 10:00 AM   #13
sisaso
Human being with feelings
 
Join Date: Jul 2015
Posts: 164
Default

Nectar is CPU intensive. There are some Tipps in the Manual and on their website.
sisaso is offline   Reply With Quote
Old 08-25-2019, 10:12 AM   #14
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 8,292
Default

Putting a SSD in your machine would be the biggest bang for the buck upgrade. That slow 5400rpm spinner is the big bottleneck in that system. It's cheap too. A 1TB SSD from Crucial is going for $110 right now.

Now, this may not be 100% of your troubles. Trying to use a resource hungry MIDI instrument plugin for example, might still cross the line for what your CPU is capable of. But the drive upgrade to a SSD would be the biggest piece of the puzzle. You'd at least have a capable machine again. It's no risk in that you'd keep that SSD if you upgraded machines down the road. You could work around CPU overloading by freezing/rendering tracks created with hungry MIDI or synth plugins as you made them if that was still a problem.

That machine may support 8GB ram. That could be a 2nd cheap upgrade. 4GB is more than enough for most audio work but some instrument plugins can use more. And/or you'd have more ability to multitask on the machine (as your OS permits).

Keep in mind that you should set your latency (block size) high (eg 512 or 1024 samples) for mixing. Only set it low for live work or live performance work like playing through MIDI instrument plugins while you record.
serr is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:03 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.