Old 11-23-2009, 02:24 PM   #1
Chris Ihao
Human being with feelings
 
Chris Ihao's Avatar
 
Join Date: Oct 2009
Posts: 323
Default Midi notes placed ahead of time

Hi guys. I think I've read a post about this on these forums before. I searched but couldnt find it though.

The issue is that when I record midi, I tend to basically have all my notes placed a tad before they are supposed to hit. Even when I try to focus on ONLY hitting the notes at the correct time I tend to get this.

I've tried several keyboards (hammer action and non), midi cabled and via usb, but everything plays out the same. I also have a good buffer (5 ms, I even tried 2.5 ms which I CAN do) so I dont think this issue is buffer based. I have also looked through the settings of Reaper, but I cant really find anything that looks like it could be the cause of this.

Is it possible that I'm actually playing ahead of the metronome or drums so consequentially? I would not think so, as I've been playing keyboards for quite some years now. It does "sound" good also, meaning that the keys hit at the exact time of the click/drum.

I'm trying to stay away from quantizing as much as I can, so this bugs me a bit. Could it be that there are some over eager latency compensation in play that fools me into hitting notes before I'm supposed to, or rather plays the sound sooner than it actually should? This sounds unlikely, but you never know.

I got an image to show what I'm experiencing:



I'd appreciate any ideas.
Chris Ihao is offline   Reply With Quote
Old 11-23-2009, 03:02 PM   #2
rawdio
Human being with feelings
 
Join Date: Apr 2007
Posts: 80
Default

If haven't really got a clue about this, but you might try the option 'Preserve PDC delayed monitoring in recorded items' (in the recording menu of the tcp)...
rawdio is offline   Reply With Quote
Old 11-23-2009, 04:26 PM   #3
Simple Simon
Human being with feelings
 
Simple Simon's Avatar
 
Join Date: Nov 2009
Location: New Zealand
Posts: 186
Default

As someone who consistently tends to play a little ahead of the beat (despite many attempts to train myself to do otherwise) I would suggest eliminating this possibility - however slim - first. The easiest way to do that would be to simply try recording midi on a different system and/or with different software and compare the results.

If all things still point to Reaper, I'd suggest experimenting a little with the buffering settings under Preferences.
Simple Simon is offline   Reply With Quote
Old 11-23-2009, 04:31 PM   #4
funkycornwall
Human being with feelings
 
Join Date: Mar 2007
Posts: 230
Default

Don't worry it's perfectly normal. Ypu are a musician not a machine so if you are playing slightly ahead of the metronome beat and it sounds fine then great. I agree with your idea of avoiding quantizing. If you are a decent keyboard performer you shoould not need to quantize - you canm always adjust the odd note. If you really don't like something better to re-record it rather than quantize.
funkycornwall is offline   Reply With Quote
Old 11-23-2009, 04:50 PM   #5
Chris Ihao
Human being with feelings
 
Chris Ihao's Avatar
 
Join Date: Oct 2009
Posts: 323
Default

Quote:
Originally Posted by rawdio View Post
If haven't really got a clue about this, but you might try the option 'Preserve PDC delayed monitoring in recorded items' (in the recording menu of the tcp)...
Thanks for your suggestion rawdio. You put me on track of some "old" threads where this was mentioned. However, I've tried recording with both normal "input" and "output: midi", toggling "preserve pdc..." on and off, and I cant really say that there is a great difference. There may be a tad less "ahead" on "midi: out" or with "preserve pdc" on, but I cant really say as its so marginal. Maybe I'm getting tired, so I'm slacking behind some


Quote:
Originally Posted by Simple Simon View Post
As someone who consistently tends to play a little ahead of the beat (despite many attempts to train myself to do otherwise) I would suggest eliminating this possibility - however slim - first. The easiest way to do that would be to simply try recording midi on a different system and/or with different software and compare the results.

If all things still point to Reaper, I'd suggest experimenting a little with the buffering settings under Preferences.
Good tip. I'll check this out at a friend of mine the next time I'm visiting. Its comforting to know that there are others in the same boat though The "ahead" is so consistent that it almost looks machinal though, so thats why I thought there may be something wrong here.


Quote:
Originally Posted by funkycornwall View Post
Don't worry it's perfectly normal. Ypu are a musician not a machine so if you are playing slightly ahead of the metronome beat and it sounds fine then great. I agree with your idea of avoiding quantizing. If you are a decent keyboard performer you shoould not need to quantize - you canm always adjust the odd note. If you really don't like something better to re-record it rather than quantize.
Hehe. Yeah. I certainly hope I'm not a machine. Like I mention above though, this "ahead" almost looks machinal due to the lack of any "behind". I guess it sounds ok most of the time however. I usually have to practice more if it doesnt, so I totally agree with your argument. The bothersome part is that when using pre roll, I almost always lose the first note (cant be quantized either as its not there). Maybe I should just set the start point one bar back then. Hehe.

Thanks for the suggestions guys. Its typical that I get derailed when writing music because of stuff like this. I'm comforted by your responses though, and shall try to ignore this "ahead" next time.
Chris Ihao is offline   Reply With Quote
Old 11-23-2009, 05:51 PM   #6
Chris Ihao
Human being with feelings
 
Chris Ihao's Avatar
 
Join Date: Oct 2009
Posts: 323
Thumbs up

Edit: Bah. Think I found the main reason; The built in synthetic metronome of Reaper. I've seen many people mentioning that they use vsti's for this purpose. I now see why. I even did a quick run with a vsti earlier tonight, but I guess I was sloppy then.

Here is the result after just doing a run with Rewired Reason Redrums as metronome instead:



Quite a difference, aye? The weird thing is that the metronome plays along fine with the Redrum pattern. I think its just not as defined or something. Now, I wonder if samples work well instead. I kind of like having that metronome button you know I'm just happy to know I can keep on using Reaper with a big midi smile on my face.

Edit 2: In all fariness, I maybe just had a really good day when this was posted. This was extremely good results for any quantization. Almost a tad too good to be reproduced in fact, but I have mainly focused on the internal metronome so I wouldnt be able to tell for sure yet. I'm convinced that the end result of using external devices (like vsti's or rewired apps) are somewhat more precise though. Maybe because of an added latency that makes the midi note timing more correct.

Last edited by Chris Ihao; 11-27-2009 at 08:45 AM. Reason: Removed initial post as it is no longer actual
Chris Ihao is offline   Reply With Quote
Old 03-11-2014, 10:46 AM   #7
musinux
Human being with feelings
 
musinux's Avatar
 
Join Date: Mar 2011
Posts: 61
Default You are talking about: Human Latency compensation!

Hi Chris,

I've read through the whole Thread. Your Workaround with a self prepared 25ms to 35ms delayed Metronome Track is great!
I've found the nudge function ( type [n] for it) as a workaround for this Problem.
Therein you can shift tracks by a chooseable value in milliseconds.
Now what is the reason for this Behaviour?

It is not Reaper! Not the Soundcard reporting wrong Latency times, neither the same issue with the MIDI Driver. And you, the musician is also not responsible to that.

The reasonis, that you are hearing, that there is a small amount of latency while playing with a VSTi Plugin. You hear a timelag between your played notes and the click. Now what happens is that you automatically play a little bit earlier in time, so that your played sound and the click are both in time. You are anticipating the played notes.
But normally you do not record the audio signal but the midi signal. And MIDI is placed there where you've pressed the Key and not there where your sound comes to your ear.

The funniest Thing is, that you've measured exactly the same time lag as I did. 25 to 35ms. I myself measured values between 28 to 34ms depending on the used virtual Instrument.

The time you've played the notes ahead is the sum of all latencys on your Computersystem.

1. Soundcard Latency (on my system 3ms)
2. sampled sound latency (normally around 1 to 8 ms)
3. MIDI Latency (can be between 1 to aprox. 6ms)
4. DA Converter time (1 ms)

Maybe this information is helpful for you. Best Regards, Musinux
musinux is offline   Reply With Quote
Old 03-11-2014, 10:58 AM   #8
musinux
Human being with feelings
 
musinux's Avatar
 
Join Date: Mar 2011
Posts: 61
Default Hint : have a look at this thread

http://forum.cockos.com/showthread.php?t=136362

Here I am discussing the same problem.
The big question is the difference between 15ms (sum of all known latencys) and the measured 28 to 34ms.
Anyone with Ideas here?

Best Regards, Musinux.
musinux is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:09 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.