Go Back   Cockos Incorporated Forums > REAPER Forums > MIDI Hardware, Control Surfaces, and OSC

Reply
 
Thread Tools Display Modes
Old 01-28-2020, 06:51 AM   #841
Regisfofo
Human being with feelings
 
Regisfofo's Avatar
 
Join Date: Mar 2017
Location: France
Posts: 324
Default

Quote:
Originally Posted by MatFluor View Post
Wow, thank you so much! What a changelog :-)
The Faders now work nicely, thanks! As a small suggestion or question - the Launchpad X has "fine adjustment" on the faders when you tap one button multiple times (3 or 4 levels I think) and the tapping on those level fade to that respective level as well - is this possible to implement?
It's totally usable and already nicely done - just as a suggestion maybe.

Love the new Delete/Duplicate mode!

Thanks for the update! I second that! Fine adjustement for launchpads would be awesome!


I'm still learning to use this awesome extension, and I have some questions for the lauchpad pro use if you can point me in the right direction :
1) Is it possible to change track color within launchpad pro?
2) Can we delete non quantized already existing notes in the sequencers ?
3) Is it possible to add tied notes in the poly sequencer ?
4) Is it be possible to toggle reaper's smooth seek option within launchpad ? I think it could be really handy to be able to.
5) Is it possible to stop playback with launchpad ? All I could find is play/pause



Little bug I noticed : Note repeat note lenght 1/16 and 1/32 work ok but don't light up in the good pads


Also, did you know about Gianni's Quantise JSFX ? It can quantize midi input in realtime ,although not perfect as you can't mute/unmute it without going out of sync.... I'm no programmer but maybe it could improve DrivenByMoss.


Cheers!
Regisfofo is offline   Reply With Quote
Old 01-29-2020, 12:40 PM   #842
themixtape
Human being with feelings
 
themixtape's Avatar
 
Join Date: Aug 2009
Posts: 851
Default

Hi Jurgen, thanks for this update. It's so nice having the tempo and play position as an overlay now instead of switching screens.

Note Repeat Length still does not work with Push 2. Selectable: 1/4, 1/4t, 1/8, 1/8t, then skips to 1/16t, then skips to 1/32t (with the encoder). With the push-buttons, you can't go below 1/8t, and if you use encoder to go to 1/32t, you can't use the button to come back up. I have no idea why it's not working.

Tested with Reaper 6.03, completely clean install. NOTHING extra... no templates, no SWS Extensions, nothing.

As for the clicks/pops during stop (finger-drumming practice or just playing Guru or Poise), same problem. Again, with nothing extra installed. Nothing.

So, essentially it's still good... I can probably live with the clicks and pops issue by using 7.05 instead when I need Guru or Poise... but I do like the new additions with 8.70. It doesn't look like we're going to be able to figure out why the audio is so glitchy with those two plugins. Again to be fair, they're older... Guru only 32-bit, and Poise has been somewhat buggy since day one.. maybe that's why he abandoned it... but I still love it, and so many Reaper users love it, too. I really have no idea why DBM has this issue with those two plugins (8.00 and above), and further, I don't know why there's still major lag with certain Arturia plugins (Matrix-12, etc), with 8.00 and above, ESPECIALLY when the track with that plugin on it, is selected in Reaper. No lag when track isn't selected.

All of these issues-- less or non-existent, with 7.05.

Thanks man!

Last edited by themixtape; 01-29-2020 at 01:00 PM.
themixtape is offline   Reply With Quote
Old 01-30-2020, 04:03 AM   #843
dadada
Human being with feelings
 
Join Date: Aug 2014
Posts: 78
Default Catalina Issues?

Hi,
I am not really sure what happended there, but when starting reaper 6.03 after moving to a Catalina mac the DrivenByMoss4Reaper plugin got disabled/moved.
I think it said something about security issues?

Do I need to update to a Catalina compatible version of the plugin?
What should I do?

Thanks for any pointers!
dadada is offline   Reply With Quote
Old 01-31-2020, 01:14 PM   #844
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 517
Default

Quote:
Originally Posted by dadada View Post
Hi,
I am not really sure what happended there, but when starting reaper 6.03 after moving to a Catalina mac the DrivenByMoss4Reaper plugin got disabled/moved.
I think it said something about security issues?

Do I need to update to a Catalina compatible version of the plugin?
What should I do?

Thanks for any pointers!
Hmm, I expected to get the same problem when I run the Notarized version of Reaper but surprisingly that works as well on my system.
Which version of Reaper are you running? The normal Mac or the Notarized one?
moss is offline   Reply With Quote
Old 01-31-2020, 01:51 PM   #845
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 517
Default

Quote:
Originally Posted by Regisfofo View Post
1) Is it possible to change track color within launchpad pro?
Currently, not.

Quote:
Originally Posted by Regisfofo View Post
2) Can we delete non quantized already existing notes in the sequencers ?
No, because I do not know which note this could be. As a workaround you could quantize the notes first.

Quote:
Originally Posted by Regisfofo View Post
3) Is it possible to add tied notes in the poly sequencer ?
4) Is it be possible to toggle reaper's smooth seek option within launchpad ? I think it could be really handy to be able to.
No.

Quote:
Originally Posted by Regisfofo View Post
5) Is it possible to stop playback with launchpad ? All I could find is play/pause
Set "Behaviour on stop" to "Pause" (weird, I know).
moss is offline   Reply With Quote
Old 02-01-2020, 12:33 PM   #846
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 517
Default

A new feature you might not have yet discovered :-)

https://www.youtube.com/watch?v=eQBeQkGOhlU

More 8.70/8.60 features:
https://youtu.be/7Gdd1lDAbqQ
moss is offline   Reply With Quote
Old 02-01-2020, 03:18 PM   #847
cjewellstudios
Human being with feelings
 
Join Date: Sep 2017
Posts: 319
Default

I'll admit this is a stupid question. But it seems like this extension can do soo many things.

I have some buyers remorse with my akai advance 49. Is there any way I can make that act as if its a komplete kontrol keyboard?
cjewellstudios is online now   Reply With Quote
Old 02-02-2020, 02:07 AM   #848
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 517
Default

Quote:
Originally Posted by cjewellstudios View Post
I'll admit this is a stupid question. But it seems like this extension can do soo many things.

I have some buyers remorse with my akai advance 49. Is there any way I can make that act as if its a komplete kontrol keyboard?
Not stupid at all and yes you can! Take a look at the Generic Flexi which is also part of DrivenByMoss. You can map any button, knob and fader and also have modes. Watch the Generic Flexi Tutorial videos on my Youtube channel:
https://www.youtube.com/watch?v=m4Dk...MQ9mdEDJDColcP
moss is offline   Reply With Quote
Old 02-02-2020, 04:48 AM   #849
cjewellstudios
Human being with feelings
 
Join Date: Sep 2017
Posts: 319
Default

Quote:
Originally Posted by moss View Post
Not stupid at all and yes you can! Take a look at the Generic Flexi which is also part of DrivenByMoss. You can map any button, knob and fader and also have modes. Watch the Generic Flexi Tutorial videos on my Youtube channel:
https://www.youtube.com/watch?v=m4Dk...MQ9mdEDJDColcP
That sounds promising! Although I am having some trouble.

I had previously tried the generic flexi thinking I could set up my midi fighter twister to control the knobs on Komplete Kontrol. I never got it set up properly.

I've troubleshooted(troubleshot? lol) myself as much as I can.

- Install files are in the correct place and not in subfolders.

- I can pull up the interface of drivenbymoss.

- The control surface page also has the UserPlugins/java-runtime


But no matter what device I select, drivenbymoss doesn't see the incoming midi. As in, it doesn't detect the knob/button I've engaged.

I do believe that's all the correct steps but I'm obviously missing something.

I scanned through this thread a bit but couldn't find anyone with the same issue.
cjewellstudios is online now   Reply With Quote
Old 02-02-2020, 07:29 AM   #850
Earthwalker
Human being with feelings
 
Join Date: Feb 2020
Posts: 2
Default APC Key25

Any idea of future support for the APC Key 25? Or does the APC Mini or 40 crossover for that as well?
Earthwalker is offline   Reply With Quote
Old 02-03-2020, 01:21 AM   #851
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 517
Default

Quote:
Originally Posted by cjewellstudios View Post
That sounds promising! Although I am having some trouble.

I had previously tried the generic flexi thinking I could set up my midi fighter twister to control the knobs on Komplete Kontrol. I never got it set up properly.

I've troubleshooted(troubleshot? lol) myself as much as I can.

- Install files are in the correct place and not in subfolders.

- I can pull up the interface of drivenbymoss.

- The control surface page also has the UserPlugins/java-runtime


But no matter what device I select, drivenbymoss doesn't see the incoming midi. As in, it doesn't detect the knob/button I've engaged.

I do believe that's all the correct steps but I'm obviously missing something.

I scanned through this thread a bit but couldn't find anyone with the same issue.
If you see the DrivenByMoss user interface, the installation is correct.

For MIDI make sure you have disabled the MIDI ports you want to use in the Reaper settings! Also make sure you have selected the correct input/outputs in the configuration page of the DrivenByMoss extension you have added.
moss is offline   Reply With Quote
Old 02-03-2020, 01:23 AM   #852
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 517
Default

Quote:
Originally Posted by Earthwalker View Post
Any idea of future support for the APC Key 25? Or does the APC Mini or 40 crossover for that as well?
There are no plans. You can give Generic Flexi a shot (see answer above).
moss is offline   Reply With Quote
Old 02-03-2020, 04:17 AM   #853
cjewellstudios
Human being with feelings
 
Join Date: Sep 2017
Posts: 319
Default

Quote:
Originally Posted by moss View Post
If you see the DrivenByMoss user interface, the installation is correct.

For MIDI make sure you have disabled the MIDI ports you want to use in the Reaper settings! Also make sure you have selected the correct input/outputs in the configuration page of the DrivenByMoss extension you have added.
For full clarity:

By disabling the midi ports you mean just not enabling them, correct? As in not enabling them for input or control. As opposed to removing them all together.

And in the drivenbymoss gui: the correct input and output is the device you are trying to configure? Like my midi fighter twister, both the input and output would be the midi fighter twister?

If that's the case then yes I have done all that.

Whichever device I select, I can't get it to detect any incoming midi.
cjewellstudios is online now   Reply With Quote
Old 02-03-2020, 05:56 AM   #854
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 517
Default

Quote:
Originally Posted by cjewellstudios View Post
By disabling the midi ports you mean just not enabling them, correct? As in not enabling them for input or control. As opposed to removing them all together.
Yes.

Quote:
Originally Posted by cjewellstudios View Post
And in the drivenbymoss gui: the correct input and output is the device you are trying to configure? Like my midi fighter twister, both the input and output would be the midi fighter twister?
Yes.

Quote:
Originally Posted by cjewellstudios View Post
If that's the case then yes I have done all that.
Whichever device I select, I can't get it to detect any incoming midi.
Hmm, then I have no real idea. Have you tried the simple Midi Monitor (Utilities -> Midi Monitor)?
moss is offline   Reply With Quote
Old 02-03-2020, 06:25 AM   #855
MatFluor
Human being with feelings
 
Join Date: Jul 2018
Posts: 12
Default

I'm not sure if it was oversight or you're working on it
I mentioned the fined details of the sliders on the Launchpad X (I think it is last post on the previous page). Is that possible?

Thanks for the videos, I was wondering what the simulator was ;-)
MatFluor is offline   Reply With Quote
Old 02-03-2020, 06:36 AM   #856
cjewellstudios
Human being with feelings
 
Join Date: Sep 2017
Posts: 319
Default

Quote:
Originally Posted by moss View Post

Hmm, then I have no real idea. Have you tried the simple Midi Monitor (Utilities -> Midi Monitor)?

Will give that a go! That should tell us something Thank you.
cjewellstudios is online now   Reply With Quote
Old 02-04-2020, 02:17 PM   #857
timothys_monster
Human being with feelings
 
timothys_monster's Avatar
 
Join Date: Jan 2012
Location: Germany
Posts: 900
Default

OK, I have been testing CSI lately but couldn't really get my Icon Platform Nano to work.

Now I tried DBM with the Mackie MCU Control Universal template and it works great so far!

Transport, fader, pan, track selection work nearly flawlessly.

Now, what can we do to have full support for the device like you have done for the other controllers? Is it necessary to start from scratch with Generic Flexi or can we use the MCU template and fiddle around from there? If so... how?
timothys_monster is offline   Reply With Quote
Old 02-05-2020, 01:14 AM   #858
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 517
Default

Quote:
Originally Posted by timothys_monster View Post
OK, I have been testing CSI lately but couldn't really get my Icon Platform Nano to work.

Now I tried DBM with the Mackie MCU Control Universal template and it works great so far!

Transport, fader, pan, track selection work nearly flawlessly.

Now, what can we do to have full support for the device like you have done for the other controllers? Is it necessary to start from scratch with Generic Flexi or can we use the MCU template and fiddle around from there? If so... how?
I do not have a Nano here but it seems the editor is available for it as well. Which means you can exchange and modify the MCU commands that the device sends to your liking.

... and if you want something completely different "Generic Flexi" is your friend :-)
moss is offline   Reply With Quote
Old 02-05-2020, 03:40 AM   #859
timothys_monster
Human being with feelings
 
timothys_monster's Avatar
 
Join Date: Jan 2012
Location: Germany
Posts: 900
Default

Quote:
Originally Posted by moss View Post
I do not have a Nano here but it seems the editor is available for it as well. Which means you can exchange and modify the MCU commands that the device sends to your liking.
Thanks, do you mean the "iMap" software from Icon or which editor do you refer to?
timothys_monster is offline   Reply With Quote
Old 02-05-2020, 05:58 AM   #860
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 517
Default

Quote:
Originally Posted by timothys_monster View Post
Thanks, do you mean the "iMap" software from Icon or which editor do you refer to?
Yes, that's what I mean.
moss is offline   Reply With Quote
Old 02-06-2020, 07:45 AM   #861
protodude
Human being with feelings
 
Join Date: Feb 2020
Posts: 3
Default

Hi Moss,
First of all, thank you for creating and maintaining this amazing tool!
Here's what's happening on my side since the recent NI A61 firmware update with the latest version of DrivenByMoss4Reaper: everything works as expected, except for the main rotary knob. Turning it to either side works fine, but tilting it upwards or to the left has no effect and returns the following in the log: 'CC should be handled in framework...'
I've checked and both 'Komplete Kontrol A DAW' and 'Komplete Kontrol A61 MIDI' are disabled in Reaper's MIDI settings.
Any idea on how to fix this?
protodude is offline   Reply With Quote
Old 02-07-2020, 06:14 AM   #862
TVbene
Human being with feelings
 
Join Date: Oct 2017
Posts: 31
Default

Yes, same problem here with my A-series. One question, can the A-series be used to control device parameters in Reaper? In your video you used the clear button that does not exist on the A-series.
TVbene is offline   Reply With Quote
Old 02-07-2020, 08:51 AM   #863
triplex
Human being with feelings
 
Join Date: Dec 2010
Posts: 17
Default

Hi Moss,

Strangely, DrivenByMoss4Reaper loads fine on my MacbookPro (OS X 10.13), but crashes Reaper on my MacPro (OS X 10.11). Here's the log:

Code:
Thread 0 Crashed:: reaper  Dispatch queue: com.apple.main-thread
0   reaper_drivenbymoss.dylib     	0x00000001152da26c _GLOBAL__sub_I_dllmain.cpp + 19
1   dyld                          	0x00007fff6489010b ImageLoaderMachO::doModInitFunctions(ImageLoader::LinkContext const&) + 265
2   dyld                          	0x00007fff64890284 ImageLoaderMachO::doInitialization(ImageLoader::LinkContext const&) + 40
3   dyld                          	0x00007fff6488c8bd ImageLoader::recursiveInitialization(ImageLoader::LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 305
4   dyld                          	0x00007fff6488c743 ImageLoader::processInitializers(ImageLoader::LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 127
5   dyld                          	0x00007fff6488c9b3 ImageLoader::runInitializers(ImageLoader::LinkContext const&, ImageLoader::InitializerTimingList&) + 75
6   dyld                          	0x00007fff64881eb0 dyld::runInitializers(ImageLoader*) + 89
7   dyld                          	0x00007fff64889308 dlopen + 555
8   libdyld.dylib                 	0x00007fff986b279c dlopen + 59
9   com.cockos.reaper             	0x000000010703a687 LoadLibrary(char const*) + 183
10  com.cockos.reaper             	0x0000000106df3217 Plugins_Load(char const*) + 999
11  com.cockos.reaper             	0x000000010717121d MainProc(HWND__*, unsigned int, unsigned long, long) + 7277
triplex is offline   Reply With Quote
Old 02-08-2020, 06:40 AM   #864
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 517
Default

Quote:
Originally Posted by protodude View Post
Hi Moss,
First of all, thank you for creating and maintaining this amazing tool!
Here's what's happening on my side since the recent NI A61 firmware update with the latest version of DrivenByMoss4Reaper: everything works as expected, except for the main rotary knob. Turning it to either side works fine, but tilting it upwards or to the left has no effect and returns the following in the log: 'CC should be handled in framework...'
I've checked and both 'Komplete Kontrol A DAW' and 'Komplete Kontrol A61 MIDI' are disabled in Reaper's MIDI settings.
Any idea on how to fix this?
Got it, will be fixed in the next update.
moss is offline   Reply With Quote
Old 02-08-2020, 07:20 AM   #865
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 517
Default

Quote:
Originally Posted by triplex View Post
Hi Moss,

Strangely, DrivenByMoss4Reaper loads fine on my MacbookPro (OS X 10.13), but crashes Reaper on my MacPro (OS X 10.11). Here's the log:

Code:
Thread 0 Crashed:: reaper  Dispatch queue: com.apple.main-thread
0   reaper_drivenbymoss.dylib     	0x00000001152da26c _GLOBAL__sub_I_dllmain.cpp + 19
1   dyld                          	0x00007fff6489010b ImageLoaderMachO::doModInitFunctions(ImageLoader::LinkContext const&) + 265
2   dyld                          	0x00007fff64890284 ImageLoaderMachO::doInitialization(ImageLoader::LinkContext const&) + 40
3   dyld                          	0x00007fff6488c8bd ImageLoader::recursiveInitialization(ImageLoader::LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 305
4   dyld                          	0x00007fff6488c743 ImageLoader::processInitializers(ImageLoader::LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 127
5   dyld                          	0x00007fff6488c9b3 ImageLoader::runInitializers(ImageLoader::LinkContext const&, ImageLoader::InitializerTimingList&) + 75
6   dyld                          	0x00007fff64881eb0 dyld::runInitializers(ImageLoader*) + 89
7   dyld                          	0x00007fff64889308 dlopen + 555
8   libdyld.dylib                 	0x00007fff986b279c dlopen + 59
9   com.cockos.reaper             	0x000000010703a687 LoadLibrary(char const*) + 183
10  com.cockos.reaper             	0x0000000106df3217 Plugins_Load(char const*) + 999
11  com.cockos.reaper             	0x000000010717121d MainProc(HWND__*, unsigned int, unsigned long, long) + 7277
I noted it in the installation file but might be easily overlooked:
"minimum version 10.12 Sierra"
moss is offline   Reply With Quote
Old 02-08-2020, 08:26 AM   #866
protodude
Human being with feelings
 
Join Date: Feb 2020
Posts: 3
Default

Quote:
Originally Posted by moss View Post
Got it, will be fixed in the next update.
Thanks a million, Moss! I'll be looking forward to it!

Have a nice weekend!
protodude is offline   Reply With Quote
Old 02-10-2020, 05:48 PM   #867
cjewellstudios
Human being with feelings
 
Join Date: Sep 2017
Posts: 319
Default

Ok so Im back

After I utilized the midi monitor, I was able to start mapping and figuring things out.

Now, so far I tried the track volume. I love that it follows visibility so if I only have 8 drum tracks visible, thats what Im controlling. Brilliant.

What Im confused about is literally most of the other stuff this extension can do

All of the device/browser stuff realllly seems like it should be able to talk to the Komplete Kontrol plugin, which is what I really set out on this journey for in the first place

But reading alot of this thread it seems like thats not what its for. So yeah, confusion ensues.

I've definitely tried reading alot of the documentation on this/watched your YT channel a bit but yeah...


So can it control the Komplete Kontrol software? and if so, how?

Many thanks! I'll be using this regardless. Great work!
cjewellstudios is online now   Reply With Quote
Old 02-11-2020, 12:41 AM   #868
HedleyLamaar
Human being with feelings
 
Join Date: Feb 2020
Posts: 2
Default Troubles with Launchpad MK2

Hey! Recently acquired a Novation Launchpad MK2 and have been trying to make this work. I've updated the firmware on the Launchpad and got the current drivers from Novation. Got the extension installed and everything enabled (or so I thought).

When I start Reaper, the Launchpad lights up. I can assign colors to tracks and I see the Launchpad responding (although not sure if correctly.) However, I'm not able to actually tie a sound to a button.

I've made a video that demonstrates my issue. I don't know if there's some other setting I'm supposed to be looking at or what, but I'm totally stuck.
Here's the video link: https://youtu.be/lO_ymLJ5RQ0

Any thoughts?
HedleyLamaar is offline   Reply With Quote
Old 02-11-2020, 07:15 AM   #869
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 517
Default

Quote:
Originally Posted by cjewellstudios View Post
Ok so Im back

After I utilized the midi monitor, I was able to start mapping and figuring things out.

Now, so far I tried the track volume. I love that it follows visibility so if I only have 8 drum tracks visible, thats what Im controlling. Brilliant.

What Im confused about is literally most of the other stuff this extension can do

All of the device/browser stuff realllly seems like it should be able to talk to the Komplete Kontrol plugin, which is what I really set out on this journey for in the first place

But reading alot of this thread it seems like thats not what its for. So yeah, confusion ensues.

I've definitely tried reading alot of the documentation on this/watched your YT channel a bit but yeah...


So can it control the Komplete Kontrol software? and if so, how?

Many thanks! I'll be using this regardless. Great work!
With the Generic Flexi it is not possible but you can simply use the NI Komplete Kontrol extension, which is also part of DrivenByMoss. This supports all available features of the Kontrol (and some more).
moss is offline   Reply With Quote
Old 02-11-2020, 07:23 AM   #870
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 517
Default

Quote:
Originally Posted by HedleyLamaar View Post
Hey! Recently acquired a Novation Launchpad MK2 and have been trying to make this work. I've updated the firmware on the Launchpad and got the current drivers from Novation. Got the extension installed and everything enabled (or so I thought).

When I start Reaper, the Launchpad lights up. I can assign colors to tracks and I see the Launchpad responding (although not sure if correctly.) However, I'm not able to actually tie a sound to a button.

I've made a video that demonstrates my issue. I don't know if there's some other setting I'm supposed to be looking at or what, but I'm totally stuck.
Here's the video link: https://youtu.be/lO_ymLJ5RQ0

Any thoughts?
This looks all good. I think you only forgot to enable "Record Monitoring".
moss is offline   Reply With Quote
Old 02-11-2020, 08:10 AM   #871
cjewellstudios
Human being with feelings
 
Join Date: Sep 2017
Posts: 319
Default

Quote:
Originally Posted by moss View Post
With the Generic Flexi it is not possible but you can simply use the NI Komplete Kontrol extension, which is also part of DrivenByMoss. This supports all available features of the Kontrol (and some more).
I have to have one of those keyboards to do that though, right?

I see that you can set the input on any one of those NI keyboard extensions but moving any knob on my midi twister results in a "cc should be handled in framework..." message in the log.
cjewellstudios is online now   Reply With Quote
Old 02-11-2020, 01:07 PM   #872
moss
Human being with feelings
 
moss's Avatar
 
Join Date: Mar 2007
Location: Germany
Posts: 517
Default

Quote:
Originally Posted by cjewellstudios View Post
I have to have one of those keyboards to do that though, right?

I see that you can set the input on any one of those NI keyboard extensions but moving any knob on my midi twister results in a "cc should be handled in framework..." message in the log.
Ah, no you need one of those keyboards.

However, since some versions back of Komplete Kontrol you can map it to any keyboard. But I think this works only if you run it standalone?! Have not tested it. If it is possible to use this in the plugin as well, you could route it through Generic Flexi (using the MIDI CC functions as output).

EDIT: Did a quick test and it seems to work. But it seems the mapping supports only absolute values (no relative knobs).

Last edited by moss; 02-11-2020 at 01:52 PM.
moss is offline   Reply With Quote
Old 02-11-2020, 01:18 PM   #873
cjewellstudios
Human being with feelings
 
Join Date: Sep 2017
Posts: 319
Default

You can map it for sure.

Through generic flexi or anything really.

The trouble is the way it reroutes midi depending what plugin is loaded. So you cant really have any sort of feedback/deep integration.

Oh well, I'll end up getting an NI keyboard because I really like the KK workflow so far. Too bad its so freaking proprietary.

Thanks for your help Moss!

Time to MAKE SOME FUNKY MUSIC...
cjewellstudios is online now   Reply With Quote
Old 02-12-2020, 05:35 AM   #874
Labadal
Human being with feelings
 
Join Date: Jan 2020
Location: Germany
Posts: 1
Default

Quote:
Originally Posted by b0se View Post
So happy to see this for Reaper (used to use it for Bitwig). Thanks Moss!

Having a problem though, it (latest version) crashes Reaper (latest version) the second I select it in the Control Surface Settings list.

Any ideas? OSX El Capitan.
Same thing here, but on Windows!
When I select drivenbymoss in the control surface menu reaper crashes immediately...
I tried version 8.70

EDIT: Windows 10 and Reaper 6.03

Last edited by Labadal; 02-12-2020 at 05:42 AM.
Labadal is offline   Reply With Quote
Old 02-12-2020, 11:25 PM   #875
HedleyLamaar
Human being with feelings
 
Join Date: Feb 2020
Posts: 2
Default Buttons unresponsive

Quote:
Originally Posted by moss View Post
This looks all good. I think you only forgot to enable "Record Monitoring".
I figured out my problem, and man, for the next person please consider putting this in big bold letters somewhere: ONLY PLUG DIRECTLY INTO PC! DON'T PLUG INTO ANY HUBS OR ANYTHING ELSE. EVEN IF A POWERED HUB--DOESN'T MATTER.

I've spent a couple days wrestling with this. Just now figured out this was my problem all along. Maybe other people will have a different experience, but for me, plugging into other hubs etc caused flaky issues with the lights and functionality of the buttons.

Thanks so much for your help!
HedleyLamaar is offline   Reply With Quote
Old 02-14-2020, 02:52 PM   #876
NoCo
Human being with feelings
 
NoCo's Avatar
 
Join Date: Feb 2020
Posts: 1
Default

Quote:
Originally Posted by moss View Post
I do not have a Nano here but it seems the editor is available for it as well. Which means you can exchange and modify the MCU commands that the device sends to your liking.

... and if you want something completely different "Generic Flexi" is your friend :-)
Hi Jurgen

Just out of curiosity, would the Generic Flexi also work with the Akai Fire? Otherwise, since someone's now developed a Bitwig Script for the Fire, could that be integrated into your DBM4R?

Link to the Bitwig extension: https://raveystabs.co.uk/blog/akai-f...ion-for-bitwig
NoCo is offline   Reply With Quote
Old 02-14-2020, 04:14 PM   #877
themixtape
Human being with feelings
 
themixtape's Avatar
 
Join Date: Aug 2009
Posts: 851
Default

Mods can we PLEASE move this thread to MIDI Controllers sub-forum? PLEASE? Thank you!!!
themixtape is offline   Reply With Quote
Old 02-16-2020, 04:24 AM   #878
matthias.matthias
Human being with feelings
 
Join Date: Jun 2010
Posts: 179
Default TC display

Besides the two points below I also noticed that an offset added to the timecode in project settings is not reflected on the controller's display.

BTW: I really like the effective shortening of track names and the smoothness of the meters.

Quote:
Originally Posted by matthias.matthias View Post
I have a Qcon Pro G2 with an extender. Most things work very well. But here's what I miss most:

1) I can choose only 4 out of the 6 automation modes (trim read in particular and preview are missing)

2) It'd be nice, if the scrub function would work.

Thank you Moss for your work!
matthias.matthias is offline   Reply With Quote
Old 02-18-2020, 06:50 PM   #879
barbaroja
Human being with feelings
 
barbaroja's Avatar
 
Join Date: Jul 2009
Posts: 313
Default

Moss, I also have found reaper to become real laggy whenever I use drivenbymoss.

Note selection, edition, lags a lot. Clip editing in arrangement is also slow.

I have tested removing the extension and enabling it and there is definitely a big difference.

It is so slow it is a showstopper here. Had to disable it to make music.

Using 8.70 here. There is a big jump in CPU use and in RT CPU use. I use a faily decent latest gen i7 intel cpu.

Sorry for the crappy screenshots. Forum size limits are really limiting and do not feel like uploading to anywhere else.

If I drag a clip around in the arrangement I can see that a cyclic lag gets introduced every 1-2 seconds. Stops responding and then updates.

I hope it has been of any help.

Edit: If someone can point me to 7.05, would be nice. Could not find it in the website. Thanks.
Attached Images
File Type: jpg DrivenbyMoss Disabled 1.jpg (60.6 KB, 17 views)
File Type: jpg DrivenbyMoss Enabled 1.jpg (54.9 KB, 16 views)

Last edited by barbaroja; 02-18-2020 at 07:06 PM.
barbaroja is offline   Reply With Quote
Old 02-18-2020, 08:11 PM   #880
themixtape
Human being with feelings
 
themixtape's Avatar
 
Join Date: Aug 2009
Posts: 851
Default

Quote:
Originally Posted by barbaroja View Post
Moss, I also have found reaper to become real laggy whenever I use drivenbymoss.

Note selection, edition, lags a lot. Clip editing in arrangement is also slow.

I have tested removing the extension and enabling it and there is definitely a big difference.

It is so slow it is a showstopper here. Had to disable it to make music.

Using 8.70 here. There is a big jump in CPU use and in RT CPU use. I use a faily decent latest gen i7 intel cpu.

Sorry for the crappy screenshots. Forum size limits are really limiting and do not feel like uploading to anywhere else.

If I drag a clip around in the arrangement I can see that a cyclic lag gets introduced every 1-2 seconds. Stops responding and then updates.

I hope it has been of any help.

Edit: If someone can point me to 7.05, would be nice. Could not find it in the website. Thanks.
This. Again, something drastically changed between version 7.xx and version 8.00. Drastically. I tried pointing this out to Jurgen and he can't figure out the issue.

The lag is WAY less with 7.05. WAAAAAAAAAAAAAAAAY less. With 8.00 and above, it's god-awful.

I really wish we could figure this out.

Again mods, can you please please please move this thread to the MIDI CONTROLLERS sub-forum? Please?
themixtape is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 07:14 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.