Old 08-11-2020, 04:43 AM   #1
matt37137
Human being with feelings
 
Join Date: Feb 2020
Posts: 6
Unhappy noob question first use

Hi, would like to teach myself oscii-bot but got stuck at the start...
I tried to get reaper to send OSC, without midi controller connected, just to see if it works.

Using alphatrack.txt with commented midi input and output.
Code:
// generic REAPER<-->alphatrack OSC, for REAPER's Default.ReaperOSC
// Only a basic volume fader works now, needs a lot more work

@input osc_in OSC "*:6500"
@output osc_out OSC "192.168.8.100:5500"

//@output midi_out MIDI "AlphaTrack"
//@input midi_in MIDI "AlphaTrack"

@init
...
...
but i get connection error...
https://drive.google.com/file/d/1k4P...ew?usp=sharing
here is screen from reaper setting. Tested with reversed ports too.
when it work, oscii-bot print out osc messages?

UPDATE:

Got connection with reaper! Yay

For anyone

Code:
// generic REAPER<-->alphatrack OSC, for REAPER's Default.ReaperOSC
// Only a basic volume fader works now, needs a lot more work

@input osc_in OSC "*:5500"
@output osc_out OSC "192.168.8.100:6500"

//@output midi_out MIDI "AlphaTrack"
//@input midi_in MIDI "AlphaTrack"

@init
and in reaper same settings with device port 5500 and * as ip and local port 6500.

buuuuuuut...

this is what i get when changing volume in reaper by mouse.

Code:
...
	Listening on '*:5500'
	0 inputs, 0 outputs, 2 bidirectional

Total: 1 scripts, 0 inputs 0 outputs 2 bidirectional

================================================================================
midisend(): device 0.000000 invalid
midisend(): device 0.000000 invalid

Last edited by matt37137; 08-11-2020 at 05:56 AM. Reason: partly solved problem myself
matt37137 is offline   Reply With Quote
Old 08-11-2020, 11:55 AM   #2
goldenarpharazon
Human being with feelings
 
Join Date: Feb 2016
Posts: 161
Default

Possibly since the code has opened no midi inputs or outputs then a midisend() error happens?

Post the whole of your code for a better reply. There appears to be no real code in any @ blocks in the examples shown. It is this code in @ blocks that make oscii-bot do some function. Good luck.
goldenarpharazon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 06:53 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.