Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Compatibility

Reply
 
Thread Tools Display Modes
Old 12-18-2019, 10:38 PM   #1
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 673
Default D50 Crashes With Roland Cloud - Can Anyone Reproduce

Looking for help reproducing this if anyone happens to have a Roland Cloud account. I'm getting constant crashes with the Roland D50 plugin on load. Usually after some spiking of the channel volume. Other Cloud plugins are working fine. This is 100% reproducible here.

Specs: Windows 10x64
Reaper 6.02 x64
D-50 Versions: VST2, VST3 (both 64-bit) - v1.09 (latest versions according to the Cloud Manager)

Steps to Reproduce:

1. load a blank project
2. Load the D50 plugin (VST2 or VST3)

Result: spike in audio and crash

Windows Event Viewer shows this:

Code:
Fault bucket 1583285995529746607, type 4
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: reaper.exe
P2: 64.110.196.196
P3: 5dfa499a
P4: D-50(VST2 64bit).dll
P5: 1.6.0.0
P6: 5b2afdd6
P7: c0000005
P8: 00000000000f31f5
P9: 
P10: 

Attached files:
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER27C7.tmp.dmp
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER2874.tmp.WERInternalMetadata.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER2875.tmp.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER2883.tmp.csv
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER2894.tmp.txt

These files may be available here:
\\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_reaper.exe_48683d2368f987ff5fc95a92f9e487b2a761967_22409468_5846b228-256b-422d-83cd-8f2cd3742d11

Analysis symbol: 
Rechecking for solution: 0
Report Id: 42e14a2d-eb88-4a10-a8f3-2b967e7634a1
Report Status: 268435456
Hashed bucket: 3459d2bdf9f56c86e5f8f6396d66b8af
Cab Guid: 0
I went looking for the .dmp files in that folder and they don't exist. I also see some entries relating to Bonjour and Eucon but I removed the Eucon plugin and closed the Eucon applications and still got the crashes.
Funkybot is offline   Reply With Quote
Old 01-16-2020, 10:43 AM   #2
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 673
Default

Oddly, after a few weeks, I just got it working by:

1. Loaded up the VST2 (loud pop - meters spiking, Reaper output muted)
2. Ran the All Notes Off action
3. Ran the Reset MIDI Devices action

By this point, the D-50 became disabled in the FX MCP's effect bin. Then I...

4. Clicked and dragged the D-50 VST3 from the FX Browser and dropped it directly over the D-50 VST2 in the effects bin
5. Then I enabled the D-50 VST3

Now it works for some reason. Saved this as a Template and it works.

No idea what's going on with the D-50 and my system, but in case anyone else has this issue, give this a go. I've at least got the VST3 version working here.

Note: I think the crashes/issues I was experiencing may relate to the Bonjour service used by iTunes, EuCon, and iLok. Whenever Reaper would crash with the D-50 plugin, there'd be additional logs referencing Bounjour and EuCon.
Funkybot is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:10 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.