Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Q&A, Tips, Tricks and Howto

Reply
 
Thread Tools Display Modes
Old 11-19-2019, 12:26 PM   #1
D Rocks
Human being with feelings
 
Join Date: Dec 2017
Location: Quebec, Canada
Posts: 547
Default [Solved] MIDI Editor insert note with pen tool doesn't follow Channel mapping

Hello,


I am using one instance of Kontakt 5 with 8 MIDI tracks that are each input mapped to a unique MIDI channel (channel 1 to 8).

Kontakt receives my keyboard inputs on the correct channels but when I am in the MIDI Editor and having a specific MIDI item selected, then the pen note creation tool inserts a MIDI note that is not mapped to the channel of this MIDI item.

For example: MIDI track 8 is mapped so that it's input goes to the 8th MIDI channel in kontakt and it triggers the instrument that is linked to channel 8.
But if I create a note with the pen tool, the note triggers the MIDI channel 1 only.
If I play the keyboard the created midi notes will be correctly sent to the mapped input.

Please help me sort it out, I know it sounds complex, but I don't know why its doing that.

Thanks
__________________
Alex | www.drocksrecords.com | Thanks for REAPER

Last edited by D Rocks; 11-19-2019 at 07:19 PM. Reason: solved
D Rocks is offline   Reply With Quote
Old 11-19-2019, 03:00 PM   #2
xpander
Human being with feelings
 
xpander's Avatar
 
Join Date: Jun 2007
Location: Terra incognita
Posts: 5,265
Default

Use the filter to select the channel you want to use for each item the first time you draw into them. You might notice there's a box saying "Draw events on channel...". When you have done this channel selection and drawn to each item on their respective channels, select "All" in the channel box.
xpander is offline   Reply With Quote
Old 11-19-2019, 07:18 PM   #3
D Rocks
Human being with feelings
 
Join Date: Dec 2017
Location: Quebec, Canada
Posts: 547
Default

Hey Thank you for your reply xpander.
It made me wonder what you were talking about as I was not aware about that.

So I digged in and finally I found something that works and is most probably the way we are supposed to do it. I was doing something wierd and I guess that's why the mapping was messed up between the tracks and the midi editor.

Good way using only the send setups: "all midi inputs sends to channel 1-8" to kontakt


Bad method I had problems with:
__________________
Alex | www.drocksrecords.com | Thanks for REAPER
D Rocks is offline   Reply With Quote
Old 11-20-2019, 04:04 AM   #4
xpander
Human being with feelings
 
xpander's Avatar
 
Join Date: Jun 2007
Location: Terra incognita
Posts: 5,265
Default

Quote:
Originally Posted by D Rocks View Post
Hey Thank you for your reply xpander.
It made me wonder what you were talking about as I was not aware about that.
Sorry D Rocks, I was probably not that clear with my answer. I meant MIDI filter, accessible from the MIDI editor toolbar. But you already found a way to do it, so that's good.

xpander is offline   Reply With Quote
Old 11-20-2019, 06:34 AM   #5
D Rocks
Human being with feelings
 
Join Date: Dec 2017
Location: Quebec, Canada
Posts: 547
Default

Thank you again xpander.

I have looked at it and the wierd thing is that with the previous method I've found, this filter dialog indicates that events are written to channel 1 on each different MIDI item, but in fact it does work correctly as I intend. It sends the events correctly to the channel I assigned with the send configuration of the MIDI tracks.

So I tihnk the bottom line is that I don't even know what MIDI mapping is in relation to simply assigning a MIDI track to a MIDI channel.

Any ways, I'm glad it's working rn. This mapping and event filter thing is interesting tho, that's why I'm still curious.
__________________
Alex | www.drocksrecords.com | Thanks for REAPER
D Rocks is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 07:45 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.