Old 03-09-2010, 08:40 PM   #1
roygbiv
Human being with feelings
 
Join Date: Oct 2007
Posts: 227
Default How to convert accidental 48K recordign to 44K?

I know this shouldn't be hard, but here's the deal:

I accidentally recorded my band I think with the card set at 48K.

Yet Reaper thinks it is at 44 K (as does Windows).

So when I render the file, and play it back at 44K, it sounds ~ 1 whole note lower in pitch (and slower).

OK, its funny for a bit, but seriously, I need to fix this.

you would think I could re-render at different rates, but it doesn't seem to be working.

I'm pretty sure it is a timing-mismatch, because if I change the speed of playback (in the Transport toolbar) to 1.088 (48K/44K), it sounds fine.

Any suggestions? r8brain (free version) doesn't seem to fix it. The only thing that has worked is to do the playback at 1.088 and render it live.

Will that make the overall sound worse?

thx

roy
roygbiv is offline   Reply With Quote
Old 03-09-2010, 10:09 PM   #2
Dstruct
Human being with feelings
 
Join Date: Jul 2006
Posts: 12,279
Default

Check www.wavosaur.com with it you can change the samplerate of a file without actually doing any resampling. Just changing the header info.
Dstruct is offline   Reply With Quote
Old 03-09-2010, 10:32 PM   #3
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 10,174
Default

If you're feeling adventurous:

- copy the wav file
- open the copy in a hex editor
- look for the 4-character string "fmt "
- count 8 more bytes forward
- the next 4 bytes should be 44 AC 00 00
- change those 4 bytes to 80 BB 00 00
- save the file
schwa is offline   Reply With Quote
Old 03-10-2010, 12:08 AM   #4
dub3000
Human being with feelings
 
dub3000's Avatar
 
Join Date: Mar 2008
Location: Sydney, Australia
Posts: 3,826
Default

i've done what schwa suggested before and it works (for 250 files!)

you can use a program like editpad pro - open the file, hit CTRL-H (for hex mode) and you can do it there. it'll also do hex search/replace across multiple files, so if you have loads of files you can batch it.

but work off backups! very easy to screw up.

failing that, i think soundforge will allow change of the wav header without resampling.
dub3000 is offline   Reply With Quote
Old 03-10-2010, 06:47 AM   #5
bloodorangeonline
Human being with feelings
 
bloodorangeonline's Avatar
 
Join Date: Feb 2009
Location: Notts
Posts: 127
Default

Sorry to stick my nose in, but I didn't know that what Dstruct, schwa and dub3000 talk about was possible.

So, you don't actually have to resample a .wav file to get it to be a different sample rate?

By making these changes then (turning a 48kHz .wav into a 44.1kHz .wav) is the resulting file exactly the same as if it were recorded at 44.1 to begin with? And there's no degradation/change to sound quality?

Using schwa's method, what changes need to be made to turn a 96kHz .wav into 44.1kHz, and would there be any loss in sound quality?

I'm fascinated!
__________________
Blood Orange on SoundCloud
bloodorangeonline is offline   Reply With Quote
Old 03-10-2010, 06:54 AM   #6
Dstruct
Human being with feelings
 
Join Date: Jul 2006
Posts: 12,279
Default

Quote:
Originally Posted by bloodorangeonline View Post
By making these changes then (turning a 48kHz .wav into a 44.1kHz .wav) is the resulting file exactly the same as if it were recorded at 44.1 to begin with?
No. You have to resample in this case. But sometimes it can happen that your soundcard was running at different samplerate than what the application thought it was set to. Then you can fix it without resampling.
Dstruct is offline   Reply With Quote
Old 03-10-2010, 06:56 AM   #7
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 10,174
Default

These are ways to fix a file that was marked with an incorrect sample rate. It's not resampling at all.
schwa is offline   Reply With Quote
Old 03-10-2010, 07:03 AM   #8
bloodorangeonline
Human being with feelings
 
bloodorangeonline's Avatar
 
Join Date: Feb 2009
Location: Notts
Posts: 127
Default

Oh, sorry, I misunderstood. Thanks both for clearing that up for me.
__________________
Blood Orange on SoundCloud
bloodorangeonline is offline   Reply With Quote
Old 03-10-2010, 11:18 AM   #9
roygbiv
Human being with feelings
 
Join Date: Oct 2007
Posts: 227
Default

Hi Guys

Thanks for the tips! I'll give them a try.

Since this isn't the 1st time this has happened to me, do you have any suggestions about how to avoid it in the future? Should I force Reaper to use request the sample rate from the card?

(the card I am using is two Echo Layla24's, which also have an option of floating the sample rate or locking it down - maybe I should just lock it down to 44k in the card itself).

roy
roygbiv is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 06:41 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.