Old 06-23-2019, 08:09 PM   #1
lemerchand
Human being with feelings
 
Join Date: May 2018
Posts: 5
Default MIDI Learn Immediately Forgets "When Focused"

Up until today I had been using "When Visible" for all my learned parameters. I decided I wanted to switch to "Enable only when focused." So I was going through my knobs and checking the checkbox for the focus option. I realized they (the knobs) were turning no matter what, ie, FX open, closed, different tracks selected, etc.

So I decided to click a knob, press learn, click "When focused", close the window, open it again. Annnnnddd the option was no longer checked.

Two interesting tidbits: (1) it WILL remember "when track or item selected." and (2) it will work if I uncheck soft takeover (which I don't want to do) it will remember.

This didn't not occur with the Visible option until today. The only things i have done different are (a) I tried out the new global hotkey function to making midi learning easier, (b) I tried using Realearn, decided I didn't want it, and uninstalled it. I have restarted both Reaper and my pc to no avail.

I've seen at least 3 posts similar to this one and no solution. Any ideas?

Update: After some fiddling around, now it will ONLY set the parameter for arming automation. It ONLY does the "Arm envelop" option.

Last edited by lemerchand; 06-23-2019 at 08:26 PM. Reason: Update
lemerchand is offline   Reply With Quote
Old 06-25-2019, 03:18 AM   #2
cutnpaste
Human being with feelings
 
Join Date: Jul 2015
Posts: 292
Default

Review your procedure vs what is written in the manual.
cutnpaste is offline   Reply With Quote
Old 06-25-2019, 10:37 AM   #3
lemerchand
Human being with feelings
 
Join Date: May 2018
Posts: 5
Default

Okay, I checked the user guide, and unless there was a term I should have ctrl+f-ed (aside from "midi learn" or "when focused") I cannot see that I am doing anything wrong. I mentioned that this was working for me in the past--I haven't changed anything about my procedure.

So unless I am misunderstanding you, have you any clue where I can look next? I am really ripping my hair out over this one.
lemerchand is offline   Reply With Quote
Old 07-15-2019, 12:56 AM   #4
rmri
Human being with feelings
 
Join Date: Jul 2019
Posts: 1
Default

As a new user I installed Reaper in the weekend and one of the things I wanted to set up was MIDI mapping for my plugins.
I checked the manual and I think I did everything right however, I could not get it working and experienced the same problems with the "when focused" option.

The steps I took:
- Create a new Reaper project
- Go to preferences: Audio -> MIDI -> set the MIDI input port to Enabled+Control
- Add a new track
- Click FX on the track and add a plug-in
- Open the plug-in window, click on a pot
- Click param -> learn
- Move the control knob on the MIDI controller, the MIDI CC is recognized, I set "Enable only when effect configuration is focused" + "Soft takeover", click "OK"
- Click param again -> learn
- The "Enable only when effect configuration is focused" is not checked, so it was not saved properly
When I move the MIDI controller pot it will change the parameter regardless if the plug-in window is focused or not.

I also noticed if I uncheck "Soft takeover", then "Enable only when effect configuration is focused" will be properly saved and seems to be working properly, but without soft takeover it's kind of useless since parameters will jump as soon as you move the pot.

When I played around with the other checkboxes and noticed that it get's even messier, so something with the saving mechanism is definitely wrong.

Since I'm new to this product, I'm not sure how to file a proper bug report, I would appreciate if anybody could direct me to the right place.

Thanks
rmri is offline   Reply With Quote
Old 07-15-2019, 12:15 PM   #5
Jazzy2040
Human being with feelings
 
Join Date: Jul 2018
Posts: 9
Default

Quote:
Originally Posted by lemerchand View Post
Okay, I checked the user guide, and unless there was a term I should have ctrl+f-ed (aside from "midi learn" or "when focused") I cannot see that I am doing anything wrong. I mentioned that this was working for me in the past--I haven't changed anything about my procedure.

So unless I am misunderstanding you, have you any clue where I can look next? I am really ripping my hair out over this one.

I scratched my head too a lot over this.
What makes the Enabled when focused consistent is when saving as default, in Default Controller Mappings, after assigning the parameters.

Hope this helps.
__________________
Windows 10, I7 3770 @ 3.4Ghz, 16GB,
RME Babyface pro, Impact LX25+, NI KK S25.
Jazzy2040 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 04:03 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.