Old 05-27-2016, 02:12 AM   #1
Colox
Human being with feelings
 
Join Date: Feb 2012
Location: The land of meatballs and blondes
Posts: 970
Default Alternate routing of solo-ed tracks, possible?

Whenever you solo a track, the sound route is the same as in non-solo mode (the Soundcraft 'solo-in-place' way). All active fx and plugins on the route from the channel and out through the main gets applied.

Is there any way to re-route a signal's path when in solo mode? So that it doesn't go through all eventual processing, buses etc that it otherwise does. And when out of solo mode, the 'normal' routing enables?

This is what happens to all sounds played back through the media explorer, for example. The sounds gets sent straight to the main output connection bypassing every sound processing tool. You can set it to pass through the Masterbus if you choose to.

I don't have a multiple output audio interface (don't plan to get one), so I can't use a different output pair for solo-ed sounds.

Having trouble figuring out how this can be done, without manual intervention every time.

Thx for any thoughts
/C
__________________
There are only two kinds of people in the world: those who entertain, and those who are absurd.
- Britney Spears

Last edited by Colox; 05-27-2016 at 02:22 AM.
Colox is offline   Reply With Quote
Old 05-27-2016, 02:19 AM   #2
metal_priest
Human being with feelings
 
metal_priest's Avatar
 
Join Date: May 2011
Location: Padova
Posts: 1,404
Default

right-click on the solo button and choose "solo (ignore routing)".
Of course you will still hear the fx chain in the soloed track, but you can simply bypass it if you need it raw.
__________________
Il mio sito
add me on Linkedin!
metal_priest is offline   Reply With Quote
Old 05-27-2016, 04:09 AM   #3
Colox
Human being with feelings
 
Join Date: Feb 2012
Location: The land of meatballs and blondes
Posts: 970
Default

Quote:
Originally Posted by metal_priest View Post
right-click on the solo button and choose "solo (ignore routing)".
Of course you will still hear the fx chain in the soloed track, but you can simply bypass it if you need it raw.
Thanks.
Signal still gets routed through the usual route, including master bus fx etc, but this is a useful option.
__________________
There are only two kinds of people in the world: those who entertain, and those who are absurd.
- Britney Spears
Colox is offline   Reply With Quote
Old 05-27-2016, 04:19 AM   #4
metal_priest
Human being with feelings
 
metal_priest's Avatar
 
Join Date: May 2011
Location: Padova
Posts: 1,404
Default

oh yes, it goes through the master track.
This can be avoided leaving the master track without plugins and making a master bus fx as a new track where all the other tracks are routed (and not to the master track) and only this master track goes to the real master track.

or you can bypass the master track fx, probably you can set up a macro to solo the selected track (ignoring routing) and bypass master fx
__________________
Il mio sito
add me on Linkedin!
metal_priest is offline   Reply With Quote
Old 05-27-2016, 05:49 AM   #5
Colox
Human being with feelings
 
Join Date: Feb 2012
Location: The land of meatballs and blondes
Posts: 970
Default

Quote:
Originally Posted by metal_priest View Post
oh yes, it goes through the master track.
This can be avoided leaving the master track without plugins and making a master bus fx as a new track where all the other tracks are routed (and not to the master track) and only this master track goes to the real master track.

or you can bypass the master track fx, probably you can set up a macro to solo the selected track (ignoring routing) and bypass master fx
Ah, you're saying what I'm sitting here thinking
I was fishing for some kind of .. I don't know, setting solution or script hack that affects Reaper's default handling. Maybe there still is, I'll have to wait and see what might show up in this thread.

But yes, re-arranging the bus system a bit, and leaving the master with .. only audio non-processing plugins, or something along those lines, that might actually work. This way you can solo a track and listen to its insert processing without also having bus fx on it from parent tracks or the master and stuff.

Good preach, Priest
__________________
There are only two kinds of people in the world: those who entertain, and those who are absurd.
- Britney Spears
Colox is offline   Reply With Quote
Old 05-25-2019, 05:55 PM   #6
Colox
Human being with feelings
 
Join Date: Feb 2012
Location: The land of meatballs and blondes
Posts: 970
Default

Reviving an old thread, because I got problems with this now. I didn't before.

According to suggestion above, I've sent all single tracks to a track which acts like a bus track. No other tracks are sent to 'master', than the bus track. And there are no parent/child dependencies in the track structure at all, and no other forms of sends back and forth are enabled.

But now, when I enable 'Solo (ignore routing)' on any of the single tracks, then everything goes total quiet. No sound is heard. I'm quite sure that didn't happen before.

I'm using Reaper 5.976 x64 on Win10, and in my Reaper Preferences > Audio > Mute/Solo, I got the bottom two checkboxes unchecked.

My question is, where do the signal get sent to, in this case, when ¨solo (ignore routing)' is enabled and 'Master send' is disabled?
__________________
There are only two kinds of people in the world: those who entertain, and those who are absurd.
- Britney Spears
Colox is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:21 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.