Old 05-29-2019, 01:06 PM   #1
DrTT
Human being with feelings
 
Join Date: Jan 2019
Posts: 17
Default Stupid Reaper Audio Question

Dear all,

sorry, I am really desperate, because I do not understand one thing that should be obvious in Reaper.

I am doing some offline-processing of audio outside of Reaper with sox (e.g. for mixing of audio files). For interactive checking I am doing the same mixes in Reaper (simply combining those audio files with fader settings), but they do not at all come out the same in Reaper and sox.

For testing I did the following:
  1. Generate two ten second sine wave audio file in sox with 1kHz and 500Hz via
    Code:
    sox -r 48000 -n sine-1kHz.wav synth 10 sine 1000
    and
    Code:
    sox -r 48000 -n sine-500Hz.wav synth 10 sine 500
  2. Mix them with 6dB reduction each into a mix file via
    Code:
    sox -m -v 0.5 sine-1kHz.wav -v 0.5 sine-500Hz.wav sine-mix.wav
  3. Put all three into Reaper tracks, reduce the pure sine waves by 6dB, and phase invert the mix file.
My naive assumption is that they cancel out completely. But they do not. There are still some -60dB sines to be heard and measured (see attachment).

Obviously I am too dumb for audio math. Or is there another explanation (distortion, audio quantization, floating point vs. integer arithmetic)? I also tried to disable dithering, but it didn't help.

Best regards
Dr_TT
Attached Images
File Type: png c.png (60.1 KB, 20 views)

Last edited by DrTT; 05-29-2019 at 02:18 PM.
DrTT is offline   Reply With Quote
Old 05-29-2019, 02:21 PM   #2
Xenakios
Human being with feelings
 
Xenakios's Avatar
 
Join Date: Feb 2007
Location: Oulu, Finland
Posts: 7,925
Default

Try -6.0206 dB as the gain for the sine waves instead of -6dB.
__________________
For info on SWS Reaper extension plugin (including Xenakios' previous extension/actions) :
http://www.sws-extension.org/
https://github.com/Jeff0S/sws
--
Xenakios blog (about HourGlass, Paul(X)Stretch and λ) :
http://xenakios.wordpress.com/
Xenakios is online now   Reply With Quote
Old 05-29-2019, 04:11 PM   #3
DrTT
Human being with feelings
 
Join Date: Jan 2019
Posts: 17
Default

Hi Xenakios,

okay, thanks, good idea, this is really the correct logarithm.

Nevertheless: I put in the -6.0206dB manually into the fader settings, but I am still at -60dB of remaining sound level. But I am not sure whether Reaper really honours all the digits for the faders...

Best regards
Dr_TT
DrTT is offline   Reply With Quote
Old 05-29-2019, 04:26 PM   #4
Xenakios
Human being with feelings
 
Xenakios's Avatar
 
Join Date: Feb 2007
Location: Oulu, Finland
Posts: 7,925
Default

Quote:
Originally Posted by DrTT View Post
Hi Xenakios,

okay, thanks, good idea, this is really the correct logarithm.

Nevertheless: I put in the -6.0206dB manually into the fader settings, but I am still at -60dB of remaining sound level. But I am not sure whether Reaper really honours all the digits for the faders...

Best regards
Dr_TT
I generated the files with sox with your command lines (I did change the sample rates to 44100hz, though...), and did the test you described in Reaper. I noticed the same about -60dB residue. Setting the single sine tracks to -6.0206dB results in silence for me. (Reaper does indeed appear to cut those values to -6.02dB but it seems to be enough to get the tracks nulling, at least here...)
__________________
For info on SWS Reaper extension plugin (including Xenakios' previous extension/actions) :
http://www.sws-extension.org/
https://github.com/Jeff0S/sws
--
Xenakios blog (about HourGlass, Paul(X)Stretch and λ) :
http://xenakios.wordpress.com/

Last edited by Xenakios; 05-29-2019 at 04:35 PM.
Xenakios is online now   Reply With Quote
Old 05-30-2019, 03:31 AM   #5
DrTT
Human being with feelings
 
Join Date: Jan 2019
Posts: 17
Default

Hi Xenakios,

Quote:
Originally Posted by Xenakios
Setting the single sine tracks to -6.0206dB results in silence for me.
FINLAND RULES, FANTASTIC!

Obviously I was too tired last night and didn't handle the fader settings correctly. Today I changed the settings in the Reaper file ("don't do this at home") to a volume of 0.5 (funnily the settings in the file are simple float volumes, not dB values).

Now it cancels out perfectly (as the enclosed spectrum indicates).

Thanks, Xenakios, for restoring my faith in digital audio processing! Your hint with the exact dB value was the decisive step...

Best regards
Dr_TT
Attached Images
File Type: png cancellation-test2.png (32.5 KB, 13 views)
DrTT is offline   Reply With Quote
Old 05-30-2019, 04:22 AM   #6
schwa
Administrator
 
schwa's Avatar
 
Join Date: Mar 2007
Location: NY
Posts: 10,254
Default

Quote:
Originally Posted by Xenakios View Post
Reaper does indeed appear to cut those values to -6.02dB
REAPER should accept all digits of whatever you type in, but only displays .XXdB. You can see the VOLPAN value in the RPP changing with more digits, though. If I enter -6.02059991328 in the dialog, the RPP stores exactly 0.5.
schwa is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:18 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.