Old 09-15-2018, 09:46 AM   #81
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,563
Default

Quote:
Originally Posted by swindus View Post
Don't know if this is intended but for me it looks like a bug. Try the following with any JSFX or Cockos plugin fader.

- Click with the left mouse button on the fader cap.
- Hold the mouse button and move the fader.
- Still hold the mouse button and then press the Cmd Key and watch the fader.

For me the fader is moving to the opposite side of the mouse movement without moving the mouse in this direction.

If you press the Cmd key before pressing the mouse button you can fine tune the fader like it should.
Thanks, fixing!
Justin is offline   Reply With Quote
Old 09-16-2018, 12:11 PM   #82
cfillion
Human being with feelings
 
cfillion's Avatar
 
Join Date: May 2015
Location: Québec, Canada
Posts: 2,880
Default

ListView_HitTest returns out-of-range indexes instead of -1 when the point is below the last item. (It's the root cause of a crash in SWS.)

Also, latest WDL's recurseOwnedWindowHitTest loops forever when right clicking again while a context menu is already opened (tested with i3wm). Shouldn't h->m_owned_next be owned->m_owned_next?

Last edited by cfillion; 09-16-2018 at 04:48 PM.
cfillion is offline   Reply With Quote
Old 09-16-2018, 03:22 PM   #83
doppelganger
Human being with feelings
 
Join Date: Feb 2017
Posts: 415
Default

can't find a way to dock script's gfx window, is it a bug?

also action "Dock/undock currently focused window" docks/undocks mixer and action list window for example, but not script's window.
doppelganger is offline   Reply With Quote
Old 09-16-2018, 04:32 PM   #84
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,563
Default

Quote:
Originally Posted by cfillion View Post
ListView_HitTest returns out-of-range indexes instead of -1 when the mouse is below the last item. (It's the root cause of a crash in SWS.)

Also, latest WDL's recurseOwnedWindowHitTest loops forever when right clicking again while a context menu is already opened (tested with i3wm). Shouldn't h->m_owned_next be owned->m_owned_next?
Thanks for both of these, fixing now!
Justin is offline   Reply With Quote
Old 09-16-2018, 04:37 PM   #85
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,563
Default

Quote:
Originally Posted by doppelganger View Post
can't find a way to dock script's gfx window, is it a bug?

also action "Dock/undock currently focused window" docks/undocks mixer and action list window for example, but not script's window.
That action doesn't work for scripts, scripts have to implement it themselves (usually via a context menu or keyboard command)
Justin is offline   Reply With Quote
Old 09-17-2018, 12:42 PM   #86
burtbick
Human being with feelings
 
Join Date: Feb 2011
Posts: 19
Default MIDI playback stutters on soft synth OR external HW synth

I've been working on setting up Linux Mint 18.3 to do some track editing.

I have Reaper for Linux (64 bit) installed and it works great on audio tracks, and I had one MIDI that plays just fine using FluidSynth (QSynth) with JACK. That MIDI has 8 active channels/tracks.

Then I tried another MIDI file and that one is erratic, with a bunch of stuttering and just not playing smoothly at all. This MIDI has 16 tracks

This happens either with the soft synth OR with an external HW synth through an Alesis IO2 as well as a no-name USB to MIDI interface that I have laying around.

This same MIDI plays smoothly in Ardour 4 with the soft synth. So the issue seems to be isolated to Reaper.

Using the virtual MIDI device in Reaper from a2j Virtual RawMIDI out to a2j FLUID Synth input ports. But I was NOT using a2j in earlier tests and the results were the same. In that earlier test routed from Virtual RawMIDI to FLUID Synth in the JACK ALSA tab.

I tested with Reaper (Windows 64bit) under Wine, and using the Qsynth as set up for my Linux test. In the Windows version running under Wine I have the Synth input port (number:0) and that is what I enabled and mapped to the MIDI tracks. It plays very smoothly just as the same MIDI does on my Windows machine.

Any suggestions on what I should look for to get this working smoothly with Reaper for Linux, or is this possibly a bug in Reaper for Linux?

Update: 9/17/18 Found the problem, or at least a solution.
In some earlier testing I had changed the Audio System from JACK to PulseAudio in Reaper's Preferences and had forgotten about it.
So on a hunch I changed it back to JACK and then changed the JACK MIDI routing to REAPER/MIDID Output 1 connected to a2j/FLUID SYnth input and that got rid of the stuttering. That may still not be the optimal configuration, but for now it is working.

Thanks,
Burt

Last edited by burtbick; 09-17-2018 at 01:49 PM. Reason: Found solution to problem.
burtbick is offline   Reply With Quote
Old 09-19-2018, 12:05 AM   #87
swindus
Human being with feelings
 
Join Date: Jun 2009
Posts: 87
Default

Quote:
Originally Posted by swindus View Post
Don't know if this is intended but for me it looks like a bug. Try the following with any JSFX or Cockos plugin fader.

- Click with the left mouse button on the fader cap.
- Hold the mouse button and move the fader.
- Still hold the mouse button and then press the Cmd Key and watch the fader.

For me the fader is moving to the opposite side of the mouse movement without moving the mouse in this direction.

If you press the Cmd key before pressing the mouse button you can fine tune the fader like it should.
This problem still exists in v5.96pre6. I can still reproduce the moving fader in this build when moving the mouse/fader while holding the Cmd key.
swindus is offline   Reply With Quote
Old 09-19-2018, 02:24 AM   #88
vocalfons
Human being with feelings
 
vocalfons's Avatar
 
Join Date: Feb 2007
Posts: 59
Default no more midi in linux, nor native, nor under wine

I do not know if this is a bug. But in both linux-native Reaper AND under wine, my midi interface/controller bcf2000 is shown to be there in the system, it is shown in Catia, it is shown in the settings of Reaper....but it is not selectable as an in or output on a channel. It seems the system made an alias and doesnt know that it's not two devices. So now I have no more midi input or output and my mixing controller does not work either. So also in Catia I vannot connect anything to it. Anyone with a clever idea? Or maybe a dunb idea? By now I'd settle for any solution
vocalfons is offline   Reply With Quote
Old 09-20-2018, 06:10 AM   #89
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,563
Default

Quote:
Originally Posted by swindus View Post
This problem still exists in v5.96pre6. I can still reproduce the moving fader in this build when moving the mouse/fader while holding the Cmd key.
Hmm I can't... what window manager? Also I assume you mean "Control" rather than command? Are you hitting the key after clicking?
Justin is offline   Reply With Quote
Old 09-20-2018, 08:30 PM   #90
swindus
Human being with feelings
 
Join Date: Jun 2009
Posts: 87
Default

I use Openbox and XFCE. Yes of course, I mean the Control key and the fader still moves when I press the Control key WHILE I move the fader with the mouse. So yes, I'm hitting the key after clicking the fader.

I can reproduce it any time with ReaEQ. I grab the frequency fader with the mouse and move it fast to the right and to the left. Then I hit the Control key and the fader moves from alone.

Last edited by swindus; 09-20-2018 at 08:38 PM.
swindus is offline   Reply With Quote
Old 09-21-2018, 06:57 PM   #91
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,563
Default

Quote:
Originally Posted by swindus View Post
I can reproduce it any time with ReaEQ. I grab the frequency fader with the mouse and move it fast to the right and to the left. Then I hit the Control key and the fader moves from alone.
Hmm here, if I drag the fader, then hit the control key without moving the mouse, nothing happens (until I move the mouse, when it hides the mouse cursor and does a small move of the fader)
Justin is offline   Reply With Quote
Old 09-22-2018, 09:59 AM   #92
swindus
Human being with feelings
 
Join Date: Jun 2009
Posts: 87
Default

Quote:
Originally Posted by Justin View Post
Hmm here, if I drag the fader, then hit the control key without moving the mouse, nothing happens (until I move the mouse, when it hides the mouse cursor and does a small move of the fader)
Yes, same for me when I don't move the fader on the key press but when I press Control while moving the fader with the mouse the fader moves away. This time in the same direction as the mouse moves before your fix it was the opposite direction. Maybe this is intended.

Another problem I have from time to time is with undo. When I undo some changes like moving and cutting itmes on the timeline they get moved to other positions or the content of the item is moved. And then there is no way to get back to the state before because the undo fails. Unfortunately I don't know how to reproduce this till now.
swindus is offline   Reply With Quote
Old 09-23-2018, 02:17 PM   #93
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,563
Default

Quote:
Originally Posted by swindus View Post
Yes, same for me when I don't move the fader on the key press but when I press Control while moving the fader with the mouse the fader moves away. This time in the same direction as the mouse moves before your fix it was the opposite direction. Maybe this is intended.
Yes, after holding control, the fader will move with the mouse (albeit at a reduced rate)

Quote:
Another problem I have from time to time is with undo. When I undo some changes like moving and cutting itmes on the timeline they get moved to other positions or the content of the item is moved. And then there is no way to get back to the state before because the undo fails. Unfortunately I don't know how to reproduce this till now.
Are you using any scripts? Perhaps they are not handling undo properly? Without more information not much I can help with here...
Justin is offline   Reply With Quote
Old 09-24-2018, 06:24 AM   #94
swindus
Human being with feelings
 
Join Date: Jun 2009
Posts: 87
Default

Quote:
Originally Posted by Justin View Post
Yes, after holding control, the fader will move with the mouse (albeit at a reduced rate)
Yes, I know that's the default behavior for fine tuning a control. What I mean is that the fader moves on without moving the mouse after hitting the control key. Or in other words I stop moving the mouse after hitting the control key and the fader still moves. When I release the control key the fader jumps back to the begin of the self movement. I made a screen capture maybe this helps.

https://imagebin.ca/v/4GoBMcAEfz9q

- move the fader
- while moving the fader press control key
- hold the control key, stop mouse movement, the fader moves or don't stop
- release control key and the fader jumps back (to the mouse position?)

Sometimes it's so complicated to describe such a small and simple thing in a non native language.
swindus is offline   Reply With Quote
Old 09-24-2018, 02:12 PM   #95
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,563
Default

Quote:
Originally Posted by swindus View Post
- move the fader
- while moving the fader press control key
- hold the control key, stop mouse movement, the fader moves or don't stop
Hmm it behaves as expected here (the continued movement moves the fader a little more, but once you stop it stops about where you'd expect).
Quote:
- release control key and the fader jumps back (to the mouse position?)
Yes, that's also expected more or less -- release the mouse cursor before or at the same time as the control key...
Justin is offline   Reply With Quote
Old 09-28-2018, 04:14 PM   #96
Tyrannocaster
Human being with feelings
 
Join Date: Jan 2011
Posts: 524
Default

I don't think this is a bug, but I thought I'd mention it, even if it may have more to do with the window manager than Reaper. The file requester when I go to load a project does not show my non-system disks. I am new to Linux and it took me a while to figure out how to overcome this, because EVERYTHING is stored on my second internal (spinning disk) drive; the internal SSD is just for the system and its stuff. Once I had managed to navigate to /media/me/DRIVE/Reaper Projects and load one, of course the next time it was already there, but I had some trouble at first with this, being used to Windows and Mac requesters. Likewise, setting the path to the new default project directory was a similar process, as my requester wouldn't let me actually type the path in so I had to navigate to it. I am using Linux Lite, which uses XFCE as the desktop environment. Do the other DEs act this way too?

Last edited by Tyrannocaster; 09-28-2018 at 04:21 PM.
Tyrannocaster is offline   Reply With Quote
Old 09-28-2018, 04:46 PM   #97
clepsydrae
Human being with feelings
 
clepsydrae's Avatar
 
Join Date: Nov 2011
Posts: 2,457
Default

AFAIK the file dialogs is going to be the same on all distributions; I don't think linux Reaper uses any of the DE file dialogs.

You should be able to click in the path at the top of the dialog and type in paths, though. You can also use the drop-down arrow to select some subset of the current path.

But yeah, the linux file dialog is still pretty rudimentary (no user shortcuts, no shortcuts to mounted drives, no tab-autocomplete or autofill in the path bar, when you enter something in the search bar and there is one result you can't hit enter to enter that dir, etc). I'm sure it's on Justin's radar for future improvements, but I'm guessing it's not the highest priority, given what I'm sure is a healthy to-do list.

In Linux the root / represents the real and true root, so any disks you have mounted will be accessible from there, as you've already found.

Personally I create mount points for all my extra disks that are off of /. E.g. /projects. That way they are always easy to access in cases like this.
clepsydrae is offline   Reply With Quote
Old 09-29-2018, 02:08 AM   #98
jazznfunk
Human being with feelings
 
Join Date: Aug 2012
Location: Riga Latvia
Posts: 106
Default

I'm sorry if this is not Reaper Linux bug.

I recorded and edited session on W10 machine with Supermaalima JS format plugins (aviable via ReaPack). Then i decided to open this session on Linux machine with Reaper 5.95 on board.

Reaper tells me that Supermaalima plugins isn't aviable, but it's not truth.



I even opened another S.LA.X instance on next channel to proove that i have it installed.



Is there solution for this problem?
jazznfunk is offline   Reply With Quote
Old 09-29-2018, 06:59 AM   #99
Tyrannocaster
Human being with feelings
 
Join Date: Jan 2011
Posts: 524
Default

Quote:
Originally Posted by clepsydrae View Post
AFAIK the file dialogs is going to be the same on all distributions; I don't think linux Reaper uses any of the DE file dialogs.

In Linux the root / represents the real and true root, so any disks you have mounted will be accessible from there, as you've already found.
Yes, but (at least on my system) you can't type in a path in the Reaper requester. So the process of getting to the right directory is quite clumsy if it's on a different drive.
Tyrannocaster is offline   Reply With Quote
Old 09-29-2018, 09:06 AM   #100
Westrabua
Human being with feelings
 
Join Date: Aug 2008
Location: Germany
Posts: 56
Default Minor bug

What:
Unexpected behaviour in "Project Settings -> Notes" text box.

How to reproduce:
1) Write some text into textbox (one line is enough)
2) Place cursor at beginning of line
3) Hit "Return" and "Backspace" consecutively a couple of times
4) Effect: The cursor moves to the right one character after each "Backspace"

Version:
5.95 (linux x64) from official download page
Westrabua is offline   Reply With Quote
Old 09-29-2018, 09:28 AM   #101
clepsydrae
Human being with feelings
 
clepsydrae's Avatar
 
Join Date: Nov 2011
Posts: 2,457
Default

Quote:
Originally Posted by Westrabua View Post
Backspace
I see it too (5.60p2 -- haven't upgraded this laptop yet) -- when the cursor is at the beginning of a line and you hit backspace, the backspace happens but the cursor is also advanced by one character. If there is nothing to advance in to (because there were no characters following the cursor to begin with), the next backspace does nothing.
clepsydrae is offline   Reply With Quote
Old 09-29-2018, 09:32 AM   #102
clepsydrae
Human being with feelings
 
clepsydrae's Avatar
 
Join Date: Nov 2011
Posts: 2,457
Default

Quote:
Originally Posted by Tyrannocaster View Post
Yes, but (at least on my system) you can't type in a path in the Reaper requester. So the process of getting to the right directory is quite clumsy if it's on a different drive.
We're talking about File -> Open? I'm using XFCE as well, and the dialog that appears I can just click on the path at the top of the dialog and a cursor appears, allowing me to edit, replace, etc. Maybe post a screenshot of such an attempt?

I don't think there should be any variation in this between DE's, so if you're seeing something else it's likely a bug.
clepsydrae is offline   Reply With Quote
Old 09-29-2018, 02:10 PM   #103
Tyrannocaster
Human being with feelings
 
Join Date: Jan 2011
Posts: 524
Default

Quote:
Originally Posted by clepsydrae View Post
We're talking about File -> Open? I'm using XFCE as well, and the dialog that appears I can just click on the path at the top of the dialog and a cursor appears, allowing me to edit, replace, etc. Maybe post a screenshot of such an attempt?

I don't think there should be any variation in this between DE's, so if you're seeing something else it's likely a bug.
I'm new to screenshots on Linux; I don't have much configured on this machine yet. Let me see if this works at all and if it does I'll edit the post.

Ah, looks like it works. In that requester, the path cannot be edited with the keyboard; all you can do is use the mouse to go up or down levels to eventually find your desired directory. Since I had already found it, Reaper is shown remembering the last file saved, but when I first opened Reaper I didn't have that luxury. It was quite confusing for a while. :-)
Attached Images
File Type: png Screenshot_2018-09-29_14-08-10.png (9.6 KB, 99 views)

Last edited by Tyrannocaster; 09-29-2018 at 02:16 PM.
Tyrannocaster is offline   Reply With Quote
Old 09-29-2018, 02:25 PM   #104
Glennbo
Human being with feelings
 
Glennbo's Avatar
 
Join Date: Mar 2008
Location: Planet Earth
Posts: 4,099
Default

Quote:
Originally Posted by Tyrannocaster View Post
I'm new to screenshots on Linux; I don't have much configured on this machine yet. Let me see if this works at all and if it does I'll edit the post.

Ah, looks like it works. In that requester, the path cannot be edited with the keyboard; all you can do is use the mouse to go up or down levels to eventually find your desired directory. Since I had already found it, Reaper is shown remembering the last file saved, but when I first opened Reaper I didn't have that luxury. It was quite confusing for a while. :-)
What I do is at the bottom where it says "file", type or paste a path to a folder, press enter and the file browser is now looking at that folder.
__________________
Glennbo
Hear My Music - Click Me!!!
--
Glennbo is offline   Reply With Quote
Old 09-29-2018, 02:33 PM   #105
Tyrannocaster
Human being with feelings
 
Join Date: Jan 2011
Posts: 524
Default

Quote:
Originally Posted by Glennbo View Post
What I do is at the bottom where it says "file", type or paste a path to a folder, press enter and the file browser is now looking at that folder.
Okay, I see what you are talking about. I was looking at the upper portion; didn't realize you could put the path there. Thanks.
Tyrannocaster is offline   Reply With Quote
Old 09-29-2018, 03:22 PM   #106
clepsydrae
Human being with feelings
 
clepsydrae's Avatar
 
Join Date: Nov 2011
Posts: 2,457
Default

So if you click in the path and type, what happens?

E.g. in the screenshot you submitted, you click at the top where it says "Reaper Projects/RiffRaff" and start typing -- no cursor? No typing appears?

Sorry to beat this horse, I'm just curious if there is some bug preventing focus there or something.
clepsydrae is offline   Reply With Quote
Old 09-29-2018, 03:31 PM   #107
Glennbo
Human being with feelings
 
Glennbo's Avatar
 
Join Date: Mar 2008
Location: Planet Earth
Posts: 4,099
Default

Quote:
Originally Posted by clepsydrae View Post
So if you click in the path and type, what happens?

E.g. in the screenshot you submitted, you click at the top where it says "Reaper Projects/RiffRaff" and start typing -- no cursor? No typing appears?

Sorry to beat this horse, I'm just curious if there is some bug preventing focus there or something.
I can click the top area and get a cursor in there, but it does *appear* as if it is greyed out. I use a dark theme and have seen weird stuff elsewhere so I don't know if it is supposed to look like that or not.
__________________
Glennbo
Hear My Music - Click Me!!!
--
Glennbo is offline   Reply With Quote
Old 09-29-2018, 03:39 PM   #108
Tyrannocaster
Human being with feelings
 
Join Date: Jan 2011
Posts: 524
Default

Quote:
Originally Posted by clepsydrae View Post
So if you click in the path and type, what happens?

E.g. in the screenshot you submitted, you click at the top where it says "Reaper Projects/RiffRaff" and start typing -- no cursor? No typing appears?

Sorry to beat this horse, I'm just curious if there is some bug preventing focus there or something.
You can't enter text there at all. No text entry area appears. All you can do is open up a dropdown menu that lets you navigate up or down the filesystem, assuming there is something in that direction. So with the one in my picture, you would only be able to go up.
Tyrannocaster is offline   Reply With Quote
Old 09-29-2018, 04:51 PM   #109
clepsydrae
Human being with feelings
 
clepsydrae's Avatar
 
Join Date: Nov 2011
Posts: 2,457
Default

Huh, weird. So neither of you can do this:

http://caseyconnor.org/pub/video/filedialogdemo.mp4
clepsydrae is offline   Reply With Quote
Old 09-29-2018, 05:43 PM   #110
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,563
Default

Quote:
Originally Posted by jazznfunk View Post
I'm sorry if this is not Reaper Linux bug.

I recorded and edited session on W10 machine with Supermaalima JS format plugins (aviable via ReaPack). Then i decided to open this session on Linux machine with Reaper 5.95 on board.

Reaper tells me that Supermaalima plugins isn't aviable, but it's not truth.



I even opened another S.LA.X instance on next channel to proove that i have it installed.



Is there solution for this problem?
Might be a case issue or the name might be slightly different? Post the .rpp and we can take a look and/or make small edits to fix that.
Justin is offline   Reply With Quote
Old 09-29-2018, 05:44 PM   #111
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,563
Default

Quote:
Originally Posted by Westrabua View Post
What:
Unexpected behaviour in "Project Settings -> Notes" text box.

How to reproduce:
1) Write some text into textbox (one line is enough)
2) Place cursor at beginning of line
3) Hit "Return" and "Backspace" consecutively a couple of times
4) Effect: The cursor moves to the right one character after each "Backspace"

Version:
5.95 (linux x64) from official download page
Thanks, fixing should be in the public WDL in a few minutes.
Justin is offline   Reply With Quote
Old 09-29-2018, 05:54 PM   #112
Glennbo
Human being with feelings
 
Glennbo's Avatar
 
Join Date: Mar 2008
Location: Planet Earth
Posts: 4,099
Default

Quote:
Originally Posted by Tyrannocaster View Post
You can't enter text there at all. No text entry area appears. All you can do is open up a dropdown menu that lets you navigate up or down the filesystem, assuming there is something in that direction. So with the one in my picture, you would only be able to go up.
Are you running v5.95? Seems like I remember some earlier versions did not let me get a cursor in that area, which is why I knew I could type a path in the lower file name window.
__________________
Glennbo
Hear My Music - Click Me!!!
--
Glennbo is offline   Reply With Quote
Old 09-29-2018, 06:20 PM   #113
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,563
Default

Quote:
Originally Posted by Tyrannocaster View Post
You can't enter text there at all. No text entry area appears. All you can do is open up a dropdown menu that lets you navigate up or down the filesystem, assuming there is something in that direction. So with the one in my picture, you would only be able to go up.
Hmm, if you click the right side of the field (by the down arrow), it should show you the menu -- if you click towards the left, where the text is, it should let you edit.
Justin is offline   Reply With Quote
Old 09-29-2018, 06:22 PM   #114
clepsydrae
Human being with feelings
 
clepsydrae's Avatar
 
Join Date: Nov 2011
Posts: 2,457
Default

Quote:
Originally Posted by Justin View Post
Hmm, if you click the right side of the field (by the down arrow), it should show you the menu -- if you click towards the left, where the text is, it should let you edit.
(see my video linked above for a visual of what Justin's referring to)
clepsydrae is offline   Reply With Quote
Old 09-30-2018, 07:12 AM   #115
Tyrannocaster
Human being with feelings
 
Join Date: Jan 2011
Posts: 524
Default

I am using Reaper 5.95. I can't click anywhere in that dropdown menu and get a text entry field. I don't know why, but my system always behaves differently from other people's - apparently, even on a fresh install of Linux. This is Linux Lite 4.0, the latest version available; it's based on Ubuntu and uses the XFCE desktop.

Now that I know about the lower field, I can get along fine.
Tyrannocaster is offline   Reply With Quote
Old 09-30-2018, 01:29 PM   #116
jazznfunk
Human being with feelings
 
Join Date: Aug 2012
Location: Riga Latvia
Posts: 106
Default

Thank You, Justin!

https://failiem.lv/down.php?cf&i=6z4...LICK+LINUX.rpp

Here's a link to file with "working" S.LA.X inserted on delay channel.

Might be here is some plugin path adressing problem.
jazznfunk is offline   Reply With Quote
Old 09-30-2018, 01:44 PM   #117
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,563
Default

Quote:
Originally Posted by jazznfunk View Post
Thank You, Justin!

https://failiem.lv/down.php?cf&i=6z4...LICK+LINUX.rpp

Here's a link to file with "working" S.LA.X inserted on delay channel.

Might be here is some plugin path adressing problem.
It looks like the linux-inserted one is named "SLAX.jsfx", vs the other ones which do not have the .jsfx extension. It might be worth going to your JSFX Effects directory in ~/.config/REAPER/Effects, finding "SLAX.jsfx", and copying it (or symlinking it) to just "SLAX".
Justin is offline   Reply With Quote
Old 09-30-2018, 01:58 PM   #118
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,563
Default

Quote:
Originally Posted by Tyrannocaster View Post
I am using Reaper 5.95. I can't click anywhere in that dropdown menu and get a text entry field. I don't know why, but my system always behaves differently from other people's - apparently, even on a fresh install of Linux. This is Linux Lite 4.0, the latest version available; it's based on Ubuntu and uses the XFCE desktop.

Now that I know about the lower field, I can get along fine.
Hmm not sure what you're doing differently here, but this is also on XFCE:


Note that the first click is on the right side of the box, that triggers the menu of recents, and the second click is closer to the text where you can edit it. This is entirely implemented in libSwell so really it should be distro and DE independent...
Justin is offline   Reply With Quote
Old 09-30-2018, 03:42 PM   #119
jazznfunk
Human being with feelings
 
Join Date: Aug 2012
Location: Riga Latvia
Posts: 106
Default

In my case there was slax without extention in Supermaalima folder. I copied content to SonicAnomaly JSFX folder and added to slax file the jsfx extension. It works!

Nevermind the folders, it works! Thank You, Justin!
jazznfunk is offline   Reply With Quote
Old 09-30-2018, 04:01 PM   #120
Glennbo
Human being with feelings
 
Glennbo's Avatar
 
Join Date: Mar 2008
Location: Planet Earth
Posts: 4,099
Default

Quote:
Originally Posted by Justin View Post
Hmm not sure what you're doing differently here, but this is also on XFCE:

Note that the first click is on the right side of the box, that triggers the menu of recents, and the second click is closer to the text where you can edit it. This is entirely implemented in libSwell so really it should be distro and DE independent...
Does the distro govern how right click menus behave? I'm using xfce on Xubuntu. When I right click the record button on tracks that are near the right edge of the screen, menus begin to display outside of the maximized REAPER container on my left monitor, and popup totally orphaned on my right monitor.

You can see what I'm talking about in this pic of my two monitors, which are not close to each other. I'm right clicking the record button of track 22, but the context sensitive menu and all it's children popup on the other monitor, which frequently is on a security cam, so I don't see the menu at all.

__________________
Glennbo
Hear My Music - Click Me!!!
--
Glennbo is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:20 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.