Old 01-16-2017, 06:27 AM   #1
sonicowl
Human being with feelings
 
sonicowl's Avatar
 
Join Date: Oct 2015
Posts: 359
Default OSCII-bot to BCF2000

OK, been trying for few hours to get faders moving on Behringer BCF2000. No luck yet.
Is there a simple way to setup this?
Where do I even start? Anybody maybe has step by step description of how to make it work?
Thnx.
sonicowl is offline   Reply With Quote
Old 01-16-2017, 06:45 AM   #2
sonicowl
Human being with feelings
 
sonicowl's Avatar
 
Join Date: Oct 2015
Posts: 359
Default

So, here is what I did, on Win10:
1. Downloaded MIDI2OSC-II.txt.zip from http://www.cockos.com/oscii-bot/, and unpacked it to folder.
2. Created folder OSCII-bot in ../AppData/Roaming.
3. Copied example script alphatrack.txt to above folder, renamed it to "BCF2000".
4. After running OSCII-bot i got errors:
Listening on '*:9000'
Warning: tried to open device matching 'AlphaTrack'(0) but failed, will retry
Warning: tried to open device matching 'AlphaTrack'(0) but failed, will retry
2 inputs, 2 outputs
5. Went into "Control Panel\Hardware and Sound\Devices and Printers", anc check for device name in BCF2000 hardware properties, and name of controller is B-CONTROL.
6. Input that device name into script - no more device error. Says:
Listening on '*:9000'
2 inputs, 2 outputs

Total: 1 scripts, 2 inputs, 2 outputs
sonicowl is offline   Reply With Quote
Old 01-16-2017, 06:53 AM   #3
sonicowl
Human being with feelings
 
sonicowl's Avatar
 
Join Date: Oct 2015
Posts: 359
Default

Next,
7. In Reaper, Settings/Control Surface Settings, I created OSC control surface, with name "OSCII-bot", as in attached image.
Attached Images
File Type: png osc setup.PNG (10.8 KB, 958 views)

Last edited by sonicowl; 02-11-2017 at 05:08 AM.
sonicowl is offline   Reply With Quote
Old 01-16-2017, 07:00 AM   #4
sonicowl
Human being with feelings
 
sonicowl's Avatar
 
Join Date: Oct 2015
Posts: 359
Default

Script is like this. I cannot get fader to move. What am I doing wrong?


Code:
// generic REAPER<-->alphatrack OSC, for REAPER's Default.ReaperOSC
// Only a basic volume fader works now, needs a lot more work

@input osc_in OSC "*:9000"
@output osc_out OSC "localhost:8000"

@output midi_out MIDI "B-CONTROL"
@input midi_in MIDI "B-CONTROL"

@init

track_index = 1;

track_voltab = 1024;

@timer

@oscmsg

function set_vol_fader(vol) (
  vol *= 16383;
  msg1=0xe0;
  msg2=vol&127;
  msg3=vol/128;
  midisend(midi_out);
);

oscmatch("/track/%d/*") ? (
  // fmt0 will have the affected track index


  oscmatch("/track/%d/select") ? (
    oscparm(0,0)>0 ? (
      track_index=fmt0;
      set_vol_fader(track_voltab[fmt0]);
    );
  ) : oscmatch("/track/%d/volume") ? (
    track_voltab[fmt0] = oscparm(0,0);
    fmt0 == track_index ? set_vol_fader(track_voltab[fmt0]);
  );
);


@midimsg

msg1 == 0xe0 ? (
  vol = (msg2 + msg3*128) / 16383;
  track_voltab[track_index] = vol;
  fmt0 = track_index;
  oscsend(osc_out,"/track/%d/volume", vol);
  set_vol_fader(vol);
);

Last edited by sonicowl; 02-11-2017 at 05:06 AM.
sonicowl is offline   Reply With Quote
Old 01-16-2017, 07:04 AM   #5
sonicowl
Human being with feelings
 
sonicowl's Avatar
 
Join Date: Oct 2015
Posts: 359
Default

To test if Reaper receives MIDI CC from BCF2000, I go to Reaper Preferences/MIDI Devices and enable "Control" for "B-CONTROL Port 1" Then I go to Reaper Actions and check MIDI input from fader in Add Shortcuts, I get the following data from fader:
MIDI Chan 1 CC 32
After this I again disable "Control" for BCF2000.


Again to Reaper Actions, and check if I can get fader to work on "Track: Set volume for selected tracks (MIDI CC/OSC only)". I get no response from OSC.


I guess I need to change something in script to connect fader CC32 with something in OSC? No idea what. Any help would be most welcome. Thnx.

Last edited by sonicowl; 01-16-2017 at 07:22 AM.
sonicowl is offline   Reply With Quote
Old 01-16-2017, 05:27 PM   #6
goldenarpharazon
Human being with feelings
 
Join Date: Feb 2016
Posts: 134
Default Suggestions to isolate the problem

Here are some simple steps to try and help get things working, or to enable others to help.


- Use MIDI-OX on windows or a similar midi monitor to check the midi being sent to or from the BCF-2000


- Check the OSC strings being sent by reaper in the OSCII-bot console


- Use printf statements to output values in the code to the OSCII-bot console for debug purposes.


- In particular check that oscmatch() has worked as expected and fmt0 has the expected value in it. It might be better to assign values to a more localised variable than fmt0 using the {} feature of match()


- Align the indentation of the ( and ); and ): so one can visualise that the code sections really do contain & execute the desired statements where expected


- Get the simplest possible code to work (eg just sending some predefined midi to the BCF-2000 in @init that moves the fader OK i.e. no OSC at all)


- Add in code, step by step, increasing the functionality sending midi to OSCII-bot or parsing OSC output from Reaper. Check each increment works OK.


- Based on all this try and isolate the problem and post a succinct summary of the behaviour or error experienced.


- Select the best forum to ask in. More folk in the Reaper community see and contribute to the Reaper compatibility forum than the OSCII-bot forum.

Last edited by goldenarpharazon; 01-17-2017 at 04:15 AM.
goldenarpharazon is offline   Reply With Quote
Old 11-05-2017, 03:56 PM   #7
mschnell
Human being with feelings
 
mschnell's Avatar
 
Join Date: Jun 2013
Location: Krefeld, Germany
Posts: 8,170
Default

Quote:
Originally Posted by sonicowl View Post
So, here is what I did, on Win10:
1. Downloaded MIDI2OSC-II.txt.zip from http://www.cockos.com/oscii-bot/,
Where to find this file ?

-Michael
mschnell is offline   Reply With Quote
Old 11-09-2017, 04:24 PM   #8
goldenarpharazon
Human being with feelings
 
Join Date: Feb 2016
Posts: 134
Default

Quote:
Originally Posted by mschnell View Post
Where to find this file ?

-Michael
It's probably just a typing error and meant to refer to the OSCII-bot03.zip file download which is the OSCII-bot install. OSCII-bot was originally called midi2osc - see http://1014.org/?article=511
goldenarpharazon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 06:32 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.