Old 11-08-2019, 06:41 AM   #1
BirdBird
Human being with feelings
 
BirdBird's Avatar
 
Join Date: Mar 2019
Posts: 60
Default How to get a more responsive GUI?

I am currently working on a project that has 140 tracks, my GUI is very slow especially in the busy parts of the project. Is it possible to bump up the GUI thread priority? Old forum posts say there has been a setting called "UI Updates" in "Preferences -> Appearance" but i can't seem to find it. Any ideas?
__________________
my high flying bird
BirdBird is online now   Reply With Quote
Old 11-09-2019, 10:06 AM   #2
ivansc
Human being with feelings
 
Join Date: Aug 2007
Location: Near Cambridge UK and Near Questembert, France
Posts: 19,126
Default

Quote:
Originally Posted by BirdBird View Post
I am currently working on a project that has 140 tracks, my GUI is very slow especially in the busy parts of the project. Is it possible to bump up the GUI thread priority? Old forum posts say there has been a setting called "UI Updates" in "Preferences -> Appearance" but i can't seem to find it. Any ideas?

Hard to help since you havent told us what platform & version (bitrate) your OS is is, what you are using for an audio MIDI interface, What bitrate & version of Reaper you are using or indeed what sort of horsepower your computer has in the first place.
Would also be helpful to know what you are using in the way of plugins, etc.

Help us help you.
__________________
"What a dick comment. I'm gonna make sure to avoid your name." Dicks other than Trump can speak????
ivansc is offline   Reply With Quote
Old 11-09-2019, 01:53 PM   #3
BirdBird
Human being with feelings
 
BirdBird's Avatar
 
Join Date: Mar 2019
Posts: 60
Default

Quote:
Originally Posted by ivansc View Post
Hard to help since you havent told us what platform & version (bitrate) your OS is is, what you are using for an audio MIDI interface, What bitrate & version of Reaper you are using or indeed what sort of horsepower your computer has in the first place.
Would also be helpful to know what you are using in the way of plugins, etc.

Help us help you.
Thanks! I will list some more info and settings:
OS: Windows 10 64bit
Reaper version: 5.984 (running 64bit)
Audio Interface: Scarlett 2i2 (Gen 3)
CPU: Intel i3 8350k (4 cores 4ghz)
No DPC latency issues on the system that i am aware of.

I do have the correct ASIO driver selected for my audio interface in REAPER preferences.
I have my buffer size at maximum and anticipative FX processing running at 700ms.

However i do get the same slowdown in smaller projects as my track count increases. I do have quite bit of CPU hungry instruments frozen as well.

I very strongly suspect this is related to how REAPER handles its threads. It seems like audio thread grabs priority over GUI thread and user inputs so the UI gets choppier and laggier as the project gets heavier on the CPU.
----------------------------------------------------------
BirdBird is online now   Reply With Quote
Old 11-10-2019, 02:36 AM   #4
ivansc
Human being with feelings
 
Join Date: Aug 2007
Location: Near Cambridge UK and Near Questembert, France
Posts: 19,126
Default

sadly I cant help but there are a bunch of users on here doing large projects (even bigger than yours by the sound of it) so pending some of them turning up in your thread, it might be worth googling something like "reaper large track counts or large projects" & see if it guides you to any relevant threads already on here.
__________________
"What a dick comment. I'm gonna make sure to avoid your name." Dicks other than Trump can speak????
ivansc is offline   Reply With Quote
Old 11-10-2019, 04:46 AM   #5
dazastah
Human being with feelings
 
dazastah's Avatar
 
Join Date: Sep 2009
Posts: 110
Default

Try tweaking asio thread priority to normal. in audio settings.

And then under audio / buffering in prefs tweak it to normal and set behaviour to relaxed.
I'm not sure if reaper will relax the audio thread for graphics but you could try that..
dazastah is offline   Reply With Quote
Old 11-10-2019, 10:09 AM   #6
BirdBird
Human being with feelings
 
BirdBird's Avatar
 
Join Date: Mar 2019
Posts: 60
Default

Quote:
Originally Posted by dazastah View Post
Try tweaking asio thread priority to normal. in audio settings.

And then under audio / buffering in prefs tweak it to normal and set behaviour to relaxed.
I'm not sure if reaper will relax the audio thread for graphics but you could try that..
Thank you! I already had asio thread priority set to normal but tweaking the thread priority and behaviour in Audio > Buffering helped a bit.

I got curious and decided to test it with thread priority set to idle and behaviour set to relaxed in an empty project. I tested it by scaling a TCP track:
Around 10 tracks all GUI interaction is near instant.
Around 50 tracks it is a bit slower.
Around 100 tracks it is very slow and makes the performance meter jump up to more than 20%.

This was a very crudely done test but to me it seems like around a certain number of tracks there is already a pretty significant slowdown due to how REAPER draws its GUI.

Edit: Found a related thread, going through it https://forum.cockos.com/showthread.php?t=222089

Last edited by BirdBird; 11-10-2019 at 10:23 AM.
BirdBird is online now   Reply With Quote
Old 11-10-2019, 10:46 AM   #7
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 8,474
Default

Check your 3rd party plugins. That can be a root cause. If it is... you kind of have to decide to live with it or find a new plugin. So kind of academic.

I can have a 300 track project with 96k audio and mixing to 5.1 and the GUI is instantaneous with seeking and such if the project is on a SSD. Pull up a couple iZotope NR plugins and set the quality to highest or insert a Soundtoys Decapitator plugin and suddenly there are cracks under the surface. Little lags. Buffers emptying out after hitting stop and spitting out a few chirps.

It's not really a big deal IMHO. Still feels more solid than what trying to work on Protools was like when they were crashing and burning with their v9 back when that happened. Or the like of Logic Audio Hell.

I should probably have a plugin cull. I still have some ancient UA plugins that use pci hardware acceleration. I've seen some flaky behavior when pulling up UA plugins too. Again, kind of expected though.

I haven't played with any of the GUI preferences around this. Maybe I give up too easily?
serr is offline   Reply With Quote
Old 11-10-2019, 11:06 AM   #8
BirdBird
Human being with feelings
 
BirdBird's Avatar
 
Join Date: Mar 2019
Posts: 60
Default

Quote:
Originally Posted by serr View Post
Check your 3rd party plugins. That can be a root cause. If it is... you kind of have to decide to live with it or find a new plugin. So kind of academic.
Unfortunately the GUI slowdown also happens with empty projects with no plugins as the track count increases. I looked around at some other threads a bit and it seems like lack of hardware acceleration in REAPER for rendering graphics is the root of my issues.
I am really bummed out because i felt really free and enjoyed using REAPER, but it seems like i have to jump ship to another DAW that draws its graphics using the GPU.

Here are some more threads talking about this for the curious:
https://forum.cockos.com/showthread.php?t=224417
https://forum.cockos.com/showthread.php?t=20149
https://forum.cockos.com/showthread.php?t=217756
BirdBird is online now   Reply With Quote
Old 11-10-2019, 12:04 PM   #9
Edgemeal
Human being with feelings
 
Edgemeal's Avatar
 
Join Date: Apr 2016
Location: ASU`ogacihC
Posts: 1,489
Default

Have you tried any of the pre-releases lately? They've been tweaking the UI performance a little bit here and there ( in pre-releases only), for example back in July they added,..
Code:
v5.980+dev0711 - July 11 2019
  + Performance: improve track panel UI behavior with large track counts
Edgemeal is offline   Reply With Quote
Old 11-10-2019, 12:10 PM   #10
serr
Human being with feelings
 
Join Date: Sep 2010
Posts: 8,474
Default

Quote:
Originally Posted by BirdBird View Post
Unfortunately the GUI slowdown also happens with empty projects with no plugins as the track count increases. I looked around at some other threads a bit and it seems like lack of hardware acceleration in REAPER for rendering graphics is the root of my issues.
I am really bummed out because i felt really free and enjoyed using REAPER, but it seems like i have to jump ship to another DAW that draws its graphics using the GPU.

Here are some more threads talking about this for the curious:
https://forum.cockos.com/showthread.php?t=224417
https://forum.cockos.com/showthread.php?t=20149
https://forum.cockos.com/showthread.php?t=217756
That's not happening for me. OSX here.
I know a couple of those threads are saying the opposite too. GUI trouble on OSX but not Windows. Not sure what to suggest! :P
serr is offline   Reply With Quote
Old 11-10-2019, 12:25 PM   #11
BirdBird
Human being with feelings
 
BirdBird's Avatar
 
Join Date: Mar 2019
Posts: 60
Default

Quote:
Originally Posted by Edgemeal View Post
Have you tried any of the pre-releases lately? They've been tweaking the UI performance a little bit here and there ( in pre-releases only), for example back in July they added,..
Code:
v5.980+dev0711 - July 11 2019
  + Performance: improve track panel UI behavior with large track counts
Thanks for letting me know, right now i am trying the latest pre-release with the same project and the GUI seems to behave so much smoother when CPU is under heavy load!
BirdBird is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 04:52 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.