Old 01-24-2020, 12:35 PM   #1
Janne83
Human being with feelings
 
Join Date: May 2010
Location: Earth
Posts: 1,833
Default Stuck/hang MIDI notes

Recent versions of Reaper (v6) have increasingly brought stuck midi notes with different things I perform in Reaper during playback.

It happens when i move the playhead, try to preview midi in media explorer, change the tempo- when i pres stop an infinite hang occurs. the vsti stops playing only if I offline it or if I perform the all notes of action (F3). It doesnt appear on every occasion but its frequent enogh to be annoying.

It happens with different Vsti or vst3i: U-he hive 2, Arturia Pigments 2, xfer Serum and also NI Massive X. All the plugins are up to date to their latest versions.

Thanks
__________________
Win10, R 64bit
Janne83 is offline   Reply With Quote
Old 01-24-2020, 01:20 PM   #2
uncleswede
Human being with feelings
 
Join Date: Feb 2015
Posts: 855
Default

I often get the same thing with Kontakt 5 when I stop playback (presumably) while a note is sounding but no note off msg has been received...

EDIT:

I just spotted this option in Prefs/MIDI devices:



... maybe setting this will cure my particular problem)
uncleswede is offline   Reply With Quote
Old 01-24-2020, 01:45 PM   #3
Janne83
Human being with feelings
 
Join Date: May 2010
Location: Earth
Posts: 1,833
Default

Quote:
Originally Posted by uncleswede View Post
I often get the same thing with Kontakt 5 when I stop playback (presumably) while a note is sounding but no note off msg has been received...

EDIT:

I just spotted this option in Prefs/MIDI devices:



... maybe setting this will cure my particular problem)
Are you using any external Midi devices- because in my case it happens with no devices connected, but my soundcard. It happens when i stop playback usualy or change playback from media explorer to arrange.
__________________
Win10, R 64bit
Janne83 is offline   Reply With Quote
Old 01-24-2020, 01:49 PM   #4
Janne83
Human being with feelings
 
Join Date: May 2010
Location: Earth
Posts: 1,833
Default

Another find:

This doesnt happen or happens rarely if Flush Fx on stop is enabled in Playback preferences.
__________________
Win10, R 64bit
Janne83 is offline   Reply With Quote
Old 01-24-2020, 02:06 PM   #5
uncleswede
Human being with feelings
 
Join Date: Feb 2015
Posts: 855
Default

Quote:
Originally Posted by Janne83 View Post
Are you using any external Midi devices- because in my case it happens with no devices connected, but my soundcard. It happens when i stop playback usualy or change playback from media explorer to arrange.
Not using any external MIDI devices...
uncleswede is offline   Reply With Quote
Old 01-24-2020, 02:10 PM   #6
Janne83
Human being with feelings
 
Join Date: May 2010
Location: Earth
Posts: 1,833
Default

Quote:
Originally Posted by uncleswede View Post
Not using any external MIDI devices...
Try to enable Flush Fx on stop in prefrences/playback- In my case it cuts down the stuck notes significantly- not completely but at least its bearable.
__________________
Win10, R 64bit
Janne83 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:19 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.