Old 02-05-2017, 04:20 PM   #1
K8ch
Human being with feelings
 
K8ch's Avatar
 
Join Date: Nov 2010
Location: New England
Posts: 264
Default Ride cymbal sounds "choked"...

Having an odd MIDI problem:

A simple ride cymbal hit should last a couple of seconds.
When I play the note with my mouse in the midi editor, I get a nice, long for sample sound.
However, when I draw in a midi note, that same ride cymbal sound gets "choked off" -even though it is the very last event in the entire track, and there is nothing else after it that might choke the sound of it.

Very odd...and frustrating.

Suggestions?

It's likely something simple that I'm overlooking


Peace,
K8ch
__________________
K8ch
(aka Keith Haydon)
K8ch is offline   Reply With Quote
Old 02-05-2017, 04:54 PM   #2
Lokasenna
Human being with feelings
 
Lokasenna's Avatar
 
Join Date: Sep 2008
Location: Calgary, AB, Canada
Posts: 5,952
Default

- Does it happen at all velocities? I've found some samples (cymbal chokes in EZD, for instance) whose length was affected by how hard you played them.

- What sampler are you using?

- By any chance, are there any extra CCs being added when you draw the note in? I had trouble with some random Note Off messages once.
Lokasenna is online now   Reply With Quote
Old 02-05-2017, 06:35 PM   #3
K8ch
Human being with feelings
 
K8ch's Avatar
 
Join Date: Nov 2010
Location: New England
Posts: 264
Default

Yep....all velocities.
No other cc lanes showing anything in them.

Using Steven Slate drums.
__________________
K8ch
(aka Keith Haydon)
K8ch is offline   Reply With Quote
Old 02-05-2017, 08:08 PM   #4
Lokasenna
Human being with feelings
 
Lokasenna's Avatar
 
Join Date: Sep 2008
Location: Calgary, AB, Canada
Posts: 5,952
Default

Weird. I'm out of ideas.
Lokasenna is online now   Reply With Quote
Old 02-05-2017, 08:57 PM   #5
Tod
Human being with feelings
 
Tod's Avatar
 
Join Date: Jan 2010
Location: Just outside of Glacier National Park
Posts: 12,501
Default

Quote:
Originally Posted by K8ch View Post
Yep....all velocities.
No other cc lanes showing anything in them.

Using Steven Slate drums.
Hi K8ch, what that means is that the ride samples are not one shot sample and/or, the release time is very short.

You might check the manual, there might be a setting(s) that's behind this.

I know for my own drums that I program in Kontakt, I do a special thing with the ride, so that it shortens the number of rides that can be on at the same time. There's a reason for this. In the real world there is only one ride cymbal, it just has different attack intensities as it is being struck. This is basically impossible to achieve with samples, because you have multiple ride samples all playing together at the same time and it's kind of unnatural.

So check the manual, there might be something about this.
__________________
Kontakt Vid Tutorials->Create Outputs / Create Templates -|- SMDrums Free drums -|- Elk Video Productions -|- Tod's Music
Tod is offline   Reply With Quote
Old 02-06-2017, 06:39 AM   #6
K8ch
Human being with feelings
 
K8ch's Avatar
 
Join Date: Nov 2010
Location: New England
Posts: 264
Default I'm not sure that logically follows...

Todd...


Sorry, but am having a tough time wrapping my head around this.

When I listen to the sample all by itself, it's clearly about 3 seconds long.
It doesn't sound like it has a truncated release/decay time but has a nice, long fade-out.
So, I just want to end the song with it.
Never anticipated it would be a pain...it makes absolutely no sense at all.

There are no other drums/percussion at all, going on. The ride cymbal is the last sound you hear, in the song itself.
Now, it sounds like a trash can top -but only when Reaper plays back the ride cymbal from the MIDI editor.
Very odd.




Peace,

Keith
https://www.reverbnation.com/keithhaydon
__________________
K8ch
(aka Keith Haydon)
K8ch is offline   Reply With Quote
Old 02-06-2017, 07:54 AM   #7
DarkStar
Human being with feelings
 
DarkStar's Avatar
 
Join Date: May 2006
Location: Surrey, UK
Posts: 17,845
Default

Which SSD kit?

Perhaps you could compress a simple problem project file (no audio samples needed) into a ZIP file and post it here as an attachment so that we can have a look at it and see what's (not) happening?

How to post attachments (in Post #1)
__________________
DarkStar ... interesting, if true. . . . Inspired by ...
DarkStar is offline   Reply With Quote
Old 02-06-2017, 09:09 AM   #8
Tod
Human being with feelings
 
Tod's Avatar
 
Join Date: Jan 2010
Location: Just outside of Glacier National Park
Posts: 12,501
Default

Quote:
Originally Posted by K8ch View Post
When I listen to the sample all by itself, it's clearly about 3 seconds long.
It doesn't sound like it has a truncated release/decay time but has a nice, long fade-out.
So, I just want to end the song with it.
Never anticipated it would be a pain...it makes absolutely no sense at all.
Hi Keith, are you cutting the note off or have you extended it to the end of the song? Is reaper stopping play, possibly cut the note off.

I know it probably shouldn't matter, but it's hard to say.

You say when you listen to the sample by itself it sounds okay. If you can trigger the note and it continues to ring out when you release it, then it's not the sample or the playback VSTi.
__________________
Kontakt Vid Tutorials->Create Outputs / Create Templates -|- SMDrums Free drums -|- Elk Video Productions -|- Tod's Music
Tod is offline   Reply With Quote
Old 02-08-2017, 09:06 AM   #9
LugNut
Human being with feelings
 
Join Date: Jun 2013
Location: So Florida
Posts: 898
Default

Hi,
Could it be that your at the end of the song and its end note off? Does the play head stop or keep going? Is the midi note length the culprit?

Edit..sorry missed tods post.
LugNut is offline   Reply With Quote
Old 02-08-2017, 09:48 PM   #10
K8ch
Human being with feelings
 
K8ch's Avatar
 
Join Date: Nov 2010
Location: New England
Posts: 264
Default

Well, I am embarrassed say it was probably user error.

It seems to work fine now.
Maybe rebooting the computer helped...but it was fine this evening, whatever the reason.


Thanks, everyone, for your willingness to help me out.



Peace,

Keith
__________________
K8ch
(aka Keith Haydon)
K8ch is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:30 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.