Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 09-17-2019, 06:10 AM   #1
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 23,332
Default Surge VST2 scrollbars appearing when downscaling zoom level

Trying to resize Surge from 150% down to 125% or 100% reduces the GUI size but also adds scrollbars even if the parent window is resized properly. Scrollbars disappear only when resizing the parent window manually to the old dimensions. This doesn't happen when upscaling the plugin size.

What is happening here?

More info, plugin-side: https://github.com/surge-synthesizer/surge/issues/1178


This doesn't happen in other hosts I tried: FL Studio 20, Live 10, Maschine...
EvilDragon is offline   Reply With Quote
Old 09-17-2019, 07:22 AM   #2
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 23,332
Default

Could stuff mentioned in this thread be possibly related?

https://forum.cockos.com/showthread.php?t=165052
EvilDragon is offline   Reply With Quote
Old 09-17-2019, 11:55 AM   #3
SmajjL
Human being with feelings
 
SmajjL's Avatar
 
Join Date: Nov 2013
Location: Sweden
Posts: 2,102
Default

Nightly-2019-09-17-659e681 64-bit VST2 works here with the latest REAPER dev (run as Native) without getting scrollbars.
Downloaded from here : https://surge-synthesizer.github.io/#downloads
Advanced UI in pref set to Aware + Ignore here if that makes a..
@ Windows 10
__________________
:)
SmajjL is offline   Reply With Quote
Old 09-17-2019, 12:13 PM   #4
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 23,332
Default

I have that same build and it doesn't work over here, scrollbars show when going from, say, 150% down to 125% or 100%. All the same things - 64-bit, run as native, multimonitor aware + ignore.
EvilDragon is offline   Reply With Quote
Old 09-17-2019, 12:23 PM   #5
SmajjL
Human being with feelings
 
SmajjL's Avatar
 
Join Date: Nov 2013
Location: Sweden
Posts: 2,102
Default

hmm, k.. I tried all sizes like a moron, can't get those scrollbars.. (yet)
--
Tried all combos of - run as, nope, can't get them
--
Tried Windows at 100%,200%,125%, nope, can't get 'em.. dammit..
__________________
:)

Last edited by SmajjL; 09-17-2019 at 12:33 PM.
SmajjL is offline   Reply With Quote
Old 09-17-2019, 12:41 PM   #6
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 23,332
Default

Well, Surge dev can reproduce it, so that's also what matters.

EvilDragon is offline   Reply With Quote
Old 09-17-2019, 12:43 PM   #7
SmajjL
Human being with feelings
 
SmajjL's Avatar
 
Join Date: Nov 2013
Location: Sweden
Posts: 2,102
Default

I tried it on a portable, SchmajjL can't... *whine* ohh well, good that
__________________
:)
SmajjL is offline   Reply With Quote
Old 09-17-2019, 01:03 PM   #8
SmajjL
Human being with feelings
 
SmajjL's Avatar
 
Join Date: Nov 2013
Location: Sweden
Posts: 2,102
Default



__________________
:)
SmajjL is offline   Reply With Quote
Old 09-17-2019, 01:23 PM   #9
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 23,332
Default

If you're going from smaller zoom level to larger, that works. When going from larger to smaller, doesn't work. You didn't have the timer enabled there so kinda hard to see which direction you went.

In any case, what's most important is that Surge dev can repro this.
EvilDragon is offline   Reply With Quote
Old 09-17-2019, 01:32 PM   #10
SmajjL
Human being with feelings
 
SmajjL's Avatar
 
Join Date: Nov 2013
Location: Sweden
Posts: 2,102
Default

I can repeat that all day though, but I found how to reproduce it.
I have to go and set it to a default in the menu to 150% then all hell brakes loose next time.
If left alone at default 100% and you resize everytime manualy, no problem'o
Go get it, devs!

Ohh, there is a timer, cool!
__________________
:)

Last edited by SmajjL; 09-17-2019 at 01:44 PM.
SmajjL is offline   Reply With Quote
Old 09-17-2019, 02:45 PM   #11
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 23,332
Default

Well you may have found something helpful. I indeed have my default zoom set to 150%, not 100%.
EvilDragon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 07:31 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.