Old 12-05-2019, 09:56 PM   #1
batcat
Human being with feelings
 
Join Date: Apr 2017
Posts: 60
Default Export configurations fails, "5 files failed to write"

The message I get says "5 files failed to write", when I'm trying to do a config export.
All boxes are selected in the export. Nothing is exported because of these five files.
Tried with latest Reaper 5 and 6 portable. Win 7 x64

Files with error.
ReaTeam Scrips, FX, Lokasenna Adjust Reasamplomatic 5000
1 - Adjust pitch offset in selected tracks - Down 0.01 semitones
2 - Adjust pitch offset in selected tracks - Down 0.05 semitones
3 - Adjust pitch offset in selected tracks - Down 0.1 semitones
4 - Adjust pitch offset in selected tracks - Down 0.5 semitones
5 - Adjust pitch offset in selected tracks - Reset to 0.0 semitones

I tried deleting them in the action list but I get the same error.
Is there an easy fix?

Last edited by batcat; Yesterday at 05:57 PM.
batcat is offline   Reply With Quote
Old Yesterday, 07:34 AM   #2
xpander
Human being with feelings
 
xpander's Avatar
 
Join Date: Jun 2007
Location: Terra incognita
Posts: 5,006
Default

Leave Reascripts unselected when doing your configuration export. That way you should get at least everything else export correctly. You could name the exported package with _no scripts or similar in the name, so you know they are not there.

Then save the whole Reascripts directory separately e.g. via Options/Show Reaper resource path and selecting the Scripts folder from there. You could even copy that saved Scripts folder later on inside the ReaperConfigZip to have everything in the same package, if you so will.

However, none of this solves why those scripts have errors. Are they actually working in your current Reaper install? You could remove them straight from the Scripts folder if you are not using them. Also, ReaPack could help managing your scripts and other resources.
xpander is online now   Reply With Quote
Old Yesterday, 05:56 PM   #3
batcat
Human being with feelings
 
Join Date: Apr 2017
Posts: 60
Default

Thanks expander!

I removed the whole map containing those reasampl5000 scripts (I don't use them), in the portable map, and that solved it.
I also tried deleting all ReaTeamScripts via Reapack but that didn't do the job.

When I synchronize packages in reapack I still get an error message:
...Adjust pitch offset in selected tracks - Up 1 semitone.lua.part:
"No such file or directory"

That error message doesn't prevent me exporting any settings though.
I get the same error message if I open a new empty project.
That map is deleted with those scripts so why does it indicate an error?
batcat is offline   Reply With Quote
Old Yesterday, 06:25 PM   #4
xpander
Human being with feelings
 
xpander's Avatar
 
Join Date: Jun 2007
Location: Terra incognita
Posts: 5,006
Default

If that error message comes while synchronizing ReaPack packages, I cannot unfortunately help...I have never even tried ReaPack. Yea, I guess in some areas I'm still a Luddite.

Hope somebody else can help with the ReaPack problem...
xpander is online now   Reply With Quote
Old Yesterday, 09:13 PM   #5
batcat
Human being with feelings
 
Join Date: Apr 2017
Posts: 60
Default

I suspect it has to do with the file names being too long.
Just before this problem occured I had renamed my Reaper folder where I have different portable installs, and it is just a few letters longer now. It so happens that the scripts causing problems are in a folder with the longest name of all scripts, and the script names are very long too.

Perhaps someone here knows if too long script names is known to cause problems like this.
batcat is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:24 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.