Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER for Linux

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 06-02-2020, 04:19 PM   #1
Rivereto Esplorado
Human being with feelings
 
Join Date: Jan 2020
Location: Mi ne plu uzas REAPER kaj ne plu aktivas en la forumoj.
Posts: 84
Default virMIDI, ALSA keyboard troubles fixed!

Often when I start Reaper, I do not have direct access to my MIDI keyboard by name (connected via MIDI cable to Behringer 204HD). Strange because every other DAW on my system (Ardour, Mixbus and Traktion) are still able to see it as "UMC204HD 192k MIDI 1". It takes reboot of my system to see it listed like that in Reaper again.

Today I discovered that if I "rmmod snd_virmidi" the direct MIDI device returns! Also, I could patch my 204HD midi through to one of the virmidi using aconnect if I really wanted and it then works in Reaper that way too. More of a pain than permanently disabling virmidi which I have now done via /etc/modules...

So, good news! I wonder why having virmidi confuses Reaper and not other DAWs?

Last edited by Rivereto Esplorado; 06-02-2020 at 04:48 PM.
Rivereto Esplorado is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:35 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.