Old 09-13-2020, 01:07 PM   #10121
Cragster
Human being with feelings
 
Join Date: Apr 2019
Location: Quakertown PA USA
Posts: 488
Default

Quote:
Originally Posted by BengtS View Post
How can I use a fader to call a Reaper function?

I have some faders in the mst file

Widget Fader1
Fader7Bit bf 00 7f
WidgetEnd

and want to call the Reaper function

Track: Set volume for track 03 (MIDI CC/OSC only) (36)

So, in the zon file, I would like to do this:

Fader1 Reaper "36"

This does not work and moves the fader only once to some fixed value.

Can this be done?

Or is there a way to allow the midi to get into the standard Reaper midi handling, where one could grab it to perform any task, including changing the track volume of channel 3.

I noticed, that when I put any channel into record mode, I do get all the midi from the device used for CSI. But I would prefer to get it also without. Is there any way to enable this?

TIA!

Best regards,
Bengt
i dont think those midi cc/osc only actions work with CSI. not 100% sure but someone else would know for sure can chime in.
Cragster is offline   Reply With Quote
Old 09-13-2020, 03:37 PM   #10122
nofish
Human being with feelings
 
nofish's Avatar
 
Join Date: Oct 2007
Location: home is where the heart is
Posts: 9,959
Default

@BengtS
For controling volume you can use the TrackVolume action.
So Fader1 TrackVolume should work I think.
(Also see the included .zon examples and https://github.com/malcolmgroves/rea...tion-Reference, though this may be partly outdated, not sure).
nofish is offline   Reply With Quote
Old 09-14-2020, 05:49 AM   #10123
Equitone
Human being with feelings
 
Join Date: Apr 2018
Posts: 22
Default CSI.ini layout

Hi,
Using a screen reader, I find it easier to edit the CSI.ini file rather than set things up in the GUI. I need to change the input and output ports on my X-Touch. The story so far...
Code begins:
MidiSurface "Behringer XTouch" 13 15 "BehringerXTouch.mst" "BehringerXTouch" NoZoneLink NoAutoMapSends NoAutoMapFX NoAutoMapFXMenu AutoMapFocusedFX
Code ends
Which elements do I need to tweak so that the input is Port 1, and the output is Port 2
Thanks as always
Equitone is offline   Reply With Quote
Old 09-14-2020, 08:21 AM   #10124
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,192
Default

Quote:
Originally Posted by conorg View Post
I had to nuke the Reaper resource folder and put my build of reaper_csurf_integrator.dylib in there from the start, swapping it in after the fact doesn't work. Working now!

I have noticed that I need to check "Auto Map FX" in the Control Surface/Midi settings to get VSTs to respond is that expected?

But it's all very fragile:

If I go into Reaper Preferences and hit "edit" on the Control Surface Integrator, as soon as I click "OK" the VST no longer responds. Removing the VST and re-inserting it starts up communication again. Nothing else seems to.

If I close the project and re-open it, the VST no longer responds. Again, removing the VST and re-inserting it starts up communication again.

Now that I am able to build and debug reaper_csurf_integrator.dylib is there any troubleshooting I can do to help figure this out?
Could it be something as simple as selecting the track ?
__________________
Beta software https://stash.reaper.fm/v/38349/CSI%20beta.zip Donate GeoffWaddington.ca
Installation / documentation / source https://github.com/GeoffAWaddington/...ntegrator/wiki
Geoff Waddington is offline   Reply With Quote
Old 09-14-2020, 08:22 AM   #10125
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,192
Default

Quote:
Originally Posted by MixMonkey View Post

How's that new version coming along Geoff?
Bit by bit
__________________
Beta software https://stash.reaper.fm/v/38349/CSI%20beta.zip Donate GeoffWaddington.ca
Installation / documentation / source https://github.com/GeoffAWaddington/...ntegrator/wiki
Geoff Waddington is offline   Reply With Quote
Old 09-14-2020, 08:25 AM   #10126
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,192
Default

Quote:
Originally Posted by Equitone View Post
Hi,
Using a screen reader, I find it easier to edit the CSI.ini file rather than set things up in the GUI. I need to change the input and output ports on my X-Touch. The story so far...
Code begins:
MidiSurface "Behringer XTouch" 13 15 "BehringerXTouch.mst" "BehringerXTouch" NoZoneLink NoAutoMapSends NoAutoMapFX NoAutoMapFXMenu AutoMapFocusedFX
Code ends
Which elements do I need to tweak so that the input is Port 1, and the output is Port 2
Thanks as always
Just change the 13 to 1 and the 15 to 2, that should do it.
__________________
Beta software https://stash.reaper.fm/v/38349/CSI%20beta.zip Donate GeoffWaddington.ca
Installation / documentation / source https://github.com/GeoffAWaddington/...ntegrator/wiki
Geoff Waddington is offline   Reply With Quote
Old 09-14-2020, 08:30 AM   #10127
Equitone
Human being with feelings
 
Join Date: Apr 2018
Posts: 22
Question

Quote:
Originally Posted by Geoff Waddington View Post
Just change the 13 to 1 and the 15 to 2, that should do it.
Geoff,
What are those numbers? The ports I'm using are virtual ports. I suppose I should say: How do you know what number those ports are?
Thanks again
Equitone is offline   Reply With Quote
Old 09-14-2020, 08:44 AM   #10128
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,192
Default

Quote:
Originally Posted by Equitone View Post
Geoff,
What are those numbers? The ports I'm using are virtual ports. I suppose I should say: How do you know what number those ports are?
Thanks again
Port assignment is upstream from CSI, perhaps in Reaper, but I think it's in the OS.

CSI just displays whatever Reaper hands it.
__________________
Beta software https://stash.reaper.fm/v/38349/CSI%20beta.zip Donate GeoffWaddington.ca
Installation / documentation / source https://github.com/GeoffAWaddington/...ntegrator/wiki
Geoff Waddington is offline   Reply With Quote
Old 09-14-2020, 09:00 AM   #10129
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,633
Default

Quote:
Originally Posted by Equitone View Post
Geoff,
What are those numbers? The ports I'm using are virtual ports. I suppose I should say: How do you know what number those ports are?
Thanks again
They're created by Reaper when it scans your MIDI gear on startup. The values, along with a lot of other confusing guff, is contained in the file reaper-midihw.ini.

As an example, my first MCUXT is connected to my MOTU Express 128 MIDI interface on port one (input and output) In the CSI init, this shows up as "XT#1 6 5" The 6 represents the input and the 5 the output.

In the reaper-midihw.ini this shows up on line 54 as "ix6=MOTU - Express 128 - Port 1" for the input (the i x bit) and on line 105 as "ox5=MOTU - Express 128 - Port 1" for the output (the o x bit)

Search the reaper-midihw.ini for the first occurence of "ix13" and you should eventually hear "XTouch" followed by the input port number. Do the same for "ox15" to hear the output port.
MixMonkey is online now   Reply With Quote
Old 09-14-2020, 11:25 AM   #10130
siniarch
Human being with feelings
 
Join Date: Jun 2018
Posts: 300
Default

Geoff,
Does OSC detect double tap of a button, or does that have to be in controller?

I'm trying to figure out how a double tap works. If my controller needs to output a different midi code when I double click a button or if CSI can detect time between same button pushed twice in a row and perform a different command.

Thanks.
siniarch is offline   Reply With Quote
Old 09-14-2020, 12:10 PM   #10131
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,192
Default

Quote:
Originally Posted by MixMonkey View Post
They're created by Reaper when it scans your MIDI gear on startup. The values, along with a lot of other confusing guff, is contained in the file reaper-midihw.ini.

As an example, my first MCUXT is connected to my MOTU Express 128 MIDI interface on port one (input and output) In the CSI init, this shows up as "XT#1 6 5" The 6 represents the input and the 5 the output.

In the reaper-midihw.ini this shows up on line 54 as "ix6=MOTU - Express 128 - Port 1" for the input (the i x bit) and on line 105 as "ox5=MOTU - Express 128 - Port 1" for the output (the o x bit)

Search the reaper-midihw.ini for the first occurence of "ix13" and you should eventually hear "XTouch" followed by the input port number. Do the same for "ox15" to hear the output port.
Thank for clarifying, I should really know that
__________________
Beta software https://stash.reaper.fm/v/38349/CSI%20beta.zip Donate GeoffWaddington.ca
Installation / documentation / source https://github.com/GeoffAWaddington/...ntegrator/wiki
Geoff Waddington is offline   Reply With Quote
Old 09-14-2020, 12:12 PM   #10132
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,192
Default

Quote:
Originally Posted by siniarch View Post
Geoff,
Does OSC detect double tap of a button, or does that have to be in controller?

I'm trying to figure out how a double tap works. If my controller needs to output a different midi code when I double click a button or if CSI can detect time between same button pushed twice in a row and perform a different command.

Thanks.
Hmmm...

Not a big fan of double tap.

It implies latency, I like really responsive interfaces.

If you have a double tap feature, it is a given that a single tap has a delay -- the time it takes to see if a second tap came in.

I much prefer modifiers.

just my 2c
__________________
Beta software https://stash.reaper.fm/v/38349/CSI%20beta.zip Donate GeoffWaddington.ca
Installation / documentation / source https://github.com/GeoffAWaddington/...ntegrator/wiki
Geoff Waddington is offline   Reply With Quote
Old 09-14-2020, 12:40 PM   #10133
siniarch
Human being with feelings
 
Join Date: Jun 2018
Posts: 300
Default

Quote:
Originally Posted by Geoff Waddington View Post
Hmmm...

Not a big fan of double tap.

It implies latency, I like really responsive interfaces.

If you have a double tap feature, it is a given that a single tap has a delay -- the time it takes to see if a second tap came in.

I much prefer modifiers.

just my 2c
Yes, I see. In hardware it certainly would have a delay. In software, I guess you could process initial command, and if second tap came in within set time, it would undo first tap command and execute different command. But I'm guessing this would be very complicated to implement between CSI and Reaper and no need to confuse things.

I was just thinking of having extra functionality. Perhaps I will implement it via hardware and be something that people can change in the bios if they like. If it's even possible.
siniarch is offline   Reply With Quote
Old 09-14-2020, 01:25 PM   #10134
mschnell
Human being with feelings
 
mschnell's Avatar
 
Join Date: Jun 2013
Location: Krefeld, Germany
Posts: 9,687
Default

Quote:
Originally Posted by Geoff Waddington View Post
perhaps in Reaper, but I think it's in the OS.
Not really. In Windows this is complicated, changing when swapping the Midi connector, and partly depending on the device driver.

The result can be seen in reaper-midihw.ini.
I did a Python program to show the configuration as the OS presents the ports to Reaper.)
-Michael
mschnell is offline   Reply With Quote
Old 09-14-2020, 01:32 PM   #10135
Equitone
Human being with feelings
 
Join Date: Apr 2018
Posts: 22
Lightbulb

Quote:
Originally Posted by Geoff Waddington View Post
Thank for clarifying, I should really know that
Thanks both,

All sorted now.
Equitone is offline   Reply With Quote
Old 09-15-2020, 10:48 AM   #10136
BengtS
Human being with feelings
 
Join Date: Feb 2012
Posts: 21
Default

Quote:
Originally Posted by nofish View Post
@BengtS
For controling volume you can use the TrackVolume action.
So Fader1 TrackVolume should work I think.
(Also see the included .zon examples and https://github.com/malcolmgroves/rea...tion-Reference, though this may be partly outdated, not sure).
Thanks for the help!

Best regards,
Bengt
BengtS is offline   Reply With Quote
Old 09-16-2020, 05:56 AM   #10137
conorg
Human being with feelings
 
Join Date: Aug 2007
Posts: 18
Default

I did think of that, but even in a project with two tracks where I can switch between them, the VST won't respond until I remove it and add it in again.

I'll maybe try creating a video to demonstrate the behaviour I am seeing.

Quote:
Originally Posted by Geoff Waddington View Post
Could it be something as simple as selecting the track ?
conorg is offline   Reply With Quote
Old 09-17-2020, 11:43 AM   #10138
pwallin
Human being with feelings
 
Join Date: Mar 2018
Posts: 62
Default missing things

First time I installed CSI. Followed very carefully instructions from the github. Win 7 here and Reaper 6. I used find resource path using 64 bit Reaper and installed files there, but when opening Reaper it showed missing VCRUNTIME140_1.dll error and CSI does not open up. When I open 32 bit version of Reaper it still shows the same resource path location as 64 bit version. That means I am not sure if I copied files to a correct place or something else is wrong. However 32 bit Reaper opens CSI main window without error message. Funny thing is that on the right side there still is no example files, it's just empty. Not sure how to fix this. I really would like to get 64 bit Reaper working with CSI, not 32 bit. I can't connect my controller, because it has not arrived yet but thought that CSI would still open without any controller attached. Could that be a reason for misbehaving?

-Pasi

Last edited by pwallin; 09-17-2020 at 12:05 PM.
pwallin is offline   Reply With Quote
Old 09-17-2020, 12:05 PM   #10139
siniarch
Human being with feelings
 
Join Date: Jun 2018
Posts: 300
Default

Quote:
Originally Posted by pwallin View Post
First time I installed CSI. Followed very carefully instructions from the github. Win 7 here and Reaper 6. I used find resource path using 64 bit Reaper, but it showed missing VCRUNTIME140_1.dll error and CSI does not open up. When I open 32 bit version of Reaper it still shows the same resource path location as 64 bit version. That means I am not sure if I copied files to a correct place or something else is wrong. However 32 bit Reaper opens CSI main window without error message. Funny thing is that on the right side there still is no example files, it's just empty. Not sure how to fix this. I really would like to get 64 bit Reaper working with CSI, not 32 bit. I can't connect my controller, because it has not arrived yet but thought that CSI would still open without any controller attached. Could that be a reason for misbehaving?

-Pasi
Take a look at this post. And this thread has some info on installing as well.


https://forum.cockos.com/showpost.ph...1&postcount=40
siniarch is offline   Reply With Quote
Old 09-17-2020, 12:19 PM   #10140
pwallin
Human being with feelings
 
Join Date: Mar 2018
Posts: 62
Default

Quote:
Originally Posted by siniarch View Post
Take a look at this post. And this thread has some info on installing as well.


https://forum.cockos.com/showpost.ph...1&postcount=40
Ok, thanks!
pwallin is offline   Reply With Quote
Old 09-17-2020, 05:45 PM   #10141
Cragster
Human being with feelings
 
Join Date: Apr 2019
Location: Quakertown PA USA
Posts: 488
Default

hey all
If i have more then one surface each with 8 faders rotarys etc can i set each one up to control different tracks ? Meaning one surface does tracks 1-8 another 9-16 ? Like an extension. Or does it have to be an extension of the main surface.And if so how would i go about setting that up in CSI. Thanks
Cragster is offline   Reply With Quote
Old 09-18-2020, 05:18 AM   #10142
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,482
Default

Quote:
Originally Posted by Cragster View Post
hey all
If i have more then one surface each with 8 faders rotarys etc can i set each one up to control different tracks ? Meaning one surface does tracks 1-8 another 9-16 ? Like an extension. Or does it have to be an extension of the main surface.And if so how would i go about setting that up in CSI. Thanks
If both surfaces are on the same page, CSI will map out the channels based on the order on the page. So surface one would get 1-8 and surface two would get 9-16. No need to do anything special in the Zone files.
Funkybot is online now   Reply With Quote
Old 09-18-2020, 05:53 AM   #10143
Cragster
Human being with feelings
 
Join Date: Apr 2019
Location: Quakertown PA USA
Posts: 488
Default

Quote:
Originally Posted by Funkybot View Post
If both surfaces are on the same page, CSI will map out the channels based on the order on the page. So surface one would get 1-8 and surface two would get 9-16. No need to do anything special in the Zone files.
Hey thanks for the help. I'll give that a go tonight
Cragster is offline   Reply With Quote
Old 09-18-2020, 05:08 PM   #10144
Nick Morris
Human being with feelings
 
Nick Morris's Avatar
 
Join Date: Nov 2010
Posts: 469
Default kill me

been trying to understand how to get this working for the last while and I'm hitting a dead end. I have a mackie C4 I was hoping to get working but not really getting anywhere. I see the zone files for reacomp for instance. I figured selecting a track and inserting it would throw parameters on the C4. How does this exactly work?

I have a mst file, I have the surface zone file and the plugin zone file. What do I do with them? The current documentation I could find does a nice job of explaining what the bits and pieces are for, just not how to do anything with them.

the only progress I have made is seeing the word reacomp appear on the C4 display LOL

If anyone with a C4 or that would know how to get this working could help I would REALLY appreciate it.

And still a no on the Eucon artist transport jog/scrub wheel working I assume?
__________________
www.ElaireStudios.com
Robo-Mic RMS robotic remote controlled mic stands aimed at mic'ing amps
Nick Morris is online now   Reply With Quote
Old 09-18-2020, 05:53 PM   #10145
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,633
Default

Quote:
Originally Posted by Nick Morris View Post
been trying to understand how to get this working for the last while and I'm hitting a dead end. I have a mackie C4 I was hoping to get working but not really getting anywhere. I see the zone files for reacomp for instance. I figured selecting a track and inserting it would throw parameters on the C4. How does this exactly work?

I have a mst file, I have the surface zone file and the plugin zone file. What do I do with them? The current documentation I could find does a nice job of explaining what the bits and pieces are for, just not how to do anything with them.

the only progress I have made is seeing the word reacomp appear on the C4 display LOL

If anyone with a C4 or that would know how to get this working could help I would REALLY appreciate it.

And still a no on the Eucon artist transport jog/scrub wheel working I assume?
I have a C4 working well here. I've attached my C4.zon and a couple of FX zones (that demonstrate the controls better than Reacomp and ReaEQ) The plugins can be downloaded at:

https://www.tokyodawn.net/tdr-vos-slickeq/
https://www.tokyodawn.net/tdr-kotelnikov/

It uses the SelectedTrackNavigator and the FXMenu. You'll need to tick Automap Sends and Automap FX Menu in the CSI prefs for the C4.

You select a track on your fader surface and the FX menu and the track sends appear on the C4. Selecting an FX from the menu causes the parameters to appear on the surface. Return to the menu using the Lock button. Read the C4.zon for the other button assignments.

See if you can get this up and running- I have loads more FX zones if you're interested. Any questions, just ask.

Last edited by MixMonkey; 09-26-2020 at 09:16 AM.
MixMonkey is online now   Reply With Quote
Old 09-19-2020, 02:30 PM   #10146
Equitone
Human being with feelings
 
Join Date: Apr 2018
Posts: 22
Question NoZoneLink

In the context of the CSI.ini file, what does this parameter mean?
Equitone is offline   Reply With Quote
Old 09-19-2020, 04:31 PM   #10147
RobinGShore
Human being with feelings
 
Join Date: May 2013
Location: New York
Posts: 557
Default

Quote:
Originally Posted by Nick Morris View Post
And still a no on the Eucon artist transport jog/scrub wheel working I assume?
I've got a Eucon Dock and the wheel on it is working just fine with CSI, so I'm not sure why the artist transport would be any different. If I remember correctly (it's been a while since I first set it up) I had to setup the wheel commands in the Eucontrol software myself, as CSI does not come with a preconfigured softkey map for eucon.
RobinGShore is offline   Reply With Quote
Old 09-19-2020, 06:18 PM   #10148
tdc
Human being with feelings
 
Join Date: Oct 2019
Location: Sydney
Posts: 455
Default

Quote:
Originally Posted by RobinGShore View Post
I've got a Eucon Dock and the wheel on it is working just fine with CSI, so I'm not sure why the artist transport would be any different. If I remember correctly (it's been a while since I first set it up) I had to setup the wheel commands in the Eucontrol software myself, as CSI does not come with a preconfigured softkey map for eucon.
Hi Robin, what settings have you got mapped in EuConSettings to CSI?
tdc is offline   Reply With Quote
Old 09-19-2020, 06:29 PM   #10149
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,633
Default

Quote:
Originally Posted by Equitone View Post
In the context of the CSI.ini file, what does this parameter mean?
It means that the "Sync Zones Across Surfaces" box is unchecked in the CSI prefs, meaning when a Zone is changed on one surface it doesn't affect other surfaces.

Last edited by MixMonkey; 09-19-2020 at 06:52 PM.
MixMonkey is online now   Reply With Quote
Old 09-19-2020, 08:03 PM   #10150
Nick Morris
Human being with feelings
 
Nick Morris's Avatar
 
Join Date: Nov 2010
Posts: 469
Default

Quote:
Originally Posted by RobinGShore View Post
I've got a Eucon Dock and the wheel on it is working just fine with CSI, so I'm not sure why the artist transport would be any different. If I remember correctly (it's been a while since I first set it up) I had to setup the wheel commands in the Eucontrol software myself, as CSI does not come with a preconfigured softkey map for eucon.
Now Iím really confused. Everything seems to work in eucon except the wheel commands for me. Guess itís just me.
__________________
www.ElaireStudios.com
Robo-Mic RMS robotic remote controlled mic stands aimed at mic'ing amps
Nick Morris is online now   Reply With Quote
Old 09-19-2020, 08:07 PM   #10151
Nick Morris
Human being with feelings
 
Nick Morris's Avatar
 
Join Date: Nov 2010
Posts: 469
Default

Quote:
Originally Posted by MixMonkey View Post
I have a C4 working well here. I've attached my C4.zon and a couple of FX zones (that demonstrate the controls better than Reacomp and ReaEQ) The plugins can be downloaded at:

https://www.tokyodawn.net/tdr-vos-slickeq/
https://www.tokyodawn.net/tdr-kotelnikov/

It uses the SelectedTrackNavigator and the FXMenu. You'll need to tick Automap Sends and Automap FX Menu in the CSI prefs for the C4.

You select a track on your fader surface and the FX menu and the track sends appear on the C4. Selecting an FX from the menu causes the parameters to appear on the surface. Return to the menu using the Lock button. Read the C4.zon for the other button assignments.

See if you can get this up and running- I have loads more FX zones if you're interested. Any questions, just ask.
I really appreciate this help.

Iím still light years away from getting anything working but I was able to see sends appear on the C4. Still canít get anything else to work with the C4. And I canít seem to repeat the success of seeing sends.

Iím confused, am I supposed to expect to see parameters just appear on the C4 or are the steps Iím missing? Is it as simple as having the zone and mst files in the csi folder and stuff should just work it do I need to be doing more setup and preference selection. I mean I understand how to use eucon under csi, but canít see what Iím missing getting this C4 to respond in a predictable way.
__________________
www.ElaireStudios.com
Robo-Mic RMS robotic remote controlled mic stands aimed at mic'ing amps
Nick Morris is online now   Reply With Quote
Old 09-19-2020, 10:48 PM   #10152
pwallin
Human being with feelings
 
Join Date: Mar 2018
Posts: 62
Default

Total frustration. I even followed steps Siniarchs posted for installing CSI. It's been almost a week now and I can't get 64 bit Reaper load CSI. Only 32 bit Reaper loads, but I need 64 bit working.

I opened Reaper. Noted resource path, closed Reaper and put 64 bit surfaceintegrator in the User Plugin folder. Then put CSI folder to Reapers root folder.

I tested with Windows 7 and it shows CSI VCRUNTIME140_1.dll error.
I tested with Windows 10 Pro and it shows no error message, but Reaper does not see the CSI in the "Control surfaces/OSC/Web" drop down list. I have set Klinke previously, so I know I'm on the right track.

What prevents 64 bit Reaper seeing CSI especially on Win 10 Pro? Do I need to put .dylib somewhere or is it just for Mac? Currently I have not put it anywhere cos I'm on PC.

Last edited by pwallin; 09-19-2020 at 11:18 PM.
pwallin is offline   Reply With Quote
Old 09-19-2020, 10:53 PM   #10153
Piszpan
Human being with feelings
 
Join Date: Aug 2016
Posts: 86
Default

Quote:
Originally Posted by pwallin View Post
Total frustration. I followed steps Siniarchs posted for installing CSI. It's been almost a week now and I can't get 64 bit Reaper load CSI. Only 32 bit Reaper loads, but I need 64 bit working.

I opened Reaper. Noted resource path, closed Reaper and put 64 bit surfaceintegrator in the User Plugin folder. Then put CSI folder to Reapers root folder.

I tested with Windows 7 and it shows CSI VCRUNTIME140_1.dll error.
I tested with Windows 10 Pro and it shows no error message, but Reaper does not see the CSI in the "Control surfaces/OSC/Web" drop down list. I have set Klinke previously, so I know I'm on the right track.

What prevents 64 bit Reaper seeing CSI? Do I need to put .dylib somewhere or is it just for Mac?
To get rid of that error in Windows 7 you need to instal Microsoft Visual C++ 2019 Redistributable Package (x64). Google it and download from Microsoft.
Piszpan is offline   Reply With Quote
Old 09-19-2020, 11:16 PM   #10154
pwallin
Human being with feelings
 
Join Date: Mar 2018
Posts: 62
Default

Quote:
Originally Posted by Piszpan View Post
To get rid of that error in Windows 7 you need to instal Microsoft Visual C++ 2019 Redistributable Package (x64). Google it and download from Microsoft.
Ok, I try that. I thought my Win 10 Pro already has it, since it shows no error message. Still does not work and it's my main DAW. Win 7 is just a netmachine and for testing purposes.
pwallin is offline   Reply With Quote
Old 09-20-2020, 05:17 AM   #10155
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,633
Default

Quote:
Originally Posted by Nick Morris View Post
I really appreciate this help.

Iím still light years away from getting anything working but I was able to see sends appear on the C4. Still canít get anything else to work with the C4. And I canít seem to repeat the success of seeing sends.

Iím confused, am I supposed to expect to see parameters just appear on the C4 or are the steps Iím missing? Is it as simple as having the zone and mst files in the csi folder and stuff should just work it do I need to be doing more setup and preference selection. I mean I understand how to use eucon under csi, but canít see what Iím missing getting this C4 to respond in a predictable way.
What you should see on the C4, when you select a track on the eucon surface, is the track's sends appear on row C and the names of the FX on the track appear on row D (row A is top, row D is bottom)

Pressing the RotaryPush on any of the row D names should display the particular FX's parameters on the C4.

Zip up your CSI folder and I'll see if I can unravel it for you. It's not impossible that there's some wierd interaction with Eucon but there have been no reports of that so far.
MixMonkey is online now   Reply With Quote
Old 09-20-2020, 12:14 PM   #10156
Nick Morris
Human being with feelings
 
Nick Morris's Avatar
 
Join Date: Nov 2010
Posts: 469
Default

Quote:
Originally Posted by MixMonkey View Post
What you should see on the C4, when you select a track on the eucon surface, is the track's sends appear on row C and the names of the FX on the track appear on row D (row A is top, row D is bottom)

Pressing the RotaryPush on any of the row D names should display the particular FX's parameters on the C4.

Zip up your CSI folder and I'll see if I can unravel it for you. It's not impossible that there's some wierd interaction with Eucon but there have been no reports of that so far.
Here you go. Thanks!
Attached Files
File Type: zip C4.zip (8.4 KB, 13 views)
__________________
www.ElaireStudios.com
Robo-Mic RMS robotic remote controlled mic stands aimed at mic'ing amps
Nick Morris is online now   Reply With Quote
Old 09-20-2020, 12:42 PM   #10157
siniarch
Human being with feelings
 
Join Date: Jun 2018
Posts: 300
Default

Quote:
Originally Posted by pwallin View Post
Total frustration. I even followed steps Siniarchs posted for installing CSI. It's been almost a week now and I can't get 64 bit Reaper load CSI. Only 32 bit Reaper loads, but I need 64 bit working.

I opened Reaper. Noted resource path, closed Reaper and put 64 bit surfaceintegrator in the User Plugin folder. Then put CSI folder to Reapers root folder.

I tested with Windows 7 and it shows CSI VCRUNTIME140_1.dll error.
I tested with Windows 10 Pro and it shows no error message, but Reaper does not see the CSI in the "Control surfaces/OSC/Web" drop down list. I have set Klinke previously, so I know I'm on the right track.

What prevents 64 bit Reaper seeing CSI especially on Win 10 Pro? Do I need to put .dylib somewhere or is it just for Mac? Currently I have not put it anywhere cos I'm on PC.
This might be the reason. "Then put CSI folder to Reapers root folder."
If you are putting CSI into the regular installation of Reaper, then it is WRONG:
C:\Program Files\REAPER (x64)


I believe you have to place the CSI folder in the User Roaming Folder of Reaper:
C:\Users\luis_\AppData\Roaming\REAPER

(obviously the "luis_" on my folder would be different for your computer. It would be whatever the user name you have.)

I hope this is the problem as it would be a simple fix.

BTW. I also have REAPER x64 and Windows 10. So there should be no issues with that.
siniarch is offline   Reply With Quote
Old 09-20-2020, 01:16 PM   #10158
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,633
Default

Quote:
Originally Posted by Nick Morris View Post
Here you go. Thanks!
The whole of your CSI folder, if you wouldn't mind - these things all work together

I had a quick look at your C4 folder. The reason the Reacomp Zone doesn't work is because it's Geoff's zone for the Softube Console One. To adapt it for the Mackie C4, it would be like this:
Code:
Zone "VST: ReaComp (Cockos)" "ReaComp"
SelectedTrackNavigator
/
DisplayUpperD1 FXParamNameDisplay "0" "Thresh"
DisplayLowerD1 FXParamValueDisplay "0" 
RotaryD1 FXParam "0" [ (0.001,0.005,0.025,0.05,0.1) ]
Toggle+RotaryPushD1 NoAction
/
DisplayUpperD2 FXParamNameDisplay "2" "Att"
DisplayLowerD2 FXParamValueDisplay "2" 
RotaryD2 FXParam "2" [ (0.001,0.005,0.025,0.05,0.1) ]
Toggle+RotaryPushD2 NoAction
/
DisplayUpperD3 FXParamNameDisplay "3" "Rel"
DisplayLowerD3 FXParamValueDisplay "3" 
RotaryD3 FXParam "3" [ (0.001,0.005,0.025,0.05,0.1) ]
Toggle+RotaryPushD3 NoAction
/
DisplayUpperD4 FXParamNameDisplay "1" "Ratio"
DisplayLowerD4 FXParamValueDisplay "1" 
RotaryD4 FXParam "1" [ (0.001,0.005,0.025,0.05,0.1) ]
Toggle+RotaryPushD4 NoAction
/
DisplayUpperD5 FXParamNameDisplay "20" "Mix"
DisplayLowerD5 FXParamValueDisplay "20"
RotaryD5 FXParam "20" [ (0.001,0.005,0.025,0.05,0.1) ]
Toggle+RotaryPushD5 FXParam "19"
/
DisplayUpperD6 NoAction
DisplayLowerD6 NoAction
RotaryD6 NoAction
Toggle+RotaryPushD6 NoAction
/  
DisplayUpperD7 NoAction
DisplayLowerD7 NoAction
RotaryD7 NoAction
Toggle+RotaryPushD7 NoAction
/  
DisplayUpperD8 NoAction
DisplayLowerD8 NoAction
RotaryD8 NoAction
Toggle+RotaryPushD8 NoAction   
/
ZoneEnd
...but the as the controls in Reacomp are scaled really poorly, it might be better to try something more forgiving, which was why I suggested the TDRs.

Try this modified C4 folder with Reacomp.

Last edited by MixMonkey; 09-26-2020 at 09:16 AM.
MixMonkey is online now   Reply With Quote
Old 09-20-2020, 01:26 PM   #10159
Nick Morris
Human being with feelings
 
Nick Morris's Avatar
 
Join Date: Nov 2010
Posts: 469
Default

Quote:
Originally Posted by MixMonkey View Post
What you should see on the C4, when you select a track on the eucon surface, is the track's sends appear on row C and the names of the FX on the track appear on row D (row A is top, row D is bottom)

Pressing the RotaryPush on any of the row D names should display the particular FX's parameters on the C4.

Zip up your CSI folder and I'll see if I can unravel it for you. It's not impossible that there's some wierd interaction with Eucon but there have been no reports of that so far.
What I see is the sends on Row C, the FX name on the track on Row D. Pressing the rotary of Row D does nothing on the C4.

I feel like I am missing a step here.

1. create mst file for surface
2. create zone file for surface
3. create zone file for fx
4. ???? anything else ????

I am trying to understand how these all work so at this point I am just copying the files you posted into my CSI folder.
__________________
www.ElaireStudios.com
Robo-Mic RMS robotic remote controlled mic stands aimed at mic'ing amps
Nick Morris is online now   Reply With Quote
Old 09-20-2020, 01:32 PM   #10160
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,633
Default

Quote:
Originally Posted by Nick Morris View Post
4. ???? anything else ????
Did you try the C4 folder I just posted?
MixMonkey is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:38 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.