Old 06-03-2020, 09:02 AM   #7001
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,646
Default

Quote:
Originally Posted by nexeu View Post
Guys,

I'd been having loads of fun exploring around LBX, and I was also re-modifying Timb's controls to my needs as well. So far, I had re-created possibilities of each knob in a different color and I realised the browser doesn't sort out the items by its name. So, its scattering everywhere disorderly.

Is there a way around to sort it by the file name? Or I missed out something?
Hmmm - might be another difference between Mac and PC, on my PC - the items are ordered by the enumerate files function which basically reads them the way they are ordered in the controls folder. Have you tried sorting the controls folder by Name and restarting Stripper? (I assume this is possible on Mac)
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 06-03-2020, 10:05 AM   #7002
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,780
Default

Quote:
Originally Posted by lb0 View Post
I haven't checked but thought this was already possible?
Ah!
i don't know any settings hint you can give me to test?


so far what i tried:

i set the PROBABILITY of the Parameters that i don't want them get effected to 0%
but didn't work,
Left Click has no problem but Right Click still randomizing them

then tried with the grouping
LNK GRP 1
WILD Off
MIN 0
MAX 0
+ve BIAS 0%
RANGE Off
TYPE Randomize X
X 0

also created second group for the parameters i want to randomize

but still no luck..
timbralzoom is offline   Reply With Quote
Old 06-03-2020, 10:16 AM   #7003
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,646
Default

Quote:
Originally Posted by timbralzoom View Post
Ah!
i don't know any settings hint you can give me to test?


so far what i tried:

i set the PROBABILITY of the Parameters that i don't want them get effected to 0%
but didn't work,
Left Click has no problem but Right Click still randomizing them

then tried with the grouping
LNK GRP 1
WILD Off
MIN 0
MAX 0
+ve BIAS 0%
RANGE Off
TYPE Randomize X
X 0

also created second group for the parameters i want to randomize

but still no luck..
Aah - I don't think I'm understanding correctly.

You want the Link groups to work across different Random buttons?? Hmm. Not sure whether that would be possible currently.

Can you describe (in as much detail as possible - as I'm an idiot) what you are trying to do?
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 06-03-2020, 11:08 AM   #7004
nexeu
Human being with feelings
 
Join Date: Mar 2020
Posts: 41
Default

Quote:
Originally Posted by lb0 View Post
Hmmm - might be another difference between Mac and PC, on my PC - the items are ordered by the enumerate files function which basically reads them the way they are ordered in the controls folder. Have you tried sorting the controls folder by Name and restarting Stripper? (I assume this is possible on Mac)
Sadly it is not working that way in Mac. It seems to randomise everything each time I reload. Can't really predict the algorithm of it.
nexeu is offline   Reply With Quote
Old 06-03-2020, 11:19 AM   #7005
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,780
Default

sorry for my Tarzanish!
(actually even in Turkish i made simple things complicated while talking )

anyway,
here is a simple video, i hope will explain a bit better
(all Randomize buttons belongs to one same Subset)

https://drive.google.com/file/d/12hq...ew?usp=sharing
timbralzoom is offline   Reply With Quote
Old 06-03-2020, 12:15 PM   #7006
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,780
Default

-sorry for the multiple posts-

a wackiest one of the lockdown

is this possible?
Macro ability to LEARN the Take Switcher

simple video with a scenario

https://drive.google.com/file/d/1xSf...ew?usp=sharing

-motto-
timbralzoom is offline   Reply With Quote
Old 06-03-2020, 09:53 PM   #7007
RJHollins
Human being with feelings
 
Join Date: Dec 2011
Posts: 1,517
Default

I was trying something different on one of the GUAGE options.

I have a plugin that displays 7 Freq on a knob, but the GUAGE display is only 0's and 1's ...

So I thought I could RENAME the individual positions to the actual Freq #'s.

After advancing to the proper Guage position [red dot], I Rt-click'd the Value display and found RENAME.

Enter a number 35 .... and LBX locked up and Crashed Reaper :|

Beside notify of this crash ... is what I was trying to do, what I should do ?

thanks
RJHollins is offline   Reply With Quote
Old 06-04-2020, 08:51 AM   #7008
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,780
Default

hmmm.

i had an idea about my Advanced Randomize question..
but have no idea if makes things easy or worse

since the Right Click is the only problem in my case..
would it be possible having an Option in the Advanced Randomize settings
something like
Lock to Left Click Only / ignore Right Click ?
timbralzoom is offline   Reply With Quote
Old 06-04-2020, 06:12 PM   #7009
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,646
Default

Quote:
Originally Posted by nexeu View Post
Sadly it is not working that way in Mac. It seems to randomise everything each time I reload. Can't really predict the algorithm of it.
There is no algorithm to it from my side - I simply ask reaper to enumerate through all the files in a folder - whatever order is down to Reaper.

I'll probably be able to add an optional sort algorithm though - when I get time.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 06-04-2020, 06:12 PM   #7010
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,646
Default

Quote:
Originally Posted by timbralzoom View Post
sorry for my Tarzanish!
(actually even in Turkish i made simple things complicated while talking )

anyway,
here is a simple video, i hope will explain a bit better
(all Randomize buttons belongs to one same Subset)

https://drive.google.com/file/d/12hq...ew?usp=sharing
I'll take a look when I get a mo!
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 06-04-2020, 06:41 PM   #7011
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,646
Default

Quote:
Originally Posted by RJHollins View Post
I was trying something different on one of the GUAGE options.

I have a plugin that displays 7 Freq on a knob, but the GUAGE display is only 0's and 1's ...

So I thought I could RENAME the individual positions to the actual Freq #'s.

After advancing to the proper Guage position [red dot], I Rt-click'd the Value display and found RENAME.

Enter a number 35 .... and LBX locked up and Crashed Reaper :|

Beside notify of this crash ... is what I was trying to do, what I should do ?

thanks
May I ask what the plugin was? Sounds like an Acustica plugin - Aqua maybe?

Anyway - forgive me - but where did you find the RENAME option?

If you right-click the value display (underneath the control image) it should insert a new tick at current position and ask you for the label for the new tick. I know I wrote it but I can't find a rename current tick (red) option.


What I would do to create labelled ticks - is simply to remove all the ticks - then move the control to each location you want a tick at - then right-click the value display and enter the tick label.

I've tested this many times with Aqua's - and although Aqua's a a big pain (due to values always between 0 and 1 and completely not representative of the actual control value) - it does work ok.

I've no idea why it locked up though - what SENS value did you have set up in the Gauge dialog? That would make certain things take a long time (and is indeed necessary for certain things when using AA plugins) - but should never lock things up forever.

I think I know what you did though - and that's left-click the display value - but what this does is it searches for the value you typed in in the control readout from the plugin - (by repeatedly setting the value - then checking the response from the plugin - adjusting the value in the correct direction, then requeries the plugin for the display value - and repeat until it either finds the value you typed in - or it gives up after a certain number of fine tuning). Now with a high sensitivity set - this may take upwards of 2 minutes to complete (depends on your CPU capabilities - my PC is pretty fast and new - and it took about 2-3 minutes to do it on SENS 10). But being patient - although it looks like a freeze up - it should come back eventually.

Did Reaper really crash? Or did you try clicking on things whilst it was 'busy' - which depending on where you're clicking can sometimes trigger Reaper to shutdown.

The thing is - I guess you typed in a frequency value - but Aqua's and Nebula do not output frequency values - just values between 0 and 1 - so this method is no good to you.

So instead of left-clicking (which will work ok with many other plugins - just not AA ones) - right-click instead just to add a tick at the current position of the control (in the image at the top) - and type in the frequency or whatever as a label.

Hope this helps.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 06-04-2020, 08:42 PM   #7012
RJHollins
Human being with feelings
 
Join Date: Dec 2011
Posts: 1,517
Default

Wow lb0 ... it was an ACQUA plugin [COFFEE-eq].

is it a PITA ? YES ... and I think I found other things about it that will likely bring on other issues with it. When changing one of the 'Character' knobs [i think that is what its called], the choices of FREQs change. So now the Cycle Knob has the wrong steps.

I sense a nightmare.

This all may force an abandonment of my hope to make an easier GUI for me to see ...

Nonetheless ... the Crash/Freeze did happen. I would need to go back and do my steps again to remember what the heck I did ...

This same concept involved the Value display for FREQs. I like to place those values in the center of a Knob for easy match/recall. I did get that to work ... until I realized they would change, based on another setting ... so again ... nightmare.

That said ... when we both get some 'FREE TIME' i'll look to re-create the steps I did to see if the crash happens ... because I know there is Love to squash 'em.
RJHollins is offline   Reply With Quote
Old 06-05-2020, 08:45 AM   #7013
nexeu
Human being with feelings
 
Join Date: Mar 2020
Posts: 41
Default

Quote:
Originally Posted by lb0 View Post
There is no algorithm to it from my side - I simply ask reaper to enumerate through all the files in a folder - whatever order is down to Reaper.

I'll probably be able to add an optional sort algorithm though - when I get time.
That's really kind of you, thanks
nexeu is offline   Reply With Quote
Old 06-05-2020, 08:51 AM   #7014
nexeu
Human being with feelings
 
Join Date: Mar 2020
Posts: 41
Default FX Learn : KONTAKT multi-channel output parameter is not detected

I'm not sure where I'm going wrong, but when I try to do PARAM LEARN to my KONTAKT multi-output channel volume slider, it returns null.

I have set up multi-instrument rack with different stereo output stream for each of the instrument for the KONTAKT, and I am trying to get the individual channel knobs at LBX. But it doesn't detect when I tried dragging the channel vol slider up/down. Any thought?
nexeu is offline   Reply With Quote
Old 06-05-2020, 09:22 AM   #7015
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,780
Default

Quote:
Originally Posted by nexeu View Post
I'm not sure where I'm going wrong, but when I try to do PARAM LEARN to my KONTAKT multi-output channel volume slider, it returns null.

I have set up multi-instrument rack with different stereo output stream for each of the instrument for the KONTAKT, and I am trying to get the individual channel knobs at LBX. But it doesn't detect when I tried dragging the channel vol slider up/down. Any thought?
Hi,

i believe its must start from the Kontakt fist..

in the Kontakt
switch to Automation / Host Automation tab
and try dragging one of the "host par." to your multi output sliders
if Kontakt allows assigning .. Stripper can LEARN

in this case
you can see only this (host par. 000 to 511) parameters in the Reaper's Automation path
so the Stripper can LEARN only this parameters.

i hope make sense.
timbralzoom is offline   Reply With Quote
Old 06-05-2020, 09:24 PM   #7016
nexeu
Human being with feelings
 
Join Date: Mar 2020
Posts: 41
Default

Quote:
Originally Posted by timbralzoom View Post
Hi,

i believe its must start from the Kontakt fist..

in the Kontakt
switch to Automation / Host Automation tab
and try dragging one of the "host par." to your multi output sliders
if Kontakt allows assigning .. Stripper can LEARN

in this case
you can see only this (host par. 000 to 511) parameters in the Reaper's Automation path
so the Stripper can LEARN only this parameters.

i hope make sense.
Hey Timb,

Thanks for your suggestion. It does hook well with instrument volume, but not to the Output channel slider. I guess KONTAKT doesn't allow it to happen

My main idea was to just lean the output channel slider so when I switch the instruments, it wouldn't be a hassle.

I would probably just learn the Reaper track's sends to tackle this.

Thanks
Attached Images
File Type: png Screenshot 2020-06-06 at 10.48.04 AM.png (28.0 KB, 11 views)
nexeu is offline   Reply With Quote
Old 06-05-2020, 09:38 PM   #7017
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,780
Default

Quote:
Originally Posted by nexeu View Post
Hey Timb,

Thanks for your suggestion. It does hook well with instrument volume, but not to the Output channel slider. I guess KONTAKT doesn't allow it to happen

My main idea was to just lean the output channel slider so when I switch the instruments, it wouldn't be a hassle.

I would probably just learn the Reaper track's sends to tackle this.

Thanks
glad if helps!

btw.
personally i would prefer to use a mixer JS for this instead of the Track Sends.
timbralzoom is offline   Reply With Quote
Old 06-05-2020, 11:43 PM   #7018
nexeu
Human being with feelings
 
Join Date: Mar 2020
Posts: 41
Default

Quote:
Originally Posted by timbralzoom View Post
glad if helps!

btw.
personally i would prefer to use a mixer JS for this instead of the Track Sends.
Oh! Is it a built-in js in Reaper? What is the actual name of the script, if I may?
nexeu is offline   Reply With Quote
Old 06-06-2020, 12:53 AM   #7019
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,780
Default

i believe original name is FX_Chain_Mixer_Stereo
i am using my 16 channels modified version

here is the Strip and modified JS (in the zip)

in the Strip
Status buttons are Cycle button .. has 3 states Mute,On,Solo
i actually barely use the Pans..
and
finally in "Master Out" must be the "Original" selected in your case ..

i hope it helps

https://stash.reaper.fm/v/39583/AUDIO_16x%20MIXER.zip
timbralzoom is offline   Reply With Quote
Old 06-06-2020, 05:38 AM   #7020
nexeu
Human being with feelings
 
Join Date: Mar 2020
Posts: 41
Default

Quote:
Originally Posted by timbralzoom View Post
i believe original name is FX_Chain_Mixer_Stereo
i am using my 16 channels modified version

here is the Strip and modified JS (in the zip)

in the Strip
Status buttons are Cycle button .. has 3 states Mute,On,Solo
i actually barely use the Pans..
and
finally in "Master Out" must be the "Original" selected in your case ..

i hope it helps

https://stash.reaper.fm/v/39583/AUDIO_16x%20MIXER.zip
Wow! This is very useful. I was lucky to find out that if you wanna assign a param, you just simply need to drag the param (at the list) to the slider (at the strip) until the outline turns red.

One question though. How do I assign the status?

I'm really loving this.

Thanks!

Edit: I think I'm getting the status button function. I'd assigned mute param to it. And at [LIVE MODE], when I double clicked it, it turns into Solo Mode although I didn't assign solo param to it.

Last edited by nexeu; 06-06-2020 at 06:06 AM.
nexeu is offline   Reply With Quote
Old 06-06-2020, 03:09 PM   #7021
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,780
Default

Quote:
Originally Posted by nexeu View Post
Wow! This is very useful. I was lucky to find out that if you wanna assign a param, you just simply need to drag the param (at the list) to the slider (at the strip) until the outline turns red.

One question though. How do I assign the status?

I'm really loving this.

Thanks!

Edit: I think I'm getting the status button function. I'd assigned mute param to it. And at [LIVE MODE], when I double clicked it, it turns into Solo Mode although I didn't assign solo param to it.
uhmm.
i think i didn't understand what you are trying to do
did you install the Sharestrip file and open the Strip first?
if so .. just change the Control PNG s to ones you like
Status parameters are "Cycle Button"
and needs 3 frames Button PNG as like i used in the Strip ..

just tried .. double click does nothing here
you can change Mute-On-Solo states by Mouse wheel in the Live Mode
timbralzoom is offline   Reply With Quote
Old 06-06-2020, 07:13 PM   #7022
nexeu
Human being with feelings
 
Join Date: Mar 2020
Posts: 41
Default

Quote:
Originally Posted by timbralzoom View Post
uhmm.
i think i didn't understand what you are trying to do
did you install the Sharestrip file and open the Strip first?
if so .. just change the Control PNG s to ones you like
Status parameters are "Cycle Button"
and needs 3 frames Button PNG as like i used in the Strip ..

just tried .. double click does nothing here
you can change Mute-On-Solo states by Mouse wheel in the Live Mode
It's strange that you can double click to solo when you assign the 'Track Sends Mute' to the cycle button.

But, when you assign the real track mute param, it doesn't work that way.

Anyway, I'm still not sure how to assign Cycle button exactly. I'd tried dragging the Mute, Solo, and Record Arm to it separately after switching the default value at control panel. When I did that, and scroll the mouse at LIVE MODE, it triggers all instead of toggling.

Here's my progress so far.
Attached Images
File Type: jpg Screenshot-2020-06-07-at-8.34.36-AM.jpg (48.3 KB, 12 views)
nexeu is offline   Reply With Quote
Old 06-06-2020, 08:05 PM   #7023
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,780
Default

ah!

i am talking about "solo-mute-on" in the JS mixer that i sent...
but seems you are trying something else there ..
normal track mute, solo etc. needs regular "Button" type..
Cycle Button is for special use cases .. like that "Status" parameter of the JS mixer
as i already tried to say
this parameter has 3 states
(depends on the parameter, it could be 20 states for example.. in this case just 3 states)
1-mute 2-solo 3-on and it needs Cycle Button and a special graphic to represent statuses in the Strip GUI..

short:
you can't assign multiple parameters to one Control as i know.
timbralzoom is offline   Reply With Quote
Old 06-06-2020, 10:31 PM   #7024
nexeu
Human being with feelings
 
Join Date: Mar 2020
Posts: 41
Default

Quote:
Originally Posted by timbralzoom View Post
ah!

i am talking about "solo-mute-on" in the JS mixer that i sent...
but seems you are trying something else there ..
normal track mute, solo etc. needs regular "Button" type..
Cycle Button is for special use cases .. like that "Status" parameter of the JS mixer
as i already tried to say
this parameter has 3 states
(depends on the parameter, it could be 20 states for example.. in this case just 3 states)
1-mute 2-solo 3-on and it needs Cycle Button and a special graphic to represent statuses in the Strip GUI..

short:
you can't assign multiple parameters to one Control as i know.
Ah... I'm probably at the wrong direction. Where do I find the "Status" param at LBX to assign to your Cycle button? Thanks for brief explanation
nexeu is offline   Reply With Quote
Old 06-06-2020, 10:57 PM   #7025
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,780
Default

Quote:
Originally Posted by nexeu View Post
Ah... I'm probably at the wrong direction. Where do I find the "Status" param at LBX to assign to your Cycle button? Thanks for brief explanation
no problem

Status parameter belongs to JS Mixer so belongs to the plugin
as i saw in your picture you already installed the sharestrip,
so you have it assigned already in the Mixer Strip.

here is a mini video:
https://drive.google.com/file/d/1zjZ...ew?usp=sharing

i hope make sense.
timbralzoom is offline   Reply With Quote
Old 06-07-2020, 12:57 AM   #7026
nexeu
Human being with feelings
 
Join Date: Mar 2020
Posts: 41
Default

Quote:
Originally Posted by timbralzoom View Post
no problem

Status parameter belongs to JS Mixer so belongs to the plugin
as i saw in your picture you already installed the sharestrip,
so you have it assigned already in the Mixer Strip.

here is a mini video:
https://drive.google.com/file/d/1zjZ...ew?usp=sharing

i hope make sense.
Yesss~ It finally comes to life! My mistake was not turning on the js mixer script that you gave. Two of them are linked together, and I was looking elsewhere. Thank you so much for your demo and explanations

P.S: It would be great if there is a pan width function in the script. But, you can also assign it from the track you are sending to, so no issues.

Thanks
Attached Images
File Type: jpg Screenshot-2020-06-07-at-2.19.37-PM.jpg (60.1 KB, 20 views)

Last edited by nexeu; 06-07-2020 at 01:10 AM.
nexeu is offline   Reply With Quote
Old 06-07-2020, 07:57 PM   #7027
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,780
Default

found a strange behavior
my guess
Strip Browser vs Modulator assignment

https://drive.google.com/file/d/1OCI...ew?usp=sharing


-motto-
timbralzoom is offline   Reply With Quote
Old 06-08-2020, 12:55 AM   #7028
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,780
Default

more on this ^^ report

seems Snapshot morph Transport panel becomes un-clickable if there is Controls behind it
also sometimes does pass through mouse clicks to the Control behind

...

i just moved all Controls & BG images down away from the Strip Browser
and Snapshot Transport areas

so far all good

...

one last thing

seems Render all Snapshots ignores/Bypasses the Modulations
i will test more to see if its specific to last (big) Strip or not


-motto-
timbralzoom is offline   Reply With Quote
Old 06-08-2020, 01:56 AM   #7029
timbralzoom
Human being with feelings
 
timbralzoom's Avatar
 
Join Date: Apr 2010
Location: Turkey/Istanbul
Posts: 1,780
Default

sorry for continuous multiple posts!

is there is/was a way to assign Faders to the Hidden Controls ?
just in case want to ask first .. if somehow i missed or forgot..

or..i am gonna use my next year's Wacky idea/wish Joker
timbralzoom is offline   Reply With Quote
Old 06-08-2020, 06:06 PM   #7030
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,646
Default

Quote:
Originally Posted by timbralzoom View Post
found a strange behavior
my guess
Strip Browser vs Modulator assignment

https://drive.google.com/file/d/1OCI...ew?usp=sharing


-motto-
Will be fixed in next update
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 06-19-2020, 01:04 AM   #7031
nexeu
Human being with feelings
 
Join Date: Mar 2020
Posts: 41
Default Group sends/knobs together

Hi all,

Is there a way to group knobs/sends together so when I adjust one of it, the other respond the same way as well?

Cheers,
Nexeu

Last edited by nexeu; 06-19-2020 at 01:12 AM.
nexeu is offline   Reply With Quote
Old 06-19-2020, 01:59 AM   #7032
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,646
Default

Quote:
Originally Posted by nexeu View Post
Hi all,

Is there a way to group knobs/sends together so when I adjust one of it, the other respond the same way as well?

Cheers,
Nexeu
Within Stripper there is the macro control - found on TRACK edit -> Other Controls.

This allows for basic linking of multiple controls that exist on a strip.

Simply add a macro control - then in LIVE/DM mode - right-click the control and you can add/edit parameters associated with the macro.

With macro controls - it is still possible to alter parameters separately if you change values not using the macro control.

Outside of Stripper - of course you can use Parameter Modulation/MIDI link to link controls to do similar things. This ensures that all linked controls always keep the same value.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 06-19-2020, 03:40 AM   #7033
nexeu
Human being with feelings
 
Join Date: Mar 2020
Posts: 41
Default I got it!

Quote:
Originally Posted by lb0 View Post
Within Stripper there is the macro control - found on TRACK edit -> Other Controls.

This allows for basic linking of multiple controls that exist on a strip.

Simply add a macro control - then in LIVE/DM mode - right-click the control and you can add/edit parameters associated with the macro.

With macro controls - it is still possible to alter parameters separately if you change values not using the macro control.

Outside of Stripper - of course you can use Parameter Modulation/MIDI link to link controls to do similar things. This ensures that all linked controls always keep the same value.
I was not actually doing this for MIDI param but looking for a better solution to group the track sends in Reaper. There wasn't any easier way to do this than to create another track to group it until now.

I had this project with multiple receives/sends to a FX track from one instrument/VSTi alone in order to subtract out the dry signal by phase cancellation (cause some vst doesn't come with dry wet signals). That requires in need of adjusting the send amount as a group. And, this solves it all to my case.

Thanks lb0
Attached Images
File Type: png Screenshot 2020-06-19 at 4.55.55 PM.png (39.9 KB, 13 views)
nexeu is offline   Reply With Quote
Old 06-19-2020, 06:24 AM   #7034
nexeu
Human being with feelings
 
Join Date: Mar 2020
Posts: 41
Default Most stupidest question...

Ok, this might be the most stupidest question ever. After arranging and setting up the knobs and Gfx nicely, I am having trouble to group or save it as a strip or into one :| I have grouped the knobs and buttons by right clicking and selecting 'Group As a Strip' at the Track Tab. However, the Gfx background doesn't seem to group together as one. I can't seem to group Label and Gfx as well. Do enlighten me... Thank you.
Attached Images
File Type: jpg Screenshot-2020-06-19-at-7.46.43-PM.jpg (58.0 KB, 8 views)
nexeu is offline   Reply With Quote
Old 06-19-2020, 06:28 AM   #7035
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,646
Default

Quote:
Originally Posted by nexeu View Post
Ok, this might be the most stupidest question ever. After arranging and setting up the knobs and Gfx nicely, I am having trouble to group or save it as a strip or into one :| I have grouped the knobs and button by right clicking and selecting 'Group As a Strip' at the Track Tab. However, the Gfx background doesn't seem to group together as one. I can't seem to group Label and Gfx as well. Do enlighten me... Thank you.
If you have created this in the standard EDIT mode (not from DM mode) - then whilst in edit mode - click on STRIP button at top of left sidebar - and underneath will be a button to SAVE STRIP.

You don't need to do any grouping of controls or anything - simply saving the strip will do what you need.



Note - if you have used Strip Switchers - then you should avoid grouping any controls that have been placed within a switcher - as it will remove the controls from the switcher.
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 06-19-2020, 06:58 AM   #7036
nexeu
Human being with feelings
 
Join Date: Mar 2020
Posts: 41
Default

Quote:
Originally Posted by lb0 View Post
If you have created this in the standard EDIT mode (not from DM mode) - then whilst in edit mode - click on STRIP button at top of left sidebar - and underneath will be a button to SAVE STRIP.

You don't need to do any grouping of controls or anything - simply saving the strip will do what you need.



Note - if you have used Strip Switchers - then you should avoid grouping any controls that have been placed within a switcher - as it will remove the controls from the switcher.
Ah... It's the easiest thing to do at the LBX. Maybe that's why I forgot to take note of it. 😅🤣 Once again, thanks lb0
nexeu is offline   Reply With Quote
Old 06-19-2020, 05:47 PM   #7037
nexeu
Human being with feelings
 
Join Date: Mar 2020
Posts: 41
Default Expand canvas size?

I have ran out of art-board/canvas area to work on further. Is there a way to expand it or I have to scale everything smaller?
Attached Images
File Type: jpg Screenshot-2020-06-20-at-7.12.38-AM.jpg (51.5 KB, 10 views)
nexeu is offline   Reply With Quote
Old 06-20-2020, 05:29 AM   #7038
lb0
Human being with feelings
 
Join Date: Apr 2014
Posts: 3,646
Default

Quote:
Originally Posted by nexeu View Post
I have ran out of art-board/canvas area to work on further. Is there a way to expand it or I have to scale everything smaller?
In Settings there's an option to create surface size >2048 - if you set this option you will get a maximum surface size of 4096x4096

You cannot create bigger than this - it's already a hack to enable sizes >2048 - and to create sizes >2048 it also slows down loading of the script (as it has to load the surface bitmap files from the disk instead of simply creating them using the APIs - which is quicker but limited to 2048x2048 pixels).

There have been many requests by scripters to raise the limit bitmap sizes can be instantiated with - but no word from the Reaper devs why it hasn't/cannot be done. One is here: https://forum.cockos.com/showthread.php?t=226894
__________________
Projects - Reascripts - Lua:
LBX Stripper | LBX Chaos Engine | LBX Floating FX Positioner | LBX SRD Smart Knobs
Donate via Paypal
lb0 is online now   Reply With Quote
Old 06-20-2020, 07:10 PM   #7039
nexeu
Human being with feelings
 
Join Date: Mar 2020
Posts: 41
Default

Quote:
Originally Posted by lb0 View Post
In Settings there's an option to create surface size >2048 - if you set this option you will get a maximum surface size of 4096x4096

You cannot create bigger than this - it's already a hack to enable sizes >2048 - and to create sizes >2048 it also slows down loading of the script (as it has to load the surface bitmap files from the disk instead of simply creating them using the APIs - which is quicker but limited to 2048x2048 pixels).

There have been many requests by scripters to raise the limit bitmap sizes can be instantiated with - but no word from the Reaper devs why it hasn't/cannot be done. One is here: https://forum.cockos.com/showthread.php?t=226894
Oh well. I guess rescaling down everything when it's over limit is the only solution then. Thanks lb0
nexeu is offline   Reply With Quote
Old 06-21-2020, 12:31 AM   #7040
nexeu
Human being with feelings
 
Join Date: Mar 2020
Posts: 41
Default Convert Vol Knob back to Macro Control?

I had accidentally dragged track Vol into the Macro Control knob in EDIT mode. Dragging the macro control from the list to it doesn't seem to switch back. Is there a way I can switch it back?
nexeu is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:38 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.