Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER for Linux

Reply
 
Thread Tools Display Modes
Old 09-15-2018, 01:55 AM   #1
monty
Human being with feelings
 
monty's Avatar
 
Join Date: Dec 2015
Posts: 199
Default Pulseaudio gets RT scheduling error

I have configured RT kernel and the kernel parameters all as recommended. My syslog shows:
[code]
Sep 15 10:31:37 lindaw rtkit-daemon[3743]: Supervising 1 threads of 1 processes of 1 users.
Sep 15 10:31:37 lindaw pulseaudio[6237]: Stale PID file, overwriting.
Sep 15 10:31:37 lindaw pulseaudio[6237]: Default and alternate sample rates are the same.
Sep 15 10:31:37 lindaw pulseaudio[6237]: JACK error >Cannot use real-time scheduling (RR/80)(1: Operation not allowed)<
Sep 15 10:31:37 lindaw pulseaudio[6237]: JACK error >JackClient::AcquireSelfRealTime error<
[code]

Jackd works well ... does that only affect pulseaudio and can this be ignored?
__________________
KDENeon (5.0.0-37-lowlatency) AMD FX-8350, 16GB, GT 630 (nvidia-435), Multiscreen (2x 22", 1x 15"), Reaper (latest) Theme: iLogic Next, Interface: Tascam US-16x08, ControlSurface: Tascam US-2400, Monitors: JBL 4412A, Tascam VL-S3 & Alesis Elevate 3 mkII
monty is offline   Reply With Quote
Old 09-29-2018, 05:26 PM   #2
s wave
Human being with feelings
 
Join Date: Sep 2018
Location: Colorado
Posts: 232
Cool RT error? Is pulse in the way? Could be other things...

You do not necessarily need a 'real' REAL TIME (RT) Kernel. If you have 'real time scheduling', that is what got me started. And sometimes you have to enter a command to allow the 'USER' to have RT (scheduling) enabled. It kinda allows a user to be able to run the RT program as Super User, with higher priority of the program. (Try extending calls time? not enough loading time). Sometimes you will get an error if Pulse and Alsa are not configured correctly. ONE note - are you using jackd1 or jackd2? Two different types of - routing try both, it depends on what OS. A final idea is manually starting Jack with Qjackctl GUI before starting REAPER or try enabling jack to automatically start when you start REAPER. hope this helps someway... good luck post a reply people here are helpful.
s wave is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 06:04 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.