Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 11-22-2019, 07:22 AM   #1
BeardedGnome
Human being with feelings
 
Join Date: Aug 2019
Posts: 14
Default Reaper Recorded Midi Items set to base Time not Ignoring Project Tempo

Setting Reaper recorded MIDI base to Time is still affected by tempo, changing Source Properties to ignore project tempo doesn't seem work correctly either. I've tried setting the entire project to all different bases too.

I recorded from my MIDI keyboard directly into Reaper. In the past I've set MIDI items to Time base and then used tap tempo, the MIDI is now still affected by changing tempo despite being set to time.

In the past I've used the time base this way and it worked but now no matter what the MIDI base is it changes with tempo.

I also tried going into the Source settings and selecting 'ignore project tempo'. The problem with this is that as soon as I turn that off the MIDI stretches with the project tempo again, even when its base is time!

Using SWS Ignore Project Tempo and then Disable... works correctly as time base would have but I would like to get time based midi items working correctly again. Audio items set to time still are unaffected by tempo changes.
BeardedGnome is offline   Reply With Quote
Old 11-22-2019, 09:09 AM   #2
nofish
Human being with feelings
 
nofish's Avatar
 
Join Date: Oct 2007
Location: home is where the heart is
Posts: 9,186
Default

To be honest I'm surprised that you say it worked for you in the past (that MIDI items are not affected by tempo changes when using timebase time), because afaik it's always been the case that you have to set the "Ignore project tempo" option to make it work.

It also says so in the 'Timebase help' text (last paragraph):
nofish is offline   Reply With Quote
Old 11-26-2019, 01:41 PM   #3
BeardedGnome
Human being with feelings
 
Join Date: Aug 2019
Posts: 14
Default

Interesting, I believe I had it working with base time about 4 or so versions ago?

I'm almost certain I had it working that way. At least I'm pretty sure I never had to use the 'Ignore project tempo' option.

The problem I have with 'ignore project tempo' though is that after changing the tempo of the project and then unchecking it so I can use quantize with the new tempo is that the tempo of the midi item will then stretch relative to the tempo set in the 'ignore...' settings.

For example default bpm is set at 80, I make the midi item ignore project tempo but I have to leave the bpm in that dialog box at 80 or else it will stretch. Then I change the project bpm to 60 and upon unchecking the 'ignore...' the midi will stretch to the new tempo as if I had just changed it without using 'ignore...' to begin with.

I'm not sure if that's how its supposed to work but I never had trouble with it before. It makes it annoying to use native reaper to record a quick idea that might be quantized later. The SWS command works as I would expect 'ignore...' to.

I don't understand why you can set midi base to 'time' if its just beats anyways. I love reaper a lot but midi and time bases feel dirty and nonsensical at times.
BeardedGnome is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:32 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.