Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER for Video Editing/Mangling

Reply
 
Thread Tools Display Modes
Old 01-30-2019, 01:18 PM   #1
insub
Human being with feelings
 
insub's Avatar
 
Join Date: Mar 2014
Location: Louisville, KY, USA
Posts: 1,048
Default MPG Video Won't Play in Reaper, Plays Fine in VLC

I have some MPG files from an old Sony Handycam DCR-SR100. The files play fine in VLC, but I cannot get them to play in REAPER. At first the Video Window stayed completely green while audio played. Then I copied the FFMPEG dll files into the Reaper Plugin folder. Now the Video Window shows the opening image, but does not play the video. The audio plays back without trouble.

Reaper 5.965 x64
VLC 3.0.3
FFMPEG 3.4.1

Was I supposed to copy files other than just the dll's from the FFMPEG folder?
Also, why would those be necessary if VLC already plays the video files?

Reaper reported video file properties:
Length: 30:06.985
Video: 720x480@29.97fps, Aspect=1.00, Decoding format=I420/YV12
Audio: 48000Hz 6ch 32bps

Using ffmpeg/libav DLL decoder v57.107.100
Video: mpeg2video (Main), yuv420p(tv, top first), 720x480 [SAR 32:27 DAR 16:9], Closed Captions, max. 9100 kb/s
Audio: ac3, 48000 Hz, 5.1(side), fltp, 448 kb/s

Loaded from: C:\Program Files\REAPER (x64)\Plugins\avcodec-57.dll
__________________
Everything you need to know about samplerates and oversampling... maybe!
My Essential FREE 64bit VST Effects, ReaEQ Presets for Instruments
Windows 10 64 bit; MOTU 828 MKII, Audio Express, & 8PRE; Behringer ADA8000
insub is offline   Reply With Quote
Old 01-30-2019, 04:14 PM   #2
insub
Human being with feelings
 
insub's Avatar
 
Join Date: Mar 2014
Location: Louisville, KY, USA
Posts: 1,048
Default

I tried changing the file extension to the various MPEG-2 extensions to no avail.
MP2 made no difference.
M2V caused the import to fail.
MPEG allowed Windows 10 to play the videos, but not in Reaper.
I don't know why I can't get them to play in Reaper.

I've resorted to converting the files to the MP4 container, H.264, with audio AC3 pass-through (AC-3 5.1ch) using Handbrake. These files play just fine in Reaper and are immensely smaller in size than the source files. From 2GB down to between 220MB-400MB for 30min clips.
__________________
Everything you need to know about samplerates and oversampling... maybe!
My Essential FREE 64bit VST Effects, ReaEQ Presets for Instruments
Windows 10 64 bit; MOTU 828 MKII, Audio Express, & 8PRE; Behringer ADA8000

Last edited by insub; 01-30-2019 at 06:47 PM.
insub is offline   Reply With Quote
Old 01-31-2019, 12:45 AM   #3
Eliseat
Human being with feelings
 
Eliseat's Avatar
 
Join Date: Mar 2018
Location: Cologne
Posts: 1,167
Default

Hi Insub,

if you were able to import the mpeg2 files and to listen to the audio of the video then there is definitely something wrong. I remember that Justin fixed something in a dev version of Reaper that had to do with the resolution and the multiple of 4 or 8. Not sure what exactly it was. But it should be implemented in the next official version of Reaper as it has a long list of video fixes, video additions and new video features. Wait a few days and try it again after the update.

You also could try to change the default decoder to ffmpeg in the preferences. This helped me with some problems in VLC. But its no guarantee that it helps in your case. Go to options/preferences/media/video and make sure ffmpeg is on first position in the decoder priority list.

By the way: Mpeg2 is not the best format for video editing but it is of course the best quality you have. Conversion could be a way to make it more compatible and easier to edit though you should make sure that you choose the best (pseudo) quality for H264 in Handbrake to avoid to much loss in quality. Keep in mind that you will have to encode everything again after your edits in Reaper.

Good luck!
Eli //✿´‿`)
__________________
☆.。.:*・°☆.。.:*・°☆.。.:*・°☆REAPER//✿◔‿◔)°☆.。.:*・°☆.。.:*・°☆
Eliseat is offline   Reply With Quote
Old 01-31-2019, 05:43 AM   #4
airon
Human being with feelings
 
airon's Avatar
 
Join Date: Aug 2006
Location: Berlin
Posts: 10,387
Default

You could try putting the video in to an MKV container.


MKVtoolnix is the tool to do that.


Check out the 5.966 pre1 for massive video improvements as well, especially when seeking.
__________________
Dialogue/FX Editor & Re-Recording Mixer
(Video)Using Latch Preview
"My ego comes pre-shrunk" - Randy Thom
airon is offline   Reply With Quote
Old 01-31-2019, 12:03 PM   #5
insub
Human being with feelings
 
insub's Avatar
 
Join Date: Mar 2014
Location: Louisville, KY, USA
Posts: 1,048
Default

Thanks for your replies!
Quote:
Originally Posted by Eliseat View Post
You also could try to change the default decoder to ffmpeg in the preferences. This helped me with some problems in VLC. But its no guarantee that it helps in your case. Go to options/preferences/media/video and make sure ffmpeg is on first position in the decoder priority list.

By the way: Mpeg2 is not the best format for video editing but it is of course the best quality you have. Conversion could be a way to make it more compatible and easier to edit though you should make sure that you choose the best (pseudo) quality for H264 in Handbrake to avoid to much loss in quality.
Reaper never appeared to actually use VLC for me, even when I tried forcing it to.

Also, I woke up wondering the same thing about the Handbrake (pseudo) quality setting. I had left it on the default setting previously, and this morning I thought, "Well I just compressed an already compressed video format."

Quote:
Originally Posted by airon View Post
You could try putting the video in to an MKV container.


MKVtoolnix is the tool to do that.


Check out the 5.966 pre1 for massive video improvements as well, especially when seeking.
Thanks for these tips, I'll try them out!

Best Regards!
__________________
Everything you need to know about samplerates and oversampling... maybe!
My Essential FREE 64bit VST Effects, ReaEQ Presets for Instruments
Windows 10 64 bit; MOTU 828 MKII, Audio Express, & 8PRE; Behringer ADA8000
insub is offline   Reply With Quote
Old 01-31-2019, 01:03 PM   #6
insub
Human being with feelings
 
insub's Avatar
 
Join Date: Mar 2014
Location: Louisville, KY, USA
Posts: 1,048
Default

Quote:
Originally Posted by airon View Post
You could try putting the video in to an MKV container.
MKVtoolnix is the tool to do that.
This worked great!
MKVtoolnix changed the container to MKV pretty fast! And, now I can work with the audio without any degradation of the video prior to Reaper editing. Awesome tip, THANKS!
__________________
Everything you need to know about samplerates and oversampling... maybe!
My Essential FREE 64bit VST Effects, ReaEQ Presets for Instruments
Windows 10 64 bit; MOTU 828 MKII, Audio Express, & 8PRE; Behringer ADA8000
insub is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:19 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.