Old 01-04-2007, 04:15 PM   #1
mrelwood
Human being with feelings
 
mrelwood's Avatar
 
Join Date: Nov 2006
Location: Finland
Posts: 1,359
Default "Apply FX..." Crash.

When apllying a few FX on a track with around ten audio events, whenever Reaper reaches the end of applying the FX, Reaper crashes. The audio has a volume-curve fade out at the end.
------------
Okay, I tested quite a bit. I removed all other tracks, removed all master FX, removed all automation, and removed all other FX but JCM900 (Simulanalog Guitar Suite). I noticed that I could remove a few of the audio events, but certain combination of events had to stay in order for the crash to happen. I have to give up on this, I don't know how to test it any more.

I will share this project, as soon as I find a sensible place to fit it in, the whole project now has a total size of almost 19Mb.
------------
The project can be downloaded for testing here: (~19Mb)
http://www.savefile.com/files/389010
__________________
______Announcing__mrelwood plugins______
.. MacBook Pro 15" Late '13 .. Scarlett 6i6, Saffire Pro 24 DSP (+ADA8000) .. FCA610 .. EVE: SC207 .. Focal: Alpha 65, CMS 40, Listen Pro ..

Last edited by mrelwood; 01-04-2007 at 05:39 PM.
mrelwood is offline   Reply With Quote
Old 01-04-2007, 04:19 PM   #2
Jason Brian Merrill
Human being with feelings
 
Jason Brian Merrill's Avatar
 
Join Date: Jun 2006
Location: Northeastern PA, USA
Posts: 20,850
Default

i think what really matters are the effects you are using.
__________________
Beliefs do not require respect. People do.
Jason Brian Merrill is offline   Reply With Quote
Old 01-05-2007, 03:40 AM   #3
mrelwood
Human being with feelings
 
mrelwood's Avatar
 
Join Date: Nov 2006
Location: Finland
Posts: 1,359
Default

Quote:
Originally Posted by Jason Brian Merrill View Post
i think what really matters are the effects you are using.
It has it's role, sure, but this chain of events is so obscure that I find it hard to just blame the vst. If I remove an audio event, the plugin shouldn't work differently, right? But the software should. It would be nice if Justin would find time to evaluate the problem, and perhaps see if this behaviour could also cause problems with other plugins.
__________________
______Announcing__mrelwood plugins______
.. MacBook Pro 15" Late '13 .. Scarlett 6i6, Saffire Pro 24 DSP (+ADA8000) .. FCA610 .. EVE: SC207 .. Focal: Alpha 65, CMS 40, Listen Pro ..
mrelwood is offline   Reply With Quote
Old 01-05-2007, 09:21 AM   #4
Jason Brian Merrill
Human being with feelings
 
Jason Brian Merrill's Avatar
 
Join Date: Jun 2006
Location: Northeastern PA, USA
Posts: 20,850
Default

errr, i think it mattters alot, so perhaps you can tell us what plugins you were using.
__________________
Beliefs do not require respect. People do.
Jason Brian Merrill is offline   Reply With Quote
Old 01-05-2007, 01:55 PM   #5
mrelwood
Human being with feelings
 
mrelwood's Avatar
 
Join Date: Nov 2006
Location: Finland
Posts: 1,359
Default

Quote:
Originally Posted by Jason Brian Merrill View Post
errr, i think it mattters alot, so perhaps you can tell us what plugins you were using.
Oh, you mean THAT. ) As stated in the first mail, the only plugin used is a trusted JCM900 from Simulanalog Guitar Suite.

http://www.simulanalog.org/guitarsuite.htm
__________________
______Announcing__mrelwood plugins______
.. MacBook Pro 15" Late '13 .. Scarlett 6i6, Saffire Pro 24 DSP (+ADA8000) .. FCA610 .. EVE: SC207 .. Focal: Alpha 65, CMS 40, Listen Pro ..
mrelwood is offline   Reply With Quote
Old 01-05-2007, 02:13 PM   #6
Jason Brian Merrill
Human being with feelings
 
Jason Brian Merrill's Avatar
 
Join Date: Jun 2006
Location: Northeastern PA, USA
Posts: 20,850
Default

Quote:
Originally Posted by mrelwood View Post
Oh, you mean THAT. ) As stated in the first mail, the only plugin used is a trusted JCM900 from Simulanalog Guitar Suite.

http://www.simulanalog.org/guitarsuite.htm
after you edited the post, of course. Strange, it is a trusted plugin.
__________________
Beliefs do not require respect. People do.
Jason Brian Merrill is offline   Reply With Quote
Old 01-06-2007, 09:35 AM   #7
mrelwood
Human being with feelings
 
mrelwood's Avatar
 
Join Date: Nov 2006
Location: Finland
Posts: 1,359
Default

Quote:
Originally Posted by Jason Brian Merrill View Post
after you edited the post, of course. Strange, it is a trusted plugin.
Oh, sorry, I thought I typed the name earlier. What I noticed is that if every audio event has a proper fade/crossfade, this crash does not happen. This was good to find, and keeps me using the plugin with less worries from now on also.
__________________
______Announcing__mrelwood plugins______
.. MacBook Pro 15" Late '13 .. Scarlett 6i6, Saffire Pro 24 DSP (+ADA8000) .. FCA610 .. EVE: SC207 .. Focal: Alpha 65, CMS 40, Listen Pro ..
mrelwood is offline   Reply With Quote
Old 01-07-2007, 04:39 PM   #8
mrelwood
Human being with feelings
 
mrelwood's Avatar
 
Join Date: Nov 2006
Location: Finland
Posts: 1,359
Default

Now the same started happening when rendering the vocal track. Plugins included are Gsnap, IQ4 and Blockfish. Adjusting proper fades to the audio events did not help.

Oh, it only crashes if IQ4 is enabled. Darn. Now there are two favourite plugins that I have to be really careful with.

Oh! It only crashes if "Always run track FX" is enabled! I think we are closing to the source...
__________________
______Announcing__mrelwood plugins______
.. MacBook Pro 15" Late '13 .. Scarlett 6i6, Saffire Pro 24 DSP (+ADA8000) .. FCA610 .. EVE: SC207 .. Focal: Alpha 65, CMS 40, Listen Pro ..

Last edited by mrelwood; 01-07-2007 at 04:42 PM. Reason: More info
mrelwood is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 04:41 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.