Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Q&A, Tips, Tricks and Howto

Reply
 
Thread Tools Display Modes
Old 09-17-2017, 07:17 AM   #1
wittenberg
Human being with feelings
 
Join Date: Oct 2008
Posts: 19
Default Folder always plays first track in it, alongside the one I want to play

I can't seem to figure this one out.

Say I have a folder with a synth on it. In the folder are several tracks, each playing a different MIDI channel of the synth. It appears that in such a setup, the instrument on channel 1 is always played, even if it not armed, alongside the channel that IS being played.

Please see the picture: Notice that track 'organ 1'is armed and routed to channel two of the 'Philharmonic folder', yet when I play this track, the Piano on channel 1 will always play as well. Similarly, if I arm 'Organ 2' on channel 3, the piano on channel 1 will play as well (but not channel 2).

When I remove the folder, all works as expected and can play each channel separatly and uniquely.

Any ideas?
Attached Images
File Type: png folder_always_plays_first_track.png (33.3 KB, 40 views)
wittenberg is offline   Reply With Quote
Old 09-17-2017, 08:01 AM   #2
nofish
Human being with feelings
 
nofish's Avatar
 
Join Date: Oct 2007
Location: home is where the heart is
Posts: 9,049
Default

Open the routing for the Piano track and untick the "Parent send" tickbox, then it should stop playing, does it ?
nofish is offline   Reply With Quote
Old 09-17-2017, 08:41 AM   #3
DarkStar
Human being with feelings
 
DarkStar's Avatar
 
Join Date: May 2006
Location: Surrey, UK
Posts: 18,017
Default

^^^
But what happens when he wants to play the piano?

@ wittenberg,
Perhaps you could compress a simple problem project file (no audio samples needed) into a ZIP file and post it here as an attachment so that we can have a look at it and see what's (not) happening?

How to post attachments (in Post #1)

Hold on a moment, tracks within a folder should not have Sends to the parent folder.
__________________
DarkStar ... interesting, if true. . . . Inspired by ...
DarkStar is offline   Reply With Quote
Old 09-17-2017, 08:59 AM   #4
nofish
Human being with feelings
 
nofish's Avatar
 
Join Date: Oct 2007
Location: home is where the heart is
Posts: 9,049
Default

Quote:
Originally Posted by DarkStar View Post
^^^
But what happens when he wants to play the piano?
Well, this case wasn't mentioned by OP.

More seriously, I've been going by the pic, where can be seen that for the Organ track "Parent send" is ticked and an additional send is set up so this seems like double-sending to me. I assumed he might have the same set up for the Piano track and if there's already a dedicated send to the parent track, the "Parent send" tick should be removed.

But you're right DS, that was rather wild guessing, example project to look into makes more sense.

edit:
Quote:
Hold on a moment, tracks within a folder should not have Sends to the parent folder.
That's what I was getting at above. Either remove the additional send or untick the "Parent send" tickbox.
nofish is offline   Reply With Quote
Old 09-17-2017, 09:11 AM   #5
DarkStar
Human being with feelings
 
DarkStar's Avatar
 
Join Date: May 2006
Location: Surrey, UK
Posts: 18,017
Default

No problem, let's see what he says.
__________________
DarkStar ... interesting, if true. . . . Inspired by ...
DarkStar is offline   Reply With Quote
Old 09-17-2017, 01:01 PM   #6
wittenberg
Human being with feelings
 
Join Date: Oct 2008
Posts: 19
Default SOLVED

Hi everybody and thank you for your suggestions. Indeed I needed to uncheck the parent/master send. Not only did this solve the issue, but now I also have a slightly better understanding of that particular checkbox and the routing structure of reaper. Thanks all!

I am not entirely sure what was going on though. I can see how I was sending to the parent as well as via the send. The thing being 'sent' must have been MIDI in both cases, since there was no audio on the track. The send was specified to midi channel 2. But then what was the 'parent checkbox' sending? Apparently MIDI, with a default to channel 1 or something? (because that is where the unwanted sounding piano was at).

Thanks again
wittenberg is offline   Reply With Quote
Old 09-17-2017, 02:34 PM   #7
nofish
Human being with feelings
 
nofish's Avatar
 
Join Date: Oct 2007
Location: home is where the heart is
Posts: 9,049
Default

Nice it's solved.

Quote:
But then what was the 'parent checkbox' sending? Apparently MIDI, with a default to channel 1 or something? (because that is where the unwanted sounding piano was at).
I think so.
I'd assume your MIDI keyboard outputs on Channel 1 and that's sent to the folder / parent because of the "Parent sent" tickbox falsely triggering the Piano. While doing it via a dedicated MIDI send you can "channelize" your input to the correct channel.
nofish is offline   Reply With Quote
Old 09-18-2017, 01:11 PM   #8
wittenberg
Human being with feelings
 
Join Date: Oct 2008
Posts: 19
Default

SPOT-ON again, NOFISH.
My MIDI keyboard is indeed on channel 1, so that was being send to the folder when the parent send chekcbox was on. When I changed it to another channel, that one got played.

Thanks again.
wittenberg is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:18 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.