COCKOS
CONFEDERATED FORUMS
Cockos : REAPER : NINJAM : Forums
Forum Home : Register : FAQ : Members List : Search :

Go Back   Cockos Incorporated Forums > NINJAM Discussion > NINJAM Developer Discussion

Reply
 
Thread Tools Display Modes
Old 12-01-2017, 09:49 AM   #1
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 11,348
Default NINJAM source code now in git, including ReaNINJAM

I've just posted the full ninjam source (with development history) to https://www.ninjam.com, with a git repository and a github mirror.

Included in that repository is ReaNINJAM, which will need the VST SDK to compile.

Send patches my way if you're so inclined...
Justin is online now   Reply With Quote
Old 12-01-2017, 10:13 AM   #2
pljones
Human being with feelings
 
pljones's Avatar
 
Join Date: Aug 2007
Location: London, UK
Posts: 585
Default

Thanks!
__________________
Quote:
Originally Posted by Tony Williams
...Playing fast around the drums is one thing. But to play with people for others, to listen to, that's something else. That's a whole other world.
pljones is online now   Reply With Quote
Old 03-12-2018, 04:24 PM   #3
dinoc
Human being with feelings
 
Join Date: Jan 2006
Posts: 19
Default vstsdk version?

Awesome!.
Question, which version of the vst sdk should we use to compile reaninjam? It seems to be having issues trying to build with sdk v2.4.
For example it says 'effIdentify' : undeclared identifier.
From what I browsed in vstsdk 2.4 effIdentify is deprecated.
Shoul we use vstsdk 2.3?
Any charitable soul has a zip copy of that sdk?
Cheers!
dinoc is offline   Reply With Quote
Old 04-17-2018, 07:12 AM   #4
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 11,348
Default

Quote:
Originally Posted by dinoc View Post
Awesome!.
Question, which version of the vst sdk should we use to compile reaninjam? It seems to be having issues trying to build with sdk v2.4.
For example it says 'effIdentify' : undeclared identifier.
From what I browsed in vstsdk 2.4 effIdentify is deprecated.
Shoul we use vstsdk 2.3?
Any charitable soul has a zip copy of that sdk?
Cheers!
There are probably some tweaks you could do to make it compile (enabling deprecated symbols in the vst 2.4 sdk?).. or you could just comment out the effIdentify block (unless there are others too)
Justin is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:32 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.