Old 05-08-2022, 06:54 AM   #1
keaton
Human being with feelings
 
Join Date: May 2022
Posts: 9
Default Scrolling issues in mac os

Hello,

I am evaluating Reaper and have a weird scrolling issue on Mac OS (11.6.4) where for some reason the view keeps wanting to snap back to the playhead as demonstrated here:

https://i.imgur.com/IWDU9JQ.mp4

I've searched some older threads for scrolling issues previous versions of Reaper but it seems to be a graphics issue that was fixed. I don't think in my case it's a graphics issue as there is perfectly smooth and responsive scrolling elsewhere in the interface. No issue on Windows.

Any help greatly appreciated. Thanks.
keaton is offline   Reply With Quote
Old 05-09-2022, 12:25 PM   #2
mlprod
Human being with feelings
 
Join Date: Jul 2015
Location: Stockholm, Sweden
Posts: 1,045
Default

Options menu: turn off "auto scroll view during playback".
__________________
Magnus Lindberg Productions - VRTKL Audio - Redmount Studios
magnuslindberg.com
mlprod is offline   Reply With Quote
Old 05-10-2022, 01:21 AM   #3
keaton
Human being with feelings
 
Join Date: May 2022
Posts: 9
Default

Hello.

Thanks for the response. Hasn't made a difference i'm afraid.
keaton is offline   Reply With Quote
Old 05-10-2022, 05:25 PM   #4
nepenthe
Human being with feelings
 
Join Date: Mar 2011
Location: USA
Posts: 265
Default

This is something that you need to configure yourself in the Actions section.

Open the Actions list and search for the "Transport" actions. What you're describing is Transport: Play/Pause (default: control+space). You can modify this to use the space bar if you'd like. You can test these functions by pressing the "Run" button in the lower right of the Actions window.

Grab your favorite beverage and spend some time scrolling through this section as there is an unbelievable amount of stuff you can and should set up. This is also where one often must go to set up whatever new features have been added during an update as these often lack default bindings.
nepenthe is offline   Reply With Quote
Old 05-11-2022, 10:25 AM   #5
keaton
Human being with feelings
 
Join Date: May 2022
Posts: 9
Default

Thanks for the reply. Am actually not talking about stop/start of playback. Just scrolling. Seems like a bug rather than a preference issue?
keaton is offline   Reply With Quote
Old 05-11-2022, 11:29 AM   #6
nepenthe
Human being with feelings
 
Join Date: Mar 2011
Location: USA
Posts: 265
Default

Quote:
Originally Posted by keaton View Post
Thanks for the reply. Am actually not talking about stop/start of playback. Just scrolling. Seems like a bug rather than a preference issue?
Omg sorry didn’t see the link. That’s a weird issue. Definitely not the snap back that I thought you were talking about! :-)

What sort of input devices are connected to your computer?

Edit: it almost seems like the “ key for scrolling to the cursor is being held down.

Last edited by nepenthe; 05-11-2022 at 11:56 AM.
nepenthe is offline   Reply With Quote
Old 05-11-2022, 01:57 PM   #7
keaton
Human being with feelings
 
Join Date: May 2022
Posts: 9
Default

No problem! No input devices connected, just using the trackpad on my MacBook air. Will double check the " key isn't being held and get back to you. Thanks.
keaton is offline   Reply With Quote
Old 05-12-2022, 01:25 AM   #8
dennech
Human being with feelings
 
Join Date: Aug 2018
Posts: 6
Default

Quote:
Originally Posted by keaton View Post
Hello,

I am evaluating Reaper and have a weird scrolling issue on Mac OS (11.6.4) where for some reason the view keeps wanting to snap back to the playhead as demonstrated here:

https://i.imgur.com/IWDU9JQ.mp4

I've searched some older threads for scrolling issues previous versions of Reaper but it seems to be a graphics issue that was fixed. I don't think in my case it's a graphics issue as there is perfectly smooth and responsive scrolling elsewhere in the interface. No issue on Windows.

Any help greatly appreciated. Thanks.
I have the same problem, and I have not yet found how to fix it. It's only on the trackpad when scrolling horizontally. The cursor comes back the same way as in your video.
dennech is offline   Reply With Quote
Old 05-13-2022, 09:42 AM   #9
keaton
Human being with feelings
 
Join Date: May 2022
Posts: 9
Default

Quote:
Originally Posted by nepenthe View Post
Edit: it almost seems like the “ key for scrolling to the cursor is being held down.
Just checked and this key is not being held down.


Quote:
Originally Posted by dennech View Post
I have the same problem, and I have not yet found how to fix it. It's only on the trackpad when scrolling horizontally. The cursor comes back the same way as in your video.
Interesting. Does it qualify as a bug I wonder?
keaton is offline   Reply With Quote
Old 05-13-2022, 10:20 AM   #10
nepenthe
Human being with feelings
 
Join Date: Mar 2011
Location: USA
Posts: 265
Default

Quote:
Originally Posted by keaton View Post
Just checked and this key is not being held down.




Interesting. Does it qualify as a bug I wonder?
I am not able to reproduce this with my MacBook Pro trackpad. What sort of troubleshooting steps have you tried?
Have you tried plugging in a mouse? Or changing your Mac OS input setting or the gesture settings in Reaper?
nepenthe is offline   Reply With Quote
Old 05-14-2022, 01:26 AM   #11
keaton
Human being with feelings
 
Join Date: May 2022
Posts: 9
Default

Quote:
Originally Posted by nepenthe View Post
I am not able to reproduce this with my MacBook Pro trackpad. What sort of troubleshooting steps have you tried?
Have you tried plugging in a mouse? Or changing your Mac OS input setting or the gesture settings in Reaper?
I don't have a mouse to try unfortunately. Mac OS trackpad settings are (I think) the default but tried messing with those to no avail.

Having a play around with the Reaper options but don't seem to be getting anywhere. I'll keep trying, perhaps the solution's in there somewhere.

Interesting that you're not having any issues with your Mac trackpad. I've deleted the Reaper user folder to reset everything to default and re-installed but it's still the same. Will post back if I find a solution. Presumably this is not something other mac trackpad users are experiencing.
keaton is offline   Reply With Quote
Old 05-15-2022, 04:00 PM   #12
nepenthe
Human being with feelings
 
Join Date: Mar 2011
Location: USA
Posts: 265
Default

Quote:
Originally Posted by keaton View Post
I don't have a mouse to try unfortunately. Mac OS trackpad settings are (I think) the default but tried messing with those to no avail.

Having a play around with the Reaper options but don't seem to be getting anywhere. I'll keep trying, perhaps the solution's in there somewhere.

Interesting that you're not having any issues with your Mac trackpad. I've deleted the Reaper user folder to reset everything to default and re-installed but it's still the same. Will post back if I find a solution. Presumably this is not something other mac trackpad users are experiencing.
I'm a bit surprised that none of the dev team has stepped in yet. But maybe post a bug report or post to the Q&A forum. This Mac forum doesn't get the most visitors TBH.
nepenthe is offline   Reply With Quote
Old Yesterday, 03:36 AM   #13
keaton
Human being with feelings
 
Join Date: May 2022
Posts: 9
Default

Ok, cheers for the help. I'll try cross-posting to a busier forum before I post a bug to see if it's something with my set up.
keaton is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:35 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.