Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER for Video Editing/Mangling

Reply
 
Thread Tools Display Modes
Old 03-07-2019, 09:35 AM   #1
wppk
Human being with feelings
 
Join Date: Feb 2019
Posts: 40
Default playeing specific videos for dubbing uses in france

here is the dialog I had with cockos support.

------------- Hello Luc,

Thank you for your email! I just tried the reaper.mp4 on my Windows 10 computer and it runs fine using the "ffmpeg/libav DLL decoder v54.42.100" (check the video item source properties for what version you run). REAPER relies on the VLC and/or FFMPEG codecs and needs them to play many formats, so whether or not a video runs smooth depends on those.

The best (and fastest) way to get started with REAPER, ask general usage questions, get help setting up your hardware or troubleshoot issues is posting in our forum, which is our support mainstay, manned 24/7. Please create an account (you just need an email address to register) here:

http://forum.cockos.com/register.php

In your post, please state your operating system/platform and your REAPER version (64 or 32 bit?) and whether or not you have FFMPEG and VLC installed and what FFMPEG/VLC versions exactly you are using (this can have a big impact).

Please also see this Wiki page:

http://wiki.cockos.com/wiki/index.php/Video_Support

And these threads:

http://forum.cockos.com/showthread.php?t=162985
http://forum.cockos.com/showthread.php?t=157081

Best regards,

Cockos Support
[r]

On 3/1/2019 12:16 PM, luc mitéran wrote:
> Hello,
> I have tested your new version of reaper. your program is great, and it would be perfect if it worded with my students. I am a coach for duibbing. in france, in professional studios, we are using a rythmo tape ( lower tape with the text scrollling) , about which I think I have already told you.
>
> at the bottom of this page, http://lucmiteran.com/cours.php yuou will find three samples with a rytjmo tape, they play flawless. you can donwload the fils by right clicking on them if you wish. they are 60 fps. I ets reper on 60 fpr int project properties, but the playing is not flawless. as you can see on this screen capture on this link. http://lucmiteran.com/reaper.mp4 (please download it instead of reading it in the browser)
>
> That would be perfect for me if one could read the fils likes those wihc are on my webpage, flawlessly. do you know where the problem comes from ? On the same computer, if I use adobe premier my files (webpage) are playing flawless. but not if I am using sony vegas or reaper.
>
> can you help ?
> thanks !!!
> kinf regards
> Luc --
--------------

so, my system is windows 8.1, In have reaper 64 bits.
I have vlc and ffmpeg on my computer, but I don't know how to find wether I have ot not the "ffmpeg/libav DLL decoder v54.42.100"
nut I assume I don't as I have issues reading my file.
do you know how I could aknowledge if I have the dll and where I could uplaod this dll in case I don't have it .? I watched on the net but didnt' fint it. Thanks !
regards
Luc
wppk is offline   Reply With Quote
Old 03-07-2019, 09:46 AM   #2
wppk
Human being with feelings
 
Join Date: Feb 2019
Posts: 40
Default

if I check the source properties, I have no info about this dll.
when you say that this video works fine on your computer, do you mean that reaper can read it flawlessly ? or that you can read the file flawlessly with vlc ? because my problem is reading id in reaper, flawlessly.
thanks
luc
wppk is offline   Reply With Quote
Old 03-07-2019, 09:48 AM   #3
wppk
Human being with feelings
 
Join Date: Feb 2019
Posts: 40
Default

I found a version of ffmpeg which is probably the latest. I can see some pepole install the fils in c programl fils reaper. but are all the files to be added there ? or in a specific place ? isn't it possible to place only the missing dll ? if yes, where, and which one is it . there is no dll of this name in the ffmpeg directory...
wppk is offline   Reply With Quote
Old 03-07-2019, 09:55 AM   #4
wppk
Human being with feelings
 
Join Date: Feb 2019
Posts: 40
Default

I imported in the plugin directory all the files which were in the ffmpeg directory, and it didn't solve the problem...
wppk is offline   Reply With Quote
Old 03-07-2019, 10:01 AM   #5
wppk
Human being with feelings
 
Join Date: Feb 2019
Posts: 40
Default

well, I have read more of your links. in the properties of the vidoe, it says repaer is using Quick time plugin ( bridged) how canb I tell reaper to use the good one ?
wppk is offline   Reply With Quote
Old 03-07-2019, 10:07 AM   #6
wppk
Human being with feelings
 
Join Date: Feb 2019
Posts: 40
Default

J have found how to change the video-rex-meic, but as soon as Iask to use ffmpeg only or remove the qt mov form the list, I cannot even open the file anymore....
wppk is offline   Reply With Quote
Old 03-07-2019, 10:09 AM   #7
wppk
Human being with feelings
 
Join Date: Feb 2019
Posts: 40
Default

in the video decoder info, I have the ffmpeg/libav DLL decoder v54.92.100 but you told me that the libav DLL decoder v54.42.100 was the one that woeks. how can I get it and change that ?
wppk is offline   Reply With Quote
Old 03-07-2019, 10:19 AM   #8
wppk
Human being with feelings
 
Join Date: Feb 2019
Posts: 40
Default

I found the right version of ffmpeg. with the goo dll. but i still cannot change it in the preferences withoutr making reaper unable to open the file.
wppk is offline   Reply With Quote
Old 03-08-2019, 07:00 AM   #9
Ollie
Super Moderator (no feelings)
 
Ollie's Avatar
 
Join Date: Dec 2007
Location: On or near a dike
Posts: 9,739
Default

Funny thing: The computer I tested the file on (in REAPER of course) doesn't even have VLC or the FFMPEG codecs installed yet, I just thought I had installed them because I never had an issue importing or exporting .mp4/.mov/etc. So it uses the 7 year old avcodec-54.dll that comes with REAPER, and any newer version should work too.

Quote:
Originally Posted by wppk View Post
J have found how to change the video-rex-meic, but as soon as Iask to use ffmpeg only or remove the qt mov form the list, I cannot even open the file anymore....
I also didn't change anything in Preferences, so it should work if you reset the video decoder priority to default. Since you have VLC installed REAPER would probably try to use that first, which might be the culprit.

Can you post a screenshot of Preferences -> Video/REX/Misc -> "Show available decoder information"?
Ollie is offline   Reply With Quote
Old 03-11-2019, 10:18 AM   #10
wppk
Human being with feelings
 
Join Date: Feb 2019
Posts: 40
Default screenshot

yap, here is the picture
i hope it worked.
thanks for your answer
I am downlaoding the last version of reaper. maybe it will help too ?
wppk is offline   Reply With Quote
Old 03-11-2019, 10:20 AM   #11
wppk
Human being with feelings
 
Join Date: Feb 2019
Posts: 40
Default

well, i upladed the picture but I cant see it. here is the text you are asking for


========== ffmpeg/libav ==========
ffmpeg/libav DLL decoder v54.92.100

Loaded from: C:\Program Files\REAPER (x64)\Plugins\FFmpeg.dll
ffmpeg/libav configuration:
--arch=x86_64
--extra-cflags=' -I../libvpx -I../libvorbis-1.3.1/include -I../libogg-1.2.0/include'
--extra-ldflags=' -L../libvpx -L../libvorbis-1.3.1/lib/.libs -L../libogg-1.2.0/src/.libs'
--enable-shared
--disable-static
--enable-memalign-hack
--disable-debug
--disable-avdevice
--disable-avfilter
--disable-network
--disable-everything
--disable-swscale-alpha
--disable-dct
--disable-fft
--disable-mdct
--disable-rdft
--disable-vaapi
--disable-vdpau
--disable-dxva2
--disable-zlib
--disable-bzlib
--enable-muxer=avi
--enable-muxer=matroska
--enable-demuxer=avi
--enable-demuxer=matroska
--enable-muxer=dv
--enable-demuxer=dv
--enable-muxer=webm
--enable-muxer=mov
--enable-demuxer=mov
--enable-encoder=qtrle
--enable-decoder=qtrle
--enable-encoder=ffv1
--enable-decoder=ffv1
--enable-encoder=huffyuv
--enable-decoder=huffyuv
--enable-encoder=dvvideo
--enable-decoder=dvvideo
--enable-libvpx
--enable-encoder=libvpx_vp8
--enable-decoder=libvpx_vp8
--enable-libvorbis
--enable-encoder=libvorbis
--enable-decoder=libvorbis
--enable-encoder=mjpeg
--enable-decoder=mjpeg
--enable-encoder=pcm_s16le
--enable-decoder=pcm_s16le
--enable-encoder=pcm_s24le
--enable-decoder=pcm_s24le
--enable-encoder=pcm_f32le
--enable-decoder=pcm_f32le
--enable-protocol=file
--disable-iconv
--disable-version3
--disable-gpl
--cc=x86_64-w64-mingw32-gcc
--ld=
--cxx=x86_64-w64-mingw32-g++
--nm=x86_64-w64-mingw32-nm
--ar=x86_64-w64-mingw32-ar

ffmpeg/libav search path:
%PATH%
C:\Program Files\REAPER (x64)
C:\Users\luc\AppData\Roaming\REAPER\UserPlugins\64
C:\Users\luc\AppData\Roaming\REAPER\UserPlugins
C:\Program Files\REAPER (x64)\Plugins

========== DirectShow ==========
DirectShow available
wppk is offline   Reply With Quote
Old 03-11-2019, 10:21 AM   #12
wppk
Human being with feelings
 
Join Date: Feb 2019
Posts: 40
Default

it is not better with reaper new version
wppk is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:11 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.