Old 02-02-2016, 05:35 PM   #1
Archimedes
Human being with feelings
 
Join Date: Aug 2011
Posts: 324
Default <ctrl>Scroll Wheel Weirdness, or is it me?

Unusual behavior (in my world, anyway) in response to <ctrl>Scroll Wheel.

In this GIF (url), new project, nothing on the tracks, scrolling is pretty much as it has always been, except the selected track scrolls out of view as I expand the track heights.

https://stash.reaper.fm/26501/Scroll%20Wheel%201.gif


In this GIF (url), I have a full project, and when I expand track lanes, only some of the lanes expand. The ones in the middle don't. I've seen this in other projects, where it didn't happen before.

https://stash.reaper.fm/26502/Scroll%20Wheel%202.gif

Have I clicked or unclicked some option somewhere to cause the second case? Is the first case normal behavior?

Thanks
Archimedes is offline   Reply With Quote
Old 02-02-2016, 05:44 PM   #2
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 5,478
Default

the ones in the middle are in a collapsed folder state.
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is offline   Reply With Quote
Old 02-02-2016, 05:51 PM   #3
Archimedes
Human being with feelings
 
Join Date: Aug 2011
Posts: 324
Default

Quote:
Originally Posted by EpicSounds View Post
the ones in the middle are in a collapsed folder state.
Wow - my eyes suck. That little arrow is hard to see. YEP!!!!

Okay - NEVER MIND!!!!
Archimedes is offline   Reply With Quote
Old 02-03-2016, 06:55 AM   #4
planetnine
Human being with feelings
 
planetnine's Avatar
 
Join Date: Oct 2007
Location: Lincoln, UK
Posts: 7,585
Default

Quote:
Originally Posted by Archimedes View Post
Unusual behavior (in my world, anyway) in response to <ctrl>Scroll Wheel.

In this GIF (url), new project, nothing on the tracks, scrolling is pretty much as it has always been, except the selected track scrolls out of view as I expand the track heights.

...

Have I clicked or unclicked some option somewhere to cause the second case? Is the first case normal behavior?

Thanks

Look in Prefs - Editing behaviour - Vertical zoom centre: In you first case it looks like you've got "Track under mouse cursor" when you expect "Last selected track". I prefer centering on the mouse cursor anyway, but maybe change it if you prefer last selected item.

Incidentally, mine zooms in and out happily on Ctrl-mousewheel on the arrange area, but only out if the mouse cursor is on the TCP, "in" is ignored...



>
planetnine is offline   Reply With Quote
Old 02-03-2016, 07:53 AM   #5
Archimedes
Human being with feelings
 
Join Date: Aug 2011
Posts: 324
Default

Quote:
Originally Posted by planetnine View Post
Look in Prefs - Editing behaviour - Vertical zoom centre: In you first case it looks like you've got "Track under mouse cursor" when you expect "Last selected track". I prefer centering on the mouse cursor anyway, but maybe change it if you prefer last selected item.

Incidentally, mine zooms in and out happily on Ctrl-mousewheel on the arrange area, but only out if the mouse cursor is on the TCP, "in" is ignored...



>
Excellent - that's helpful too! Thanks very much!
Archimedes is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:55 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.