Old 09-25-2018, 02:44 AM   #1
Equal
Human being with feelings
 
Join Date: Jun 2018
Posts: 56
Default special hotkeys don't work

Hi,

For some reason I cannot make reaper respond to the ctrl, shift and other special keys for binding new actions.
Is this a known bug, of do I need to change something in my operating system (Ubuntu 18.04)

Thanks in advance for your help!
Equal is offline   Reply With Quote
Old 09-25-2018, 03:17 AM   #2
Jack Winter
Human being with feelings
 
Jack Winter's Avatar
 
Join Date: Aug 2007
Location: Luxembourg/Spain
Posts: 1,803
Default

My guess is that your DE/WM is overriding the specific hotkeys for some other purpose. For instance Alt-click is mostly used to move X windows around, so unless reconfigured it won't reach reaper.
__________________
Reaper for Linux Documentation (WIP). Software: Archlinux/KDE, Fabfilter FX, Komplete 8, Nebula, Schwa/Stillwell, T-racks Max/Amplitube/SVX, etc. Gear: i7-2600k/4700HQ/16GB, RME Multiface/Babyface, Behringer X32, Genelec 8040, etc. :)
Jack Winter is online now   Reply With Quote
Old 09-25-2018, 07:28 AM   #3
Glennbo
Human being with feelings
 
Glennbo's Avatar
 
Join Date: Mar 2008
Location: Planet Earth
Posts: 4,055
Default

Quote:
Originally Posted by Jack Winter View Post
My guess is that your DE/WM is overriding the specific hotkeys for some other purpose. For instance Alt-click is mostly used to move X windows around, so unless reconfigured it won't reach reaper.
One thing I ran into was with Pulse Audio. Pulse now has profiles for media players, and wants to own some keys on the keyboard. The effect I saw from it was that some keys did not work at all when prompted for a key-combination while creating shortcuts.

I had to right click the Pulse audio speaker icon, go into properties, and disable the control of keys and media players.
__________________
Glennbo
Hear My Music - Click Me!!!
--
Glennbo is offline   Reply With Quote
Old 09-27-2018, 01:11 AM   #4
Equal
Human being with feelings
 
Join Date: Jun 2018
Posts: 56
Default

Thanks for the help guys. Unfortunately both options did not work.
So I will continue searching!

For some reason the shortcuts do work on the laptop, but not with my usb keyboard which is connected to the laptop.
Equal is offline   Reply With Quote
Old 09-27-2018, 10:35 PM   #5
Snap
Human being with feelings
 
Snap's Avatar
 
Join Date: Jul 2011
Posts: 850
Default

Try to change the keyboard model in your keyboard settings. Usually DEs have tools for that and ways to switch maps, models and layouts using kkb. Anyway this should help to check your current settings.

Code:
setxkbmap -query
This should help too

https://wiki.archlinux.org/index.php..._configuration
Snap is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:39 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.