Old 02-21-2019, 05:59 PM   #1
vectorwarrior
Human being with feelings
 
vectorwarrior's Avatar
 
Join Date: Aug 2014
Posts: 159
Default 5.97 - Video is more sluggish since update

I use video captures (usually mp4's) in most of my projects as I am a sound designer for video games. I just updated and the newer version is causing some sluggish behaviour that I haven't had before, so I presume it's related to the update.

The current issue I'm seeing is loop playback is causing the video to stick on a frame for a while (a second ish) when it loops back to the start. This is with a short loop (I'm working on a short sound which is why I noticed it) and I'm not seeing it for the first loop.

It feels like it's caching the first sec or so when playback is stopped (or something like that), but when looping it doesn't have the start cached so it pauses while it grabs what it needs. That's what it feels like at least.

I get the same sluggishness when jumping around in a video during playback.

I've only just updated, so will update this post as I get more info, but I figured I should post this now in case it's a legit/serious problem.

Thanks!
vectorwarrior is offline   Reply With Quote
Old 02-21-2019, 06:27 PM   #2
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 5,428
Default

right-click in the video window for cache settings.
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is offline   Reply With Quote
Old 02-21-2019, 06:43 PM   #3
vectorwarrior
Human being with feelings
 
vectorwarrior's Avatar
 
Join Date: Aug 2014
Posts: 159
Default

Quote:
Originally Posted by EpicSounds View Post
right-click in the video window for cache settings.
Ah, thanks! Just tried maxing out all the settings, the only one that helped was bumping up the video cache to 2 seconds, the rest of them didn't change anything. I'm curious to see if I get issues with longer loops.
vectorwarrior is offline   Reply With Quote
Old 02-21-2019, 08:30 PM   #4
EpicSounds
Human being with feelings
 
EpicSounds's Avatar
 
Join Date: Jul 2009
Posts: 5,428
Default

I would think that turning off all caching and disabling prefetch would be better.


is there something specific we can test?
__________________
REAPER Video Tutorials, Tips & Tricks and more at The REAPER Blog
EpicSounds is offline   Reply With Quote
Old 02-22-2019, 02:20 AM   #5
dsyrock
Human being with feelings
 
dsyrock's Avatar
 
Join Date: Sep 2018
Location: China
Posts: 140
Default

I came across the same issue. And I must say none of those experimental options can fix that issue for me.
dsyrock is offline   Reply With Quote
Old 02-22-2019, 05:15 AM   #6
Sju
Human being with feelings
 
Join Date: Jun 2015
Posts: 672
Default

Same exact use case and problem here; Try setting Video window rclick -> Performance tweaks -> Video cache -> All media and video FX are not cached. That fixed the glitchiness on short loops for me. I also set the cache time to 0.1s FWIW.
Sju is offline   Reply With Quote
Old 02-22-2019, 06:59 AM   #7
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,066
Default

Edit: aha, fixed for the next +dev build, thanks! This fix will also get into the inevitable 5.971.

Last edited by Justin; 02-22-2019 at 08:14 AM.
Justin is offline   Reply With Quote
Old 02-22-2019, 10:22 AM   #8
vectorwarrior
Human being with feelings
 
vectorwarrior's Avatar
 
Join Date: Aug 2014
Posts: 159
Default

Quote:
Originally Posted by Justin View Post
Edit: aha, fixed for the next +dev build, thanks! This fix will also get into the inevitable 5.971.
Awesome, thank you!
vectorwarrior is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:42 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.