Go Back   Cockos Incorporated Forums > REAPER Forums > newbieland

Reply
 
Thread Tools Display Modes
Old 12-09-2019, 07:26 PM   #1
SpookyNoodle
Human being with feelings
 
Join Date: Nov 2018
Posts: 10
Default A Tale of Two Drivers (Discrepancies Between Recording Quality)

tl;dr: I have to keep switching between ASIO and WASAPI drivers, depending on whether I want to record or edit. It's doable, but kinda tedious, and if there's a better solution I'd gladly like to find it out.

SOLUTION: Focusrite devices need drivers to work with Windows systems. Installing the Windows drivers for my particular device solved all problems with the ASIO audio system.

Hi all, I recently set up a studio with some equipment, but I'm hitting something of a problem:

Whenever I record, no matter which of the 2 inputs I use, which USB I use to connect the interface to the computer, whether I have it set to 'Line' or 'Instrument' level, the recording is always SUPER hot, incredibly loud. This is even when I have the gain all the way down on the input, and the problem is only worsened when I increase the gain.

The only thing that I've found that fixes this problem is by installing and using the ASIO Audio system, and the ASIO4ALL v2 Audio driver. When I'm using that system and hit record, with otherwise identical circumstances, and the audio quality and levels are fantastic, just like what I remembered from the old studio (which used a Mac computer, rather than my Win10).

However, I haven't found any way to suitably use ASIO to do output.



This is what the I/O looks like, the same Scarlett 2i2 as both input and output. Unlike with every other audio system, I have no way to use the ASIO drivers to output to my headset, which looks like this:



That 'USB' device is a little interface, which I plug my headphones into, to get rid of crackly EMI when I'm trying to do post work. The studio and my desktop are on separate floors, and it'd be excessively difficult to run a second pair of headphones from the interface up to my workstation.

So, while I'm recording I'd have to switch the drivers to ASIO, then once I'm trying to mix things, I'd have to switch it back to WASAPI or WaveOut. And then back to ASIO when I want to do retakes.

It's not too bad, my recording and editing sessions are usually each quite long, but it is kind of a hassle. I guess what I'm wondering is, how do I do one of the following:
  1. Configure ASIO so that I can properly hear output from Reaper
  2. Configure one of the other driversets to record proper input levels
  3. Set up a shortcut or hotkey to easily switch between ASIO and WASAPI drivers, so that I'm able to switch those without having to go into the preferences.

I haven't yet tried out EVERY set of drivers, mostly because I got tired of running up and down the stairs. If there's some driver that can strike a balance of ASIO's delightful recording, and the ability to output to my headphones, I'd be happy to experiment with it.

tl;dr: I have to keep switching between ASIO and WASAPI drivers, depending on whether I want to record or edit. It's doable, but kinda tedious, and if there's a better solution I'd gladly like to find it out.

I appreciate any advice you can offer.

Cheers

Last edited by SpookyNoodle; 12-11-2019 at 10:15 PM.
SpookyNoodle is offline   Reply With Quote
Old 12-09-2019, 08:02 PM   #2
SpookyNoodle
Human being with feelings
 
Join Date: Nov 2018
Posts: 10
Default A Challenger Appears

SOLUTION: Focusrite devices need drivers to work with Windows systems. Installing the Windows drivers for my particular device solved all problems with the ASIO audio system.


IMPORTANT UPDATE

So I found a way to simultaneously enable the Scarlett's input and the USB Device's output. There's just one problem: any time I make any kinds of recordings with the headphone's output enabled, it records as sounding incredibly garbled, digitized, and awful.

Here's how my settings look, under ideal conditions:



And here's my ASIO configuration:



The little number markers aren't there, but I placed them there for ease of reference.

For whatever reason, if [2] is turned on when I'm recording, then it's garbled, distorted. If it's switched off while I'm recording, then turned on while playing it back, it's smooth as butter.

Those are the only factors I can find that will effect the recorded quality. [2] in the ASIO settings must be off while recording, but it must be ON in order to hear anything.

Oh man, I feel like I'm so close, I just have no idea what to try next.

As a point of comparison, I've added this: It's two takes where I recorded the same snippet, in the same posture, with the same settings, except I switched the driver. Top is DirectSound, bottom is my jerry-rigged ASIO workaround.


Last edited by SpookyNoodle; 12-11-2019 at 10:16 PM.
SpookyNoodle is offline   Reply With Quote
Old 12-10-2019, 09:40 PM   #3
Philbo King
Human being with feelings
 
Philbo King's Avatar
 
Join Date: May 2017
Posts: 1,781
Default

Try setting both to 48k.
__________________
Tangent Studio - Philbo King
www.soundclick.com/philboking - stream music
www.facebook.com/philboking - gigs and news
Philbo King is offline   Reply With Quote
Old 12-10-2019, 10:14 PM   #4
SpookyNoodle
Human being with feelings
 
Join Date: Nov 2018
Posts: 10
Default

Quote:
Originally Posted by Philbo King View Post
Try setting both to 48k.
I have no way to manually edit the sampling rate of the devices. I tried checking 'always resample 44.1kHz <-> 48kHz' box for both the interface and speakers, and set a 'Requested Sample Rate' in the Reaper settings, as follows:



Same problems with static, crackling.

I think it has something to do with the bitrate (16 vs 24 bit), but when I tried checking "Force WDM to 16 bits" for both devices, that had no effect either.

Okay, did some additional testing, and found something strange: I did a recording, with the USB Device Off (in ASIO), with the reaper output set to be the interface. I did the record, but when I play the clip back through the headphones on the interface, it sounds all garbled and gross.

Come back upstairs, turn the USB Device On, set the Reaper Output Device to USB, and it plays back perfectly clear. Switch the USB off, switch the Reaper Output to Interface: it's all garbled.

I just tried the same method in reverse-- Had USB enabled and set for output, recorded it (came out garbled), disabled USB, set output to Interface, played back the recording (garbled), switched back to USB output (garbled again.) I really wish I could just use some other driver and have it record at normal levels :/

Last edited by SpookyNoodle; 12-10-2019 at 11:03 PM.
SpookyNoodle is offline   Reply With Quote
Old 12-10-2019, 11:54 PM   #5
Fergler
Human being with feelings
 
Fergler's Avatar
 
Join Date: Jan 2014
Posts: 3,970
Default

I'm assuming you somehow have run cables upstairs from the studio to the interface, why not one more for headphones?
__________________
Check out my hip-hop, funk-rock band Theatre Crisp
Fergler is offline   Reply With Quote
Old 12-11-2019, 09:27 AM   #6
SpookyNoodle
Human being with feelings
 
Join Date: Nov 2018
Posts: 10
Default

Quote:
Originally Posted by Fergler View Post
I'm assuming you somehow have run cables upstairs from the studio to the interface, why not one more for headphones?
Quote:
Originally Posted by SpookyNoodle View Post
I did a recording, with the USB Device Off (in ASIO), with the reaper output set to be the interface. I did the record, but when I play the clip back through the headphones on the interface, it sounds all garbled and gross.
Even if I did run that, it wouldn't solve the problem, since the audio still sounds garbled if I listen through the interface.
SpookyNoodle is offline   Reply With Quote
Old 12-11-2019, 10:51 AM   #7
domzy
Human being with feelings
 
Join Date: Feb 2017
Posts: 1,977
Default

Quote:
Originally Posted by SpookyNoodle View Post
Even if I did run that, it wouldn't solve the problem, since the audio still sounds garbled if I listen through the interface.
but wouldn't that mean you could ditch the USB device and ASIO4all and use the proper driver for your interface?
domzy is offline   Reply With Quote
Old 12-11-2019, 11:07 AM   #8
SpookyNoodle
Human being with feelings
 
Join Date: Nov 2018
Posts: 10
Default

Quote:
Originally Posted by domzy View Post
but wouldn't that mean you could ditch the USB device and ASIO4all and use the proper driver for your interface?
I have no idea what that driver would be, since when I record with anything but ASIO, the recording is blown out and ultra loud.

So, even when I have USB disabled in ASIO, the recording still sounds garbled when played through the interface. But when I switch the driver back to the USB device, suddenly it sounds fine.
SpookyNoodle is offline   Reply With Quote
Old 12-11-2019, 11:41 AM   #9
domzy
Human being with feelings
 
Join Date: Feb 2017
Posts: 1,977
Default

the proper driver would be the one from Focurite

https://customer.focusrite.com/support/downloads

it sounds like you are describing some sort of issue with your windows sound settings - check the sample rate there (by the way, in your previous pic you are requesting 44100 in reaper but then asking asio4all to resample to 48000?) and also check your recording levels in the windows sound settings, that might be the reason for loud input if you aren't using proper drivers.
domzy is offline   Reply With Quote
Old 12-11-2019, 01:30 PM   #10
SpookyNoodle
Human being with feelings
 
Join Date: Nov 2018
Posts: 10
Default

Quote:
Originally Posted by domzy View Post
the proper driver would be the one from Focurite

https://customer.focusrite.com/support/downloads
Iiinteresting, that may explain some of the strangeness. My old studio workstation was a Mac, but my current one is Windows 10, and on the download page for the drivers, there's this:



I guess I just never thought the interface would need its own drivers. I'll install, reboot, and update with any changes I find.

UPDATE: OH MY GOD, YOU BEAUTIFUL GENIUS. Just did a recording with ASIO, enabled all the devices I wanted for input and output, did a recording, it's perfect, the drivers did just the trick. Idk how to give reputation, or I would.

Last edited by SpookyNoodle; 12-11-2019 at 04:53 PM.
SpookyNoodle is offline   Reply With Quote
Old 12-14-2019, 08:39 AM   #11
JeffreyET
Human being with feelings
 
JeffreyET's Avatar
 
Join Date: Dec 2012
Location: Raleigh, NC, USA
Posts: 362
Default

Cool thread - I have been with MS Win from the beginning, so I have always taken for granted that drivers needed to be installed per each device.
BUT I still swap ASIO for internal laptop sound drivers a lot, and I have always wanted to make a KB shortcut to do that. (I can open the audio interface dialog box, but I want a faster toggle)
__________________
JET Guitars Website http://www.jetguitars.com
Jeffrey's REAPER tracks http://soundcloud.com/jeffreyet
JeffreyET is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:12 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.