Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER for macOS X

Reply
 
Thread Tools Display Modes
Old 11-15-2019, 01:27 AM   #1
pireap
Human being with feelings
 
Join Date: Jun 2017
Posts: 4
Default MIDI editing is so hard to do, slow, sticky and not comfortable immediately reacting

Hi, I am struggling with the midi editing in Reaper. In the Pianoroll the dragging of note length is so sticky and reacts so slow it seams to stick on place till it suddenly reacts on my dragging. I have the feeling, that there is something slow and not immediately reacting. In Ableton there is everything so quick prompted, note drawing and length shorten and make longer, in my Reaper on iMac everything is like a strething rubber band when I am moving some notes or strething lenght or chaning ocate by dragging.

Can I do a preference or anything to make the midi editing smoother and faster?

Thanks for any help.
pireap is offline   Reply With Quote
Old 11-15-2019, 08:12 AM   #2
tls11823
Human being with feelings
 
tls11823's Avatar
 
Join Date: Aug 2010
Location: Harrisburg, PA USA
Posts: 1,408
Default

From your description, it sounds as though you have snap-to-grid enabled. Try turning off snapping to see if that gives you what you want.
__________________
We act as though comfort and luxury were the chief requirements of life, when all that we need to make us happy is something to be enthusiastic about.
--Charles Kingsley... or maybe Albert Einstein... definitely somebody wiser than myself--
tls11823 is offline   Reply With Quote
Old 11-15-2019, 08:36 AM   #3
foxAsteria
Human being with feelings
 
foxAsteria's Avatar
 
Join Date: Dec 2009
Location: Oblivion
Posts: 7,238
Default

It's also worth configuring the mouse modifier preferences for MIDI editor so that different mouse actions produce the results you expect.
__________________
Myyy Wyyyrd Music
foxAsteria is offline   Reply With Quote
Old 11-15-2019, 11:40 AM   #4
Calaban
Human being with feelings
 
Join Date: Aug 2009
Posts: 149
Default

If you have snapping enabled, you can temporarily bypass it by holding SHIFT while moving a note.

I use this all the time but there may be an easier mouse modifier. I have not explored those.
Calaban is offline   Reply With Quote
Old 11-22-2019, 01:51 AM   #5
pireap
Human being with feelings
 
Join Date: Jun 2017
Posts: 4
Default I hope the screen

Hey Guys, thanks for all of your answers.

I have tried all your hints and have not perceived any improvement so far.

Yes, I have snap to grid enabled and holding shift to disable it temporarily does not make any difference so far. The mousemodifiers are not self explaining to me so I did not find something that solves my problem.

My problem is, that midi editing feels sooooo slow and sticky, the mouse drag is far further than the movement reaction of the midi note shows and this feels so strange to me. Maybe it is regular behaviour? I hope the video can display what I mean.

*
https://drive.google.com/open?id=1ry...l6FEDySVgb3YN9
*

Is there maybe an action that makes this midi note movement more fluid an quicker?

Thanks for help ...
pireap is offline   Reply With Quote
Old 11-22-2019, 12:23 PM   #6
foxAsteria
Human being with feelings
 
foxAsteria's Avatar
 
Join Date: Dec 2009
Location: Oblivion
Posts: 7,238
Default

That looks like your computer simply lagging out. Check the performance meter, right click and enable RTCPU display and see where you're at on resources. Do you have some very intensive plugins in your project?

If you don't have anticipative fx turned on in prefs/buffering, that will give you a performance boost.

Have a look here for general system tweaks to optimize performance:
https://www.cantabilesoftware.com/glitchfree/

What is your OS and audio device/interface?
__________________
Myyy Wyyyrd Music
foxAsteria is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:52 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.